Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Calligra/Okular blocks with Plasma Desktop Profile [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
adsicks
n00b
n00b


Joined: 08 Sep 2012
Posts: 37
Location: Oklahoma, USA

PostPosted: Sat Aug 22, 2015 10:53 am    Post subject: Calligra/Okular blocks with Plasma Desktop Profile [SOLVED] Reply with quote

Am I reading the out put of this right? This is telling me that 15.08 of Okular needs the 4.14 library (and the installed 5-9999 is not picked up by the greater than because it is a major version higher(!?)) And the same with Calligra and libkdcraw?

Code:
(kde-apps/libkexiv2-4.14.3:4/4.14::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-apps/libkexiv2-4.14.3:4[aqua=] (>=kde-apps/libkexiv2-4.14.3:4[-aqua]) required by (kde-apps/okular-15.08.49.9999:4/15.08::kde, ebuild scheduled for merge)

  (kde-apps/libkexiv2-5.9999:5/5::kde, installed) pulled in by
    >=kde-apps/libkexiv2-5.9999:5 required by (kde-apps/thumbnailers-5.9999:5/5::kde, installed)

  (kde-apps/libkdcraw-5.9999:5/5::kde, installed) pulled in by
    >=kde-apps/libkdcraw-5.9999:5 required by (kde-apps/thumbnailers-5.9999:5/5::kde, installed)

  (kde-apps/libkdcraw-4.14.3:4/4.14::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-apps/libkdcraw-4.4:4[aqua=] (>=kde-apps/libkdcraw-4.4:4[-aqua]) required by (app-office/calligra-9999:4/4::gentoo, ebuild scheduled for merge)


The Calligra block itself I can almost understand because it is in slot 4/4, but Okular has me baffled. Should I file a bug on the Okular, Calligra, both or neither. This has me a little stumped.....


Last edited by adsicks on Fri Oct 16, 2015 2:56 am; edited 1 time in total
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4403

PostPosted: Sat Aug 22, 2015 11:07 am    Post subject: Reply with quote

Okular-15.08.49.9999 is still in SLOT:4, which means KDE4. If you want the KF5-version you need to go plain SCM: v9999:5 should be OK.
It seems like libkexiv2 must be either from :4 or :5, you can't install them in parallel, that's where the block comes from. Probably uninstalling kde-apps/thumbnailers can fix both blocks?
Back to top
View user's profile Send private message
adsicks
n00b
n00b


Joined: 08 Sep 2012
Posts: 37
Location: Oklahoma, USA

PostPosted: Sun Aug 23, 2015 1:37 am    Post subject: Reply with quote

That is exactly what I thought. I just really have to wonder why a library from KDE libkexiv2 is a build depend for Okular 15.08. Like I say, the Calligra block I can understand as there is no Calligra 5 yet that I am aware of...

KDE 4 and 5 won't install in parallel due to upstream KDE development....

But looking at it again, I may just have the wrong slot for Okular...

Calligra is only in slot 4....

I would have to downgrad my slots for the other stuff to get it...
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4403

PostPosted: Sun Aug 23, 2015 6:17 am    Post subject: Reply with quote

adsicks wrote:
KDE 4 and 5 won't install in parallel due to upstream KDE development....

Not true ;) The only thing that actually really blocks is desktop stuff (plasma). kde-apps really can be installed kde4/kde5 side by side. They actually are intended to be used that way: kde-apps (collection of apps, versionend YEAR-MONTH, e.g. 15.08) is a mix of kde4/kde5 apps. The devs decided to release this way as it would minimize porting pressure but still release "something". That's why you currently really have to look at the SLOT of packages in kde-apps categrory. E.g. kate and gwenview in 15.08 are already ported to kde5 while okular still isn't. That's why you probably run the best currently when you use only the released versions (kde-apps-15.08).
Back to top
View user's profile Send private message
adsicks
n00b
n00b


Joined: 08 Sep 2012
Posts: 37
Location: Oklahoma, USA

PostPosted: Mon Aug 24, 2015 2:53 am    Post subject: Reply with quote

Thanks. That explains the slot conflict. I guess I thought the stuff in slot 5 was KDE 5.....

I downgraded the thumbnailer back to slot 4, depcleaned, and the blocks were gone....
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4403

PostPosted: Mon Aug 24, 2015 7:41 am    Post subject: Reply with quote

No, SLOT 5 is KF5, SLOT4 is KDE4. But okular-15.08.0 is NOT SLOT 5 but SLOT 4, while kde-apps/kate-15.08.0 is SLOT 5. Especially kde-apps/thumbnailers-5.9999 is SLOT 5, while thumbnailers-15.08.0 is SLOT 4. Not installing live ebuild (those ending with .9999) but relying on released version (apps e.g. 15.08.0) fixes the issue.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum