Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
wdm on alpha (and perhaps other 64 bit environments?)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Altivo
n00b
n00b


Joined: 01 Aug 2015
Posts: 49
Location: Northern Illinois

PostPosted: Wed Aug 19, 2015 2:08 am    Post subject: wdm on alpha (and perhaps other 64 bit environments?) Reply with quote

I wanted a lightweight, simple display manager to allow me to log in remotely using another PC or X-terminal, and wdm looked like the best choice. Most of the more widely used managers (kdm, gdm, lightdm, entrance) are masked in Portage (at least on the alpha,) and xdm has a lot of dependencies and one of those is blocked. So I merged wdm, which brought in WindowMaker (wmaker) with it. The latter works fine, but isn't really my cup of tea I think. I'm using fluxbox at the moment. Unfortunately, wdm will not start successfully.

I've been over the wdm-config, Xresources and Xsetup_0 repeatedly. They seem to match what is expected.

When launched from the command line by root, There are two attempts to paint the screen on vt7, each ending in a flash and going to black. Then the display returns to vt1 where root is logged in, showing this:

    gendalf ~ # wdm -nodaemon
    geometry: 530x240+-2147483648+-2147483648
    geometry: 530x240+-2147483648+-2147483648


Obviously that's the geometry for a window, presumably the login prompt. The window offsets are absurd, though. Except, if you had a -1 value in a 64 bit register but interpreted only the low order 32 bits, isn't that the number you'd get? I don't imagine it is possible to open a window with that geometry, which would explain the failure. The wdm process remains running, the vt7 screen remains blank, and I have to use CTRL-C to close down wdm.

Here is what comes up in /var/log/xdm-errors.log:

    X.Org X Server 1.16.4
    Release Date: 2014-12-20
    X Protocol Version 11, Revision 0
    Build Operating System: Linux 4.0.5-gentoo alpha Gentoo
    Current Operating System: Linux gendalf 4.0.5-gentoo #12 Sat Aug 15 06:13:41 CDT 2015 alpha
    Kernel command line: rootfstype=ext3 ro root=/dev/sdd4 vga=0x305
    Build Date: 16 August 2015 10:35:19AM

    Current version of pixman: 0.32.6
    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
    Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (==) Log file: "/var/log/Xorg.0.log", Time: Tue Aug 18 20:43:55 2015
    (==) Using system config directory "/usr/share/X11/xorg.conf.d"
    Cannot open config file. Using builtin defaults
    X Error of failed request: BadMatch (invalid parameter attributes)
    Major opcode of failed request: 2 (X_ChangeWindowAttributes)
    Serial number of failed request: 1343
    Current serial number in output stream: 1345
    Greet: guarenteed_read error, UNMANAGE DISPLAY
    Greet: pipe read error with /usr/bin/wdmLogin
    Server crash rate too high: removing display :0
    (EE) Server terminated successfully (0). Closing log file.


The "Cannot open config file" line makes no sense. The file is there, readable by all. So I tried passing the file on the command line with "-config /etc/X11/wdm/wdm-config" but the results look just the same.

So two questions arise here at least. Where does wdm really think its configuration file should be? And why is it misinterpreting the window offset position when it uses the built-in default?

And the bigger question: Has anyone managed to use wdm on a 64-bit processor? I suspect this looks the same on all of them, or at least on the little endian ones.

My next step, I suppose, is to try to read the source code, but I'm not well-versed in C so I thought I'd ask just in case someone already knows.
_________________
Have patience with me, I'm only half-baked.
--Altivo
Back to top
View user's profile Send private message
Altivo
n00b
n00b


Joined: 01 Aug 2015
Posts: 49
Location: Northern Illinois

PostPosted: Fri Aug 21, 2015 11:30 am    Post subject: Reply with quote

After digging through the wdm source code, I concluded that the "default" path for the wdm-config is actually /usr/lib/X11/wdm/wdm-config so I copied the wdm directory from /etc/X11 to /usr/lib/X11 but this changed nothing. Same symptoms, same error log entries.

Comments from other threads seem to indicate that wdm works on i386, so it appears that this is an alpha specific issue (or possibly 32 bit vs 64 bit processor issue.)

Does anyone know of a display manager that actually works on alpha? I haven't tried xdm yet, but looking at the dependencies I suspect it will also have issues.
_________________
Have patience with me, I'm only half-baked.
--Altivo
Back to top
View user's profile Send private message
Altivo
n00b
n00b


Joined: 01 Aug 2015
Posts: 49
Location: Northern Illinois

PostPosted: Sat Aug 22, 2015 2:28 pm    Post subject: Reply with quote

Further examination reveals that the default directory thing really is part of the problem. The compiled code looks in /usr/lib/X11/wdm for its configuration files, but the Portage installation created those files in /etc/X11/wdm instead. Adding a soft link from the former to the latter does solve some of the problem. It also appears that, since wdm is intended as an xdm replacement, tihe default wdm configuration files make reference to some xdm configuration files which may or may not exist on the local machine. That would depend on whether xdm had ever been configured there. I didn't have those files.

The present state of affairs still remains puzzling.

I can now get a login screen from wdm on two of three remote terminals that I've tried. One is a somewhat out of date Ubuntu (10.04 LTS) installation on a Pentium 4 Dell, which can log in, and get a WindowMaker desktop at least. Everything appears to be functional from there. Another is an Asus netbook running Linux Mint Maya, which can also log in successfully at least with WindowMaker. So far, selecting fluxbox from the session pull down on either machine does NOT work for some reason, though fluxbox works at the alpha console when launched by startx.

The third machine is a Raspberry Pi 2 model B running Raspbian (Debian) which fails to get the login screen up. The connection succeeds because the cursor arrow changes shape briefly before the black screen closes and you are returned to the screen from which X was invoked. The X error output shows no errors, even when set to audit level 4. It just shows four unnamed applications being opened and then closed in reverse sequence before X exits successfully. I thought at first that this was because the Raspberry Pi has the modern wide screen display while the Dell has the old conventional 3:2 aspect ratio. However, that isn't the case because the Asus netbook is a wide screen (though tiny) and comes up at 1024x700 with no difficulty.

It may be that the Raspberry Pi has some permission or authorization issues, and I will look into that. The Pi does, however, succeed in getting a full screen login to the alpha when the latter is running OpenVMS or OpenBSD.

I've always found remote X connectivity to be finicky to set up. With wdm on Gentoo, however, there are definitely issues with both the documentation and the default configurations.

[This post was made from Dillo, running on Gentoo Alpha over a remote connection from Linux Mint. The functionality is fine when it is running.]

And if it seems that I'm talking to myself, yes, that is the case. No advice or suggestions have been coming here or on the IRC channels, but I'm recording what I find in case it will be of use to someone in the future. This even though I may well be the first person in many months (or years) to actually install Gentoo on an Alpha from scratch. I'd love to find out that I'm wrong about that, but I see no evidence to the contrary.
_________________
Have patience with me, I'm only half-baked.
--Altivo
Back to top
View user's profile Send private message
Altivo
n00b
n00b


Joined: 01 Aug 2015
Posts: 49
Location: Northern Illinois

PostPosted: Sun Aug 23, 2015 3:17 pm    Post subject: Reply with quote

Confirmed: wdm can consistently manage a login and start a WindowMaker session on at least some remote X servers. The one X server on which it fails does work with every other X client system I have, including those that run on the Alpha (OpenVMS, OpenBSD, Debian 4.0) as well as on i386 (Ubuntu, Linux Mint.) Unfortunately, wdm remains unable to start a session on the local console, for reasons that are unclear to me.

Also confirmed: wdm cannot initiate a fluxbox session, though no error is logged. It just blinks and returns to the login greeter. Once a WindowMaker session is started, however, it is possible to convert it to a fluxbox session by using the "restart as fluxbox" choice in the WindowMaker root menu. Then fluxbox works normally.

This all seems pretty erratic and bizarre to me. :-(
.
_________________
Have patience with me, I'm only half-baked.
--Altivo
Back to top
View user's profile Send private message
lost+found
Guru
Guru


Joined: 15 Nov 2004
Posts: 508
Location: North~Sea~Coa~s~~t~~~

PostPosted: Sun Aug 23, 2015 5:14 pm    Post subject: Reply with quote

Hi,

I use wdm on x86 and amd64 (both Gentoo). From my memory, it worked pretty much out of the box, but I'm not starting wdm from the command line. The default procedure on Gentoo seems to be adding xdm to default runlevel (or starting /etc/init.d/xdm manually), and add DISPLAYMANAGER="wdm" to /etc/conf.d/xdm.

Hold on, I'll try to look up the changes I've made to the config files (also to improve security, and font rendering)... :)
Back to top
View user's profile Send private message
lost+found
Guru
Guru


Joined: 15 Nov 2004
Posts: 508
Location: North~Sea~Coa~s~~t~~~

PostPosted: Sun Aug 23, 2015 7:07 pm    Post subject: Reply with quote

Some quick notes... What's needed depends on the situation ofc. Maybe I'll find some more things I did for wdm. :) ...

/etc/X11/wdm/Xsession (toolbar in xterm):
Code:
-    exec @FAILSAFE@ -geometry 80x24-0-0
+    exec xterm -geometry 80x24-4-29


/etc/X11/wdm/Xservers:
Code:
-    :0 local /usr/bin/X
+    :0 local /usr/bin/X -nolisten tcp vt7 -novtswitch


/etc/X11/wdm/Xaccess:
Code:
#*               #any host can get a login window
comment out *, and add your hosts instead


/etc/X11/wdm/Xclients. Create a menu entry for Fluxbox, etc., also env variables can be handy here.
This is just an example with WindowMaker I'm using:
Code:
   wmaker*|WindowMaker*)
      # startup WindowMaker
      WMAKER_PATH=/usr/bin/wmaker
      if ! test -x $WMAKER_PATH ; then
         FindInPath $WMAKER_PATH
         if test -n "$result" -a -x "$result"; then
            WMAKER_PATH="$result";
         fi
      fi
   
      if test -x $WMAKER_PATH ; then
         ### custom stuff:
         export LANG="nl_NL@euro"
         export GNUSTEP_STRING_ENCODING="NSISOLatin9StringEncoding"
         if [ "$USER" != "test" ]; then
            export XDG_CACHE_HOME="/tmp/.cache-$USER"
         fi

         if [ "$DISPLAY" = "otherbox.mynet:1" ]; then
            cp -a ~/.config/fontconfig/fonts.conf.otherbox ~/.config/fontconfig/fonts.conf
            echo Starting WindowMaker >$HOME/.xwm-otherbox.msgs
            env > "$HOME"/Xrootenv.1
            exec $WMAKER_PATH --dont-restore --no-autolaunch --static >>$HOME/.xwm-otherbox.msgs 2>&1
         else
            cp -a ~/.config/fontconfig/fonts.conf.bak ~/.config/fontconfig/fonts.conf
            echo Starting WindowMaker >$HOME/.xwm.msgs
            env > "$HOME"/Xrootenv.0
            exec $WMAKER_PATH >>$HOME/.xwm.msgs 2>&1
         fi
         ###
         #echo Starting WindowMaker >$HOME/.xwm.msgs
         #env > "$HOME"/Xrootenv.0
         #exec $WMAKER_PATH >>$HOME/.xwm.msgs 2>&1
      fi
      ;;


/etc/X11/wdm/wdm-config (some changes I've made, explained in the man pages):
Code:
--- /etc/config-archive/etc/X11/wdm/wdm-config.dist.new   2015-05-22 14:04:35.906066000 +0200
+++ /etc/X11/wdm/wdm-config   2015-06-16 20:10:32.871674649 +0200
@@ -10,8 +10,9 @@
 ! All displays should use authorization, but we cannot be sure
 ! X terminals will be configured that way, so by default
 ! use authorization only for local displays :0, :1, etc.
-DisplayManager._0.authorize:    true
-DisplayManager._1.authorize:    true
+!DisplayManager._0.authorize:    true
+!DisplayManager._1.authorize:    true
+DisplayManager*authorize:    true
 ! The following three resources set up display :0 as the console.
 DisplayManager._0.setup:        /etc/X11/wdm/Xsetup_0
 DisplayManager._0.startup:      /etc/X11/wdm/GiveConsole
@@ -26,7 +27,8 @@
 ! display screen background--if not set or set to none, then the
 !                            background is not set by wdm.
 ! DisplayManager*wdmBg:         none
-DisplayManager*wdmBg:           solid:RoyalBlue
+! DisplayManager*wdmBg:           solid:RoyalBlue
+DisplayManager*wdmBg:           solid:SlateGray
 ! DisplayManager*wdmBg:         dgradient:RoyalBlue,FireBrick,Black
 ! DisplayManager*wdmBg:         hgradient:RoyalBlue,FireBrick,Black
 ! DisplayManager*wdmBg:         vgradient:RoyalBlue,FireBrick,Black
@@ -34,6 +36,7 @@
 !
 ! optional pixmap for logo
 ! DisplayManager*wdmLogo:  /usr/share/pixmaps/wdm/Eagle.xpm
+DisplayManager*wdmLogo:  /etc/X11/wdm/GoGentooGo.jpeg
 !
 ! optional help file to display in the help panel
 ! long lines may cause an ugly display
@@ -54,6 +57,8 @@
 ! list of window managers which can be started
 ! or 'None' if you want only NoChange to appear
 ! e.g.: DisplayManager*wdmWm:   None
+!DisplayManager*wdmWm:           WindowMaker:FVWM
+DisplayManager._0.wdmWm:           WindowMaker:FVWM-Crystal:FVWM
 DisplayManager*wdmWm:           WindowMaker
 !
 ! commands for reboot and halt
@@ -66,9 +71,13 @@
 ! DisplayManager*wdmHalt:       /sbin/shutdown -t3 -h now
 !
 ! true/false to require valid username/passwd to reboot,halt, or exit
-DisplayManager*wdmVerify:       true
+!DisplayManager*wdmVerify:       true
+DisplayManager*wdmVerify:       false
 ! true/false to require root as valid username/passwd to reboot,halt, or exit
 DisplayManager*wdmRoot:         false
 ! true=enable, false=disable shake and rollup animations
 DisplayManager*wdmAnimations:   true
-
+!
+! more custom stuff
+!DisplayManager.requestPort: 0
+DisplayManager*wdmLocale: nl_NL@euro


Some wdm ports have a moving port number (hard for iptables to block).
Code:
# netstat -anp


/usr/portage/x11-misc/wdm/wdm-1.28-r3.ebuild (patched for fontconfig $HOME and localization):
Code:
--- /usr/portage/x11-misc/wdm/wdm-1.28-r3.ebuild   2015-08-09 22:34:56.000000000 +0200
+++ /usr/local/portage/x11-misc/wdm/wdm-1.28-r3.ebuild   2015-06-04 09:45:48.876799607 +0200
@@ -1,6 +1,6 @@
 # Copyright 1999-2012 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Id$
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/wdm/wdm-1.28-r3.ebuild,v 1.5 2012/03/02 23:02:25 klausman Exp $
 
 EAPI=2
 inherit eutils pam
@@ -30,7 +30,10 @@
 }
 
 src_configure() {
+   # fix QA notice; fix locale path: files removed by localegen
    econf \
+      --with-fakehome=/var/lib/wdm \
+      --with-nlsdir=/usr/share/locale \
       --exec-prefix=/usr \
       --with-wdmdir=/etc/X11/wdm \
       $(use_enable pam) \
@@ -42,3 +45,8 @@
    rm -f "${D}"/etc/pam.d/wdm
    pamd_mimic system-local-login wdm auth account password session
 }
+
+# custom
+pkg_postinst() {
+   msgfmt -c -o /usr/share/locale/nl/LC_MESSAGES/wdm.mo /home/moi/translations/WDM/wdm.po
+}


/var/lib/wdm/.config/fontconfig/fonts.conf:
Code:
<?xml version='1.0'?>
<!DOCTYPE fontconfig SYSTEM 'fonts.dtd'>
<fontconfig>
 <match target="font">
  <edit mode="assign" name="rgba">
   <const>rgb</const>
  </edit>
 </match>
 <match target="font">
  <edit mode="assign" name="lcdfilter">
   <!-- lcdnone, lcddefault, lcdlight, lcdlegacy -->
   <const>lcddefault</const>
  </edit>
 </match>
 <match target="font">
  <edit mode="assign" name="hinting">
   <bool>true</bool>
  </edit>
 </match>
 <match target="font">
  <edit mode="assign" name="hintstyle">
   <!-- hintnone, hintslight, hintmedium, hintfull -->
   <const>hintmedium</const>
  </edit>
 </match>
 <match target="font">
  <edit mode="assign" name="antialias">
   <bool>true</bool>
  </edit>
 </match>
</fontconfig>


Code:
# ls -al /var/lib/wdm/.fonts.conf
lrwxrwxrwx 1 root root 42 May 22 15:28 /var/lib/wdm/.fonts.conf -> /var/lib/wdm/.config/fontconfig/fonts.conf


/var/lib/wdm/GNUstep/Defaults/WMGLOBAL:
Code:
{
  MouseWheelDown = Button5;
  AntialiasedText = Yes;
  BoldSystemFont = "DejaVu Sans:slant=0:weight=200:width=100:pixelsize=11";
  DefaultFontSize = 11;
  DoubleClickTime = 250;
  FloppyPath = "/media/floppy";
  SystemFont = "DejaVu Sans:slant=0:weight=80:width=100:pixelsize=11";
  MouseWheelUp = Button4;
}



Edit 24/8/2015: adding some [ code ] markup tags for readability


Last edited by lost+found on Mon Aug 24, 2015 8:31 am; edited 1 time in total
Back to top
View user's profile Send private message
Altivo
n00b
n00b


Joined: 01 Aug 2015
Posts: 49
Location: Northern Illinois

PostPosted: Mon Aug 24, 2015 1:55 am    Post subject: Reply with quote

Thanks for the tips. Some of those things I had already done, others I didn't even know to look at. I should be able to adjust things and retry tomorrow.

As for starting wdm from the command line, the man page does say you can do that. Primarily for debugging, I'm sure, but that's what I'm still doing.
_________________
Have patience with me, I'm only half-baked.
--Altivo
Back to top
View user's profile Send private message
lost+found
Guru
Guru


Joined: 15 Nov 2004
Posts: 508
Location: North~Sea~Coa~s~~t~~~

PostPosted: Mon Aug 24, 2015 8:21 am    Post subject: Reply with quote

More random notes. Most probably also known. WDM really deserves a wiki...

Code:
/etc/hosts ;-)


Commands:
Code:
$ X :1 -query otherhost -from thishost
(Not in X. Ctrl-Alt-F1/F8 etc.: switching between terminal and remote login; DISPLAY :0 is F7)

$ Xephyr :1 -query otherhost -from thishost -screen 1280x1024
$ pkill -u $USER -f 'Xephyr :1 '
(Within WindowMaker/Fluxbox. Xephyr is installed by USE=kdrive (or xnest in some versions) on the x11-base/xorg-server package)


A script I stole from FVWM-Crystal, to be used in a (WindowMaker) menu or on the command line, to start another WM in Xephyr. This is only slightly related to wdm: I reserve DISPLAY :1 for a remote connection, and start other Xephyr sessions from DISPLAY :2 and up.
/usr/local/bin/launchwm:
Code:
#!/bin/sh
# Launch a nested session inside FVWM-Crystal using Xephyr
## Syntax: launchwm $[vp.width] $[vp.height] <wm>
# Syntax: launchwm <wm> <wm_title>

# next free $DISPLAY, needed for nested wm in nested wm :)
##XephyrDisplay=$((`echo $DISPLAY|cut -d: -f2|cut -d. -f1`+1))
XephyrDisplay="2"
while [ -e /tmp/.X11-unix/X$XephyrDisplay ]; do
   let XephyrDisplay=$XephyrDisplay+1
done
##
# nested session dimension; you can change it
#XephyrWidth=$((`echo $(($1-200))`))
#XephyrHeight=$((`echo $(($2-100))`))
##XephyrWidth=$1
##XephyrHeight=$2
XephyrWidth="1280"
XephyrHeight="1024"

##EXECWM=`grep Exec $3 | grep -v Try | sed -e 's:Exec=::'`


# launch Xephyr
##Xephyr -ac -reset -nolisten tcp -title `basename $EXECWM` -screen "$XephyrWidth"x"$XephyrHeight" :$XephyrDisplay &
Xephyr :$XephyrDisplay -nolisten tcp -screen ${XephyrWidth}x${XephyrHeight} \
-title "$2 op :$XephyrDisplay (Ctrl+Shift regelt muis en toetsenbord) - Xephyr" &
##XEPHYR_PID=`echo $!`

# wait and bring Xephyr in full screen
sleep 0.4
##FvwmCommand "All (Xephyr) Fullscreen-Start"

# launch the wm
### We dont want the fvwm and fvwm-themes files to be mixed with fvwm-crystal
##ENVWM=`basename $EXECWM`
##if [ "$ENVWM" = "fvwm-themes-start" ] ; then
##    FVWM_USERDIR="${HOME}/.fvwm" DISPLAY=:$XephyrDisplay $EXECWM 2>/dev/null
##else
##    if [ "$ENVWM" = "fvwm" ] ; then
##   FVWM_USERDIR="/${HOME}/.fvwm" DISPLAY=:$XephyrDisplay $EXECWM 2>/dev/null
##    else
##   DISPLAY=:$XephyrDisplay $EXECWM 2>/dev/null
   DISPLAY=":$XephyrDisplay" $1
##    fi
##fi

# stop Xephyr
##FvwmCommand "All (Xephyr) Fullscreen-Stop"
sleep 0.2
kill $!


Iptables:
Code:
DISPLAY :0 = tcp port 6000 (Shouldn't be there, when `-nolisten tcp' is used)
DISPLAY :1 = tcp port 6001 (accept for specified hosts, in and out)
DISPLAY :2 = tcp port 6002 (accept for specified hosts, in and out)
etc.
WDM udp listen port 177 (accept for specified hosts, in and out)
There's a random tcp port too. Don't know it's purpose, and never saw connection attempts. (drop/not accept all)

Remote X the wdm way, is not suitable for non-trusted networks. Possitive point: it's FAST!


/etc/X11/wdm/wdm-config:
Code:
DisplayManager._0.wdmWm:           WindowMaker:FVWM-Crystal:FVWM
DisplayManager*wdmWm:           WindowMaker
(I don't want to use FVWM on remote connections, because the menus are slow. Here you can put Fluxbox, to get the login menu option: _0 = DISPLAY :0, * = DISPLAY :1 and up)


Code:
~/.wm_style: Last used WM by wdm

~/.xsession: if this file exists, the selected WM menu entry is ignored
Back to top
View user's profile Send private message
Altivo
n00b
n00b


Joined: 01 Aug 2015
Posts: 49
Location: Northern Illinois

PostPosted: Mon Aug 24, 2015 2:05 pm    Post subject: Reply with quote

Thanks again. You've at least solved one problem for me: I didn't realize that I needed to add scripting to get fluxbox started. I had added it in wdm-config but not in Xclients. All the other familiar window managers are in there, but fluxbox was omitted. After adding an option for fluxbox, wdm is able to start a fluxbox session just as it already could do WindowMaker.

The big puzzle is still why wdm can't start up on the local vt7. It tries, and fails. So far I've not been able to get any debug or error information on why this failure happens. You can see it start to paint the background, then there's a flash and it flips back to the last text console session that was used. And it isn't because the local X server can't run. With startx or xinit a session can be opened there and runs normally. But getting wdm to place a login panel there to begin a session has so far failed every time.

I did have wdm inserted into /etc/conf.d/xdm and it is possible to start wdm with
Code:

sudo /etc/init.d/xdm start


That does get wdm running and makes it possible to connect remote X sessions to the Alpha. But wdm still fails when it tries to put the greeter panel up on the local vt7. Generally there are two tries that I can see, then it gives up.
_________________
Have patience with me, I'm only half-baked.
--Altivo
Back to top
View user's profile Send private message
lost+found
Guru
Guru


Joined: 15 Nov 2004
Posts: 508
Location: North~Sea~Coa~s~~t~~~

PostPosted: Mon Aug 24, 2015 3:05 pm    Post subject: Reply with quote

Just a guess... wdm has a default $HOME directory path compiled in: /var/run/wdm. Does this directory really exist? I think it's installed once, but since a few years /var/run has become a symlink to /run (tmpfs!), and the contents won't survive a reboot. That's the reason I recompiled wdm with the `--with-fakehome=/var/lib/wdm' configure option (for fontconfig files).


Edit: removed 'Never tried the greeter. ' I confused it with the Chooser.


Last edited by lost+found on Mon Aug 24, 2015 8:46 pm; edited 1 time in total
Back to top
View user's profile Send private message
Altivo
n00b
n00b


Joined: 01 Aug 2015
Posts: 49
Location: Northern Illinois

PostPosted: Mon Aug 24, 2015 5:51 pm    Post subject: Reply with quote

As a quick test of that, I created /var/lib/wdm and made a soft link from /var/run/wdm to it. Restarted xdm (really wdm) and still the same results. Two attempts and a black screen.

/var/log/xdm-errors.log has this:


    ...
    X Error of failed request: BadMatch (invalid parameter attributes)
    Major opcode of failed request: 2 (X_ChangeWindowAttributes)
    Serial number of failed request: 1340
    Current serial number in output stream: 1342
    Greet: guarenteed_read error, UNMANAGE DISPLAY
    Greet: pipe read error with /usr/bin/wdmLogin
    Server crash rate too high: removing display :0
    (EE) Server terminated successfully (0). Closing log file.


I've been resisting the urge to fix that misspelling "guarenteed" because there clearly are worse issues here. ;-p
_________________
Have patience with me, I'm only half-baked.
--Altivo
Back to top
View user's profile Send private message
lost+found
Guru
Guru


Joined: 15 Nov 2004
Posts: 508
Location: North~Sea~Coa~s~~t~~~

PostPosted: Mon Aug 24, 2015 6:58 pm    Post subject: Reply with quote

Too bad wdm is unmaintained upstream. I hope it's not bit rotting away. The project development has been handed over, but after that no new release followed. The last dev still seems interested in Window Maker development though. On Github he made some changes related to the greeter, but I can't read C unfortunately.
Back to top
View user's profile Send private message
Altivo
n00b
n00b


Joined: 01 Aug 2015
Posts: 49
Location: Northern Illinois

PostPosted: Mon Aug 24, 2015 8:11 pm    Post subject: Reply with quote

I can read it a little, but not well enough to mess with someone else's code. It's often said that C is a "write only" or a "write once, read never" language and I'm inclined to agree.

In this particular case, I'm more inclined to suspect that my configuration is somehow incomplete, since wdm works in about half the test conditions I've tried. The lack of clear diagnostics I'd lay at the feet of Xorg, since they and XFree86 before them have always been horribly obtuse about telling you what went wrong.

Maybe a better release will come along. At least startx does work at the console, and I have only one remote machine where I'd really like to get in through wdm but it's shut out. The other remotes all work.

The odd machine out is a Raspberry Pi, and I've noticed that remote nodes often think it is a Macintosh, which may have some bearing on the problem. Or not.
_________________
Have patience with me, I'm only half-baked.
--Altivo
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum