Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
eselect-lapack/blas/cblas is blocking *-reference & gls
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
chi86
Apprentice
Apprentice


Joined: 30 Jul 2013
Posts: 165
Location: Austria

PostPosted: Fri Dec 18, 2015 12:52 pm    Post subject: eselect-lapack/blas/cblas is blocking *-reference & gls Reply with quote

Hi,
I got some problems with the science overlay ...

When I do:
Code:
emerge --update --deep --newuse --with-bdeps=y --quiet-build y world

I get:
Code:

[uninstall     ] sci-libs/lapack-reference-3.6.0-r1
[uninstall     ] sci-libs/cblas-reference-20151113-r2
[blocks B      ] app-eselect/eselect-lapack ("app-eselect/eselect-lapack" is blocking sci-libs/blas-reference-20151113-r1, app-admin/eselect-1.4.5-r103, sci-libs/gsl-1.16-r2, sci-libs/cblas-reference-20151113-r2, sci-libs/lapack-reference-3.6.0-r1)
[blocks B      ] app-eselect/eselect-blas ("app-eselect/eselect-blas" is blocking sci-libs/lapack-reference-3.6.0-r1, sci-libs/gsl-1.16-r2, sci-libs/cblas-reference-20151113-r2, sci-libs/blas-reference-20151113-r1, virtual/blas-2.1-r4, app-admin/eselect-1.4.5-r103)
[blocks B      ] app-eselect/eselect-cblas ("app-eselect/eselect-cblas" is blocking sci-libs/lapack-reference-3.6.0-r1, sci-libs/cblas-reference-20151113-r2, sci-libs/gsl-1.16-r2, sci-libs/blas-reference-20151113-r1)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (virtual/blas-2.1-r4:0/0::science, installed) pulled in by
    virtual/blas required by (dev-libs/igraph-0.7.1-r1:0/0::gentoo, installed)
    virtual/blas:0 required by (dev-lang/R-3.2.2:0/0::gentoo, installed)
    virtual/blas required by (sci-libs/umfpack-5.6.2:0/0::gentoo, installed)
    =virtual/blas-2.1-r4 required by (sci-libs/qrupdate-1.1.0:0/0::gentoo, installed)
    virtual/blas required by (dev-python/cvxopt-1.1.8:0/0::sage-on-gentoo, installed)
    virtual/blas required by (sci-libs/arpack-3.1.3-r1:0/0::gentoo, installed)
    =virtual/blas-2.1-r4 required by (sci-libs/arpack-3.1.3-r1:0/0::gentoo, installed)
    =virtual/blas-2.1-r4 required by (sci-libs/umfpack-5.6.2:0/0::gentoo, installed)
    =virtual/blas-2.1-r4 required by (dev-libs/igraph-0.7.1-r1:0/0::gentoo, installed)
    virtual/blas required by @selected
    =virtual/blas-2.1-r4 required by (dev-lang/R-3.2.2:0/0::gentoo, installed)
    virtual/blas required by (sci-libs/qrupdate-1.1.0:0/0::gentoo, installed)
    =virtual/blas-2.1-r4 required by (dev-python/cvxopt-1.1.8:0/0::sage-on-gentoo, installed)

  (sci-libs/gsl-1.16-r2:0/0::science, installed) pulled in by
    sci-libs/gsl:0/0= required by (dev-python/cvxopt-1.1.8:0/0::sage-on-gentoo, installed)
    sci-libs/gsl required by (sci-mathematics/gmp-ecm-6.4.4-r2:0/0::sage-on-gentoo, installed)
    sci-libs/gsl required by (media-gfx/inkscape-0.48.5-r1:0/0::gentoo, installed)
    >=sci-libs/gsl-1.16 required by (sci-mathematics/sage-6.9:0/0::sage-on-gentoo, installed)
    sci-libs/gsl required by (mail-filter/bogofilter-1.2.4-r1:0/0::gentoo, installed)
    sci-libs/gsl[-cblas-external] required by (virtual/cblas-1.0:0/0::gentoo, installed)
    sci-libs/gsl:0= required by (dev-python/cvxopt-1.1.8:0/0::sage-on-gentoo, installed)

  (app-eselect/eselect-lapack-0.1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    app-eselect/eselect-lapack required by (sci-libs/mkl-10.0.5.025:0/0::gentoo, installed)

  (app-eselect/eselect-blas-0.1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    app-eselect/eselect-blas required by (sci-libs/mkl-10.0.5.025:0/0::gentoo, installed)

  (app-eselect/eselect-cblas-0.1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    app-eselect/eselect-cblas required by (sci-libs/mkl-10.0.5.025:0/0::gentoo, installed)

  (app-admin/eselect-1.4.5-r103:0/0::science, installed) pulled in by
    >=app-admin/eselect-1.2.4 required by (app-eselect/eselect-mesa-0.0.10:0/0::gentoo, installed)
    >=app-admin/eselect-1.2.4 required by (app-eselect/eselect-opengl-1.3.1-r4:0/0::gentoo, installed)
    >=app-admin/eselect-1.0.6 required by (app-eselect/eselect-vi-1.1.7-r1:0/0::gentoo, installed)
    app-admin/eselect required by (app-eselect/eselect-java-0.1.0:0/0::gentoo, installed)
    app-admin/eselect required by @selected
    >=app-admin/eselect-1.4.5-r103 required by (sci-libs/blas-reference-20151113-r1:0/3.6.0::science, installed)
    >=app-admin/eselect-1.2.4 required by (app-eselect/eselect-qtgraphicssystem-1.1.1:0/0::gentoo, installed)
    app-admin/eselect required by (app-eselect/eselect-wxwidgets-20140423:0/0::gentoo, installed)
    >=app-admin/eselect-1.2.6 required by (app-eselect/eselect-emacs-1.18:0/0::gentoo, installed)
    >=app-admin/eselect-1.0.2 required by (app-eselect/eselect-ruby-20131227:0/0::gentoo, installed)
    app-admin/eselect required by (app-eselect/eselect-gnome-shell-extensions-20120911:0/0::gentoo, installed)
    >=app-admin/eselect-1.2.3 required by (app-eselect/eselect-ctags-1.18:0/0::gentoo, installed)
    >=app-admin/eselect-1.2 required by (sys-apps/portage-2.2.24:0/0::gentoo, ebuild scheduled for merge)
    >=app-admin/eselect-1.2.3 required by (app-eselect/eselect-python-20151117-r1:0/0::gentoo, ebuild scheduled for merge)
    >=app-admin/eselect-1.2.3 required by (app-eselect/eselect-pdftex-0.3:0/0::gentoo, installed)
    >=app-admin/eselect-1.2.4 required by (app-eselect/eselect-php-0.7.1-r4:0/0::gentoo, installed)
    >=app-admin/eselect-1.2.3 required by (app-eselect/eselect-fontconfig-1.1:0/0::gentoo, installed)
    app-admin/eselect required by (app-eselect/eselect-lib-bin-symlink-0.1.1:0/0::gentoo, installed)
    >=app-admin/eselect-1.0.5 required by (app-eselect/eselect-cblas-0.1:0/0::gentoo, ebuild scheduled for merge)
    >=app-admin/eselect-1.0.5 required by (app-eselect/eselect-lapack-0.1:0/0::gentoo, ebuild scheduled for merge)
    >=app-admin/eselect-1.0.5 required by (app-eselect/eselect-blas-0.1:0/0::gentoo, ebuild scheduled for merge)
    >=app-admin/eselect-1.4.5-r103 required by (sci-libs/gsl-1.16-r2:0/0::science, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


And I can't get rid of it .... Any idears?
Back to top
View user's profile Send private message
wpettersson
n00b
n00b


Joined: 04 Jun 2014
Posts: 16

PostPosted: Sat Dec 26, 2015 4:20 am    Post subject: Reply with quote

The science overlay don't use eselect-{lapack,blas,cblas} from the official portage. They instead using something called "alternatives-2" in their own slightly modified version of eselect, which blocks those eselect-* packages. However, some things in official portage still use eselect-* which is causing the issue. I think the solution for you is to keyword a higher version of sci-libs/mkl, a version that is in the science overlay rather than official portage.

Edit: I'm working through a similar problem myself at the moment. https://wiki.gentoo.org/wiki/User_talk:Houseofsuns is something I just found which might help.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum