Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Why is net.br0 trying to start?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
eborg
n00b
n00b


Joined: 20 Sep 2014
Posts: 9

PostPosted: Fri Aug 14, 2015 1:53 am    Post subject: Why is net.br0 trying to start? Reply with quote

I am getting this message when booting a diskless node. I do not have a net.br0 link within /etc/runlevels/boot, nor do I have a br interfaced configured within /etc/conf.d/net, so I'm still not sure why it's trying to start. I do have 802.1d bridging configured in the kernel.

Any thoughts?

Code:
* Bringing up interface br0
*   ERROR: interface br0 does not exist
*   Ensure that you have loaded the correct kernel module for your hardware
*   ERROR: net.br0 failed to start
*   ERROR: cannot start netmount as net.br0 would not start
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2659

PostPosted: Fri Aug 14, 2015 6:18 am    Post subject: Re: Why is net.br0 trying to start? Reply with quote

eborg wrote:
I am getting this message when booting a diskless node. I do not have a net.br0 link within /etc/runlevels/boot, nor do I have a br interfaced configured within /etc/conf.d/net, so I'm still not sure why it's trying to start. I do have 802.1d bridging configured in the kernel.

Any thoughts?

Code:
* Bringing up interface br0
*   ERROR: interface br0 does not exist
*   Ensure that you have loaded the correct kernel module for your hardware
*   ERROR: net.br0 failed to start
*   ERROR: cannot start netmount as net.br0 would not start

Sounds like your computer tried starting netmount. To remove it:
Code:
# /etc/init.d/netmount stop && rc-update del netmount

Then again check rc-config show --all.
Back to top
View user's profile Send private message
eborg
n00b
n00b


Joined: 20 Sep 2014
Posts: 9

PostPosted: Fri Aug 14, 2015 6:58 am    Post subject: Re: Why is net.br0 trying to start? Reply with quote

charles17 wrote:
Sounds like your computer tried starting netmount. To remove it:
Code:
# /etc/init.d/netmount stop && rc-update del netmount

Well, it is a diskless node which mounts it's file system from an NFSv4 export from the main node. The boot process ends up w/ the following, so I am unable to yet login to the console.
Code:
INIT: Id "c1" respawning too fast: disabled for 5 minutes
INIT: no more processes left in this runlevel

And therefore rc-update isn't an option. And even if it were, / is read-only. My RW's are tmpfs's. Any adjustments to /etc/runlevels is done manually w/ sym links. Besides, I believe I require netmount. I actually have a few other errors afterwards, but I'm taking it one error at a time.
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2659

PostPosted: Fri Aug 14, 2015 7:07 am    Post subject: Re: Why is net.br0 trying to start? Reply with quote

Can you chroot into that box? Then set rc_interactive="YES" in /etc/rc.conf and on beginning of reboot press I to get into the interactive mode.
There you will see which service starts the br0 crap.
Back to top
View user's profile Send private message
szatox
Veteran
Veteran


Joined: 27 Aug 2013
Posts: 1762

PostPosted: Fri Aug 14, 2015 5:14 pm    Post subject: Reply with quote

try '/etc/init.d/net.br0 needsme'
Also, it provides net, needed by quite a few daemons, so if you set rc_br0_provide=" !net" those services will no longer start it. Not 100% sure about exact variable name, but you certainly get the point.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum