Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
app-text/datovka complaining about absent 'ssl' module
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
pavel.stratil
Tux's lil' helper
Tux's lil' helper


Joined: 23 Oct 2005
Posts: 134

PostPosted: Thu Aug 13, 2015 7:13 am    Post subject: app-text/datovka complaining about absent 'ssl' module Reply with quote

I probably broke a piece of my python installation. Datovka (previously working) now refuses to start. The error message is


Code:
Your Python installation does not contain the ssl module used to verify server certificates, etc. For security reasons, Datovka does not support such installations.

HINT: You can use version 0.4.1 of dsgui which does not require the 'ssl' module.


I tried running python-updater, revep-rebuild, etc., unmerged and reemerged datovka to no avail. Any hints please? TIA!
_________________
Senbonzakura
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Thu Aug 13, 2015 8:00 am    Post subject: Reply with quote

Code:
eix dev-lang/python
[I] dev-lang/python
     Available versions: 
     (2.7)  2.7.9-r1 (~)2.7.9-r2 (~)2.7.10
     (3.3)  3.3.5-r1
     (3.4)  (~)3.4.0 3.4.1 (~)3.4.2 (~)3.4.3
       {-berkdb build doc examples gdbm hardened ipv6 +ncurses +readline sqlite +ssl +threads tk +wide-unicode wininst +xml ELIBC="uclibc"}
     Installed versions:  2.7.10(2.7)(07:46:16 29.05.2015)(gdbm ipv6 ncurses readline sqlite ssl threads tk wide-unicode xml -berkdb -build -doc -examples -hardened -wininst ELIBC="-uclibc") 3.4.3(3.4)(13:02:57 03.03.2015)(gdbm ipv6 ncurses readline sqlite ssl threads tk xml -build -examples -hardened -wininst ELIBC="-uclibc")
     Homepage:            http://www.python.org/
     Description:         An interpreted, interactive, object-oriented programming language



... 2.7.10(2.7)(07:46:16 29.05.2015)(... ssl...

Did you enalbed ssl flag for this package?, see my example above ...
Back to top
View user's profile Send private message
pavel.stratil
Tux's lil' helper
Tux's lil' helper


Joined: 23 Oct 2005
Posts: 134

PostPosted: Thu Aug 13, 2015 10:54 am    Post subject: Reply with quote

yep, here's my

Code:
uuu ~ # eix dev-lang/python
[I] dev-lang/python
     Available versions: 
     (2.7)  2.7.9-r1 ~2.7.9-r2 ~2.7.10
     (3.3)  3.3.5-r1
     (3.4)  ~3.4.0 3.4.1 ~3.4.2 ~3.4.3
       {-berkdb build doc examples gdbm hardened ipv6 +ncurses +readline sqlite +ssl +threads tk +wide-unicode wininst +xml ELIBC="uclibc"}
     Installed versions:  2.7.9-r1(2.7)(07:42:45 AM 07/28/2015)(gdbm ipv6 ncurses readline sqlite ssl threads wide-unicode xml -berkdb -build -doc -examples -hardened -tk -wininst ELIBC="-uclibc") 3.3.5-r1(3.3)(11:06:56 PM 10/05/2014)(gdbm ipv6 ncurses readline sqlite ssl threads xml -build -doc -examples -hardened -tk -wininst ELIBC="-uclibc") 3.4.1(3.4)(08:20:59 AM 07/28/2015)(gdbm ipv6 ncurses readline sqlite ssl threads xml -build -examples -hardened -tk -wininst ELIBC="-uclibc")
     Homepage:            http://www.python.org/
     Description:         An interpreted, interactive, object-oriented programming language

_________________
Senbonzakura
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Thu Aug 13, 2015 4:59 pm    Post subject: Reply with quote

you need to find out which package provide ssl for your application..

i assume you already have ssl set accordingly in make.conf, right?
Back to top
View user's profile Send private message
pavel.stratil
Tux's lil' helper
Tux's lil' helper


Joined: 23 Oct 2005
Posts: 134

PostPosted: Fri Aug 14, 2015 10:32 am    Post subject: Reply with quote

exactly
_________________
Senbonzakura
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum