Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
google-chrome-stable processes linger, browser oddities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
dman777
l33t
l33t


Joined: 10 Jan 2007
Posts: 914

PostPosted: Mon Aug 10, 2015 7:40 pm    Post subject: google-chrome-stable processes linger, browser oddities Reply with quote

I am having a strange issue with google-chrome. When I close the browser, there will still be processes running...even though I have the option disabled to run apps after browser is closed:


Code:
4 S one      12906     1  0  80   0 -  1589 wait   14:41 ?        00:00:00 /opt/google/chrome/chrome-sandbox /opt/google/chrome/chrome --type=zygote
4 S one      12908 12906  0  80   0 - 111551 wait  14:41 ?        00:00:00 /opt/google/chrome/chrome --type=zygote
4 S one      12910 12908  0  80   0 -  1589 wait   14:41 ?        00:00:00 /opt/google/chrome/chrome-sandbox /opt/google/chrome/nacl_helper
4 S one      12911 12910  0  80   0 - 28139 skb_re 14:41 ?        00:00:00 /opt/google/chrome/nacl_helper
1 S one      12913 12908  0  80   0 - 111551 skb_re 14:41 ?       00:00:00 /opt/google/chrome/chrome --type=zygote
0 S one      12930     1  0  80   0 - 110311 poll_s 14:41 ?       00:00:00 /opt/google/chrome/chrome --type=gpu-process --channel=12896.0.1519079863 --v8-natives-passed-by-fd --v8-snapshot-passed-by-fd --supports-dual-gpus=false --gpu-driver-bug-workarounds=2,8,15,45,57 --disable-accelerated-video-decode --gpu-vendor-id=0x8086 --gpu-device-id=0x0162 --gpu-driver-vendor --gpu-driver-version --v8-natives-passed-by-fd --v8-snapshot-passed-by-fd
1 S one      12950 12930  0  80   0 - 108262 skb_re 14:41 ?       00:00:00 /opt/google/chrome/chrome --type=gpu-broker                                                                                                                                                                                                                                                                                                                           
1 S one      12955     1  0  80   0 - 180841 futex_ 14:41 ?       00:00:00 /opt/google/chrome/chrome --extra-plugin-dir=/usr/lib64/nsbrowser/plugins --extra-plugin-dir=/usr/lib64/nsbrowser/plugins --extra-plugin-dir=/usr/lib64/nsbrowser/plugins   
0 S one      13261 13010  0  80   0 - 28148 pipe_w 14:43 pts/10   00:00:00 grep --colour=auto -i chrome


Also, sometimes when I try to start a browser session the gui never comes up and I have to manually kill all the processes and restart the browser.

I am using

Code:
one@localhost ~/github/ucp $ google-chrome-stable --version
Google Chrome 44.0.2403.130
one@localhost ~/github/ucp $


Anyone know what is going on?
_________________
<h5>Checkout <em>#grandmasboy</em> on <em>freenode</em>...chat with jayP bot from the movie!</h5>
Back to top
View user's profile Send private message
russK
l33t
l33t


Joined: 27 Jun 2006
Posts: 618

PostPosted: Tue Aug 11, 2015 2:55 am    Post subject: Reply with quote

I have noticed this from time to time myself.

I have made a habit of using "Exit" from the menu, instead of hitting the 'x' in the upper right (to kill the window, that's where I have it on gnome).

I believe that using Exit from the menu helps tell the application that you are really done with it, since the 'x' on the frame might only kill one set of tabs, I often right-click on a link and select "Open link in new window". Additionally, some extensions seem to have a life of their own. Hangouts is one that seems to hang around even if you select Exit from the menu. So possibly there is an extension that is not paying attention or is not killed when the main chrome app loses track and decides to quit.

For a while I was in the habit of launching chrome from the command line so I could see if it really quit and I had a prompt when I though I was finished with it. If it was stubborn I would Ctrl-C it or issue a 'killall chrome' from another window.

Sorry I don't have a solution, except I tend to favor Exit from the menu and I kill the Hangouts extension if I am using it.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum