Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KDE 5 Upgrade
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Atmmac
Tux's lil' helper
Tux's lil' helper


Joined: 17 Oct 2013
Posts: 130
Location: Watertown, MA

PostPosted: Thu Aug 06, 2015 6:50 pm    Post subject: KDE 5 Upgrade Reply with quote

So i just finished doing the KDE upgrade. I went the full KDE4 removal before I did the upgrade. It was mainly this

eselect profile (set plasma for systemd or non systemd)

Remove KDE 4 via the gentoo wiki instructions https://wiki.gentoo.org/wiki/KDE/Removal

hit an emerge --unmerge kde-apps/* kde-base/* emerge --unmerge kdm

update the use flags to be -qt4 and -kde and add qt5 (make sure you have -upower if your systemd)

do an emerge --ask --changed-use --new-use --deep @world

emerge --depclean

revdep-rebuild for good measure

now hit the emerge --ask kde-plasma/plasma-meta (takes forever)

make sure you then install sddm with the KDE plugin

emerge --ask x11-misc/sddm kde-plasma/sddm-kcm

Mark it for automatic startup and disable old kdm

systemctl disable kdm

systemctl enable sddm

I had to put in the xrandr settings in Xsetup for SDDM since i have an optimus laptop. (i can shoot you in the right direction if this is needed just respond to the thread.)

At this point you should be good to go.

I figured Id let everyone know the exact steps I took. If I missed anything let me know.
Back to top
View user's profile Send private message
bdronka
n00b
n00b


Joined: 22 Jan 2015
Posts: 5

PostPosted: Fri Aug 07, 2015 6:47 pm    Post subject: Reply with quote

And what about the new version of kde -apps and kde -framework ?
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Fri Aug 07, 2015 7:10 pm    Post subject: Re: KDE 5 Upgrade Reply with quote

Atmmac wrote:
update the use flags to be -qt4 and -kde and add qt5 (make sure you have -upower if your systemd)

I disagree with that, qt4 should only selectively be disabled.

- no need for it, plasma profile should settle any conflicts
- it enables visual integration of legacy (kde4-based or qt4) packages inside a plasma-5 environment
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
mir3x
Guru
Guru


Joined: 02 Jun 2012
Posts: 427

PostPosted: Fri Aug 07, 2015 9:39 pm    Post subject: Reply with quote

Most important step before uninstalling KDE4 is to do installation state with demerge, so
you can easily revert changes.
_________________
Installation aborted to prevent system self-destruction
Back to top
View user's profile Send private message
Atmmac
Tux's lil' helper
Tux's lil' helper


Joined: 17 Oct 2013
Posts: 130
Location: Watertown, MA

PostPosted: Mon Aug 10, 2015 1:27 pm    Post subject: Re: KDE 5 Upgrade Reply with quote

genstorm wrote:
Atmmac wrote:
update the use flags to be -qt4 and -kde and add qt5 (make sure you have -upower if your systemd)

I disagree with that, qt4 should only selectively be disabled.

- no need for it, plasma profile should settle any conflicts
- it enables visual integration of legacy (kde4-based or qt4) packages inside a plasma-5 environment


I would have thought the same but I hit serious blockers when trying to do it using only the profile. I put qt4 in package.use where necessary going forward (portage actually takes care of this for you in combination with etc-update).
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Mon Aug 10, 2015 1:37 pm    Post subject: Re: KDE 5 Upgrade Reply with quote

You should not hit blockers when you do not set qt4 in make.conf at all (that's different than -qt4). That way you do get qt4 where really recommended (e.g. in plasma-desktop and breeze) without having to find out through missing features/integration. If you did, it would have been interesting exactly what's the problem.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Atmmac
Tux's lil' helper
Tux's lil' helper


Joined: 17 Oct 2013
Posts: 130
Location: Watertown, MA

PostPosted: Mon Aug 10, 2015 7:15 pm    Post subject: Reply with quote

Still have blockers if I remove the -qt4

Code:
poweradv-amac andy # emerge --ask --changed-use --update --deep @world

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/libgcrypt:0

  (dev-libs/libgcrypt-1.5.4-r1:0/11::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/libgcrypt-1.6.3:0/20::gentoo, installed) pulled in by
    >=dev-libs/libgcrypt-1.2.2:0/20= required by (app-crypt/libsecret-0.18.2:0/0::gentoo, installed)
                              ^^^^^^                                                                                                   
    >=dev-libs/libgcrypt-1.6.2 required by (app-crypt/gnupg-2.1.6:0/0::gentoo, installed)
    ^^                   ^^^^^                                                                                                                 
    (and 2 more with the same problems)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


!!! The ebuild selected to satisfy ">=media-video/vlc-2.0.1:0/5-8=[dbus,ogg,vorbis]" has unmet requirements.
- media-video/vlc-2.2.1::gentoo USE="X a52 alsa avcodec avformat cdda dbus dts dvbpsi dvd encode ffmpeg flac gcrypt ieee1394 jpeg kde libnotify libsamplerate mp3 mpeg ncurses ogg opengl png qt4 qt5 samba sdl svg swscale truetype udev v4l vorbis x264 xcb xml xv -aalib (-altivec) -atmo (-audioqueue) -bidi -bluray -cddb -chromaprint -dc1394 -debug -directfb (-directx) -dvb (-dxva2) -faad -fdk -fluidsynth -fontconfig -gme -gnome -gnutls -growl -httpd -jack -kate -libass -libav -libcaca -libtar -libtiger -linsys -lirc -live -lua (-macosx-dialog-provider) (-macosx-eyetv) (-macosx-qtkit) (-macosx-quartztext) -matroska (-media-library) -modplug -mtp -musepack (-neon) -omxil -opencv -optimisememory -opus -postproc -projectm -pulseaudio -rdp -rtsp -run-as-root -schroedinger -sdl-image -sftp -shout -sid -skins -speex -taglib -test -theora -tremor -twolame -upnp -vaapi -vcdx -vdpau -vlm -vnc -vpx -wma-fixed -x265 -zeroconf -zvbi" ABI_X86="64" CPU_FLAGS_X86="mmx sse"

  The following REQUIRED_USE flag constraints are unsatisfied:
    qt4? ( !qt5 ) qt5? ( !qt4 )

  The above constraints are a subset of the following complete expression:
    aalib? ( X ) bidi? ( truetype ) cddb? ( cdda ) dvb? ( dvbpsi ) dxva2? ( avcodec ) ffmpeg? ( avcodec avformat swscale ) fontconfig? ( truetype ) gnutls? ( gcrypt ) httpd? ( lua ) libcaca? ( X ) libtar? ( skins ) libtiger? ( kate ) qt4? ( X !qt5 ) qt5? ( X !qt4 ) sdl? ( X ) skins? ( truetype X exactly-one-of ( qt4 qt5 ) ) vaapi? ( avcodec X ) vlm? ( encode ) xv? ( xcb )

(dependency required by "media-libs/phonon-vlc-0.8.2::gentoo" [installed])
(dependency required by "media-libs/phonon-4.8.3-r1::gentoo[vlc]" [installed])
(dependency required by "kde-base/kdelibs-4.14.10::gentoo" [installed])
(dependency required by "kde-base/katepart-4.14.3::gentoo[handbook]" [installed])
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Mon Aug 10, 2015 7:31 pm    Post subject: Reply with quote

Quote:
!!! The ebuild selected to satisfy ">=media-video/vlc-2.0.1:0/5-8=[dbus,ogg,vorbis]" has unmet requirements.
- media-video/vlc-2.2.1::gentoo USE="X a52 alsa avcodec avformat cdda dbus dts dvbpsi dvd encode ffmpeg flac gcrypt ieee1394 jpeg kde libnotify libsamplerate mp3 mpeg ncurses ogg opengl png qt4 qt5 samba sdl svg swscale truetype udev v4l vorbis x264 xcb xml xv -aalib (-altivec) -atmo (-audioqueue) -bidi -bluray -cddb -chromaprint -dc1394 -debug -directfb (-directx) -dvb (-dxva2) -faad -fdk -fluidsynth -fontconfig -gme -gnome -gnutls -growl -httpd -jack -kate -libass -libav -libcaca -libtar -libtiger -linsys -lirc -live -lua (-macosx-dialog-provider) (-macosx-eyetv) (-macosx-qtkit) (-macosx-quartztext) -matroska (-media-library) -modplug -mtp -musepack (-neon) -omxil -opencv -optimisememory -opus -postproc -projectm -pulseaudio -rdp -rtsp -run-as-root -schroedinger -sdl-image -sftp -shout -sid -skins -speex -taglib -test -theora -tremor -twolame -upnp -vaapi -vcdx -vdpau -vlm -vnc -vpx -wma-fixed -x265 -zeroconf -zvbi" ABI_X86="64" CPU_FLAGS_X86="mmx sse"

The following REQUIRED_USE flag constraints are unsatisfied:
qt4? ( !qt5 ) qt5? ( !qt4 )


Quote:
qt4? ( !qt5 )
vlc only allows qt4 or qt5 but not both !

Code:
grep vlc /etc/portage/package.use
please
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Mon Aug 10, 2015 7:35 pm    Post subject: Reply with quote

Ah yes, one of the last required_use annoyances. Problem is +qt4 inside ebuild which will conflict in a qt5 setup.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Atmmac
Tux's lil' helper
Tux's lil' helper


Joined: 17 Oct 2013
Posts: 130
Location: Watertown, MA

PostPosted: Mon Aug 10, 2015 7:41 pm    Post subject: Reply with quote

Realized the same TW.
Code:

poweradv-amac andy # grep vlc /etc/portage/package.use
# required by media-video/vlc-2.2.0::gentoo[samba]
# required by media-libs/phonon-vlc-0.8.2::gentoo
# required by media-libs/phonon-4.8.3::gentoo[vlc]
# required by media-libs/phonon-4.8.3-r1::gentoo[vlc]
>=media-libs/phonon-vlc-0.8.2 qt4
# required by media-libs/phonon-vlc-0.8.2::gentoo


changing the qt4 for it in package.use to -qt4 and removing the -qt4 from make.conf has no impact. Which seems odd to me.


Thanks,
-Andy
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Mon Aug 10, 2015 10:06 pm    Post subject: Reply with quote

genstorm wrote:
Ah yes, one of the last required_use annoyances. Problem is +qt4 inside ebuild which will conflict in a qt5 setup.


as genstorm, an ex devloper afaik, already wrote, it seems qt4 is hardcoded in that ebuild. or is required by vlc
Back to top
View user's profile Send private message
davidm
Guru
Guru


Joined: 26 Apr 2009
Posts: 557
Location: US

PostPosted: Mon Aug 10, 2015 10:18 pm    Post subject: Reply with quote

In package.use:

Code:

media-video/vlc qt5 -qt4


That should do it. At least it works fine here.
Back to top
View user's profile Send private message
joj_sport
n00b
n00b


Joined: 11 Aug 2015
Posts: 1

PostPosted: Tue Aug 11, 2015 7:14 pm    Post subject: Reply with quote

Hi guys,

so did someone of the forumers test Plasma 5?
Reviews would be v.apreciated :)
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Thu Aug 13, 2015 11:02 am    Post subject: Reply with quote

Atmmac wrote:
Still have blockers if I remove the -qt4

Thanks to your report, there's a fix pending for merge setting things straight for vlc and other ebuilds with an exactly-one-of setup, if you use the plasma profile.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Atmmac
Tux's lil' helper
Tux's lil' helper


Joined: 17 Oct 2013
Posts: 130
Location: Watertown, MA

PostPosted: Thu Aug 13, 2015 3:02 pm    Post subject: Reply with quote

Quote:
Thanks to your report, there's a fix pending for merge setting things straight for vlc and other ebuilds with an exactly-one-of setup, if you use the plasma profile.


Glad i made note of it then. It definitely confused me a bit.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum