Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
wicd won't connect to wireless network
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
HungGarTiger
Apprentice
Apprentice


Joined: 04 Feb 2014
Posts: 155
Location: /nz/auckland

PostPosted: Wed Aug 05, 2015 11:43 pm    Post subject: wicd won't connect to wireless network Reply with quote

Hi guys,

As stated in the topic wicd won't connect to my wireless network.

I've set up networkmanager, following the wiki https://wiki.gentoo.org/wiki/NetworkManager here verbatim. Including all the euse commands.

Now I don't want to use networkmanager because nm-applet pulls in too many gnome.3.14 packages for my liking. So I set up wicd, I can scan and see my network however when I connect it doesn't work. I've tried putting my password in the wireless-settingd.conf, which is here

Code:
[00:0E:8F:C5:94:34]
afterscript = None
dhcphostname = tux
bssid = 00:0E:8F:C5:94:34
encryption = True
use_global_dns = False
use_settings_globally = False
use_static_dns = False
usedhcphostname = False
encryption_method = WPA2
essid = vodafoneHJGC
postdisconnectscript = None
beforescript = None
hidden = False
predisconnectscript = None
channel = 6
mode = Master


Also, when I remove network manager from startup and add wicd like this

Code:
rc-update del NetworkManager default
rc-update add wicd default


my wired connection isn't started by wicd. (I can see it and it works when networkmanager is starting it). wired-settings.conf

Code:
[wired-default]
ip = None
broadcast = None
netmask = None
gateway = None
search_domain = None
dns_domain = None
dns1 = None
dns2 = None
dns3 = None
beforescript = None
afterscript = None
predisconnectscript = None
postdisconnectscript = None
encryption_enabled = None
default = True
dhcphostname = tux
lastused = True


My manager-settings.conf is here

Code:
[Settings]
backend = external
wireless_interface = wlp2s0
wired_interface = enp1s0
wpa_driver = wext
always_show_wired_interface = False
use_global_dns = False
global_dns_1 = None
global_dns_2 = None
global_dns_3 = None
global_dns_dom = None
global_search_dom = None
auto_reconnect = True
debug_mode = False
wired_connect_mode = 1
signal_display_type = 0
should_verify_ap = 1
dhcp_client = 0
link_detect_tool = 0
flush_tool = 0
sudo_app = 0
prefer_wired = False
show_never_connect = True


Any input would be fantastic!
Back to top
View user's profile Send private message
ian.au
Guru
Guru


Joined: 07 Apr 2011
Posts: 422
Location: Australia

PostPosted: Thu Aug 06, 2015 12:05 am    Post subject: Reply with quote

dhpcd and wpa_supplicant I guess. I haven't done it for ages: (I drank the kool-aid :)

Start here https://wiki.gentoo.org/wiki/Wpa_supplicant
and here https://wiki.gentoo.org/wiki/Network_management_using_DHCPCD
Back to top
View user's profile Send private message
Aiken
Apprentice
Apprentice


Joined: 22 Jan 2003
Posts: 210
Location: Toowoomba/Australia

PostPosted: Thu Aug 06, 2015 2:38 am    Post subject: Reply with quote

What happens if you use a client for wicd? From the cmd line I use wicd-client and from in kde I use the wicd thingy (my technical term for the day) in the system tray area. I can not recall ever editing any wicd config files and all laptops here use wicd.

There is a trap and from memory CONFIG_CFG80211_WEXT has to be configured in the kernel for wicd work properly. I think that is the offending option. Awhile since I played with that and that option is part of my standard config and not had to think about it for awhile.

Looking at the wicd network manager on the laptop next to me running kde I have

General Settings
wireless interface wlan0
wired interface eth0
always show wired interface not ticked
always switched to wired connection when available ticked

External Programs
all are set to auto

Advanced settings
driver nl80211
backend external
ping gateway after connecting

For each ssid I want to connect to auto connect is ticked, use encrtption is ticked and the pass phrase entered. This is with ap running wpa2. Wicd is auto connecting for me all all devices. Changes to wired if I plug in an ethernet cable and change back to wifi if I remove the ethernet cable.
_________________
Beware the grue.
Back to top
View user's profile Send private message
HungGarTiger
Apprentice
Apprentice


Joined: 04 Feb 2014
Posts: 155
Location: /nz/auckland

PostPosted: Thu Aug 06, 2015 3:13 am    Post subject: Reply with quote

Aiken wrote:
For each ssid I want to connect to auto connect is ticked, use encrtption is ticked and the pass phrase entered. This is with ap running wpa2. Wicd is auto connecting for me all all devices. Changes to wired if I plug in an ethernet cable and change back to wifi if I remove the ethernet cable.


Where are these option? When I try to "->" the config file for the network wicd-curses just closes.

I'm just using the wicd-curses to interact with wicd.
Back to top
View user's profile Send private message
Aiken
Apprentice
Apprentice


Joined: 22 Jan 2003
Posts: 210
Location: Toowoomba/Australia

PostPosted: Thu Aug 06, 2015 3:38 am    Post subject: Reply with quote

A bit more of a play and wicd thingy I use in kde is wicd-gtk. Running wicd-curses shift-p should take you to the preferences. In wicd-cuses

General -> wlan0, eth0, ticked are always switch, use default profile, automatically reconnect

External programs -> auto, auto, auto

Advanced -> nl80211, external, ping gateway

That should match my previous post. The options are across the bottom of the screen. To use the letters next to each option you need to hit shift-letter and not just the letter by itself.
_________________
Beware the grue.
Back to top
View user's profile Send private message
HungGarTiger
Apprentice
Apprentice


Joined: 04 Feb 2014
Posts: 155
Location: /nz/auckland

PostPosted: Thu Aug 06, 2015 9:26 pm    Post subject: Reply with quote

Thanks Aiken, I'll try those settings out. The only difference I have is I'm using wext as my wireless driver not nl8211.

The main issue I think I'm having is that nowhere does it ask me to enter the password for my network. I just attempt to connect and it fails. obviously because it's password protected. How are you supposed to enter the password for each network you want to connect to?
Back to top
View user's profile Send private message
Aiken
Apprentice
Apprentice


Joined: 22 Jan 2003
Posts: 210
Location: Toowoomba/Australia

PostPosted: Thu Aug 06, 2015 11:22 pm    Post subject: Reply with quote

Was long enough since I used the cmd line client I had forgotten hitting the right arrow was where you entered the password for that network. Looks like that might be a patch that fixes that in a possible unreleased version. Was used to the wicd-gtk behaviour of being asked for auth type and password if they were not already known.

After time playing with google seems a problem with 1.7.3. In the mean time I added =net-misc/wicd-1.7.3 to packages.mask and going back to 1.7.2.4 on all computers here that use it. With the earlier version hitting the right arrow takes me to the screen to select auth type and enter the password. Using wicd-curses from 1.7.2.4 my laptop just connected to an ap it has never connected to before.
_________________
Beware the grue.
Back to top
View user's profile Send private message
ian.au
Guru
Guru


Joined: 07 Apr 2011
Posts: 422
Location: Australia

PostPosted: Fri Aug 07, 2015 12:14 am    Post subject: Reply with quote

HungGarTiger wrote:
Thanks Aiken, I'll try those settings out. The only difference I have is I'm using wext as my wireless driver not nl8211.

What's necessitating use of the wext driver? https://wiki.gentoo.org/wiki/Wifi#WEXT
In particular from that link
Quote:
The "cfg80211 wireless extensions compatibility" option aka WEXT[3] will support old wireless-tools & iwconfig and will be needed only for exotic or very old devices.
does this apply to your hardware?
I'll bet NM builds magic functionality on top of the very minimal feature set supplied by WEXT and you need more glue to get it working without.

You could always use wpa_supplicant from my above link and use the cli to see whats going on (you can even build it with the qt use flag and have a Kde gui) :)
Back to top
View user's profile Send private message
Aiken
Apprentice
Apprentice


Joined: 22 Jan 2003
Posts: 210
Location: Toowoomba/Australia

PostPosted: Fri Aug 07, 2015 12:31 am    Post subject: Reply with quote

ian.au part of the problem is in 1.7.3 wicd-curses crashes when trying to enter the screen where you select auth type and enter the password. My initial thought was a config problem or the wext compatability bit which I always compile in. Once I had a bit more a play I finally hit the same problem as HungGarTiger with not being able to enter the password. Version 1.7.2.3 works and from what I found the fix will be in 1.7.4 when it is eventually released.

Wext problem or not there is a bug in wicd 1.7.3 giving the crash mentioned not allowing the password to be entered when using the cmd line client.
_________________
Beware the grue.
Back to top
View user's profile Send private message
ian.au
Guru
Guru


Joined: 07 Apr 2011
Posts: 422
Location: Australia

PostPosted: Fri Aug 07, 2015 1:46 am    Post subject: Reply with quote

Aiken wrote:
ian.au part of the problem is in 1.7.3 wicd-curses crashes when trying to enter the screen where you select auth type and enter the password. My initial thought was a config problem or the wext compatability bit which I always compile in. Once I had a bit more a play I finally hit the same problem as HungGarTiger with not being able to enter the password. Version 1.7.2.3 works and from what I found the fix will be in 1.7.4 when it is eventually released.

Wext problem or not there is a bug in wicd 1.7.3 giving the crash mentioned not allowing the password to be entered when using the cmd line client.

:) That wouldn't be a recommendation for Wicd, to my way of thinking. I used it previously, but not without problems. wpa_supplicant just worked better on my old x86 laptop that's why I recommended it.
Laptop's been dead for a year, replaced with a chromebook, so unfortunately I don't have the means to revise my setup of it now, and my advice could well be dated.
Back to top
View user's profile Send private message
Aiken
Apprentice
Apprentice


Joined: 22 Jan 2003
Posts: 210
Location: Toowoomba/Australia

PostPosted: Fri Aug 07, 2015 3:13 am    Post subject: Reply with quote

Now for the reason that should annoy some, I know it annoyed me before I walked away from computer support. I do it this way because that is the way I have always done it.

Had enough trouble with network manager I never want to see it again. With running wpa_supplicant directly I have only done that with 1 machine and that is an eeepc where I bridge eth0 and wlan0 to use wifi to connect an isolated wired network to the main network. Until this thread I was happy to way wicd problem free for me. Must not have used the cmd line client since before 1.7.3 went live.
_________________
Beware the grue.
Back to top
View user's profile Send private message
ian.au
Guru
Guru


Joined: 07 Apr 2011
Posts: 422
Location: Australia

PostPosted: Fri Aug 07, 2015 4:31 am    Post subject: Reply with quote

Aiken wrote:
Now for the reason that should annoy some, I know it annoyed me before I walked away from computer support. I do it this way because that is the way I have always done it.

Had enough trouble with network manager I never want to see it again. With running wpa_supplicant directly I have only done that with 1 machine and that is an eeepc where I bridge eth0 and wlan0 to use wifi to connect an isolated wired network to the main network. Until this thread I was happy to way wicd problem free for me. Must not have used the cmd line client since before 1.7.3 went live.


I don't think there's anything that would particularly annoy anyone in this thread? We all use what works for us, because there's typically >1 way of doing things, who is to say which is better?
Back to top
View user's profile Send private message
HungGarTiger
Apprentice
Apprentice


Joined: 04 Feb 2014
Posts: 155
Location: /nz/auckland

PostPosted: Mon Aug 10, 2015 4:25 am    Post subject: Reply with quote

Hi guys,

Thanks for the info!

Yes I did wonder why wicd kept crashing every time I wanted to do something with a specific network. At least I know that the problem isn't between the chair and the keyboard, so that is a step in the right direction!

ian.au wrote:
What's necessitating use of the wext driver? https://wiki.gentoo.org/wiki/Wifi#WEXT
In particular from that link
Quote:
The "cfg80211 wireless extensions compatibility" option aka WEXT[3] will support old wireless-tools & iwconfig and will be needed only for exotic or very old devices.
does this apply to your hardware?


The wicd wiki page specifically says

Quote:
Wicd is not able to scan for Wireless Networks while using the new nl80211 Interface

As stated here there is a known bug in Wicd that prevents Wicd using the new nl80211 kernel interface Scanning for Wireless Networks, even if you change the Wicd config to use the new interface. There is currently no working workaround for this. Be sure to enable the cfg80211 - wireless configuration API in your kernel using the kernel option suggested above and select wext as the driver.


Which is which I'm using the wext driver. I'll give the wpa_supplicant-cli or qt a quick bash and let you guys know how it goes as it seems no progress will be made using wicd untill 1.7.4 becomes available.
Back to top
View user's profile Send private message
HungGarTiger
Apprentice
Apprentice


Joined: 04 Feb 2014
Posts: 155
Location: /nz/auckland

PostPosted: Mon Aug 10, 2015 7:33 am    Post subject: Reply with quote

no luck so far with wpa_gui.

When I load it just says "Could not get status from wpa_supplicant." Running as root also doesn't change this.
Back to top
View user's profile Send private message
ian.au
Guru
Guru


Joined: 07 Apr 2011
Posts: 422
Location: Australia

PostPosted: Mon Aug 10, 2015 10:37 am    Post subject: Reply with quote

HungGarTiger wrote:
no luck so far with wpa_gui.

When I load it just says "Could not get status from wpa_supplicant." Running as root also doesn't change this.

You need to supply a bit more info than that.

Can I suggest a new thread, titled 'wpa_supplicant - could not get status' or similar. You'll maybe catch more relevant eyeballs than buried here titled Wicd... hopefully someone whose regularly (or at least recently) set this up will jump in.

Either way you'll need to supply some detail on how you you set it up so far ie. contents of files:
/etc/wpa_supplicant/wpa_supplicant.conf # less any sensitive items
/etc/conf.d/net
Permissions on /etc/wpa_supplicant/wpa_supplicant.conf
And output of
Code:
ifconfig -a
groups <youruser>
Back to top
View user's profile Send private message
HungGarTiger
Apprentice
Apprentice


Joined: 04 Feb 2014
Posts: 155
Location: /nz/auckland

PostPosted: Mon Aug 10, 2015 7:11 pm    Post subject: Reply with quote

thanks ian.au.

I was just throwing it in there as an update as I didn't really have time to go into further details.

I've got it connecting to wpa_supplicant now i've had more than 30 seconds to sit down and look at it. I'll keep hacking away and see what I can do before starting the thread.

This thread is pretty much closed now I guess, seeing as we've nailed the wicd issue down to a bug in the program version rather than anything I've been doing wrong/not doing.

thanks for the help so far :D
Back to top
View user's profile Send private message
Aiken
Apprentice
Apprentice


Joined: 22 Jan 2003
Posts: 210
Location: Toowoomba/Australia

PostPosted: Mon Aug 10, 2015 10:21 pm    Post subject: Reply with quote

ian.au wrote:

I don't think there's anything that would particularly annoy anyone in this thread? We all use what works for us, because there's typically >1 way of doing things, who is to say which is better?


It is said by people who refuse to change the way they do things even when the current way they do something is inefficient or even bad. They will refuse to change to a simpler or bug free way of doing something because 'this is how we have always done it'. Not just computers. Someone who revved the motor of their car the moment it fires, one engine the big end bearings died due to a few thousand rpm before sufficient oil pressure had been produced multiple times every day. They have not owned a car where a person needed to touch the gas pedal when starting for 3 decades and they still rev the motor of their current car the moment it fires. Why? -> "that is how I have always started a car" (actual answer when queried) and refuse to change even after killing a car engine.

Back on topic. The last laptop has just had wicd downgraded. At least thanks to this thread I won't have a dead wicd-curses next time I need it which should be in the next day or so when I redo one of the laptops.
_________________
Beware the grue.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum