Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
My XFCE desktop is gone! [WORKFORME]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
msulli1355
Apprentice
Apprentice


Joined: 24 Nov 2005
Posts: 179
Location: OKlahoma, USA

PostPosted: Thu Jul 30, 2015 3:16 am    Post subject: My XFCE desktop is gone! [WORKFORME] Reply with quote

On Sundays I run emerge --sync and emerge -uD world. Occassionally I run emerge -avuD world just to make sure no packages are being built with USE flags I don't want. I very very rarely reboot my system. I installed the current system last April/May. Today I rebooted the system. I logged intoo xfce and my desktop background does not show up and there are no icons on my desktop. Clicking the desktop with either the left of the right mouse buttons yields no result. I've done some research on this issue, but haven't found anything that improves the situation.

camille ~ # emerge -pv xfdesktop

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild R ] xfce-base/xfdesktop-4.12.2::gentoo USE="libnotify thunar -debug" 0 KiB

Total: 1 package (1 reinstall), Size of downloads: 0 KiB

I don't really know where to go from here in addressing this problem. I thank you for any help you can offer in resolving this problem...


Last edited by msulli1355 on Thu Jul 30, 2015 7:14 pm; edited 1 time in total
Back to top
View user's profile Send private message
Buffoon
Veteran
Veteran


Joined: 17 Jun 2015
Posts: 1074
Location: EU or US

PostPosted: Thu Jul 30, 2015 6:48 am    Post subject: Reply with quote

The problem probably lies in config in your home directory.
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Thu Jul 30, 2015 9:33 am    Post subject: Reply with quote

did you check with a new user with a clean homedirectory?

did you checked output of:
Code:
emerge -ave xfce4-meta

anything to be updated? new?
Back to top
View user's profile Send private message
msulli1355
Apprentice
Apprentice


Joined: 24 Nov 2005
Posts: 179
Location: OKlahoma, USA

PostPosted: Thu Jul 30, 2015 4:48 pm    Post subject: Reply with quote

I logged out, moved /home/mcihael/.config/xfce4 to another directory and logged back in. Although all my settings were reset, no desktop still. So I moved it back. I've issued the command you suggested, but estimate it will take a couple of days at least to complete. This computer will be ten years old in September. I'll let you know when it finishes...
Back to top
View user's profile Send private message
Buffoon
Veteran
Veteran


Joined: 17 Jun 2015
Posts: 1074
Location: EU or US

PostPosted: Thu Jul 30, 2015 6:43 pm    Post subject: Reply with quote

Did you try creating a test user as tw04l124 recommended?
Back to top
View user's profile Send private message
msulli1355
Apprentice
Apprentice


Joined: 24 Nov 2005
Posts: 179
Location: OKlahoma, USA

PostPosted: Thu Jul 30, 2015 7:14 pm    Post subject: Reply with quote

I ran:

michael@camille ~ $ xfdesktop &

and now it's back. I don't know why I didn't think of that in the beginning...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum