Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Problems installing KDE/Plasma
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Tux's lil' helper
Tux's lil' helper

Joined: 17 Apr 2014
Posts: 90

PostPosted: Sun Jul 26, 2015 1:26 pm    Post subject: [Solved] Problems installing KDE/Plasma Reply with quote

I'm on a fresh install of Gentoo and I want to install Plasma 5. I'm trying to follow the instructions in the following page:

I opted not to install Overlay, I don't know if that's a wise choice...

After sorting out a few issues with USE flags and complaints about updating config files I managed to get emerge to run. But now it is failing to install 'dev-libs/boost-1.56.0-r1', 'emerge --info' yields:

Portage 2.2.20 (python 2.7.9-final-0, default/linux/amd64/13.0/desktop/plasma, gcc-4.8.4, glibc-2.20-r2, 4.0.5-gentoo x86_64)
                         System Settings
System uname: Linux-4.0.5-gentoo-x86_64-Intel-R-_Xeon-R-_CPU_E5-1620_v2_@_3.70GHz-with-gentoo-2.2
KiB Mem:     2056592 total,   1812968 free
KiB Swap:          0 total,         0 free
Timestamp of repository gentoo: Sun, 26 Jul 2015 09:00:01 +0000
sh bash 4.3_p33-r2
ld GNU ld (Gentoo 2.24 p1.4) 2.24
app-shells/bash:          4.3_p33-r2::gentoo
dev-lang/perl:            5.20.2::gentoo
dev-lang/python:          2.7.9-r1::gentoo, 3.3.5-r1::gentoo, 3.4.1::gentoo
dev-util/cmake:           3.2.2::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.17::gentoo
sys-apps/sandbox:         2.6-r1::gentoo
sys-devel/autoconf:       2.69::gentoo
sys-devel/automake:       1.15::gentoo
sys-devel/binutils:       2.24-r3::gentoo
sys-devel/gcc:            4.8.4::gentoo
sys-devel/gcc-config:     1.7.3::gentoo
sys-devel/libtool:        2.4.6::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 3.18::gentoo (virtual/os-headers)
sys-libs/glibc:           2.20-r2::gentoo

    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://
    priority: -1000

CFLAGS="-march=native -O2 -pipe"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X a52 aac acl acpi alsa amd64 berkdb bindist bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus declarative dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gif glamor gpm gtk iconv ipv6 jpeg kde kipi lcms ldap libkms libnotify mad mmx mmxext mng modules mp3 mp4 mpeg multilib ncurses nls nptl ogg opengl openmp pam pango pcre pdf phonon plasma png policykit ppds qml qt3support qt4 qt5 readline sdl semantic-desktop session spell sse sse2 ssl startup-notification svg tcpd tiff truetype udev udisks unicode upower usb vorbis widgets wxwidgets x264 xa xcb xcomposite xinerama xml xscreensaver xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

The -pqv output of emerge is:

[ebuild  N    ] dev-libs/boost-1.56.0-r1  USE="nls threads -context -debug -doc -icu -mpi -python -static-libs -tools" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7 python3_4 -python3_3"

In the build log it looks like it runs out of memory which I don't understand since I have 2GB RAM plus a 512MB swap partition:

virtual memory exhausted: Cannot allocate memory
gcc.compile.c++ bin.v2/libs/log/build/gcc-4.8/gentoorelease/

The whole log can be seen here: or by the command

$ curl | less

in the terminal to show the log with ANSI colors enabled.

Anyone who have run into this and/or knows of any solution?

Edit1: It seems that the compilation of this particular package hogs a lot of memory. I'm currently attempting to use the "-j1" flag and with that option, over 1GB memory is used.
Edit2: The "-j1" flag made the boost package compile successfully, continuing the plasma installation with "-j4" again.

Last edited by thurnax on Mon Jul 27, 2015 2:16 pm; edited 2 times in total
Back to top
View user's profile Send private message

Joined: 05 Apr 2007
Posts: 7968
Location: Austria

PostPosted: Sun Jul 26, 2015 2:23 pm    Post subject: Reply with quote

Since you appear to run an amd64 system here you should definitely add more swap, at least 2 GB, some packages like *webkit do take even more.
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Tux's lil' helper
Tux's lil' helper

Joined: 17 Apr 2014
Posts: 90

PostPosted: Sun Jul 26, 2015 7:07 pm    Post subject: Reply with quote

The following packages turned out to be problem packages during the installation process of plasma-meta:

which could be built using the "-j1" flag. I decided to also build the kdewebkit package with the same flag. But now in retrospect I don't think that kdewebkit would be a problem to build with "-j4". Some of its dependency packages perhaps, as emerging the kdewebkit package also involved a total of 46 packages, but likely not kdewebkit itself.

This rises a few questions however as to how much system resources that really are needed to build and run a Gentoo desktop environment. It doesn't sit to well with what is stated in the Handbook:

and 2GB + 512MB seems quite superfluous in comparison.

Another thought that occurred to me is that adding more cores to the compile/build process may not increase performance if data must be shuffled out to swap.

But somehow I believe that there must be something else that is causing the issues with using j-flags greater than 1. Something else than memory issues that is...
Back to top
View user's profile Send private message
Tux's lil' helper
Tux's lil' helper

Joined: 17 Apr 2014
Posts: 90

PostPosted: Sun Jul 26, 2015 8:04 pm    Post subject: Reply with quote

I cannot get the KDE/Plasma login screen. The installation is on a VirtualBox environment. When building the kernel, I didn't manually add any particular video driver, instead I trusted genkernel to find hardware and assign appropriate drivers.

I also installed virtualbox guest additions from the CD. The installation went fine except when adding links to complaining that path doesn't exist. But doesn't Plasma5 use Wayland/KMS now, isn't that an alternative to and therefore configured differently from traditional

When trying to 'startx' manually it complains that no screens are found. I installed sddm and added it to default runlevel. Even when starting sddm/xdm manually the message says, 'xdm already running'.

Update1: The VirtualBox developer team hints that Wayland doesn't support VirtualBox, but that was back in 2014 though...

Update2: I decided to install, following the Gentoo instructions for emerging the relevant packages for I removed the config update and insisted that xdm shall use sddm as I had set before. I also re-installed the guest additions so that the installer could apply those links in the dirs.

There are problems however, I don't know whether I should continue with those problems on this thread or start a new one. I consider the installation process per se to be successful...

The problems I have is that after the virtualbox drivers were applied, the menu bar at the bottom keeps disappearing and so are windows. They can reappear temporarily when resizing the entire window as the vbox driver automatically adjusts the screen resolution of the guest. Sometimes also the mouse cursor disappear. When logging out the window manager crashed.

Please, don't tell me that this is a stable release :D

Perhaps it is better to go with overlay and submit bug reports to the KDE team. Otherwise I like the simplistic layout, it looks nice.

Update3: The issues went away by disabling 3D acceleration in the VM. KDE4, GNOME3 and other desktop environments work well with 3D acceleration in the VM but apparently not KDE5/Plasma5. A developer in the KDE team stated that;
"KDE5 makes *much* more use of *much* more advanced OpenGL in *many* more GL contexts (QtQuick being the main driver here, but we also removed the OpenGL 1.3 backend from KWin) - it's very likely that this knocks out the virtualbox GL driver, ..."
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum