Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
problem emerging gnome 3.16
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
cheuk3
n00b
n00b


Joined: 27 Jun 2015
Posts: 8

PostPosted: Fri Jul 24, 2015 1:56 am    Post subject: problem emerging gnome 3.16 Reply with quote

I have gnome 3.14 installed and I want to upgrade to 3.16. However, when i try to emerge, it said dev-util/gdbus-codegen-2.44.1 is blocking dev-libs/glib-2.441

I tried to emerge 3.16 on a fresh installed computer but still get the same message. Does anyone emerge 3.16 successfully?

Quote:

[ebuild U ~] gnome-base/gnome-core-apps-3.16.0:3.0::gentoo [3.14.0:3.0::gentoo] USE="bluetooth cdr cups" 0 KiB
[ebuild U ~] gnome-extra/gnome-shell-extensions-3.16.1::gentoo [3.14.4::gentoo] USE="-examples" 225 KiB
[ebuild U ~] gnome-base/gnome-extra-apps-3.16.0:3.0::gentoo [3.14.0-r1:3.0::gentoo] USE="games share shotwell tracker" 0 KiB
[ebuild U ~] gnome-base/gnome-3.16.0:2.0::gentoo [3.14.0:2.0::gentoo] USE="bluetooth cdr classic cups extras -accessibility" 0 KiB
[blocks B ] <dev-util/gdbus-codegen-2.44.1 ("<dev-util/gdbus-codegen-2.44.1" is blocking dev-libs/glib-2.44.1)

Total: 104 packages (94 upgrades, 6 new, 4 in new slots), Size of downloads: 252,351 KiB
Conflict: 1 block (1 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/libgcrypt:0

(dev-libs/libgcrypt-1.5.4-r1:0/11::gentoo, installed) pulled in by
>=dev-libs/libgcrypt-1.5.4:0/11= required by (media-libs/libmtp-1.1.8:0/9::gentoo, installed)
^^^^^^
(and 5 more with the same problem)

(dev-libs/libgcrypt-1.6.3-r3:0/20::gentoo, ebuild scheduled for merge) pulled in by
>=dev-libs/libgcrypt-1.6.2 required by (app-crypt/gnupg-2.1.6:0/0::gentoo, ebuild scheduled for merge)
^^ ^^^^^

gnome-extra/evolution-data-server:0

(gnome-extra/evolution-data-server-3.16.4_pre20150619:0/52::gentoo, ebuild scheduled for merge) pulled in by
>=gnome-extra/evolution-data-server-3.16:=[gtk,weather?] required by (mail-client/evolution-3.16.3:2.0/2.0::gentoo, ebuild scheduled for merge)
^^ ^^^^
(and 3 more with the same problem)

(gnome-extra/evolution-data-server-3.12.11:0/49::gentoo, installed) pulled in by
>=gnome-extra/evolution-data-server-3.8:0/49=[vala] required by (dev-libs/folks-0.10.1-r1:0/25::gentoo, installed)
^^^^^^
Back to top
View user's profile Send private message
Keruskerfuerst
Advocate
Advocate


Joined: 01 Feb 2006
Posts: 2288
Location: near Augsburg, Germany

PostPosted: Fri Jul 24, 2015 7:09 am    Post subject: Reply with quote

First you have remove the blocking packages.
Back to top
View user's profile Send private message
cheuk3
n00b
n00b


Joined: 27 Jun 2015
Posts: 8

PostPosted: Fri Jul 24, 2015 9:16 am    Post subject: Reply with quote

Keruskerfuerst wrote:
First you have remove the blocking packages.


I have removed both of them but they are required by alot of gnome application...so they will emerge again...
Back to top
View user's profile Send private message
acrox999
n00b
n00b


Joined: 25 Jul 2015
Posts: 5

PostPosted: Wed Jul 29, 2015 5:01 am    Post subject: Reply with quote

GNOME 3.16 is still in the testing branch, and it will also pull a lot of dependencies from the testing branch. The easiest approach is for you to move completely to the testing branch, by defining ACCEPT_KEYWORDS="~arch" inside your make.conf. This is not recommended, but if you really need GNOME 3.16, this is the easiest way.

The second, "safer" way is to install all of the blocking packages from the testing branch. You can specify them inside your package.accept_keywords or package.keywords.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum