Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
nl80211: Could not re-add multicast membership
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
royalts
n00b
n00b


Joined: 06 Jan 2015
Posts: 39

PostPosted: Thu Jul 09, 2015 1:20 pm    Post subject: nl80211: Could not re-add multicast membership Reply with quote

Hey Guys!

I'm trying for hours to solve this problem and found nowhere else an answer. Always I boot or start wpa_supplicant I got the error:

Code:

nl80211: Could not re-add multicast membership for vendor events: -2 (No such file or directory)


I got the following hardware:

Code:

*-network
       description: Wireless interface
       product: Centrino Advanced-N 6205 [Taylor Peak]
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: wlan0
       version: 34
       serial: 08:11:96:3d:17:90
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=3.6.11 firmware=18.168.6.1 ip=192.168.0.181 latency=0 link=yes multicast=yes wireless=IEEE 802.11abgn
       resources: irq:47 memory:b0600000-b0601fff


and I use the nl80211 Driver. Question in between: why is the driver iwlwifi listed above when I use the nl80211?

Here is a piece of output of: wpa_supplicant -i wlan0 -c /etc/wpa_supplicant/wpa_supplicant_A_S.conf -D nl80211 -d

Code:

wpa_supplicant v2.4
random: Trying to read entropy from /dev/random
Successfully initialized wpa_supplicant
Initializing interface 'wlan0' conf '/etc/wpa_supplicant/wpa_supplicant_A_S.conf' driver 'nl80211' ctrl_interface 'N/A' bridge 'N/A'
Configuration file '/etc/wpa_supplicant/wpa_supplicant_A_S.conf' -> '/etc/wpa_supplicant/wpa_supplicant_A_S.conf'
Reading configuration file '/etc/wpa_supplicant/wpa_supplicant_A_S.conf'
ctrl_interface_group='0'
ap_scan=1
ctrl_interface='DIR=/var/run/wpa_supplicant GROUP=wheel'
update_config=1
eapol_version=1
Priority group 1
   id=0 ssid='A/S'
nl80211: Could not add multicast membership for vendor events: -2 (No such file or directory)
rfkill: initial event: idx=0 type=1 op=0 soft=0 hard=0
nl80211: Supported cipher 00-0f-ac:1
nl80211: Supported cipher 00-0f-ac:5
nl80211: Supported cipher 00-0f-ac:2
nl80211: Supported cipher 00-0f-ac:4
nl80211: Supported cipher 00-0f-ac:6
nl80211: Using driver-based off-channel TX
nl80211: Use separate P2P group interface (driver advertised support)
nl80211: interface wlan0 in phy phy0
nl80211: Set mode ifindex 3 iftype 2 (STATION)
nl80211: Subscribe to mgmt frames with non-AP handle 0x26734b0
nl80211: Register frame type=0xd0 (WLAN_FC_STYPE_ACTION) nl_handle=0x26734b0 match=0104
nl80211: Register frame type=0xd0 (WLAN_FC_STYPE_ACTION) nl_handle=0x26734b0 match=040a
nl80211: Register frame type=0xd0 (WLAN_FC_STYPE_ACTION) nl_handle=0x26734b0 match=040b
nl80211: Register frame type=0xd0 (WLAN_FC_STYPE_ACTION) nl_handle=0x26734b0 match=040c
nl80211: Register frame type=0xd0 (WLAN_FC_STYPE_ACTION) nl_handle=0x26734b0 match=040d
nl80211: Register frame type=0xd0 (WLAN_FC_STYPE_ACTION) nl_handle=0x26734b0 match=090a
nl80211: Register frame type=0xd0 (WLAN_FC_STYPE_ACTION) nl_handle=0x26734b0 match=090b



output of lshw -vv:

Code:

03:00.0 Network controller: Intel Corporation Centrino Advanced-N 6205 [Taylor Peak] (rev 34)
   Subsystem: Intel Corporation Centrino Advanced-N 6205 AGN
   Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
   Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
   Latency: 0, Cache Line Size: 64 bytes
   Interrupt: pin A routed to IRQ 47
   Region 0: Memory at b0600000 (64-bit, non-prefetchable) [size=8K]
   Capabilities: [c8] Power Management version 3
      Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
      Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
   Capabilities: [d0] MSI: Enable+ Count=1/1 Maskable- 64bit+
      Address: 00000000fee0f00c  Data: 4152
   Capabilities: [e0] Express (v1) Endpoint, MSI 00
      DevCap:   MaxPayload 128 bytes, PhantFunc 0, Latency L0s <512ns, L1 unlimited
         ExtTag- AttnBtn- AttnInd- PwrInd- RBE+ FLReset+
      DevCtl:   Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
         RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop+ FLReset-
         MaxPayload 128 bytes, MaxReadReq 128 bytes
      DevSta:   CorrErr+ UncorrErr- FatalErr- UnsuppReq+ AuxPwr+ TransPend-
      LnkCap:   Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Latency L0 <4us, L1 <32us
         ClockPM+ Surprise- LLActRep- BwNot-
      LnkCtl:   ASPM L1 Enabled; RCB 64 bytes Disabled- Retrain- CommClk+
         ExtSynch- ClockPM+ AutWidDis- BWInt- AutBWInt-
      LnkSta:   Speed 2.5GT/s, Width x1, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
   Capabilities: [100 v1] Advanced Error Reporting
      UESta:   DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
      UEMsk:   DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
      UESvrt:   DLP+ SDES- TLP- FCP+ CmpltTO- CmpltAbrt- UnxCmplt- RxOF+ MalfTLP+ ECRC- UnsupReq- ACSViol-
      CESta:   RxErr- BadTLP- BadDLLP- Rollover- Timeout- NonFatalErr+
      CEMsk:   RxErr- BadTLP- BadDLLP- Rollover- Timeout- NonFatalErr+
      AERCap:   First Error Pointer: 00, GenCap- CGenEn- ChkCap- ChkEn-
   Capabilities: [140 v1] Device Serial Number 08-11-96-ff-ff-3d-17-90
   Kernel driver in use: iwlwifi
   Kernel modules: iwlwifi



I'm able to connect to the network but I want to get rid of this failure! Could anyone help me please?

Kind of regards

Stefan
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2657

PostPosted: Thu Jul 09, 2015 2:49 pm    Post subject: Re: nl80211: Could not re-add multicast membership Reply with quote

royalts wrote:
and I use the nl80211 Driver. Question in between: why is the driver iwlwifi listed above when I use the nl80211?

See https://wiki.gentoo.org/wiki/Wifi and https://wireless.wiki.kernel.org/en/users/drivers/iwlwifi
Back to top
View user's profile Send private message
royalts
n00b
n00b


Joined: 06 Jan 2015
Posts: 39

PostPosted: Thu Jul 09, 2015 2:52 pm    Post subject: Reply with quote

I did work through https://wiki.gentoo.org/wiki/Wifi. Otherwise I wouldn't post a question here
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2657

PostPosted: Fri Jul 10, 2015 6:34 am    Post subject: Reply with quote

royalts wrote:
I did work through https://wiki.gentoo.org/wiki/Wifi. Otherwise I wouldn't post a question here

Are you confused about having those two drivers?
The one is for the network stack and the other for the nic.
Back to top
View user's profile Send private message
royalts
n00b
n00b


Joined: 06 Jan 2015
Posts: 39

PostPosted: Sat Jul 11, 2015 11:33 am    Post subject: Reply with quote

Thanks for the answer :)

But my main Problem is still present: nl80211: Could not add multicast membership for vendor events: -2 (No such file or directory)

why did it appear and how can I solve this?

Could anybody help me please?
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Sat Jul 11, 2015 1:03 pm    Post subject: Re: nl80211: Could not re-add multicast membership Reply with quote

royalts wrote:
Code:
Reading configuration file '/etc/wpa_supplicant/wpa_supplicant_A_S.conf'
ctrl_interface_group='0'
[...]
ctrl_interface='DIR=/var/run/wpa_supplicant GROUP=wheel'

royalts ... that doesn't look kosher to me, and while you haven't provided the contents of wpa_supplicant_A_S.conf the above suggests you are setting 'ctrl_interface_group=' and 'GROUP' ... the former to '0' (root) and the latter to 'wheel'. I speculate this is the reason behind the subsequent "No such file or directory". If I'm correct then remove the 'ctrl_interface_group' entry from the config ...

best ... khay
Back to top
View user's profile Send private message
royalts
n00b
n00b


Joined: 06 Jan 2015
Posts: 39

PostPosted: Mon Jul 13, 2015 6:07 am    Post subject: Reply with quote

Hey,

you were right! I had such entries in my config. Unfortunately, the problem persists after comment those lines out
and my config looks like:

Quote:


#ctrl_interface_group=0
ap_scan=1

# Allow users in the 'wheel' group to control wpa_supplicant
#ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=wheel

# Make this file writable for wpa_gui
update_config=1


eapol_version=1


network={
ssid="A/S"
priority=1
scan_ssid=1
proto=RSN
key_mgmt=WPA-PSK
pairwise=CCMP TKIP
group=TKIP CCMP
psk="**********
}



and the comannd I execute wpa_supplicant:

Code:

wpa_supplicant -i wlan0 -c /etc/wpa_supplicant/wpa_supplicant_A_S.conf -D nl80211
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2657

PostPosted: Mon Jul 13, 2015 8:50 am    Post subject: Reply with quote

royalts wrote:
Hey,

you were right! I had such entries in my config. Unfortunately, the problem persists after comment those lines out
and my config looks like:

Quote:


#ctrl_interface_group=0
ap_scan=1

# Allow users in the 'wheel' group to control wpa_supplicant
#ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=wheel

# Make this file writable for wpa_gui
update_config=1


eapol_version=1


network={
ssid="A/S"
priority=1
scan_ssid=1
proto=RSN
key_mgmt=WPA-PSK
pairwise=CCMP TKIP
group=TKIP CCMP
psk="**********
}


?????
Why do you think you need to comment out that line?
Back to top
View user's profile Send private message
royalts
n00b
n00b


Joined: 06 Jan 2015
Posts: 39

PostPosted: Mon Jul 13, 2015 6:42 pm    Post subject: Reply with quote

Yes, you are right. But there are no differences. If I uncomment this line I will get the same error...

Now the config file looks like:

Code:


#ctrl_interface_group=0
ap_scan=1

# Allow users in the 'wheel' group to control wpa_supplicant
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=wheel

# Make this file writable for wpa_gui
#update_config=1

.....

Back to top
View user's profile Send private message
royalts
n00b
n00b


Joined: 06 Jan 2015
Posts: 39

PostPosted: Sun Jul 26, 2015 12:04 pm    Post subject: Reply with quote

does nobody have a hint for me?
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2657

PostPosted: Sun Jul 26, 2015 2:49 pm    Post subject: Reply with quote

royalts wrote:
does nobody have a hint for me?

The message you are receiving is from driver_nl80211.c of wpa_supplicant:
Code:
static void nl80211_check_global(struct nl80211_global *global)
{
        struct nl_handle *handle;
        const char *groups[] = { "scan", "mlme", "regulatory", "vendor", NULL };
        int ret;
        unsigned int i;

        /*
         * Try to re-add memberships to handle case of cfg80211 getting reloaded
         * and all registration having been cleared.
         */
        handle = (void *) (((intptr_t) global->nl_event) ^
                           ELOOP_SOCKET_INVALID);

        for (i = 0; groups[i]; i++) {
                ret = nl_get_multicast_id(global, "nl80211", groups[i]);
                if (ret >= 0)
                        ret = nl_socket_add_membership(handle, ret);
                if (ret < 0) {
                        wpa_printf(MSG_INFO,
                                   "nl80211: Could not re-add multicast membership for %s events: %d (%s)",
                                   groups[i], ret, strerror(-ret));
                }
        }
}
HTH
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Sun Jul 26, 2015 4:37 pm    Post subject: Reply with quote

charles17 wrote:
royalts wrote:
does nobody have a hint for me?

The message you are receiving is from driver_nl80211.c of wpa_supplicant:

Yes, but I think the issue probably lies with the kernel driver for whatever card the OP has ... anyhow, royalts, I don't think this is serious, you could try and suppress the error with the following:

/etc/conf.d/net
Code:
wpa_supplicant_wlan0="-Dnl80211 -qq"

... or simply adding '-qq' to your command.

HTH & best ... khay
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum