Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Is there a simple QT IRC client
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2769

PostPosted: Sun Jul 19, 2015 11:26 pm    Post subject: Is there a simple QT IRC client Reply with quote

Hi, ALL,
For Gnome/GTK+ there is a pidgin. For QT it looks like there is a "quassel", but it looks like the server and not the client.

I just want a simple IRC client to connect and talk on IRC channel...

Thank you.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6823
Location: Austria

PostPosted: Sun Jul 19, 2015 11:29 pm    Post subject: Reply with quote

konversation or in fact quassel - it has a server flag if you want the server built, otherwise you get the client.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
ct85711
Veteran
Veteran


Joined: 27 Sep 2005
Posts: 1691

PostPosted: Sun Jul 19, 2015 11:50 pm    Post subject: Reply with quote

another irc client you can use is hexchat, it appears to be gtk+ (or at the least support it)
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2769

PostPosted: Tue Jul 21, 2015 12:01 am    Post subject: Reply with quote

Hi, guys,
2genstorm:

Trying to install quassel, I got:

Code:

IgorDellGentoo wxWidgets # emerge -pv quassel
 * Last emerge --sync was 33d 22h 58m ago.

These are the packages that would be merged, in order:

Calculating dependencies \

!!! Problem resolving dependencies for net-irc/quassel
... done!

!!! The ebuild selected to satisfy "quassel" has unmet requirements.
- net-irc/quassel-0.10.0-r1::gentoo USE="X crypt dbus kde phonon ssl (-ayatana) -debug -monolithic -postgres -server -syslog -webkit" ABI_X86="64"

  The following REQUIRED_USE flag constraints are unsatisfied:
    crypt? ( any-of ( server monolithic ) )
                                                                                                                                                                                               
  The above constraints are a subset of the following complete expression:                                                                                                                     
    any-of ( X server monolithic ) crypt? ( any-of ( server monolithic ) ) postgres? ( any-of ( server monolithic ) ) syslog? ( any-of ( server monolithic ) ) kde? ( any-of ( X monolithic ) ) phonon? ( any-of ( X monolithic ) ) dbus? ( any-of ( X monolithic ) ) ayatana? ( any-of ( X monolithic ) ) webkit? ( any-of ( X monolithic ) )                                                 
                                                                                                                                                                                               
                                                                                                                                                                                               
 * IMPORTANT: 7 news items need reading for repository 'gentoo'.                                                                                                                               
 * Use eselect news read to view new items.


However, the konversation, does not have any issues:

Code:

IgorDellGentoo wxWidgets # emerge -pv konversation
 * Last emerge --sync was 34d 23h 1m 36s ago.

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] net-irc/konversation-1.5.1:4::gentoo  USE="crypt handbook (-aqua) -debug" LINGUAS="ru -bg -bs -ca -ca@valencia -cs -da -de -el -en_GB -es -et -fi -fr -gl -he -hu -it -ja -kk -km -ko -lt -nb -nds -nl -pa -pl -pt -pt_BR -si -sk -sl -sr -sr@ijekavian -sr@ijekavianlatin -sr@latin -sv -tr -uk -zh_CN -zh_TW" 3114 KiB

Total: 1 package (1 new), Size of downloads: 3114 KiB

 * IMPORTANT: 7 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


2ct86711:
Well, I specifically asked for a QT IRC client... ;-)

Thank you.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum