Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]: Failure to upgrade kleopatra
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2769

PostPosted: Mon Jul 20, 2015 12:19 pm    Post subject: Reply with quote

OK,
I didn't skip it, I just restarted the merge and it finished successfully.

Now, I got following:

Code:

>>> No outdated packages were found on your system.

 * GNU info directory index is up-to-date.

!!! existing preserved libs:
>>> package: media-gfx/exiv2-0.24-r1
 *  - /usr/lib64/libexiv2.so.12
 *  - /usr/lib64/libexiv2.so.12.0.0
 *      used by /usr/lib64/kde4/nepomukexiv2extractor.so (kde-base/nepomuk-core-4.12.5)
Use emerge @preserved-rebuild to rebuild packages using these libraries

 * IMPORTANT: 6 config files in '/etc' need updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.

 * IMPORTANT: 7 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.

 * After world updates, it is important to remove obsolete packages with
 * emerge --depclean. Refer to `man emerge` for more information.


Should I run "emerge @preserved-rebuild" since there is no more nepomuk?

After that I am planning to run "emerge --depclean && emerge kmail kleopatra && etc-update".

Thank you.

[EDIT]
More info:

Code:

IgorDellGentoo wxWidgets # emerge --pretend @preserved-rebuild
 * Last emerge --sync was 34d 11h 44m 57s ago.

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] kde-base/nepomuk-core-4.14.3 [4.12.5] USE="migrator%*"

 * IMPORTANT: 7 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.

IgorDellGentoo wxWidgets # equery d nepomuk-core
 * These packages depend on nepomuk-core:
kde-apps/kget-4.14.3 (nepomuk ? >=kde-base/nepomuk-core-4.14.3:4[aqua=])
kde-base/akonadiconsole-4.12.5 (>=kde-base/nepomuk-core-4.12.5:4[-aqua])
kde-base/kactivities-4.13.3 (nepomuk ? >=kde-base/nepomuk-core-4.13.3:4[aqua=])
kde-base/kdelibs-4.14.8 (nepomuk ? >=kde-base/nepomuk-core-4.14.3:4[aqua=])
kde-base/nepomuk-widgets-4.12.5 (>=kde-base/nepomuk-core-4.12.5:4[-aqua])
kde-base/plasma-workspace-4.11.19 (nepomuk ? >=kde-base/nepomuk-core-4.11.19:4[aqua=])

[/EDIT]
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Mon Jul 20, 2015 2:08 pm    Post subject: Reply with quote

I'm going to repeat myself:
genstorm wrote:
Regardless, please take care of your config files and news items. I don't want to see that appear once again!
Code:

 * IMPORTANT: 6 config files in '/etc' need updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.

 * IMPORTANT: 7 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


ONEEYEMAN wrote:
Should I run "emerge @preserved-rebuild" since there is no more nepomuk?

No, that would rebuild nepomuk-core, which you don't want anymore. Unmerge it instead. Again, to be sure, you can check if it's still required with one of those nice equery commands you've seen earlier.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2769

PostPosted: Mon Jul 20, 2015 2:31 pm    Post subject: Reply with quote

Hi,
genstorm wrote:

I'm going to repeat myself:
genstorm wrote:

Regardless, please take care of your config files and news items. I don't want to see that appear once again!
Code:

 * IMPORTANT: 6 config files in '/etc' need updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.

 * IMPORTANT: 7 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.



I will. I just want to make sure that everything that needs to be remerged is remerged.

genstorm wrote:

ONEEYEMAN wrote:

Should I run "emerge @preserved-rebuild" since there is no more nepomuk?

No, that would rebuild nepomuk-core, which you don't want anymore. Unmerge it instead. Again, to be sure, you can check if it's still required with one of those nice equery commands you've seen earlier.

That is already there in the "EDIT - More info" section. And I think I can't just uninstall it - akonadiconsole has a hard dependency on it - no USE-flag. :(

Thank you.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Mon Jul 20, 2015 2:38 pm    Post subject: Reply with quote

Update of akonadiconsole to >=4.14 will remove the nepomuk dependency. ;)

And then there's only nepomuk-widgets left.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2769

PostPosted: Mon Jul 20, 2015 5:53 pm    Post subject: Reply with quote

genstorm,
@ work now. Will do when I get back home. ;-)

Thank you.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2769

PostPosted: Mon Jul 20, 2015 11:53 pm    Post subject: Reply with quote

genstorm,
I upgraded akonadiconsole, and now that's what I have:

Code:

IgorDellGentoo wxWidgets # equery d nepomuk-core
 * These packages depend on nepomuk-core:
kde-apps/kget-4.14.3 (nepomuk ? >=kde-base/nepomuk-core-4.14.3:4[aqua=])
kde-base/kactivities-4.13.3 (nepomuk ? >=kde-base/nepomuk-core-4.13.3:4[aqua=])
kde-base/kdelibs-4.14.8 (nepomuk ? >=kde-base/nepomuk-core-4.14.3:4[aqua=])
kde-base/nepomuk-widgets-4.12.5 (>=kde-base/nepomuk-core-4.12.5:4[-aqua])
kde-base/plasma-workspace-4.11.19 (nepomuk ? >=kde-base/nepomuk-core-4.11.19:4[aqua=])

IgorDellGentoo wxWidgets # equery d nepomuk-widgets
 * These packages depend on nepomuk-widgets:
kde-apps/kget-4.14.3 (nepomuk ? >=kde-base/nepomuk-widgets-4.14.3:4[aqua=])
kde-base/kdelibs-4.14.8 (nepomuk ? >=kde-base/nepomuk-widgets-4.14.3:4[aqua=])

IgorDellGentoo wxWidgets # emerge -pv kget kdelibs kactivities plasma-workspace
 * Last emerge --sync was 34d 22h 51m 50s ago.

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] kde-base/kdelibs-4.14.8:4/4.14::gentoo  USE="acl alsa bzip2 crypt fam handbook nls opengl (policykit) spell ssl udev udisks upower (-altivec) (-aqua) -debug -doc -jpeg2k -kerberos -lzma -nepomuk -openexr {-test} -zeroconf" CPU_FLAGS_X86="mmx sse sse2 -3dnow" 0 KiB
[ebuild   R    ] kde-base/kactivities-4.13.3:4/4.13::gentoo  USE="(-aqua) -minimal -nepomuk" 0 KiB
[ebuild   R    ] kde-apps/kget-4.14.3:4/4.14::gentoo  USE="handbook (-aqua) -bittorrent -debug -gpg -mms -nepomuk -sqlite -webkit" 0 KiB
[ebuild   R    ] kde-base/plasma-workspace-4.11.19:4/4.11::gentoo  USE="handbook kdepim (-aqua) -debug -gps -json -nepomuk -python -qalculate" PYTHON_TARGETS="python2_7" 0 KiB

Total: 4 packages (4 reinstalls), Size of downloads: 0 KiB

 * IMPORTANT: 7 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.



Should I rebuild all those packages? Or just do "emerge --unmerge nepomuk-core nepomuk-widgets"?

And after that I will need to look into/kmail/kleopatra stuff...

Code:

IgorDellGentoo wxWidgets # emerge -pv kmail kleopatra
 * Last emerge --sync was 34d 22h 55m 8s ago.

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] kde-base/kontact-4.14.8:4/4.14::gentoo [4.12.5:4/4.12::gentoo] USE="handbook (-aqua) -debug" 0 KiB
[ebuild     U  ] kde-base/kleopatra-4.14.8:4/4.14::gentoo [4.12.5:4/4.12::gentoo] USE="handbook (-aqua) -debug" 0 KiB
[ebuild     U  ] kde-base/korganizer-4.14.8:4/4.14::gentoo [4.12.5:4/4.12::gentoo] USE="handbook kontact (-aqua) -debug" 0 KiB
[ebuild  N     ] kde-base/kmail-4.14.8:4/4.14::gentoo  USE="handbook kontact (-aqua) -debug {-test}" 0 KiB

Total: 4 packages (3 upgrades, 1 new), Size of downloads: 0 KiB

 * IMPORTANT: 7 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


kmail was uninstalled during the akonadiconsole upgrade...

Thank you.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Tue Jul 21, 2015 10:31 am    Post subject: Reply with quote

ONEEYEMAN wrote:
Should I rebuild all those packages? Or just do "emerge --unmerge nepomuk-core nepomuk-widgets"?

Why would you rebuild them? As you can see, nepomuk is already switched off for them.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2769

PostPosted: Tue Jul 21, 2015 10:51 am    Post subject: Reply with quote

OK, so I unmerged those 2 and merging kleopatra and kmail.

Now here is the question. How do I check what else needs to be upgraded? Should I re-run "emerge -vuD world"? Or is there some other way?

Thank you.

[EDIT]
Re-running "emerge -vuD world" does not see anything. Am I to be sure that everything is up to date?
[/EDIT]
Back to top
View user's profile Send private message
ct85711
Veteran
Veteran


Joined: 27 Sep 2005
Posts: 1692

PostPosted: Tue Jul 21, 2015 12:08 pm    Post subject: Reply with quote

One thing I saw, is this...


Quote:
* Last emerge --sync was 34d 22h 55m 8s ago.

You may need to sync to get a updated portage tree, to see what needs updated.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Tue Jul 21, 2015 1:24 pm    Post subject: Reply with quote

Another problem is your PIM packages are not recorded in world, that's why they were not considered for update, so either emerge the separate packages you like (i.e. kmail) or emerge the full suite (kdepim-meta).
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2769

PostPosted: Tue Jul 21, 2015 1:39 pm    Post subject: Reply with quote

genstorm,
OK, Will try kdepim-meta later today.

Then I will run etc-update. ;-)
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2769

PostPosted: Tue Jul 21, 2015 10:52 pm    Post subject: Reply with quote

genstorm,

Here is what I get:

Code:

IgorDellGentoo wxWidgets # emerge -pv kdepim-meta
 * Last emerge --sync was 35d 21h 50m 6s ago.

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] kde-base/ktnef-4.14.8:4/4.14::gentoo [4.12.5:4/4.12::gentoo] USE="handbook (-aqua) -debug" 0 KiB
[ebuild     U  ] kde-base/kabcclient-4.14.8:4/4.14::gentoo [4.12.5:4/4.12::gentoo] USE="handbook (-aqua) -debug" 0 KiB
[ebuild  N     ] net-libs/libkgapi-2.2.0:4::gentoo  USE="(-aqua) -debug" 125 KiB
[ebuild     U  ] kde-base/kdepim-kresources-4.14.8:4/4.14::gentoo [4.12.5:4/4.12::gentoo] USE="(-aqua) -debug" 0 KiB
[ebuild     U  ] kde-base/calendarjanitor-4.14.8:4/4.14::gentoo [4.12.5:4/4.12::gentoo] USE="handbook (-aqua) -debug" 0 KiB
[ebuild     U  ] kde-base/konsolekalendar-4.14.8:4/4.14::gentoo [4.12.5:4/4.12::gentoo] USE="handbook (-aqua) -debug" 0 KiB
[ebuild     U  ] kde-base/kalarm-4.14.8:4/4.14::gentoo [4.12.5:4/4.12::gentoo] USE="handbook (-aqua) -debug" 0 KiB
[ebuild     U  ] kde-base/blogilo-4.14.8:4/4.14::gentoo [4.12.5:4/4.12::gentoo] USE="handbook (-aqua) -debug" 0 KiB
[ebuild     U  ] kde-base/knode-4.14.8:4/4.14::gentoo [4.12.5:4/4.12::gentoo] USE="handbook kontact (-aqua) -debug" 0 KiB
[ebuild     U  ] kde-base/knotes-4.14.8:4/4.14::gentoo [4.12.5:4/4.12::gentoo] USE="handbook kontact (-aqua) -debug" 0 KiB
[ebuild     U  ] kde-base/akregator-4.14.8:4/4.14::gentoo [4.12.5:4/4.12::gentoo] USE="handbook kontact (-aqua) -debug" 0 KiB
[ebuild     U  ] kde-base/kjots-4.14.8:4/4.14::gentoo [4.12.5:4/4.12::gentoo] USE="handbook kontact (-aqua) -debug" 0 KiB
[ebuild     U  ] kde-base/ktimetracker-4.14.8:4/4.14::gentoo [4.12.5:4/4.12::gentoo] USE="handbook kontact (-aqua) -debug" 0 KiB
[ebuild     U  ] kde-base/kaddressbook-4.14.8:4/4.14::gentoo [4.12.5:4/4.12::gentoo] USE="handbook kontact (-aqua) -debug" 0 KiB
[uninstall     ] kde-base/contactthemeeditor-4.12.5:4/4.12::gentoo  USE="handbook (-aqua) -debug"
[blocks b      ] kde-base/contactthemeeditor ("kde-base/contactthemeeditor" is blocking kde-base/kaddressbook-4.14.8)
[ebuild     U  ] kde-base/kdepim-meta-4.14.8:4::gentoo [4.12.5:4::gentoo] USE="nls (-aqua)" 0 KiB

Total: 15 packages (14 upgrades, 1 new, 1 uninstall), Size of downloads: 125 KiB
Conflict: 1 block

 * IMPORTANT: 7 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.



So kdepim-meta is installed, but it's not in the world tree.

I think that this update will put it there, right? And after this merge I will need to re-install "contactherneditor" as it will be unmerged.

Am I good with such a plan?

Thank you.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Wed Jul 22, 2015 5:53 am    Post subject: Reply with quote

ONEEYEMAN wrote:
And after this merge I will need to re-install "contactherneditor" as it will be unmerged.

No:
Code:
[blocks b      ] kde-base/contactthemeeditor ("kde-base/contactthemeeditor" is blocking kde-base/kaddressbook-4.14.8)

kaddressbook-4.14.8 blocks _any_ version of contactthemeeditor.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2769

PostPosted: Thu Jul 23, 2015 3:30 am    Post subject: Reply with quote

genstorm,
Everything else is merged and the system is updated, right?

Code:

emerge -pvuD world


does not yield anything...

Will do the "etc-update" now...

P.S.: Could you please reply to this thread as well. ;-)

P.P.S.:

Doing "etc-update". There are some changes that I did. ;-)

First one was "/etc/nsswitch.conf". Modified for "Samba" to add "wins" to "Host" line.
Second one was "/etc/conf.d/modules", which contains modules I am building from the kernel.
Next one is /etc/conf.d/xdm where I changed a DISPLAYMANAGER to ue to be kdm.
And then there are 2 grub configuration files - a main one since I have a standard "net.wlan0" network name, and the custom since I added entry for Solaris.

So all, in all there was nothing to do... ;-)
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2769

PostPosted: Fri Jul 24, 2015 11:46 am    Post subject: Reply with quote

genstorm,
Everything now looks good.

Thank you.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum