Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]: Failure to upgrade kleopatra
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2769

PostPosted: Sun Jul 19, 2015 5:11 pm    Post subject: [SOLVED]: Failure to upgrade kleopatra Reply with quote

Hi, ALL,

Code:

IgorDellGentoo wxWidgets # emerge -pv kleopatra
 * Last emerge --sync was 33d 16h 8m 25s ago.

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] kde-base/baloo-4.14.3:4/4.14::gentoo  USE="(-aqua) -debug -minimal" 0 KiB
[ebuild     U  ] kde-base/kdepim-icons-4.14.8:4/4.14::gentoo [4.12.5:4/4.12::gentoo] USE="(-aqua)" 14235 KiB
[ebuild     U  ] kde-base/kdepim-runtime-4.14.8:4/4.14::gentoo [4.12.5:4/4.12::gentoo] USE="(-aqua) -debug -facebook -google -kolab" 1147 KiB
[ebuild     U  ] kde-base/kdepim-common-libs-4.14.8:4/4.14::gentoo [4.12.5:4/4.12::gentoo] USE="(-aqua) -debug" 0 KiB
[ebuild     U  ] kde-base/kleopatra-4.14.8:4/4.14::gentoo [4.12.5:4/4.12::gentoo] USE="handbook (-aqua) -debug" 0 KiB
[blocks B      ] <kde-base/kmail-4.14.5 ("<kde-base/kmail-4.14.5" is blocking kde-base/kdepim-common-libs-4.14.8)

Total: 5 packages (4 upgrades, 1 new), Size of downloads: 15381 KiB
Conflict: 1 block (1 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (kde-base/kmail-4.12.5:4/4.12::gentoo, installed) pulled in by
    >=kde-base/kmail-4.12.5:4[-aqua] required by (kde-base/contactthemeeditor-4.12.5:4/4.12::gentoo, installed)
    >=kde-base/kmail-4.12.5:4[-aqua] required by (kde-base/kdepim-meta-4.12.5:4/4::gentoo, installed)

  (kde-base/kdepim-common-libs-4.14.8:4/4.14::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-base/kdepim-common-libs-4.12.5:4[-aqua] required by (kde-base/kdepim-kresources-4.12.5:4/4.12::gentoo, installed)
    >=kde-base/kdepim-common-libs-4.12.5:4[-aqua] required by (kde-base/blogilo-4.12.5:4/4.12::gentoo, installed)
    >=kde-base/kdepim-common-libs-4.12.5:4[-aqua] required by (kde-base/kontact-4.12.5:4/4.12::gentoo, installed)
    >=kde-base/kdepim-common-libs-4.12.5:4[-aqua] required by (kde-base/akregator-4.12.5:4/4.12::gentoo, installed)
    >=kde-base/kdepim-common-libs-4.12.5:4[-aqua] required by (kde-base/ktimetracker-4.12.5:4/4.12::gentoo, installed)
    >=kde-base/kdepim-common-libs-4.14.8:4[aqua=] (>=kde-base/kdepim-common-libs-4.14.8:4[-aqua]) required by (kde-base/kleopatra-4.14.8:4/4.14::gentoo, ebuild scheduled for merge)
    >=kde-base/kdepim-common-libs-4.12.5:4[-aqua] required by (kde-base/akonadiconsole-4.12.5:4/4.12::gentoo, installed)
    >=kde-base/kdepim-common-libs-4.12.1-r1:4[-aqua] required by (kde-base/knode-4.12.5:4/4.12::gentoo, installed)
    >=kde-base/kdepim-common-libs-4.12.5:4[-aqua] required by (kde-base/korganizer-4.12.5:4/4.12::gentoo, installed)
    >=kde-base/kdepim-common-libs-4.12.5:4[-aqua] required by (kde-base/calendarjanitor-4.12.5:4/4.12::gentoo, installed)
    >=kde-base/kdepim-common-libs-4.12.5:4[-aqua] required by (kde-base/kjots-4.12.5:4/4.12::gentoo, installed)
    >=kde-base/kdepim-common-libs-4.12.5:4[-aqua] required by (kde-base/kalarm-4.12.5:4/4.12::gentoo, installed)
    >=kde-base/kdepim-common-libs-4.12.5:4[-aqua] required by (kde-base/konsolekalendar-4.12.5:4/4.12::gentoo, installed)
    >=kde-base/kdepim-common-libs-4.12.5:4[-aqua] required by (kde-base/kaddressbook-4.12.5:4/4.12::gentoo, installed)
    >=kde-base/kdepim-common-libs-4.12.5:4[-aqua] required by (kde-base/knotes-4.12.5:4/4.12::gentoo, installed)
    >=kde-base/kdepim-common-libs-4.12.1-r2:4[-aqua] required by (kde-base/kmail-4.12.5:4/4.12::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


 * IMPORTANT: 7 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


What is the best way to resolve it?

Thank you.


Last edited by ONEEYEMAN on Fri Jul 24, 2015 11:44 am; edited 1 time in total
Back to top
View user's profile Send private message
Keruskerfuerst
Advocate
Advocate


Joined: 01 Feb 2006
Posts: 2288
Location: near Augsburg, Germany

PostPosted: Sun Jul 19, 2015 6:32 pm    Post subject: Reply with quote

[blocks B ] <kde-base/kmail-4.14.5 ("<kde-base/kmail-4.14.5" is blocking kde-base/kdepim-common-libs-4.14.8)

Uninstall kmail
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2769

PostPosted: Sun Jul 19, 2015 7:29 pm    Post subject: Reply with quote

Hi,
Does this mean that "kmail" is not in the KDE 4.14.5? And its functionality is moved to kdepim?

Please clarify.

Thank you.
Back to top
View user's profile Send private message
Keruskerfuerst
Advocate
Advocate


Joined: 01 Feb 2006
Posts: 2288
Location: near Augsburg, Germany

PostPosted: Sun Jul 19, 2015 7:46 pm    Post subject: Reply with quote

No.

It only means, that kmail blocks the installation/update of kdepim.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2769

PostPosted: Sun Jul 19, 2015 7:59 pm    Post subject: Reply with quote

So I uninstall it, install kleopatra and then install kmail?
Or what do I do?

The only reason I'm looking at kleopatra is because boost needs it:

Code:

IgorDellGentoo wxWidgets # MAKEOPTS="-j1" emerge boost

 * IMPORTANT: 7 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.

 * Last emerge --sync was 33d 16h 1m 21s ago.
Calculating dependencies... done!
[ebuild     U  ] dev-libs/boost-1.55.0-r2 [1.52.0-r7] USE="-context%" ABI_X86="(64%*) -32% (-x32)" PYTHON_TARGETS="-python3_4%"

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/boost:0

  (dev-libs/boost-1.55.0-r2:0/1.55.0::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/boost (Argument)

  (dev-libs/boost-1.52.0-r7:0/1.52::gentoo, installed) pulled in by
    dev-libs/boost:0/1.52= required by (kde-base/kleopatra-4.12.5:4/4.12::gentoo, installed)
                  ^^^^^^^^                                                                                                     
    (and 4 more with the same problem)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


I had to do "MAKEOPTS" since boost has a problem with compiling thru the multiple threads...

Thank you.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Sun Jul 19, 2015 8:50 pm    Post subject: Reply with quote

No, you update kmail at the same time as kleopatra.

Your installed (ancient) version of kleopatra would break when upgrading boost, that's what portage is telling you up there. It would trigger an update of kleopatra at the same time, but for some reason (I suspect the block in between PIM versions) portage doesn't - a higher backtrack value as suggested might help as well.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2769

PostPosted: Sun Jul 19, 2015 9:02 pm    Post subject: Reply with quote

genstorm,
So, I will just do:

Code:

emerge kmail kleopatra
MAKEOPTS="-j1" emerge boost"


and that should solve it?

Thank you.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Sun Jul 19, 2015 9:08 pm    Post subject: Reply with quote

That will trigger another rebuild of kleopatra as soon as you update boost. You should really do that at the same time. Any reason why you do not upgrade world?

Why do you think boost has a problem with >-j1? I can't find a bug report.

Also,
Code:
* IMPORTANT: 7 news items need reading for repository 'gentoo'.

Neglected system?
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2769

PostPosted: Sun Jul 19, 2015 9:14 pm    Post subject: Reply with quote

OK, trying to do just that I got:

Code:

IgorDellGentoo wxWidgets # emerge -pv kmail kleopatra
 * Last emerge --sync was 33d 20h 6m 31s ago.

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] kde-base/baloo-4.14.3:4/4.14::gentoo  USE="(-aqua) -debug -minimal" 0 KiB
[ebuild     U  ] kde-base/kdepim-icons-4.14.8:4/4.14::gentoo [4.12.5:4/4.12::gentoo] USE="(-aqua)" 14235 KiB
[ebuild     U  ] kde-base/kdepim-runtime-4.14.8:4/4.14::gentoo [4.12.5:4/4.12::gentoo] USE="(-aqua) -debug -facebook -google -kolab" 1147 KiB
[ebuild     U  ] kde-base/kdepim-common-libs-4.14.8:4/4.14::gentoo [4.12.5:4/4.12::gentoo] USE="(-aqua) -debug" 0 KiB
[ebuild     U  ] kde-base/kontact-4.14.8:4/4.14::gentoo [4.12.5:4/4.12::gentoo] USE="handbook (-aqua) -debug" 0 KiB
[ebuild     U  ] kde-base/kleopatra-4.14.8:4/4.14::gentoo [4.12.5:4/4.12::gentoo] USE="handbook (-aqua) -debug" 0 KiB
[ebuild     U  ] kde-base/korganizer-4.14.8:4/4.14::gentoo [4.12.5:4/4.12::gentoo] USE="handbook kontact (-aqua) -debug" 0 KiB
[ebuild     U  ] kde-base/kmail-4.14.8:4/4.14::gentoo [4.12.5:4/4.12::gentoo] USE="handbook kontact (-aqua) -debug {-test}" 0 KiB
[blocks b      ] <kde-base/kmail-4.14.5 ("<kde-base/kmail-4.14.5" is blocking kde-base/kdepim-common-libs-4.14.8)

Total: 8 packages (7 upgrades, 1 new), Size of downloads: 15381 KiB
Conflict: 1 block

 * IMPORTANT: 7 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


However, last time I tried to install baloo, I had a problem, because of its conflict with nepomuk. See this and this thread for the reference.

I fear I will have the same issue again...

Is there a safe way to install baloo?

Thank you.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Sun Jul 19, 2015 9:18 pm    Post subject: Reply with quote

ONEEYEMAN wrote:
Is there a safe way to install baloo?

Yeah, upgrade nepomuk first so that no ancient version of it collides with baloo.

If you upgrade dependencies, make sure you always add -1 to emerge so you don't get unwanted records in your world file.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2769

PostPosted: Sun Jul 19, 2015 9:30 pm    Post subject: Reply with quote

OK.
Trying to upgrade nepomuk I get:

Code:

IgorDellGentoo wxWidgets # emerge -1pv nepomuk
 * Last emerge --sync was 33d 20h 27m 7s ago.

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] kde-base/kdelibs-4.14.8:4/4.14::gentoo  USE="acl alsa bzip2 crypt fam handbook nepomuk* nls opengl (policykit) spell ssl udev udisks upower (-altivec) (-aqua) -debug -doc -jpeg2k -kerberos -lzma -openexr {-test} -zeroconf" CPU_FLAGS_X86="mmx sse sse2 -3dnow" 0 KiB
[ebuild  N     ] kde-base/baloo-4.14.3:4/4.14::gentoo  USE="(-aqua) -debug -minimal" 0 KiB
[ebuild     U  ] kde-base/nepomuk-core-4.14.3:4/4.14::gentoo [4.12.5:4/4.12::gentoo] USE="exif migrator%* pdf (-aqua) -debug -epub -ffmpeg -taglib" 0 KiB
[ebuild     U  ] kde-base/nepomuk-widgets-4.14.3:4/4.14::gentoo [4.12.5:4/4.12::gentoo] USE="(-aqua) -debug" 48 KiB
[ebuild     U  ] kde-apps/nepomuk-4.14.3:4/4.14::gentoo [4.12.5:4/4.12::gentoo] USE="handbook (-aqua) -debug" 0 KiB

Total: 5 packages (3 upgrades, 1 new, 1 reinstall), Size of downloads: 48 KiB

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by kde-apps/nepomuk-4.14.3::gentoo
# required by nepomuk (argument)
>=kde-base/kdelibs-4.14.8 nepomuk

 * IMPORTANT: 7 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


The only thing is - nepomuk is going away and it will be superceeded by baloo.

So why do I need to include it in the USE flags? Or I will take it out after switching to baloo?

Please clarify.

Thank you.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Sun Jul 19, 2015 9:36 pm    Post subject: Reply with quote

ONEEYEMAN wrote:
The only thing is - nepomuk is going away and it will be superceeded by baloo.

So why do I need to include it in the USE flags? Or I will take it out after switching to baloo?

Then why do you have nepomuk still installed?

In fact, even in 4.14.10 nepomuk can still be present - alongside baloo - depending on your choice of use flags / package selection. I can not know how you configured your system*, I can only tell that nepomuk in its current (ancient) form seems to collide as soon as you upgrade baloo. ;)

You need to do a full system upgrade, plain and simple.

* To be sure,
Code:
equery d nepomuk

but that was mentioned in your linked threads already.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2769

PostPosted: Sun Jul 19, 2015 9:44 pm    Post subject: Reply with quote

So, do:

Code:

emerge -vuD world


Thank you.

[EDIT]
This is what I got:

Code:

IgorDellGentoo wxWidgets # emerge -pvuD world
 * Last emerge --sync was 33d 21h 3m 29s ago.

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  r  U  ] dev-libs/boost-1.55.0-r2:0/1.55.0::gentoo [1.52.0-r7:0/1.52::gentoo] USE="nls threads -context% -debug -doc -icu -mpi -python -static-libs -tools" ABI_X86="(64%*) -32% (-x32)" PYTHON_TARGETS="python2_7 python3_3 -python3_4% (-python3_2%)" 0 KiB
[ebuild  rR    ] app-office/akonadi-server-1.13.0::gentoo  USE="mysql qt4 -postgres (-qt5) -soprano -sqlite {-test}" 0 KiB
[ebuild  rR    ] media-libs/qt-gstreamer-1.2.0::gentoo  USE="{-test}" 0 KiB
[ebuild  rR    ] kde-base/kdepimlibs-4.14.8:4/4.14::gentoo  USE="handbook ldap (-aqua) -debug -prison {-test}" 0 KiB
[ebuild  N     ] kde-base/baloo-4.14.3:4/4.14::gentoo  USE="(-aqua) -debug -minimal" 0 KiB
[ebuild     U  ] kde-apps/gwenview-4.14.3:4/4.14::gentoo [4.12.5:4/4.12::gentoo] USE="handbook kipi semantic-desktop (-aqua) -debug" 0 KiB
[ebuild  N     ] kde-base/baloo-widgets-4.14.3:4/4.14::gentoo  USE="(-aqua) -debug" 0 KiB
[ebuild     U  ] kde-apps/kdegraphics-meta-4.14.3:4::gentoo [4.12.5:4::gentoo] USE="(-aqua) -scanner" 0 KiB
[ebuild     U  ] kde-apps/dolphin-4.14.3:4/4.14::gentoo [4.12.5:4/4.12::gentoo] USE="handbook semantic-desktop (-aqua) -debug -thumbnail" 0 KiB
[ebuild  N     ] net-libs/webkit-gtk-2.4.8:3/25::gentoo  USE="X egl geoloc gstreamer introspection jit opengl spell webgl (-aqua) -coverage -debug -gles2 -libsecret {-test} -wayland" 0 KiB
[ebuild     U  ] kde-apps/kdebase-meta-4.14.3:4::gentoo [4.12.5:4::gentoo] USE="display-manager%* wallpapers (-aqua) -minimal%" 0 KiB
[ebuild     U  ] dev-vcs/gitg-3.14.0::gentoo [0.2.7::gentoo] USE="python%* -debug -glade" PYTHON_TARGETS="python3_3%* -python3_4%" 0 KiB
[ebuild     U  ] kde-base/kde-meta-4.14.3:4::gentoo [4.12.5:4::gentoo] USE="nls -accessibility (-aqua) -kdepim% -minimal% -sdk (-semantic-desktop%*)" 0 KiB

Total: 13 packages (7 upgrades, 3 new, 3 reinstalls), Size of downloads: 0 KiB

The following packages are causing rebuilds:

  (dev-libs/boost-1.55.0-r2:0/1.55.0::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (app-office/akonadi-server-1.13.0:0/0::gentoo, ebuild scheduled for merge)
    (media-libs/qt-gstreamer-1.2.0:0/0::gentoo, ebuild scheduled for merge)
    (kde-base/kdepimlibs-4.14.8:4/4.14::gentoo, ebuild scheduled for merge)

 * IMPORTANT: 7 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


Should I run this? Or is there any additional steps I need?
[/EDIT]
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Sun Jul 19, 2015 10:12 pm    Post subject: Reply with quote

Well, the strange thing is that you do not get a full PIM upgrade, even though you have packages like kleopatra and kmail definitely installed. Since nepomuk is again missing here, its lack of being upgraded will mean trouble for baloo once more.

Try this:
Code:
emerge -1vuD world nepomuk kleopatra kmail


Otherwise, use the equery command above to go and see if nepomuk is really not needed on your system and unmerge it if positive.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2769

PostPosted: Sun Jul 19, 2015 10:25 pm    Post subject: Reply with quote

genstorm,
The results are:

Code:

IgorDellGentoo wxWidgets # emerge -1pvuD world nepomuk kleopatra kmail
 * Last emerge --sync was 33d 21h 22m 12s ago.

These are the packages that would be merged, in order:

Calculating dependencies... done!

The following packages are causing rebuilds:

  (dev-libs/boost-1.55.0-r2:0/1.55.0::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (app-office/akonadi-server-1.13.0:0/0::gentoo, ebuild scheduled for merge)
    (media-libs/qt-gstreamer-1.2.0:0/0::gentoo, ebuild scheduled for merge)
    (kde-base/kdepimlibs-4.14.8:4/4.14::gentoo, ebuild scheduled for merge)
[ebuild  r  U  ] dev-libs/boost-1.55.0-r2:0/1.55.0::gentoo [1.52.0-r7:0/1.52::gentoo] USE="nls threads -context% -debug -doc -icu -mpi -python -static-libs -tools" ABI_X86="(64%*) -32% (-x32)" PYTHON_TARGETS="python2_7 python3_3 -python3_4% (-python3_2%)" 0 KiB
[ebuild  rR    ] app-office/akonadi-server-1.13.0::gentoo  USE="mysql qt4 -postgres (-qt5) -soprano -sqlite {-test}" 0 KiB
[ebuild  rR    ] media-libs/qt-gstreamer-1.2.0::gentoo  USE="{-test}" 0 KiB
[ebuild  rR    ] kde-base/kdepimlibs-4.14.8:4/4.14::gentoo  USE="handbook ldap (-aqua) -debug -prison {-test}" 0 KiB
[ebuild  N     ] kde-base/baloo-4.14.3:4/4.14::gentoo  USE="(-aqua) -debug -minimal" 0 KiB
[ebuild     U  ] kde-base/kdepim-icons-4.14.8:4/4.14::gentoo [4.12.5:4/4.12::gentoo] USE="(-aqua)" 14235 KiB
[ebuild     U  ] kde-base/kdepim-runtime-4.14.8:4/4.14::gentoo [4.12.5:4/4.12::gentoo] USE="(-aqua) -debug -facebook -google -kolab" 1147 KiB
[ebuild     U  ] kde-apps/gwenview-4.14.3:4/4.14::gentoo [4.12.5:4/4.12::gentoo] USE="handbook kipi semantic-desktop (-aqua) -debug" 0 KiB
[ebuild  N     ] net-libs/webkit-gtk-2.4.8:3/25::gentoo  USE="X egl geoloc gstreamer introspection jit opengl spell webgl (-aqua) -coverage -debug -gles2 -libsecret {-test} -wayland" 0 KiB
[ebuild     U  ] dev-vcs/gitg-3.14.0::gentoo [0.2.7::gentoo] USE="python%* -debug -glade" PYTHON_TARGETS="python3_3%* -python3_4%" 0 KiB
[ebuild   R    ] kde-base/kdelibs-4.14.8:4/4.14::gentoo  USE="acl alsa bzip2 crypt fam handbook nepomuk* nls opengl (policykit) spell ssl udev udisks upower (-altivec) (-aqua) -debug -doc -jpeg2k -kerberos -lzma -openexr {-test} -zeroconf" CPU_FLAGS_X86="mmx sse sse2 -3dnow" 0 KiB
[ebuild     U  ] kde-base/nepomuk-core-4.14.3:4/4.14::gentoo [4.12.5:4/4.12::gentoo] USE="exif migrator%* pdf (-aqua) -debug -epub -ffmpeg -taglib" 0 KiB
[ebuild     U  ] kde-base/nepomuk-widgets-4.14.3:4/4.14::gentoo [4.12.5:4/4.12::gentoo] USE="(-aqua) -debug" 48 KiB
[ebuild  N     ] kde-base/baloo-widgets-4.14.3:4/4.14::gentoo  USE="(-aqua) -debug" 0 KiB
[ebuild     U  ] kde-apps/nepomuk-4.14.3:4/4.14::gentoo [4.12.5:4/4.12::gentoo] USE="handbook (-aqua) -debug" 0 KiB
[ebuild     U  ] kde-apps/dolphin-4.14.3:4/4.14::gentoo [4.12.5:4/4.12::gentoo] USE="handbook semantic-desktop (-aqua) -debug -thumbnail" 0 KiB
[ebuild     U  ] kde-apps/kdegraphics-meta-4.14.3:4::gentoo [4.12.5:4::gentoo] USE="(-aqua) -scanner" 0 KiB
[ebuild     U  ] kde-apps/kdebase-meta-4.14.3:4::gentoo [4.12.5:4::gentoo] USE="display-manager%* wallpapers (-aqua) -minimal%" 0 KiB
[ebuild     U  ] kde-base/kde-meta-4.14.3:4::gentoo [4.12.5:4::gentoo] USE="nls -accessibility (-aqua) -kdepim% -minimal% -sdk (-semantic-desktop%*)" 0 KiB
[ebuild     U  ] kde-base/kdepim-common-libs-4.14.8:4/4.14::gentoo [4.12.5:4/4.12::gentoo] USE="(-aqua) -debug" 0 KiB
[ebuild     U  ] kde-base/kontact-4.14.8:4/4.14::gentoo [4.12.5:4/4.12::gentoo] USE="handbook (-aqua) -debug" 0 KiB
[ebuild     U  ] kde-base/kleopatra-4.14.8:4/4.14::gentoo [4.12.5:4/4.12::gentoo] USE="handbook (-aqua) -debug" 0 KiB
[ebuild     U  ] kde-base/korganizer-4.14.8:4/4.14::gentoo [4.12.5:4/4.12::gentoo] USE="handbook kontact (-aqua) -debug" 0 KiB
[ebuild     U  ] kde-base/kmail-4.14.8:4/4.14::gentoo [4.12.5:4/4.12::gentoo] USE="handbook kontact (-aqua) -debug {-test}" 0 KiB
[blocks b      ] <kde-base/kmail-4.14.5 ("<kde-base/kmail-4.14.5" is blocking kde-base/kdepim-common-libs-4.14.8)

Total: 24 packages (17 upgrades, 3 new, 4 reinstalls), Size of downloads: 15429 KiB
Conflict: 1 block

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by kde-apps/nepomuk-4.14.3::gentoo
# required by nepomuk (argument)
>=kde-base/kdelibs-4.14.8 nepomuk

emerge: there are no ebuilds built with USE flags to satisfy ">=kde-base/kdelibs-4.14.3:4[aqua=,nepomuk]".
!!! One of the following packages is required to complete your request:
- kde-base/kdelibs-4.14.3-r1::gentoo (Change USE: +nepomuk)
(dependency required by "kde-apps/nepomuk-4.14.3::gentoo" [ebuild])
(dependency required by "nepomuk" [argument])

 * IMPORTANT: 7 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


Here are the equery result:

Code:

IgorDellGentoo wxWidgets # equery d nepomuk
 * These packages depend on nepomuk:
kde-apps/kdebase-runtime-meta-4.14.3 (nepomuk ? >=kde-apps/nepomuk-4.14.3:4[aqua=])
kde-base/systemsettings-4.11.19 (nepomuk ? >=kde-apps/nepomuk-4.11.19:4[aqua=])


And checking those 2 I get:

Code:

IgorDellGentoo wxWidgets # emerge -pv kdebase-runtime-meta systemsettings
 * Last emerge --sync was 33d 21h 27m 18s ago.

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] kde-apps/kdebase-runtime-meta-4.14.3:4::gentoo  USE="crash-reporter handbook (-aqua) -minimal -nepomuk" 0 KiB
[ebuild   R    ] kde-base/systemsettings-4.11.19:4/4.11::gentoo  USE="gtk handbook kscreen opengl usb (-aqua) -debug -nepomuk {-test}" 0 KiB

Total: 2 packages (2 reinstalls), Size of downloads: 0 KiB

 * IMPORTANT: 7 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


So should I just unmerge nepomuk? And what do I do next?

But maybe all this will be taken care on the subsequent "world" emerge?

Thank you.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Sun Jul 19, 2015 10:27 pm    Post subject: Reply with quote

Well, then just remove nepomuk from your system. It won't go away automatically.

Also, if you are in fact using the KDE PIM suite, you should know that it doesn't seem to be well established on your system, so it remains at much too old 4.12.something. Either you are missing 'kde-base/kdepim-meta' to pull in all of it, or you record the individual packages of it inside your world file.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2769

PostPosted: Sun Jul 19, 2015 10:47 pm    Post subject: Reply with quote

OK, so after:

Code:

emerge --unmerge nepomuk


what do I do? You still recommend to upgrade world with those 2 extras (kmail, kleopatra)? Or just world?

What worries me is that even though "emerge -vuD world" included boost, it didn't say anythiong about kleopatra.

And what is KDE PIM? I am using KDE, but no idea about PIM...

Thank you.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Sun Jul 19, 2015 10:59 pm    Post subject: Reply with quote

See also my previous post.

KDE PIM = personal information manager suite of KDE, which kmail and kleopatra are part of:

Code:
$ equery g kdepim-meta
 * Searching for kdepim-meta ...

 * dependency graph for kde-base/kdepim-meta-4.14.3
 `--  kde-base/kdepim-meta-4.14.3  amd64
   `--  kde-base/akonadiconsole-4.14.10  (>=kde-base/akonadiconsole-4.14.3) ~amd64  [aqua=]
   `--  kde-base/akregator-4.14.10  (>=kde-base/akregator-4.14.3) ~amd64  [aqua=]
   `--  kde-base/blogilo-4.14.10  (>=kde-base/blogilo-4.14.3) ~amd64  [aqua=]
   `--  kde-base/calendarjanitor-4.14.10  (>=kde-base/calendarjanitor-4.14.3) ~amd64  [aqua=]
   `--  kde-base/kabcclient-4.14.10  (>=kde-base/kabcclient-4.14.3) ~amd64  [aqua=]
   `--  kde-base/kaddressbook-4.14.10  (>=kde-base/kaddressbook-4.14.3) ~amd64  [aqua=]
   `--  kde-base/kalarm-4.14.10  (>=kde-base/kalarm-4.14.3) ~amd64  [aqua=]
   `--  kde-base/kdepim-icons-4.14.10  (>=kde-base/kdepim-icons-4.14.3) ~amd64  [aqua=]
   `--  kde-base/kdepim-kresources-4.14.10  (>=kde-base/kdepim-kresources-4.14.3) ~amd64  [aqua=]
   `--  kde-base/kdepim-runtime-4.14.10  (>=kde-base/kdepim-runtime-4.14.3) ~amd64  [aqua=]
   `--  kde-base/kjots-4.14.10  (>=kde-base/kjots-4.14.3) ~amd64  [aqua=]
   `--  kde-base/kleopatra-4.14.10  (>=kde-base/kleopatra-4.14.3) ~amd64  [aqua=]
   `--  kde-base/kmail-4.14.10  (>=kde-base/kmail-4.14.3) ~amd64  [aqua=]
   `--  kde-base/knode-4.14.10  (>=kde-base/knode-4.14.3) ~amd64  [aqua=]
   `--  kde-base/knotes-4.14.10  (>=kde-base/knotes-4.14.3) ~amd64  [aqua=]
   `--  kde-base/konsolekalendar-4.14.10  (>=kde-base/konsolekalendar-4.14.3) ~amd64  [aqua=]
   `--  kde-base/kontact-4.14.10  (>=kde-base/kontact-4.14.3) ~amd64  [aqua=]
   `--  kde-base/korganizer-4.14.10  (>=kde-base/korganizer-4.14.3) ~amd64  [aqua=]
   `--  kde-base/ktimetracker-4.14.10  (>=kde-base/ktimetracker-4.14.3) ~amd64  [aqua=]
   `--  kde-base/ktnef-4.14.10  (>=kde-base/ktnef-4.14.3) ~amd64  [aqua=]
   `--  kde-apps/kde4-l10n-15.04.3  (>=kde-apps/kde4-l10n-15.04.0) ~amd64  [aqua=]
   `--  kde-base/kdepim-l10n-4.14.3  (>=kde-base/kdepim-l10n-4.14.3) amd64  [aqua=]
[ kde-base/kdepim-meta-4.14.3 stats: packages (23), max depth (1) ]


Upgrade world and deal with kmail/kleopatra afterwards.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2769

PostPosted: Sun Jul 19, 2015 11:22 pm    Post subject: Reply with quote

OK, so I unmerged nepomuk and then did this with following results:

Code:

IgorDellGentoo wxWidgets # emerge -pvuD world
 * Last emerge --sync was 33d 22h 21m 46s ago.

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  r  U  ] dev-libs/boost-1.55.0-r2:0/1.55.0::gentoo [1.52.0-r7:0/1.52::gentoo] USE="nls threads -context% -debug -doc -icu -mpi -python -static-libs -tools" ABI_X86="(64%*) -32% (-x32)" PYTHON_TARGETS="python2_7 python3_3 -python3_4% (-python3_2%)" 0 KiB
[ebuild  rR    ] app-office/akonadi-server-1.13.0::gentoo  USE="mysql qt4 -postgres (-qt5) -soprano -sqlite {-test}" 0 KiB
[ebuild  rR    ] media-libs/qt-gstreamer-1.2.0::gentoo  USE="{-test}" 0 KiB
[ebuild  rR    ] kde-base/kdepimlibs-4.14.8:4/4.14::gentoo  USE="handbook ldap (-aqua) -debug -prison {-test}" 0 KiB
[ebuild  N     ] kde-base/baloo-4.14.3:4/4.14::gentoo  USE="(-aqua) -debug -minimal" 0 KiB
[ebuild  N     ] kde-base/baloo-widgets-4.14.3:4/4.14::gentoo  USE="(-aqua) -debug" 0 KiB
[ebuild     U  ] kde-apps/gwenview-4.14.3:4/4.14::gentoo [4.12.5:4/4.12::gentoo] USE="handbook kipi semantic-desktop (-aqua) -debug" 0 KiB
[ebuild     U  ] kde-apps/kdegraphics-meta-4.14.3:4::gentoo [4.12.5:4::gentoo] USE="(-aqua) -scanner" 0 KiB
[ebuild     U  ] kde-apps/dolphin-4.14.3:4/4.14::gentoo [4.12.5:4/4.12::gentoo] USE="handbook semantic-desktop (-aqua) -debug -thumbnail" 0 KiB
[ebuild  N     ] net-libs/webkit-gtk-2.4.8:3/25::gentoo  USE="X egl geoloc gstreamer introspection jit opengl spell webgl (-aqua) -coverage -debug -gles2 -libsecret {-test} -wayland" 0 KiB
[ebuild     U  ] kde-apps/kdebase-meta-4.14.3:4::gentoo [4.12.5:4::gentoo] USE="display-manager%* wallpapers (-aqua) -minimal%" 0 KiB
[ebuild     U  ] dev-vcs/gitg-3.14.0::gentoo [0.2.7::gentoo] USE="python%* -debug -glade" PYTHON_TARGETS="python3_3%* -python3_4%" 0 KiB
[ebuild     U  ] kde-base/kde-meta-4.14.3:4::gentoo [4.12.5:4::gentoo] USE="nls -accessibility (-aqua) -kdepim% -minimal% -sdk (-semantic-desktop%*)" 0 KiB

Total: 13 packages (7 upgrades, 3 new, 3 reinstalls), Size of downloads: 0 KiB

The following packages are causing rebuilds:

  (dev-libs/boost-1.55.0-r2:0/1.55.0::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (app-office/akonadi-server-1.13.0:0/0::gentoo, ebuild scheduled for merge)
    (media-libs/qt-gstreamer-1.2.0:0/0::gentoo, ebuild scheduled for merge)
    (kde-base/kdepimlibs-4.14.8:4/4.14::gentoo, ebuild scheduled for merge)

 * IMPORTANT: 7 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


Should I remove the "--pretend" option and run it? The message seems to be just a warning...

Thank you.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Sun Jul 19, 2015 11:27 pm    Post subject: Reply with quote

I can't see any warning except in my signature. ;) Do it!
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2769

PostPosted: Sun Jul 19, 2015 11:36 pm    Post subject: Reply with quote

OK, started.
If and when it will fail I will come back to this thread. So don't go anywhere... ;-)

About the warning: I was talking about the boost message that appears under the list of packages.

Than k you.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Sun Jul 19, 2015 11:41 pm    Post subject: Reply with quote

...which isn't a warning, just an information. Read carefully ;)
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2769

PostPosted: Mon Jul 20, 2015 2:11 am    Post subject: Reply with quote

OK, so this last command failed like this:

Code:

libtool: compile:  x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -fno-strict-aliasing -DPACKAGE_LOCALE_DIR=\"/usr/share/locale\" -Wall -W -Wcast-align -Wchar-subscripts -Wreturn-type -Wformat -Wformat-security -Wno-format-y2k -Wundef -Wmissing-format-attribute -Wpointer-arith -Wwrite-strings -Wno-unused-parameter -Wno-parentheses -fno-exceptions -DBUILDING_CAIRO__ -DBUILDING_GTK__ -DBUILDING_WEBKIT2__ -include ./Source/WebKit2/WebKit2Prefix.h -I./Source/WebKit/gtk -I./Source/WebKit2 -I./Source/WebKit2/gtk -I./Source/WebKit2/NetworkProcess -I./Source/WebKit2/NetworkProcess/FileAPI -I./Source/WebKit2/Platform -I./Source/WebKit2/Platform/IPC/gtk -I./Source/WebKit2/Platform/IPC -I./Source/WebKit2/Platform/gtk -I./Source/WebKit2/PluginProcess -I./Source/WebKit2/Shared -I./Source/WebKit2/Shared/API -I./Source/WebKit2/Shared/API/c -I./Source/WebKit2/Shared/API/c/gtk -I./Source/WebKit2/Shared/API/c/soup -I./Source/WebKit2/Shared/Authentication -I./Source/WebKit2/Shared/CoreIPCSupport -I./Source/WebKit2/Shared/Downloads -I./Source/WebKit2/Shared/Downloads/soup -I./Source/WebKit2/Shared/FileAPI -I./Source/WebKit2/Shared/Databases -I./Source/WebKit2/Shared/Databases/IndexedDB -I./Source/WebKit2/Shared/gtk -I./Source/WebKit2/Shared/Network -I./Source/WebKit2/Shared/Network/CustomProtocols -I./Source/WebKit2/Shared/Network/CustomProtocols/soup -I./Source/WebKit2/Shared/Plugins -I./Source/WebKit2/Shared/Plugins/Netscape -I./Source/WebKit2/Shared/Plugins/Netscape/x11 -I./Source/WebKit2/Shared/soup -I./Source/WebKit2/UIProcess -I./Source/WebKit2/UIProcess/API -I./Source/WebKit2/UIProcess/API/C -I./Source/WebKit2/UIProcess/API/C/gtk -I./Source/WebKit2/UIProcess/API/C/soup -I./Source/WebKit2/UIProcess/API/cpp -I./Source/WebKit2/UIProcess/API/gtk -I./Source/WebKit2/UIProcess/Authentication -I./Source/WebKit2/UIProcess/Downloads -I./Source/WebKit2/UIProcess/gtk -I./Source/WebKit2/UIProcess/Launcher -I./Source/WebKit2/UIProcess/Launcher/gtk -I./Source/WebKit2/UIProcess/Network -I./Source/WebKit2/UIProcess/Network/CustomProtocols -I./Source/WebKit2/UIProcess/Network/CustomProtocols/soup -I./Source/WebKit2/UIProcess/Notifications -I./Source/WebKit2/UIProcess/Plugins -I./Source/WebKit2/UIProcess/Plugins/gtk -I./Source/WebKit2/UIProcess/Plugins/unix -I./Source/WebKit2/UIProcess/Storage -I./Source/WebKit2/UIProcess/soup -I./Source/WebKit2/UIProcess/InspectorServer -I./Source/WebKit2/WebProcess -I./Source/WebKit2/WebProcess/ApplicationCache -I./Source/WebKit2/WebProcess/Battery -I./Source/WebKit2/WebProcess/Cookies -I./Source/WebKit2/WebProcess/Databases -I./Source/WebKit2/WebProcess/Databases/IndexedDB -I./Source/WebKit2/WebProcess/FileAPI -I./Source/WebKit2/WebProcess/FullScreen -I./Source/WebKit2/WebProcess/Geolocation -I./Source/WebKit2/WebProcess/gtk -I./Source/WebKit2/WebProcess/IconDatabase -I./Source/WebKit2/WebProcess/InjectedBundle -I./Source/WebKit2/WebProcess/InjectedBundle/API -I./Source/WebKit2/WebProcess/InjectedBundle/API/c -I./Source/WebKit2/WebProcess/InjectedBundle/API/gtk -I./Source/WebKit2/WebProcess/InjectedBundle/DOM -I./Source/WebKit2/WebProcess/InjectedBundle/gtk -I./Source/WebKit2/WebProcess/KeyValueStorage -I./Source/WebKit2/WebProcess/Launching -I./Source/WebKit2/WebProcess/MediaCache -I./Source/WebKit2/WebProcess/Network -I./Source/WebKit2/WebProcess/NetworkInfo -I./Source/WebKit2/WebProcess/Notifications -I./Source/WebKit2/WebProcess/OriginData -I./Source/WebKit2/WebProcess/ResourceCache -I./Source/WebKit2/WebProcess/Storage -I./Source/WebKit2/WebProcess/soup -I./Source/WebKit2/WebProcess/Plugins -I./Source/WebKit2/WebProcess/Plugins/Netscape -I./Source/WebKit2/WebProcess/Plugins/Netscape/unix -I./Source/WebKit2/WebProcess/WebCoreSupport -I./Source/WebKit2/WebProcess/WebCoreSupport/gtk -I./Source/WebKit2/WebProcess/WebCoreSupport/soup -I./Source/WebKit2/WebProcess/WebPage -I./Source/WebKit2/WebProcess/WebPage/atk -I./Source/WebKit2/WebProcess/WebPage/gtk -I./DerivedSources/WebKit2 -I./DerivedSources/WebKit2/include -I./DerivedSources/WebKit2/webkit2gtk -I./DerivedSources/WebKit2/webkit2gtk/include -I./DerivedSources/WebKit2/webkit2gtk/webkit2 -I./DerivedSources/WebKit2/webkit2extension/include -I./DerivedSources/WebKit2/include/JavaScriptCore -I./DerivedSources/WebKit2/include/WebCore -I./DerivedSources/WebKit2/include/WebKit2 -I./DerivedSources/webkitdom -DLIBEXECDIR=\"/usr/libexec\" -DLIBDIR=\"/usr/lib64\" -DBUILDING_WEBKIT -DWEBKIT2_COMPILATION -DENABLE_PLUGIN_PROCESS=1 -I./Source/ThirdParty/ANGLE/src -I./Source/ThirdParty/ANGLE/include -I./Source/ThirdParty/ANGLE/include/GLSLANG -I./Source/ThirdParty/ANGLE/include/KHR -I./DerivedSources/Platform -DWEBKITGTK_API_VERSION_STRING=\"3.0\" -DDATA_DIR=\"/usr/share\" -I./Source/ThirdParty/ANGLE/src -I./Source/ThirdParty/ANGLE/include -I./Source/ThirdParty/ANGLE/include/GLSLANG -I./Source/ThirdParty/ANGLE/include/KHR -I./Source/WebCore -I./Source/WebCore/Modules/battery -I./Source/WebCore/Modules/gamepad -I./Source/WebCore/Modules/geolocation -I./Source/WebCore/Modules/indexeddb -I./Source/WebCore/Modules/indexeddb/leveldb -I./Source/WebCore/Modules/indieui -I./Source/WebCore/Modules/mediasource -I./Source/WebCore/Modules/mediastream -I./Source/WebCore/Modules/navigatorcontentutils -I./Source/WebCore/Modules/notifications -I./Source/WebCore/Modules/plugins -I./Source/WebCore/Modules/proximity -I./Source/WebCore/Modules/quota -I./Source/WebCore/Modules/webaudio -I./Source/WebCore/Modules/webdatabase -I./Source/WebCore/Modules/websockets -I./Source/WebCore/accessibility -I./Source/WebCore/bindings -I./Source/WebCore/bindings/generic -I./Source/WebCore/bindings/js -I./Source/WebCore/bridge -I./Source/WebCore/bridge/c -I./Source/WebCore/bridge/jsc -I./Source/WebCore/crypto -I./Source/WebCore/crypto/keys -I./Source/WebCore/css -I./Source/WebCore/cssjit -I./Source/WebCore/dom -I./Source/WebCore/dom/default -I./Source/WebCore/editing -I./Source/WebCore/fileapi -I./Source/WebCore/history -I./Source/WebCore/html -I./Source/WebCore/html/canvas -I./Source/WebCore/html/forms -I./Source/WebCore/html/parser -I./Source/WebCore/html/shadow -I./Source/WebCore/html/track -I./Source/WebCore/inspector -I./Source/WebCore/loader -I./Source/WebCore/loader/appcache -I./Source/WebCore/loader/archive -I./Source/WebCore/loader/archive/mhtml -I./Source/WebCore/loader/cache -I./Source/WebCore/loader/icon -I./Source/WebCore/mathml -I./Source/WebCore/page -I./Source/WebCore/page/animation -I./Source/WebCore/page/scrolling -I./Source/WebCore/platform -I./Source/WebCore/platform/animation -I./Source/WebCore/platform/audio -I./Source/WebCore/platform/graphics -I./Source/WebCore/platform/graphics/cpu/arm -I./Source/WebCore/platform/graphics/cpu/arm/filters/ -I./Source/WebCore/platform/graphics/filters -I./Source/WebCore/platform/graphics/filters/texmap -I./Source/WebCore/platform/graphics/freetype -I./Source/WebCore/platform/graphics/gpu -I./Source/WebCore/platform/graphics/harfbuzz -I./Source/WebCore/platform/graphics/harfbuzz/ng -I./Source/WebCore/platform/graphics/opengl -I./Source/WebCore/platform/graphics/opentype -I./Source/WebCore/platform/graphics/transforms -I./Source/WebCore/platform/image-decoders -I./Source/WebCore/platform/image-decoders/bmp -I./Source/WebCore/platform/image-decoders/gif -I./Source/WebCore/platform/image-decoders/ico -I./Source/WebCore/platform/image-decoders/jpeg -I./Source/WebCore/platform/image-decoders/png -I./Source/WebCore/platform/image-decoders/webp -I./Source/WebCore/platform/leveldb -I./Source/WebCore/platform/linux -I./Source/WebCore/platform/mediastream -I./Source/WebCore/platform/mediastream/gstreamer -I./Source/WebCore/platform/mock -I./Source/WebCore/platform/mock/mediasource -I./Source/WebCore/platform/network -I./Source/WebCore/platform/network/gtk -I./Source/WebCore/platform/sql -I./Source/WebCore/platform/text -I./Source/WebCore/platform/text/icu -I./Source/WebCore/platform/win -I./Source/WebCore/plugins -I./Source/WebCore/plugins/win -I./Source/WebCore/rendering -I./Source/WebCore/rendering/line -I./Source/WebCore/rendering/mathml -I./Source/WebCore/rendering/shapes -I./Source/WebCore/rendering/style -I./Source/WebCore/rendering/svg -I./Source/WebCore/storage -I./Source/WebCore/style -I./Source/WebCore/svg -I./Source/WebCore/svg/animation -I./Source/WebCore/svg/graphics -I./Source/WebCore/svg/graphics/filters -I./Source/WebCore/svg/properties -I./Source/WebCore/testing -I./Source/WebCore/testing/js -I./Source/WebCore/websockets -I./Source/WebCore/workers -I./Source/WebCore/xml -I./Source/WebCore/xml/parser -I./WebCore/bindings/js -I./DerivedSources/WebCore -I./DerivedSources -I./DerivedSources/JavaScriptCore -I./Source/WebCore/platform/graphics/texmap -DWEBKITGTK_API_VERSION_STRING=\"3.0\" -I./Source/WebCore/accessibility/atk -I./Source/WebCore/loader/gtk -I./Source/WebCore/page/gtk -I./Source/WebCore/platform/cairo -I./Source/WebCore/platform/audio/gstreamer -I./Source/WebCore/platform/graphics/cairo -I./Source/WebCore/platform/graphics/freetype -I./Source/WebCore/platform/graphics/glx -I./Source/WebCore/platform/graphics/harfbuzz -I./Source/WebCore/platform/graphics/harfbuzz/ng -I./Source/WebCore/platform/graphics/egl -I./Source/WebCore/platform/graphics/gstreamer -I./Source/WebCore/platform/graphics/gtk -I./Source/WebCore/platform/gtk -I./Source/WebCore/platform/mediastream/gstreamer -I./Source/WebCore/platform/network/soup -I./Source/WebCore/platform/text/enchant -I./Source -I./Source/JavaScriptCore -I./Source/JavaScriptCore/API -I./Source/JavaScriptCore/ForwardingHeaders -I./Source/JavaScriptCore/assembler -I./Source/JavaScriptCore/bindings -I./Source/JavaScriptCore/bytecode -I./Source/JavaScriptCore/bytecompiler -I./Source/JavaScriptCore/debugger -I./Source/JavaScriptCore/dfg -I./Source/JavaScriptCore/disassembler -I./Source/JavaScriptCore/ftl -I./Source/JavaScriptCore/heap -I./Source/JavaScriptCore/inspector -I./Source/JavaScriptCore/inspector/agents -I./Source/JavaScriptCore/interpreter -I./Source/JavaScriptCore/jit -I./Source/JavaScriptCore/llint -I./Source/JavaScriptCore/parser -I./Source/JavaScriptCore/profiler -I./Source/JavaScriptCore/runtime -I./Source/JavaScriptCore/tools -I./Source/JavaScriptCore/yarr -I./DerivedSources/JavaScriptCore -I./Source/WTF -fno-omit-frame-pointer -fno-tree-dce -pthread -I/usr/include/enchant -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/cairo -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/libdrm -I/usr/include/libpng16 -I/usr/include/freetype2 -I/usr/include/harfbuzz -I/usr/include/harfbuzz -pthread -I/usr/include/gio-unix-2.0/ -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -pthread -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -pthread -I/usr/include/gtk-3.0 -I/usr/include/at-spi2-atk/2.0 -I/usr/include/at-spi-2.0 -I/usr/include/dbus-1.0 -I/usr/lib64/dbus-1.0/include -I/usr/include/gtk-3.0 -I/usr/include/gio-unix-2.0/ -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/harfbuzz -I/usr/include/pango-1.0 -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libdrm -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/libpng16 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -pthread -I/usr/include/gtk-3.0/unix-print -I/usr/include/gtk-3.0 -I/usr/include/at-spi2-atk/2.0 -I/usr/include/at-spi-2.0 -I/usr/include/dbus-1.0 -I/usr/lib64/dbus-1.0/include -I/usr/include/gtk-3.0 -I/usr/include/gio-unix-2.0/ -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/harfbuzz -I/usr/include/pango-1.0 -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libdrm -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/libpng16 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -pthread -I/usr/include/libsoup-2.4 -I/usr/include/libxml2 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include -fno-rtti -O2 -pipe -march=native -pthread -std=c++11 -Wno-c++11-compat -MT DerivedSources/WebKit2/libwebkit2gtk_3_0_la-WebProcessMessageReceiver.lo -MD -MP -MF DerivedSources/WebKit2/.deps/libwebkit2gtk_3_0_la-WebProcessMessageReceiver.Tpo -c DerivedSources/WebKit2/WebProcessMessageReceiver.cpp  -fPIC -DPIC -o DerivedSources/WebKit2/.libs/libwebkit2gtk_3_0_la-WebProcessMessageReceiver.o
x86_64-pc-linux-gnu-g++: internal compiler error: Killed (program cc1plus)
Please submit a full bug report,
with preprocessed source if appropriate.
See <https://bugs.gentoo.org/> for instructions.
GNUmakefile:76630: recipe for target 'DerivedSources/WebKit2/libwebkit2gtk_3_0_la-WebPageProxyMessageReceiver.lo' failed
make[1]: *** [DerivedSources/WebKit2/libwebkit2gtk_3_0_la-WebPageProxyMessageReceiver.lo] Error 1
make[1]: *** Waiting for unfinished jobs....
mv -f DerivedSources/WebKit2/.deps/libwebkit2gtk_3_0_la-WebPageMessageReceiver.Tpo DerivedSources/WebKit2/.deps/libwebkit2gtk_3_0_la-WebPageMessageReceiver.Plo
mv -f DerivedSources/WebKit2/.deps/libwebkit2gtk_3_0_la-WebProcessMessageReceiver.Tpo DerivedSources/WebKit2/.deps/libwebkit2gtk_3_0_la-WebProcessMessageReceiver.Plo
make[1]: Leaving directory '/var/tmp/portage/net-libs/webkit-gtk-2.4.8/work/webkitgtk-2.4.8'
GNUmakefile:25584: recipe for target 'all' failed
make: *** [all] Error 2
 * ERROR: net-libs/webkit-gtk-2.4.8::gentoo failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=net-libs/webkit-gtk-2.4.8::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=net-libs/webkit-gtk-2.4.8::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/net-libs/webkit-gtk-2.4.8/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-libs/webkit-gtk-2.4.8/temp/environment'.
 * Working directory: '/var/tmp/portage/net-libs/webkit-gtk-2.4.8/work/webkitgtk-2.4.8'
 * S: '/var/tmp/portage/net-libs/webkit-gtk-2.4.8/work/webkitgtk-2.4.8'

>>> Failed to emerge net-libs/webkit-gtk-2.4.8, Log file:

>>>  '/var/tmp/portage/net-libs/webkit-gtk-2.4.8/temp/build.log'

 * Messages for package app-office/akonadi-server-1.13.0:

 * QMYSQL has been set as your default akonadi storage backend.
 * You can override it in your ~/.config/akonadi/akonadiserverrc.
 * Available drivers are:  QMYSQL

 * Messages for package kde-apps/gwenview-4.14.3:

 * For SVG support, install kde-base/svgpart:4/4.14
 * The plugins for the KIPI inteface can be found in media-plugins/kipi-plugins

 * Messages for package kde-apps/dolphin-4.14.3:

 * For .exe file preview support, install media-gfx/icoutils.

 * Messages for package net-libs/webkit-gtk-2.4.8:

 * ERROR: net-libs/webkit-gtk-2.4.8::gentoo failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=net-libs/webkit-gtk-2.4.8::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=net-libs/webkit-gtk-2.4.8::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/net-libs/webkit-gtk-2.4.8/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-libs/webkit-gtk-2.4.8/temp/environment'.
 * Working directory: '/var/tmp/portage/net-libs/webkit-gtk-2.4.8/work/webkitgtk-2.4.8'
 * S: '/var/tmp/portage/net-libs/webkit-gtk-2.4.8/work/webkitgtk-2.4.8'

 * GNU info directory index is up-to-date.

!!! existing preserved libs:
>>> package: media-gfx/exiv2-0.24-r1
 *  - /usr/lib64/libexiv2.so.12
 *  - /usr/lib64/libexiv2.so.12.0.0
 *      used by /usr/lib64/kde4/nepomukexiv2extractor.so (kde-base/nepomuk-core-4.12.5)
Use emerge @preserved-rebuild to rebuild packages using these libraries

 * IMPORTANT: 6 config files in '/etc' need updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.

 * IMPORTANT: 7 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.

 * After world updates, it is important to remove obsolete packages with
 * emerge --depclean. Refer to `man emerge` for more information.


Should I do "emerge --skipfirst --resume" or...?

Thank you.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Mon Jul 20, 2015 6:24 am    Post subject: Reply with quote

ONEEYEMAN wrote:
Should I do "emerge --skipfirst --resume" or...?

Yes please, and deal with webkit-gtk later. Better, find out if it's even required on your (presumably) Qt-centered system, with one of the commands we had above.

Code:
/libwebkit2gtk_3_0_la-WebProcessMessageReceiver.o
x86_64-pc-linux-gnu-g++: internal compiler error: Killed (program cc1plus)
Please submit a full bug report,
with preprocessed source if appropriate.
See <https://bugs.gentoo.org/> for instructions.
GNUmakefile:76630: recipe for target 'DerivedSources/WebKit2/libwebkit2gtk_3_0_la-WebPageProxyMessageReceiver.lo' failed
make[1]: *** [DerivedSources/WebKit2/libwebkit2gtk_3_0_la-WebPageProxyMessageReceiver.lo] Error 1
make[1]: *** Waiting for unfinished jobs....
mv -f DerivedSources/WebKit2/.deps/libwebkit2gtk_3_0_la-WebPageMessageReceiver.Tpo DerivedSources/WebKit2/.deps/libwebkit2gtk_3_0_la-WebPageMessageReceiver.Plo
mv -f DerivedSources/WebKit2/.deps/libwebkit2gtk_3_0_la-WebProcessMessageReceiver.Tpo DerivedSources/WebKit2/.deps/libwebkit2gtk_3_0_la-WebProcessMessageReceiver.Plo
make[1]: Leaving directory '/var/tmp/portage/net-libs/webkit-gtk-2.4.8/work/webkitgtk-2.4.8'
GNUmakefile:25584: recipe for target 'all' failed
make: *** [all] Error 2
 * ERROR: net-libs/webkit-gtk-2.4.8::gentoo failed (compile phase):
 *   emake failed

This looks bad and might also hint at a hardware failure, exposed by webkit-gtk's heaviness.

Regardless, please take care of your config files and news items. I don't want to see that appear once again!
Code:

 * IMPORTANT: 6 config files in '/etc' need updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.

 * IMPORTANT: 7 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.

_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6193

PostPosted: Mon Jul 20, 2015 8:02 am    Post subject: Reply with quote

...more like "I've ran OOM" than a hardware failure.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum