Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
GNOME Without Systemd
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 16, 17, 18, 19  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Elleni
Guru
Guru


Joined: 23 May 2006
Posts: 415

PostPosted: Mon Oct 30, 2017 9:44 pm    Post subject: Reply with quote

dantrell wrote:

So it was mostly your fault. I hope you are happy. :twisted:

Yeah, I did not expect something else - another oportunity to learn :twisted:
dantrell wrote:

That's a lot of red but none of it seems relevant to your issue.

ok, I see.
dantrell wrote:

You can check if this trips up anything (but it might be the same as the -v flag these days):

Code:
G_MESSAGES_DEBUG=all gnome-control-center

Code:
G_MESSAGES_DEBUG=all gnome-control-center
(gnome-control-center:5708): Gtk-DEBUG: Connecting to session manager
(gnome-control-center:5708): printers-cc-panel-DEBUG: Could not check 'Clean' maintenance command: Vorgang wurde abgebrochen
(gnome-control-center:5708): display-cc-panel-DEBUG: setting adjustment 20.000 to 20:00
(gnome-control-center:5708): display-cc-panel-DEBUG: setting adjustment 6.000 to 6:00
(gnome-control-center:5708): display-cc-panel-DEBUG: SensorProxy vanished
(gnome-control-center:5708): display-cc-panel-DEBUG: Has no accelerometer
(gnome-control-center:5708): display-cc-panel-DEBUG: setting adjustment -1.000 to -1:00
(gnome-control-center:5708): display-cc-panel-DEBUG: setting adjustment -1.000 to -1:00
(gnome-control-center:5708): display-cc-panel-DEBUG: setting adjustment -1.000 to -1:00
(gnome-control-center:5708): display-cc-panel-DEBUG: setting adjustment -1.000 to -1:00
(gnome-control-center:5708): display-cc-panel-DEBUG: setting adjustment -1.000 to -1:00
(gnome-control-center:5708): display-cc-panel-DEBUG: setting adjustment -1.000 to -1:00


dantrell wrote:

Wait, you don't have an /etc/X11/Xorg.conf file managing things do you?


Ähm, yes, I have some files in that folder, but most of them are completly comented out, so its like they are empty. Following are not commented out:

Code:
Section "Files"
EndSection

Section "Device"
  Identifier  "Radeon"
  Driver      "radeon"
  Option      "DRI3"   "on"
EndSection


But as you are asking it that way, I ll check out what happens without them :lol:

That would have been too easy; moved /etc/X11/xorg.conf.d/ away but still the same. :(

By the way, I am thinking to go back to sddm, as a new error appeared, now that shutdown does something. It hangs at:
Code:
starting cgroups cleanup
:twisted:

Another idea I had, was if it would be worth a try to not use the extended profile but the normal 3-26.

Or to try an older Version of GNOME if there is one, which is considered more stable.
Back to top
View user's profile Send private message
saboya
Guru
Guru


Joined: 28 Nov 2006
Posts: 333
Location: Brazil

PostPosted: Tue Oct 31, 2017 10:06 am    Post subject: Reply with quote

Elleni wrote:
By the way, I am thinking to go back to sddm, as a new error appeared, now that shutdown does something. It hangs at:
Code:
starting cgroups cleanup
:twisted:

I'm having the exact same issue, with xdm.

This issue started after the stabilization of OpenRC 0.32.1, it did not happen previously. I believe OpenRC didn't even had cgroup support in the previous stable.
Back to top
View user's profile Send private message
Elleni
Guru
Guru


Joined: 23 May 2006
Posts: 415

PostPosted: Tue Oct 31, 2017 2:22 pm    Post subject: Reply with quote

I realized that it happens wirh gdm but not with sddm.
Back to top
View user's profile Send private message
dantrell
Apprentice
Apprentice


Joined: 01 Jun 2007
Posts: 294
Location: Earth

PostPosted: Wed Nov 01, 2017 12:24 am    Post subject: Reply with quote

ZappingLinux wrote:
So basically I think that the font is too big for nearly all applications. Any clue as to how this has come to be and how to change it?

GNOME Tweak Tool -> Fonts -> Scaling Factor

Elleni wrote:
Or to try an older Version of GNOME if there is one, which is considered more stable.

There are currently 7 release versions available.

Downgrading to, let's say 3.24, might give you a more stable experience but I don't think it will fix your multi-monitor problem as the relevant code that I linked in an earlier post seems like it was ported 1:1.

Edit: You know what, you can save time by ruling out your current version GNOME Control Center:

Code:
layman --add dantrell-gnome-3-24
emerge --ask --nodeps --oneshot =gnome-base/libgtop-2.36.0 =gnome-base/gnome-control-center-3.24.3

If that works then we have answer.

Elleni wrote:
By the way, I am thinking to go back to sddm, as a new error appeared, now that shutdown does something. It hangs at [...]

saboya wrote:
I'm having the exact same issue, with xdm.

This issue started after the stabilization of OpenRC 0.32.1, it did not happen previously. I believe OpenRC didn't even had cgroup support in the previous stable.

Elleni wrote:
I realized that it happens wirh gdm but not with sddm.

If this issue is what I experienced, it'll hang for a long time but eventually shutdown. If you have time to confirm please mask OpenRC 0.30 and greater:

/etc/portage/package.mask/openrc:
>=sys-apps/openrc-0.30

downgrade, reboot and try shutting down again.
_________________
Dantrell B.
Back to top
View user's profile Send private message
Elleni
Guru
Guru


Joined: 23 May 2006
Posts: 415

PostPosted: Wed Nov 01, 2017 1:46 am    Post subject: Reply with quote

It looks different, but still lacks the desperately desired option to change from mirror to extend.
https://imagebin.ca/v/3fk27BdAeEhD

I can confirm, that downcrading openrc-0.28 does not hang anymore till it eventually shutting down.

Edit - found out that I have to click on the monitors and then there were the settings to extend mirror deactivate or define as primary/secondary screen, but nothing happend when i tried to mirror or deactivate monitor.

Then I tapped display in gnome search menu after taping on activitys and discovered lxrandr, which lets me activate / deactivate monitor. I switched monitor of with it, and when reactivated it, it was mirrored but still not possible to set any setting in gnome display settings. Now reverting back to 3-26 gnome control center and unmerging lxrandr. I ll report back if this solved the problem :lol:

Edit 2 - Unfortunately unmerge of lxrandr did not solve the issues with monitor settings in fact I completely unmerged lxde but display settings look like the link posted some days ago with the monitors beeing very small in those settings and missing the mirror/extend settings. Maybe I ll revert back again to 3.24 to see if the settings now actually act as supposed, now that lxde is unmerged. If not, I will have to look further what could block gnome display settings.
Back to top
View user's profile Send private message
dantrell
Apprentice
Apprentice


Joined: 01 Jun 2007
Posts: 294
Location: Earth

PostPosted: Thu Nov 02, 2017 10:37 am    Post subject: Reply with quote

GNOME 3.26.2 is now available so we are out of beta. Next volunteer meetup will be for GNOME 3.28. :twisted:

From my testing, three packages are acting funny:
  • GNOME Builder [ref. GNOME bug #787578]
  • GNOME Notes (Bijiben)
  • GNOME Photos
Mutter and GNOME Shell are each temporarily missing one Quality of Life improvement (i.e. the old background code).

Elleni wrote:
It looks different, but still lacks the desperately desired option to change from mirror to extend.

Sounds like changing GNOME release versions won't matter as the problem is in your setup somewhere.

Could it be the way the monitors are plugged in? I vaguely recall that might have been an issue at one time (e.g. they might all have to be plugged into the same card).

Elleni wrote:
I can confirm, that downcrading openrc-0.28 does not hang anymore till it eventually shutting down.

I tested 0.29 and 0.30 and those are good to go too. There is now a mask in place.
_________________
Dantrell B.
Back to top
View user's profile Send private message
Elleni
Guru
Guru


Joined: 23 May 2006
Posts: 415

PostPosted: Fri Nov 03, 2017 7:57 pm    Post subject: Reply with quote

With gnome-3.24 I started gnome-control-center in console with -v and see that if I try to set mirror but also if I simply try to change resolution of monitor, it does not work and the following is printed in console:

Code:
(gnome-control-center:4443): display-cc-panel-WARNING **: Error applying configuration: GDBus.Error:org.freedesktop.DBus.Error.UnknownMethod: Method ApplyConfiguration is not implemented on interface org.gnome.Mutter.DisplayConfig
:(
Back to top
View user's profile Send private message
dantrell
Apprentice
Apprentice


Joined: 01 Jun 2007
Posts: 294
Location: Earth

PostPosted: Sat Nov 04, 2017 4:08 am    Post subject: Reply with quote

Elleni wrote:
With gnome-3.24 I started gnome-control-center in console with -v and see that if I try to set mirror but also if I simply try to change resolution of monitor, it does not work and the following is printed in console [...]

This finally led me to Launchpad bugs #1714410 and #1714908 but I don't see a resolution there.

If you haven't synced up yet, GNOME Control Center and Mutter have updates. I don't know if that will do it though. :(
_________________
Dantrell B.
Back to top
View user's profile Send private message
Juippisi
Apprentice
Apprentice


Joined: 30 Sep 2005
Posts: 174
Location: /home

PostPosted: Mon Nov 06, 2017 9:51 am    Post subject: Reply with quote

dantrell wrote:

I tested 0.29 and 0.30 and those are good to go too. There is now a mask in place.


Hey, I dont really mind this mask, but I just wanted to let you know that I use use Gnome-3.22 with consolekit and I dont have any problems when turning off the computer. I currently have openrc-0.34.4 installed and as said, Gnome-3.22 and gdm-3.22.3-r1. However when I did use elogind and newer Gnome I was hit by that error. I think its somehow related to elogind and gdm, heres an earlier post of mine about it too:
https://forums.gentoo.org/viewtopic-t-1070700-highlight-.html

I might unmask it locally or downgrade, since downgrading doesnt break anything.
Back to top
View user's profile Send private message
dantrell
Apprentice
Apprentice


Joined: 01 Jun 2007
Posts: 294
Location: Earth

PostPosted: Mon Nov 06, 2017 10:15 am    Post subject: Reply with quote

Juippisi wrote:
Hey, I dont really mind this mask, but I just wanted to let you know that I use use Gnome-3.22 with consolekit and I dont have any problems when turning off the computer. I currently have openrc-0.34.4 installed and as said, Gnome-3.22 and gdm-3.22.3-r1. However when I did use elogind and newer Gnome I was hit by that error. I think its somehow related to elogind and gdm, heres an earlier post of mine about it too:
https://forums.gentoo.org/viewtopic-t-1070700-highlight-.html

I might unmask it locally or downgrade, since downgrading doesnt break anything.

Thanks for the feedback.

From what I found, SDDM isn't affected by this issue but GDM is. However, it isn't elogind related as I experienced it with GNOME 3.14 and ConsoleKit. I'm going to say this is an upstream (OpenRC) issue and resolving it shouldn't require fiddling around with configuration files (not that fiddling will work anyway :P).

A project goal is to have as much working out-of-the-box as possible, hence the reason for the mask (speaking of which, I think I'll tighten that mask to 0.30 and greater as while 0.30 may shutdown, it changes the noise level of the shutdown process).

Downgrading, as you said, won't break anything. There will just be less features. :wink:

Feel free to unmask it locally though until this issue is resolved.
_________________
Dantrell B.
Back to top
View user's profile Send private message
Shibotto
n00b
n00b


Joined: 19 Jun 2015
Posts: 38
Location: Italy

PostPosted: Mon Nov 06, 2017 10:15 am    Post subject: Reply with quote

dantrell wrote:
Mutter and GNOME Shell are each temporarily missing one Quality of Life improvement (i.e. the old background code).

Quick update: I don't get corrupted background on resume from suspend anymore on GNOME 3.26, instead sometimes the "separators" (the horizontal lines) in GNOME Shell search results are slightly corrupted. And I sincerely couldn't care less about that. This is on my laptop with x11-drivers/nvidia-drivers-340.104 aka legacy drivers. If someone could provide some other test case and confirm this is not an issue anymore, maybe it could lift a burden off of dantrell's back. :D
Back to top
View user's profile Send private message
Shibotto
n00b
n00b


Joined: 19 Jun 2015
Posts: 38
Location: Italy

PostPosted: Mon Nov 06, 2017 10:27 am    Post subject: Reply with quote

Sorry for the double post, but while we are at it I'd like to interject on the GDM/shutdown matter, since I run into this problem too. According to /etc/init.d/xdm, AUTOCLEAN_CGROUP defaults to no (https://gitweb.gentoo.org/repo/gentoo.git/tree/x11-base/xorg-server/files/xdm.initd-11#n165) and GDM is the only one forcing it to yes (https://gitweb.gentoo.org/repo/gentoo.git/tree/x11-base/xorg-server/files/xdm.initd-11#n83), so maybe that's why SDDM and the others aren't affected. Prior to OpenRC downgrade I actually commented out that line and my system would shut down properly, however I'm not sure if this had any side effect. I forgot until now that I made this change, sorry I didn't bring it up earlier.
Back to top
View user's profile Send private message
cono
n00b
n00b


Joined: 15 Sep 2016
Posts: 4

PostPosted: Tue Nov 07, 2017 9:34 am    Post subject: Reply with quote

After recent update, I got @preserved-rebuild notice of vinagre-3.20.2-r1 packet. But it fails:

Code:

plugins/rdp/vinagre-rdp-tab.c: In function ‘frdp_post_connect’:
plugins/rdp/vinagre-rdp-tab.c:596:21: error: ‘CLRBUF_32BPP’ undeclared (first use in this function)
                     CLRBUF_32BPP,
                     ^
plugins/rdp/vinagre-rdp-tab.c:596:21: note: each undeclared identifier is reported only once for each function it appears in
plugins/rdp/vinagre-rdp-tab.c:590:3: error: too many arguments to function ‘gdi_init’
   gdi_init (instance,


I see that in main repo 3.22.0-r1 already unmasked (~), so looks like it should be ported in:
Code:

[I] net-misc/vinagre
     Available versions: 
            3.20.2-r1 [2]
       [M]  3.22.0-r1   [rdp spice +ssh +telepathy zeroconf] Masked to freeze the state of GNOME
       [M]~ 3.22.0-r2   [rdp spice +ssh +telepathy zeroconf] Masked to freeze the state of GNOME
...
[2] "dantrell-gnome-3-20" /usr/local/portage/dantrell-gnome-3-20
Back to top
View user's profile Send private message
dantrell
Apprentice
Apprentice


Joined: 01 Jun 2007
Posts: 294
Location: Earth

PostPosted: Tue Nov 07, 2017 11:41 am    Post subject: Reply with quote

Shibotto wrote:
If someone could provide some other test case and confirm this is not an issue anymore, maybe it could lift a burden off of dantrell's back. :D

I would definitely love feedback on this one but if no one else steps up, I'll carry the patch forward. It's not really a burden, I just mostly forgot about it. Twice. Whoops. :lol:

Shibotto wrote:
Prior to OpenRC downgrade I actually commented out that line and my system would shut down properly, however I'm not sure if this had any side effect. I forgot until now that I made this change, sorry I didn't bring it up earlier.

This is interesting. I'm now less sure which where the issue needs to be fixed (i.e. in OpenRC or X.Org Server) but more sure the mask should stay in place until it is fixed.

cono wrote:
After recent update, I got @preserved-rebuild notice of vinagre-3.20.2-r1 packet. But it fails [...]

Looks like GNOME bug #765444.

Sync up and rebuild.

cono wrote:
I see that in main repo 3.22.0-r1 already unmasked (~), so looks like it should be ported in [...]

This is intentional. Except in certain instances, package versions are tied to specific GNOME release versions (i.e. the state of GNOME is frozen).

So Vinagre 3.20.2 is appropriately tied to GNOME 3.20 and Vinagre 3.22.0 is appropriately tied to at least GNOME 3.22. If you want the newest possible version of a package, you need to unmask it (and deal with any potential breakage on your own) or upgrade to a newer GNOME release version.
_________________
Dantrell B.
Back to top
View user's profile Send private message
Elleni
Guru
Guru


Joined: 23 May 2006
Posts: 415

PostPosted: Wed Nov 08, 2017 9:30 pm    Post subject: Reply with quote

dantrell wrote:
Could it be the way the monitors are plugged in? I vaguely recall that might have been an issue at one time (e.g. they might all have to be plugged into the same card).


They are all pluged on the same gpu. And I can change resolution and mirror/extended mode within plasma.

dantrell wrote:
This finally led me to Launchpad bugs #1714410 and #1714908 but I don't see a resolution there.

If you haven't synced up yet, GNOME Control Center and Mutter have updates. I don't know if that will do it though. :(


Synced/updated but still the same. I cannot even change resolution with
Code:
layman --add dantrell-gnome-3-24
emerge --ask --nodeps --oneshot =gnome-base/libgtop-2.36.0 =gnome-base/gnome-control-center-3.24.3

Same console output as above.

I can change resolution with actual 3.26 gnome control center. Console output is:
Code:
(gnome-control-center:29798): display-cc-panel-WARNING **: Config not applicable: GDBus.Error:org.freedesktop.DBus.Error.AccessDenied: The requested configuration is based on stale information

But still missing the option for changing from extended to mirrored. I guess, I ll have to wait n hope it will be fixed soon. I had same situation on a suse tumbleweed gnome 3 with system d which I booted from an usbstick, so it has nothing to do with gentoo gnome without systemd from dantrell.


Last edited by Elleni on Wed Nov 08, 2017 10:28 pm; edited 1 time in total
Back to top
View user's profile Send private message
Elleni
Guru
Guru


Joined: 23 May 2006
Posts: 415

PostPosted: Tue Nov 14, 2017 9:49 am    Post subject: Reply with quote

Today I synced and tried to update system. It failed @ net-misc/networkmanager-1.10.0.

Code:
configure: error: Jansson is required for ovs support

Code:
cat /tmp/portage/net-misc/networkmanager-1.10.0/work/NetworkManager-1.10.0-abi_x86_32.x86/config.log | wgetpaste

https://paste.pound-python.org/show/GemKPLPYAG0BU0DU5gxz/
Back to top
View user's profile Send private message
dantrell
Apprentice
Apprentice


Joined: 01 Jun 2007
Posts: 294
Location: Earth

PostPosted: Tue Nov 14, 2017 11:54 am    Post subject: Reply with quote

Elleni wrote:
But still missing the option for changing from extended to mirrored. I guess, I ll have to wait n hope it will be fixed soon. I had same situation on a suse tumbleweed gnome 3 with system d which I booted from an usbstick, so it has nothing to do with gentoo gnome without systemd from dantrell.

Yep. GNOME just doesn't like your monitor setup. :(

Elleni wrote:
Today I synced and tried to update system. It failed @ net-misc/networkmanager-1.10.0.

Thanks for the feedback. It reminded me I had some profile tweaking to do.

Sync up and you should be good to go (although, that version will now only update for ~).
_________________
Dantrell B.
Back to top
View user's profile Send private message
Shibotto
n00b
n00b


Joined: 19 Jun 2015
Posts: 38
Location: Italy

PostPosted: Wed Nov 22, 2017 9:28 am    Post subject: Reply with quote

Just a question out of curiosity: is it really necessary to unmask media-libs/mesa::gentoo ~* in 3.26 profile? I'm asking because recently every week there is a new rc of mesa 17.3.
Back to top
View user's profile Send private message
Juippisi
Apprentice
Apprentice


Joined: 30 Sep 2005
Posts: 174
Location: /home

PostPosted: Wed Nov 22, 2017 11:28 am    Post subject: Reply with quote

Hey,

today when I did a normal system upgrade, it asked me to do a @preserved-rebuild after. I cant remember what was updated during system upgrade. I cant finish @preserved-rebuild though, it stops with an error to gnome-base/librsvg-2.40.19

Code:

checking for    gdk-pixbuf-2.0 >= 2.20    glib-2.0 >= 2.12.0    gio-2.0 >= 2.24.0    libxml-2.0 >= 2.9.0    pangocairo >= 1.38.0    pangoft2 >= 1.38.0    cairo >= 1.2.0 cairo-png >= 1.2.0
        libcroco-0.6 >= 0.6.1... no
configure: error: Package requirements (   gdk-pixbuf-2.0 >= 2.20    glib-2.0 >= 2.12.0    gio-2.0 >= 2.24.0    libxml-2.0 >= 2.9.0    pangocairo >= 1.38.0    pangoft2 >= 1.38.0    cairo >= 1.2.0    cairo-png >= 1.2.0
        libcroco-0.6 >= 0.6.1) were not met:

No package 'pangocairo' found
No package 'pangoft2' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables LIBRSVG_CFLAGS
and LIBRSVG_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.


Does this need a patch or bump to a package version? Im using Gnome-3.22.

Code:

# emerge -p @preserved-rebuild

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] gnome-base/librsvg-2.40.19
[ebuild   R    ] media-libs/gst-plugins-base-1.12.3
[ebuild   R    ] dev-cpp/pangomm-2.40.1-r1
[ebuild   R    ] x11-libs/gtk+-3.22.26
[ebuild   R    ] x11-libs/gtk+-2.24.31-r2
[ebuild   R    ] x11-themes/gtk-engines-adwaita-3.22.3
[ebuild   R    ] media-libs/libcanberra-0.30-r5
[ebuild   R    ] gnome-base/libglade-2.6.4-r2
[ebuild   R    ] x11-themes/gtk-engines-murrine-0.98.2-r1


EDIT:
So none of the packages in that @preserved-rebuild list compiled. I thought I could ignore it, but my gnome-shell started crashing after a while so I tried to do my best to fix it. I tried to re-emerge every package in that "checking for" list, gdk-pixbuf, glib, libxml2, pango, cairo, libcroco but it didnt help.

In the end I restored a previous state of your "gentoo-overlay-dantrell-gnome" and downgraded 3 packages, including pango. Now my system is working again, and emerge doesnt want to do @preserved-rebuild. I dont know what happened, and was I the only one experiencing errors!

Code:

# git reset --hard da0579391daded193f3026e3f34e7c1e6cdc7fcc


Calculating dependencies... done!
[ebuild     UD ] media-libs/babl-0.1.30::dantrell-gnome [0.1.38::dantrell-gnome] USE="(-altivec)" CPU_FLAGS_X86="mmx sse sse2 sse4_1 -f16c" 603 KiB
[ebuild     UD ] x11-libs/pango-1.40.13::dantrell-gnome [1.40.14-r1::dantrell-gnome] USE="X introspection {-test}" ABI_X86="32 (64) (-x32)" 838 KiB
[ebuild     UD ] dev-libs/gmime-3.0.3:3.0::dantrell-gnome [3.0.4:3.0::dantrell-gnome] USE="crypt -doc -idn -static-libs {-test} -vala" 744 KiB


Oh by the way, when installing the newest librsvg it complained something about gtk-optional.patch ending too early... but it seemed to apply the patch anyway :I
Back to top
View user's profile Send private message
dantrell
Apprentice
Apprentice


Joined: 01 Jun 2007
Posts: 294
Location: Earth

PostPosted: Thu Nov 23, 2017 1:12 am    Post subject: Reply with quote

Shibotto wrote:
Just a question out of curiosity: is it really necessary to unmask media-libs/mesa::gentoo ~* in 3.26 profile? I'm asking because recently every week there is a new rc of mesa 17.3.

Yep, since Mutter now requires at least Mesa 17.2.0 which is slotted in ~.

Technically, I could have forked the ebuild but I generally avoid that when a simple keyword unmask works. Although, in this situation, I can be a bit more restrictive so I went ahead and integrated my Mesa mask file which blocks Release Candidates into the GNOME 3.26 profiles (as I have long since found them annoying).

Juippisi wrote:
today when I did a normal system upgrade, it asked me to do a @preserved-rebuild after. I cant remember what was updated during system upgrade. I cant finish @preserved-rebuild though, it stops with an error to gnome-base/librsvg-2.40.19

Juippisi wrote:
Does this need a patch or bump to a package version? Im using Gnome-3.22.

This looks Pango related but I don't see how. There was a recent change I made in relation to supporting older GNOME release versions and a newer Pango was part of the package (although the one slotted for ~ uses the Meson build system).

I tried every scenario I could think of but I can't reproduce your issue. :(

Juippisi wrote:
So none of the packages in that @preserved-rebuild list compiled. I thought I could ignore it, but my gnome-shell started crashing after a while so I tried to do my best to fix it. I tried to re-emerge every package in that "checking for" list, gdk-pixbuf, glib, libxml2, pango, cairo, libcroco but it didnt help.

I wonder if x11-libs/pango-1.40.14 would have worked instead of 1.40.14-r1?

Juippisi wrote:
In the end I restored a previous state of your "gentoo-overlay-dantrell-gnome" and downgraded 3 packages, including pango. Now my system is working again, and emerge doesnt want to do @preserved-rebuild. I dont know what happened, and was I the only one experiencing errors!

Are you saying you downgraded, resynced then updated @world again (but successfully this time)?

Juippisi wrote:
Oh by the way, when installing the newest librsvg it complained something about gtk-optional.patch ending too early... but it seemed to apply the patch anyway :I

Harmless noise and as you found, the patch will still work. I corrected it anyway.
_________________
Dantrell B.
Back to top
View user's profile Send private message
Juippisi
Apprentice
Apprentice


Joined: 30 Sep 2005
Posts: 174
Location: /home

PostPosted: Thu Nov 23, 2017 6:09 am    Post subject: Reply with quote

dantrell wrote:

Are you saying you downgraded, resynced then updated @world again (but successfully this time)?


Hmm, I restored the state of your overlay to such time my local copy doesnt have the latest commit. So, in my HDD the tree isnt synced to see these changes:
https://github.com/dantrell/gentoo-overlay-dantrell-gnome/commit/42db886ad3b667100f9a780eaa3d810864dd437c
(and anything after that)

I saw you made lots of changes related to pango in that commit.

Anyway Im going to try upgrading to pango-1.40.14 today in 6 hours when I get home. I will report how that goes, and hope it gives some answers!

EDIT: So, -r1 is definitely the problem. Synced up the tree, first upgraded pango to 1.40.14. No preserved-rebuild errors and system is working fine. Then I upgraded to 1.40,14-r1 and the same problems started again.

I tried to closely look the build.log for successful pango-1.40.14-r1 but there was nothing out of the ordinary there,
Code:

Found pkg-config: /usr/bin/pkg-config (0.29.2)
Native dependency gobject-2.0 found: YES 2.54.2
Dependency libthai found: NO
Native dependency harfbuzz found: YES 1.7.1
Native dependency fontconfig found: YES 2.12.6
Checking for function "FcWeightFromOpenType": YES
Native dependency freetype2 found: YES 21.0.15
Native dependency xft found: YES 2.3.2
Native dependency xrender found: YES 0.9.10
Native dependency cairo found: YES 1.15.8
Native dependency cairo-ft found: YES 1.15.8
Dependency cairo-win32 found: NO
Dependency cairo-quartz found: NO
Native dependency cairo-png found: YES 1.15.8
Native dependency cairo-ps found: YES 1.15.8
Native dependency cairo-pdf found: YES 1.15.8
Native dependency cairo-xlib found: YES 1.15.8
Configuring pango.pc using configuration
Configuring pangoft2.pc using configuration
Configuring pangoxft.pc using configuration
Configuring pangocairo.pc using configuration
Configuring config.h using configuration
Configuring pango-features.h using configuration


So I have masked 1.40.14-r1 locally now and am using 1.40.14. Im guessing at this point Im the only one with this problems, so Im open to ideas how to solve!

EDIT2:
So I decided to compare the files installed by 1.40.14 and 1.40.14-r1,
Code:

# diff pangoWorking.txt pangoNotWorking.txt
42d41
< /usr/lib32/libpango-1.0.so
45d43
< /usr/lib32/libpangocairo-1.0.so
48d45
< /usr/lib32/libpangoft2-1.0.so
51,58d47
< /usr/lib32/libpangoxft-1.0.so
< /usr/lib32/libpangoxft-1.0.so.0
< /usr/lib32/libpangoxft-1.0.so.0.4000.14
< /usr/lib32/pkgconfig
< /usr/lib32/pkgconfig/pango.pc
< /usr/lib32/pkgconfig/pangocairo.pc
< /usr/lib32/pkgconfig/pangoft2.pc
< /usr/lib32/pkgconfig/pangoxft.pc
67c56
< /usr/lib64/libpango-1.0.so.0.4000.14
---
> /usr/lib64/libpango-1.0.so.0.4000.13
70c59
< /usr/lib64/libpangocairo-1.0.so.0.4000.14
---
> /usr/lib64/libpangocairo-1.0.so.0.4000.13
73c62
< /usr/lib64/libpangoft2-1.0.so.0.4000.14
---
> /usr/lib64/libpangoft2-1.0.so.0.4000.13
76c65
< /usr/lib64/libpangoxft-1.0.so.0.4000.14
---
> /usr/lib64/libpangoxft-1.0.so.0.4000.13

then the rest is pretty much just documents. So -r1 installs .14 library into 32-bit path, but .13 library into 64bit path?
Back to top
View user's profile Send private message
dantrell
Apprentice
Apprentice


Joined: 01 Jun 2007
Posts: 294
Location: Earth

PostPosted: Thu Nov 23, 2017 2:53 pm    Post subject: Reply with quote

Juippisi wrote:
So, -r1 is definitely the problem. Synced up the tree, first upgraded pango to 1.40.14. No preserved-rebuild errors and system is working fine. Then I upgraded to 1.40,14-r1 and the same problems started again.

Guess my gut feeling was correct regarding Meson shenanigans. :(

Juippisi wrote:
So I have masked 1.40.14-r1 locally now and am using 1.40.14. Im guessing at this point Im the only one with this problems, so Im open to ideas how to solve!

An unlucky edge case looks like.

Honestly, when it comes to issues with the Meson build system, if I can't find a solution in a hour, tops, I'm moving on. Right now, Autotools is still the default for Pango so I switched back to it.

Sync up and you'll see -r2 (which is -r0 with a couple backported patches).
_________________
Dantrell B.
Back to top
View user's profile Send private message
Juippisi
Apprentice
Apprentice


Joined: 30 Sep 2005
Posts: 174
Location: /home

PostPosted: Thu Nov 23, 2017 3:34 pm    Post subject: Reply with quote

dantrell wrote:


Sync up and you'll see -r2 (which is -r0 with a couple backported patches).


Hey,

-r2 works fine :)

Seems like somehow meson doesnt understand multilib systems? And weird that it would do an .so file that ends in .13...

Code:

[ebuild   R    ] x11-libs/pango-1.40.14-r2::dantrell-gnome  USE="X introspection {-test}" ABI_X86="32 (64) (-x32)"


Thanks for your hard work!
Back to top
View user's profile Send private message
BuBuaBu
l33t
l33t


Joined: 09 Jul 2005
Posts: 904
Location: France

PostPosted: Thu Nov 23, 2017 8:32 pm    Post subject: Reply with quote

Hello,

I've switched to gnome-3-26 few days ago.

I've got an issue when updating gnome-packagekit-3.26.0:
https://gist.github.com/BuBuaBu/70833b03cc66a8b1feff08aa889eb059

Also, when I upgrade to a new version, I just add the new overlay and switch the profile. But I keep older overlays. Should I remove them?
If I search for ebuild from old overlays, it looks like there are still some installed from older version?
Code:

 * Searching for repository dantrell-gnome-3-22 ...
[I-O] [  ] media-libs/clutter-gtk-1.8.2:1.0
[I-O] [  ] x11-themes/gnome-themes-standard-3.22.3:0
[I-O] [  ] x11-themes/gtk-engines-adwaita-3.22.3:0
 * Searching for repository dantrell-gnome-3-24 ...
[I-O] [  ] gnome-extra/gnome-packagekit-3.24.0:0
Back to top
View user's profile Send private message
tiago4171
n00b
n00b


Joined: 24 Nov 2017
Posts: 6
Location: Brasil

PostPosted: Fri Nov 24, 2017 12:54 am    Post subject: Reply with quote

Hello,
I'm trying to install gnome in Gentoo, but when compiling the games-board/gnome-chess package it gives error while compiling.
I could just ignore it, but it's mandatory dependency for gnome.
I did not understand much of reading the build.log, so I ask for help.
Here are the logs:

Code:
 * Package:    games-board/gnome-chess-3.22.2
 * Repository: dantrell-gnome-3-22
 * Maintainer: gnome@gentoo.org
 * USE:        abi_x86_64 amd64 elibc_glibc engines kernel_linux userland_GNU
 * FEATURES:   preserve-libs sandbox userpriv usersandbox
>>> Unpacking source...
>>> Unpacking gnome-chess-3.22.2.tar.xz to /var/tmp/portage/games-board/gnome-chess-3.22.2/work
>>> Source unpacked in /var/tmp/portage/games-board/gnome-chess-3.22.2/work
>>> Preparing source in /var/tmp/portage/games-board/gnome-chess-3.22.2/work/gnome-chess-3.22.2 ...
 * Disabling deprecation warnings ...
 [ ok ]
 * Running elibtoolize in: gnome-chess-3.22.2/
 *   Applying portage/1.2.0 patch ...
 *   Applying sed/1.5.6 patch ...
 *   Applying as-needed/2.4.3 patch ...
 *   Applying ppc64le/2.4.4 patch ...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/games-board/gnome-chess-3.22.2/work/gnome-chess-3.22.2 ...
 * econf: updating gnome-chess-3.22.2/config.guess with /usr/share/gnuconfig/config.guess
 * econf: updating gnome-chess-3.22.2/config.sub with /usr/share/gnuconfig/config.sub
./configure --prefix=/usr --build=x86_64-pc-linux-gnu --host=x86_64-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --disable-dependency-tracking --disable-silent-rules --docdir=/usr/share/doc/gnome-chess-3.22.2 --htmldir=/usr/share/doc/gnome-chess-3.22.2/html --libdir=/usr/lib64 --disable-maintainer-mode --disable-schemas-compile
checking for a BSD-compatible install... /usr/lib/portage/python3.4/ebuild-helpers/xattr/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether make supports nested variables... yes
checking whether make supports nested variables... (cached) yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking for valac... /usr/bin/valac-0.38
checking whether /usr/bin/valac-0.38 is at least version 0.27.1... yes
checking build system type... x86_64-pc-linux-gnu
checking host system type... x86_64-pc-linux-gnu
checking how to print strings... printf
checking for style of include used by make... GNU
checking for x86_64-pc-linux-gnu-gcc... x86_64-pc-linux-gnu-gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether x86_64-pc-linux-gnu-gcc accepts -g... yes
checking for x86_64-pc-linux-gnu-gcc option to accept ISO C89... none needed
checking whether x86_64-pc-linux-gnu-gcc understands -c and -o together... yes
checking dependency style of x86_64-pc-linux-gnu-gcc... none
checking for a sed that does not truncate output... /bin/sed
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for fgrep... /bin/grep -F
checking for ld used by x86_64-pc-linux-gnu-gcc... /usr/x86_64-pc-linux-gnu/bin/ld
checking if the linker (/usr/x86_64-pc-linux-gnu/bin/ld) is GNU ld... yes
checking for BSD- or MS-compatible name lister (nm)... /usr/bin/x86_64-pc-linux-gnu-nm -B
checking the name lister (/usr/bin/x86_64-pc-linux-gnu-nm -B) interface... BSD nm
checking whether ln -s works... yes
checking the maximum length of command line arguments... 1572864
checking how to convert x86_64-pc-linux-gnu file names to x86_64-pc-linux-gnu format... func_convert_file_noop
checking how to convert x86_64-pc-linux-gnu file names to toolchain format... func_convert_file_noop
checking for /usr/x86_64-pc-linux-gnu/bin/ld option to reload object files... -r
checking for x86_64-pc-linux-gnu-objdump... x86_64-pc-linux-gnu-objdump
checking how to recognize dependent libraries... pass_all
checking for x86_64-pc-linux-gnu-dlltool... no
checking for dlltool... no
checking how to associate runtime and link libraries... printf %s\n
checking for x86_64-pc-linux-gnu-ar... x86_64-pc-linux-gnu-ar
checking for archiver @FILE support... @
checking for x86_64-pc-linux-gnu-strip... x86_64-pc-linux-gnu-strip
checking for x86_64-pc-linux-gnu-ranlib... x86_64-pc-linux-gnu-ranlib
checking command to parse /usr/bin/x86_64-pc-linux-gnu-nm -B output from x86_64-pc-linux-gnu-gcc object... ok
checking for sysroot... no
checking for a working dd... /bin/dd
checking how to truncate binary pipes... /bin/dd bs=4096 count=1
checking for x86_64-pc-linux-gnu-mt... no
checking for mt... no
checking if : is a manifest tool... no
checking how to run the C preprocessor... x86_64-pc-linux-gnu-gcc -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking for dlfcn.h... yes
checking for objdir... .libs
checking if x86_64-pc-linux-gnu-gcc supports -fno-rtti -fno-exceptions... no
checking for x86_64-pc-linux-gnu-gcc option to produce PIC... -fPIC -DPIC
checking if x86_64-pc-linux-gnu-gcc PIC flag -fPIC -DPIC works... yes
checking if x86_64-pc-linux-gnu-gcc static flag -static works... yes
checking if x86_64-pc-linux-gnu-gcc supports -c -o file.o... yes
checking if x86_64-pc-linux-gnu-gcc supports -c -o file.o... (cached) yes
checking whether the x86_64-pc-linux-gnu-gcc linker (/usr/x86_64-pc-linux-gnu/bin/ld -m elf_x86_64) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... yes
checking for x86_64-pc-linux-gnu-pkg-config... /usr/bin/x86_64-pc-linux-gnu-pkg-config
checking pkg-config is at least version 0.16... yes
checking for appstream-util... /usr/bin/appstream-util
checking for GNOME_CHESS... yes
checking for LIBCHESS... yes
checking for TEST... yes
checking linux/prctl.h usability... yes
checking linux/prctl.h presence... yes
checking for linux/prctl.h... yes
checking for desktop-file-validate... /usr/bin/desktop-file-validate
checking for glib-compile-resources... /usr/bin/glib-compile-resources
checking whether NLS is requested... yes
checking for msgfmt... /usr/bin/msgfmt
checking for gmsgfmt... /usr/bin/gmsgfmt
checking for xgettext... /usr/bin/xgettext
checking for msgmerge... /usr/bin/msgmerge
checking for ld used by x86_64-pc-linux-gnu-gcc... /usr/x86_64-pc-linux-gnu/bin/ld -m elf_x86_64
checking if the linker (/usr/x86_64-pc-linux-gnu/bin/ld -m elf_x86_64) is GNU ld... yes
checking for shared library run path origin... done
checking for CFPreferencesCopyAppValue... no
checking for CFLocaleCopyCurrent... no
checking for GNU gettext in libc... yes
checking whether to use NLS... yes
checking where the gettext function comes from... libc
checking for itstool... itstool
checking for xmllint... xmllint
checking that generated files are newer than configure... done
configure: creating ./config.status
config.status: creating Makefile
config.status: creating data/Makefile
config.status: creating data/icons/Makefile
config.status: creating data/icons/hicolor/Makefile
config.status: creating data/pieces/Makefile
config.status: creating data/pieces/fancy/Makefile
config.status: creating data/pieces/simple/Makefile
config.status: creating help/Makefile
config.status: creating lib/Makefile
config.status: creating po/Makefile.in
config.status: creating src/Makefile
config.status: creating tests/Makefile
config.status: executing depfiles commands
config.status: executing libtool commands
config.status: executing po-directories commands
config.status: creating po/POTFILES
config.status: creating po/Makefile
>>> Source configured.
>>> Compiling source in /var/tmp/portage/games-board/gnome-chess-3.22.2/work/gnome-chess-3.22.2 ...
make
Making all in data
make[1]: Entering directory '/var/tmp/portage/games-board/gnome-chess-3.22.2/work/gnome-chess-3.22.2/data'
Making all in icons
make[2]: Entering directory '/var/tmp/portage/games-board/gnome-chess-3.22.2/work/gnome-chess-3.22.2/data/icons'
Making all in hicolor
make[3]: Entering directory '/var/tmp/portage/games-board/gnome-chess-3.22.2/work/gnome-chess-3.22.2/data/icons/hicolor'
make[3]: Nothing to be done for 'all'.
make[3]: Leaving directory '/var/tmp/portage/games-board/gnome-chess-3.22.2/work/gnome-chess-3.22.2/data/icons/hicolor'
make[3]: Entering directory '/var/tmp/portage/games-board/gnome-chess-3.22.2/work/gnome-chess-3.22.2/data/icons'
make[3]: Nothing to be done for 'all-am'.
make[3]: Leaving directory '/var/tmp/portage/games-board/gnome-chess-3.22.2/work/gnome-chess-3.22.2/data/icons'
make[2]: Leaving directory '/var/tmp/portage/games-board/gnome-chess-3.22.2/work/gnome-chess-3.22.2/data/icons'
Making all in pieces
make[2]: Entering directory '/var/tmp/portage/games-board/gnome-chess-3.22.2/work/gnome-chess-3.22.2/data/pieces'
Making all in fancy
make[3]: Entering directory '/var/tmp/portage/games-board/gnome-chess-3.22.2/work/gnome-chess-3.22.2/data/pieces/fancy'
make[3]: Nothing to be done for 'all'.
make[3]: Leaving directory '/var/tmp/portage/games-board/gnome-chess-3.22.2/work/gnome-chess-3.22.2/data/pieces/fancy'
Making all in simple
make[3]: Entering directory '/var/tmp/portage/games-board/gnome-chess-3.22.2/work/gnome-chess-3.22.2/data/pieces/simple'
make[3]: Nothing to be done for 'all'.
make[3]: Leaving directory '/var/tmp/portage/games-board/gnome-chess-3.22.2/work/gnome-chess-3.22.2/data/pieces/simple'
make[3]: Entering directory '/var/tmp/portage/games-board/gnome-chess-3.22.2/work/gnome-chess-3.22.2/data/pieces'
make[3]: Nothing to be done for 'all-am'.
make[3]: Leaving directory '/var/tmp/portage/games-board/gnome-chess-3.22.2/work/gnome-chess-3.22.2/data/pieces'
make[2]: Leaving directory '/var/tmp/portage/games-board/gnome-chess-3.22.2/work/gnome-chess-3.22.2/data/pieces'
make[2]: Entering directory '/var/tmp/portage/games-board/gnome-chess-3.22.2/work/gnome-chess-3.22.2/data'
/usr/bin/msgfmt --desktop --template gnome-chess.desktop.in -d ../po -o gnome-chess.desktop
glib-compile-schemas --strict --dry-run  --schema-file=org.gnome.chess.gschema.xml && mkdir -p . && touch org.gnome.chess.gschema.valid
make[2]: Leaving directory '/var/tmp/portage/games-board/gnome-chess-3.22.2/work/gnome-chess-3.22.2/data'
make[1]: Leaving directory '/var/tmp/portage/games-board/gnome-chess-3.22.2/work/gnome-chess-3.22.2/data'
Making all in lib
make[1]: Entering directory '/var/tmp/portage/games-board/gnome-chess-3.22.2/work/gnome-chess-3.22.2/lib'
/bin/sh ../libtool  --tag=CC   --mode=compile x86_64-pc-linux-gnu-gcc -DPACKAGE_NAME=\"GNOME\ Chess\" -DPACKAGE_TARNAME=\"gnome-chess\" -DPACKAGE_VERSION=\"3.22.2\" -DPACKAGE_STRING=\"GNOME\ Chess\ 3.22.2\" -DPACKAGE_BUGREPORT=\"https://bugzilla.gnome.org/\" -DPACKAGE_URL=\"https://wiki.gnome.org/Apps/Chess\" -DPACKAGE=\"gnome-chess\" -DVERSION=\"3.22.2\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DLT_OBJDIR=\".libs/\" -DHAVE_LINUX_PRCTL_H=1 -DENABLE_NLS=1 -DHAVE_GETTEXT=1 -DHAVE_DCGETTEXT=1 -I.  -pthread -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -DGETTEXT_PACKAGE=\"gnome-chess\"  -w -march=core2 -O2 -pipe -c -o libchess_la-chess-bitboard.lo `test -f 'chess-bitboard.c' || echo './'`chess-bitboard.c
libtool: compile:  x86_64-pc-linux-gnu-gcc "-DPACKAGE_NAME=\"GNOME Chess\"" -DPACKAGE_TARNAME=\"gnome-chess\" -DPACKAGE_VERSION=\"3.22.2\" "-DPACKAGE_STRING=\"GNOME Chess 3.22.2\"" -DPACKAGE_BUGREPORT=\"https://bugzilla.gnome.org/\" -DPACKAGE_URL=\"https://wiki.gnome.org/Apps/Chess\" -DPACKAGE=\"gnome-chess\" -DVERSION=\"3.22.2\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DLT_OBJDIR=\".libs/\" -DHAVE_LINUX_PRCTL_H=1 -DENABLE_NLS=1 -DHAVE_GETTEXT=1 -DHAVE_DCGETTEXT=1 -I. -pthread -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -DGETTEXT_PACKAGE=\"gnome-chess\" -w -march=core2 -O2 -pipe -c chess-bitboard.c  -fPIC -DPIC -o .libs/libchess_la-chess-bitboard.o
libtool: compile:  x86_64-pc-linux-gnu-gcc "-DPACKAGE_NAME=\"GNOME Chess\"" -DPACKAGE_TARNAME=\"gnome-chess\" -DPACKAGE_VERSION=\"3.22.2\" "-DPACKAGE_STRING=\"GNOME Chess 3.22.2\"" -DPACKAGE_BUGREPORT=\"https://bugzilla.gnome.org/\" -DPACKAGE_URL=\"https://wiki.gnome.org/Apps/Chess\" -DPACKAGE=\"gnome-chess\" -DVERSION=\"3.22.2\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DLT_OBJDIR=\".libs/\" -DHAVE_LINUX_PRCTL_H=1 -DENABLE_NLS=1 -DHAVE_GETTEXT=1 -DHAVE_DCGETTEXT=1 -I. -pthread -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -DGETTEXT_PACKAGE=\"gnome-chess\" -w -march=core2 -O2 -pipe -c chess-bitboard.c -o libchess_la-chess-bitboard.o >/dev/null 2>&1
/bin/sh ../libtool  --tag=CC   --mode=compile x86_64-pc-linux-gnu-gcc -DPACKAGE_NAME=\"GNOME\ Chess\" -DPACKAGE_TARNAME=\"gnome-chess\" -DPACKAGE_VERSION=\"3.22.2\" -DPACKAGE_STRING=\"GNOME\ Chess\ 3.22.2\" -DPACKAGE_BUGREPORT=\"https://bugzilla.gnome.org/\" -DPACKAGE_URL=\"https://wiki.gnome.org/Apps/Chess\" -DPACKAGE=\"gnome-chess\" -DVERSION=\"3.22.2\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DLT_OBJDIR=\".libs/\" -DHAVE_LINUX_PRCTL_H=1 -DENABLE_NLS=1 -DHAVE_GETTEXT=1 -DHAVE_DCGETTEXT=1 -I.  -pthread -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -DGETTEXT_PACKAGE=\"gnome-chess\"  -w -march=core2 -O2 -pipe -c -o libchess_la-chess-clock.lo `test -f 'chess-clock.c' || echo './'`chess-clock.c
libtool: compile:  x86_64-pc-linux-gnu-gcc "-DPACKAGE_NAME=\"GNOME Chess\"" -DPACKAGE_TARNAME=\"gnome-chess\" -DPACKAGE_VERSION=\"3.22.2\" "-DPACKAGE_STRING=\"GNOME Chess 3.22.2\"" -DPACKAGE_BUGREPORT=\"https://bugzilla.gnome.org/\" -DPACKAGE_URL=\"https://wiki.gnome.org/Apps/Chess\" -DPACKAGE=\"gnome-chess\" -DVERSION=\"3.22.2\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DLT_OBJDIR=\".libs/\" -DHAVE_LINUX_PRCTL_H=1 -DENABLE_NLS=1 -DHAVE_GETTEXT=1 -DHAVE_DCGETTEXT=1 -I. -pthread -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -DGETTEXT_PACKAGE=\"gnome-chess\" -w -march=core2 -O2 -pipe -c chess-clock.c  -fPIC -DPIC -o .libs/libchess_la-chess-clock.o
libtool: compile:  x86_64-pc-linux-gnu-gcc "-DPACKAGE_NAME=\"GNOME Chess\"" -DPACKAGE_TARNAME=\"gnome-chess\" -DPACKAGE_VERSION=\"3.22.2\" "-DPACKAGE_STRING=\"GNOME Chess 3.22.2\"" -DPACKAGE_BUGREPORT=\"https://bugzilla.gnome.org/\" -DPACKAGE_URL=\"https://wiki.gnome.org/Apps/Chess\" -DPACKAGE=\"gnome-chess\" -DVERSION=\"3.22.2\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DLT_OBJDIR=\".libs/\" -DHAVE_LINUX_PRCTL_H=1 -DENABLE_NLS=1 -DHAVE_GETTEXT=1 -DHAVE_DCGETTEXT=1 -I. -pthread -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -DGETTEXT_PACKAGE=\"gnome-chess\" -w -march=core2 -O2 -pipe -c chess-clock.c -o libchess_la-chess-clock.o >/dev/null 2>&1
/bin/sh ../libtool  --tag=CC   --mode=compile x86_64-pc-linux-gnu-gcc -DPACKAGE_NAME=\"GNOME\ Chess\" -DPACKAGE_TARNAME=\"gnome-chess\" -DPACKAGE_VERSION=\"3.22.2\" -DPACKAGE_STRING=\"GNOME\ Chess\ 3.22.2\" -DPACKAGE_BUGREPORT=\"https://bugzilla.gnome.org/\" -DPACKAGE_URL=\"https://wiki.gnome.org/Apps/Chess\" -DPACKAGE=\"gnome-chess\" -DVERSION=\"3.22.2\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DLT_OBJDIR=\".libs/\" -DHAVE_LINUX_PRCTL_H=1 -DENABLE_NLS=1 -DHAVE_GETTEXT=1 -DHAVE_DCGETTEXT=1 -I.  -pthread -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -DGETTEXT_PACKAGE=\"gnome-chess\"  -w -march=core2 -O2 -pipe -c -o libchess_la-chess-game.lo `test -f 'chess-game.c' || echo './'`chess-game.c
libtool: compile:  x86_64-pc-linux-gnu-gcc "-DPACKAGE_NAME=\"GNOME Chess\"" -DPACKAGE_TARNAME=\"gnome-chess\" -DPACKAGE_VERSION=\"3.22.2\" "-DPACKAGE_STRING=\"GNOME Chess 3.22.2\"" -DPACKAGE_BUGREPORT=\"https://bugzilla.gnome.org/\" -DPACKAGE_URL=\"https://wiki.gnome.org/Apps/Chess\" -DPACKAGE=\"gnome-chess\" -DVERSION=\"3.22.2\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DLT_OBJDIR=\".libs/\" -DHAVE_LINUX_PRCTL_H=1 -DENABLE_NLS=1 -DHAVE_GETTEXT=1 -DHAVE_DCGETTEXT=1 -I. -pthread -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -DGETTEXT_PACKAGE=\"gnome-chess\" -w -march=core2 -O2 -pipe -c chess-game.c  -fPIC -DPIC -o .libs/libchess_la-chess-game.o
libtool: compile:  x86_64-pc-linux-gnu-gcc "-DPACKAGE_NAME=\"GNOME Chess\"" -DPACKAGE_TARNAME=\"gnome-chess\" -DPACKAGE_VERSION=\"3.22.2\" "-DPACKAGE_STRING=\"GNOME Chess 3.22.2\"" -DPACKAGE_BUGREPORT=\"https://bugzilla.gnome.org/\" -DPACKAGE_URL=\"https://wiki.gnome.org/Apps/Chess\" -DPACKAGE=\"gnome-chess\" -DVERSION=\"3.22.2\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DLT_OBJDIR=\".libs/\" -DHAVE_LINUX_PRCTL_H=1 -DENABLE_NLS=1 -DHAVE_GETTEXT=1 -DHAVE_DCGETTEXT=1 -I. -pthread -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -DGETTEXT_PACKAGE=\"gnome-chess\" -w -march=core2 -O2 -pipe -c chess-game.c -o libchess_la-chess-game.o >/dev/null 2>&1
/bin/sh ../libtool  --tag=CC   --mode=compile x86_64-pc-linux-gnu-gcc -DPACKAGE_NAME=\"GNOME\ Chess\" -DPACKAGE_TARNAME=\"gnome-chess\" -DPACKAGE_VERSION=\"3.22.2\" -DPACKAGE_STRING=\"GNOME\ Chess\ 3.22.2\" -DPACKAGE_BUGREPORT=\"https://bugzilla.gnome.org/\" -DPACKAGE_URL=\"https://wiki.gnome.org/Apps/Chess\" -DPACKAGE=\"gnome-chess\" -DVERSION=\"3.22.2\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DLT_OBJDIR=\".libs/\" -DHAVE_LINUX_PRCTL_H=1 -DENABLE_NLS=1 -DHAVE_GETTEXT=1 -DHAVE_DCGETTEXT=1 -I.  -pthread -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -DGETTEXT_PACKAGE=\"gnome-chess\"  -w -march=core2 -O2 -pipe -c -o libchess_la-chess-move.lo `test -f 'chess-move.c' || echo './'`chess-move.c
libtool: compile:  x86_64-pc-linux-gnu-gcc "-DPACKAGE_NAME=\"GNOME Chess\"" -DPACKAGE_TARNAME=\"gnome-chess\" -DPACKAGE_VERSION=\"3.22.2\" "-DPACKAGE_STRING=\"GNOME Chess 3.22.2\"" -DPACKAGE_BUGREPORT=\"https://bugzilla.gnome.org/\" -DPACKAGE_URL=\"https://wiki.gnome.org/Apps/Chess\" -DPACKAGE=\"gnome-chess\" -DVERSION=\"3.22.2\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DLT_OBJDIR=\".libs/\" -DHAVE_LINUX_PRCTL_H=1 -DENABLE_NLS=1 -DHAVE_GETTEXT=1 -DHAVE_DCGETTEXT=1 -I. -pthread -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -DGETTEXT_PACKAGE=\"gnome-chess\" -w -march=core2 -O2 -pipe -c chess-move.c  -fPIC -DPIC -o .libs/libchess_la-chess-move.o
libtool: compile:  x86_64-pc-linux-gnu-gcc "-DPACKAGE_NAME=\"GNOME Chess\"" -DPACKAGE_TARNAME=\"gnome-chess\" -DPACKAGE_VERSION=\"3.22.2\" "-DPACKAGE_STRING=\"GNOME Chess 3.22.2\"" -DPACKAGE_BUGREPORT=\"https://bugzilla.gnome.org/\" -DPACKAGE_URL=\"https://wiki.gnome.org/Apps/Chess\" -DPACKAGE=\"gnome-chess\" -DVERSION=\"3.22.2\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DLT_OBJDIR=\".libs/\" -DHAVE_LINUX_PRCTL_H=1 -DENABLE_NLS=1 -DHAVE_GETTEXT=1 -DHAVE_DCGETTEXT=1 -I. -pthread -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -DGETTEXT_PACKAGE=\"gnome-chess\" -w -march=core2 -O2 -pipe -c chess-move.c -o libchess_la-chess-move.o >/dev/null 2>&1
/bin/sh ../libtool  --tag=CC   --mode=compile x86_64-pc-linux-gnu-gcc -DPACKAGE_NAME=\"GNOME\ Chess\" -DPACKAGE_TARNAME=\"gnome-chess\" -DPACKAGE_VERSION=\"3.22.2\" -DPACKAGE_STRING=\"GNOME\ Chess\ 3.22.2\" -DPACKAGE_BUGREPORT=\"https://bugzilla.gnome.org/\" -DPACKAGE_URL=\"https://wiki.gnome.org/Apps/Chess\" -DPACKAGE=\"gnome-chess\" -DVERSION=\"3.22.2\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DLT_OBJDIR=\".libs/\" -DHAVE_LINUX_PRCTL_H=1 -DENABLE_NLS=1 -DHAVE_GETTEXT=1 -DHAVE_DCGETTEXT=1 -I.  -pthread -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -DGETTEXT_PACKAGE=\"gnome-chess\"  -w -march=core2 -O2 -pipe -c -o libchess_la-chess-pgn.lo `test -f 'chess-pgn.c' || echo './'`chess-pgn.c
libtool: compile:  x86_64-pc-linux-gnu-gcc "-DPACKAGE_NAME=\"GNOME Chess\"" -DPACKAGE_TARNAME=\"gnome-chess\" -DPACKAGE_VERSION=\"3.22.2\" "-DPACKAGE_STRING=\"GNOME Chess 3.22.2\"" -DPACKAGE_BUGREPORT=\"https://bugzilla.gnome.org/\" -DPACKAGE_URL=\"https://wiki.gnome.org/Apps/Chess\" -DPACKAGE=\"gnome-chess\" -DVERSION=\"3.22.2\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DLT_OBJDIR=\".libs/\" -DHAVE_LINUX_PRCTL_H=1 -DENABLE_NLS=1 -DHAVE_GETTEXT=1 -DHAVE_DCGETTEXT=1 -I. -pthread -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -DGETTEXT_PACKAGE=\"gnome-chess\" -w -march=core2 -O2 -pipe -c chess-pgn.c  -fPIC -DPIC -o .libs/libchess_la-chess-pgn.o
libtool: compile:  x86_64-pc-linux-gnu-gcc "-DPACKAGE_NAME=\"GNOME Chess\"" -DPACKAGE_TARNAME=\"gnome-chess\" -DPACKAGE_VERSION=\"3.22.2\" "-DPACKAGE_STRING=\"GNOME Chess 3.22.2\"" -DPACKAGE_BUGREPORT=\"https://bugzilla.gnome.org/\" -DPACKAGE_URL=\"https://wiki.gnome.org/Apps/Chess\" -DPACKAGE=\"gnome-chess\" -DVERSION=\"3.22.2\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DLT_OBJDIR=\".libs/\" -DHAVE_LINUX_PRCTL_H=1 -DENABLE_NLS=1 -DHAVE_GETTEXT=1 -DHAVE_DCGETTEXT=1 -I. -pthread -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -DGETTEXT_PACKAGE=\"gnome-chess\" -w -march=core2 -O2 -pipe -c chess-pgn.c -o libchess_la-chess-pgn.o >/dev/null 2>&1
/bin/sh ../libtool  --tag=CC   --mode=compile x86_64-pc-linux-gnu-gcc -DPACKAGE_NAME=\"GNOME\ Chess\" -DPACKAGE_TARNAME=\"gnome-chess\" -DPACKAGE_VERSION=\"3.22.2\" -DPACKAGE_STRING=\"GNOME\ Chess\ 3.22.2\" -DPACKAGE_BUGREPORT=\"https://bugzilla.gnome.org/\" -DPACKAGE_URL=\"https://wiki.gnome.org/Apps/Chess\" -DPACKAGE=\"gnome-chess\" -DVERSION=\"3.22.2\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DLT_OBJDIR=\".libs/\" -DHAVE_LINUX_PRCTL_H=1 -DENABLE_NLS=1 -DHAVE_GETTEXT=1 -DHAVE_DCGETTEXT=1 -I.  -pthread -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -DGETTEXT_PACKAGE=\"gnome-chess\"  -w -march=core2 -O2 -pipe -c -o libchess_la-chess-piece.lo `test -f 'chess-piece.c' || echo './'`chess-piece.c
libtool: compile:  x86_64-pc-linux-gnu-gcc "-DPACKAGE_NAME=\"GNOME Chess\"" -DPACKAGE_TARNAME=\"gnome-chess\" -DPACKAGE_VERSION=\"3.22.2\" "-DPACKAGE_STRING=\"GNOME Chess 3.22.2\"" -DPACKAGE_BUGREPORT=\"https://bugzilla.gnome.org/\" -DPACKAGE_URL=\"https://wiki.gnome.org/Apps/Chess\" -DPACKAGE=\"gnome-chess\" -DVERSION=\"3.22.2\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DLT_OBJDIR=\".libs/\" -DHAVE_LINUX_PRCTL_H=1 -DENABLE_NLS=1 -DHAVE_GETTEXT=1 -DHAVE_DCGETTEXT=1 -I. -pthread -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -DGETTEXT_PACKAGE=\"gnome-chess\" -w -march=core2 -O2 -pipe -c chess-piece.c  -fPIC -DPIC -o .libs/libchess_la-chess-piece.o
libtool: compile:  x86_64-pc-linux-gnu-gcc "-DPACKAGE_NAME=\"GNOME Chess\"" -DPACKAGE_TARNAME=\"gnome-chess\" -DPACKAGE_VERSION=\"3.22.2\" "-DPACKAGE_STRING=\"GNOME Chess 3.22.2\"" -DPACKAGE_BUGREPORT=\"https://bugzilla.gnome.org/\" -DPACKAGE_URL=\"https://wiki.gnome.org/Apps/Chess\" -DPACKAGE=\"gnome-chess\" -DVERSION=\"3.22.2\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DLT_OBJDIR=\".libs/\" -DHAVE_LINUX_PRCTL_H=1 -DENABLE_NLS=1 -DHAVE_GETTEXT=1 -DHAVE_DCGETTEXT=1 -I. -pthread -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -DGETTEXT_PACKAGE=\"gnome-chess\" -w -march=core2 -O2 -pipe -c chess-piece.c -o libchess_la-chess-piece.o >/dev/null 2>&1
/bin/sh ../libtool  --tag=CC   --mode=compile x86_64-pc-linux-gnu-gcc -DPACKAGE_NAME=\"GNOME\ Chess\" -DPACKAGE_TARNAME=\"gnome-chess\" -DPACKAGE_VERSION=\"3.22.2\" -DPACKAGE_STRING=\"GNOME\ Chess\ 3.22.2\" -DPACKAGE_BUGREPORT=\"https://bugzilla.gnome.org/\" -DPACKAGE_URL=\"https://wiki.gnome.org/Apps/Chess\" -DPACKAGE=\"gnome-chess\" -DVERSION=\"3.22.2\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DLT_OBJDIR=\".libs/\" -DHAVE_LINUX_PRCTL_H=1 -DENABLE_NLS=1 -DHAVE_GETTEXT=1 -DHAVE_DCGETTEXT=1 -I.  -pthread -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -DGETTEXT_PACKAGE=\"gnome-chess\"  -w -march=core2 -O2 -pipe -c -o libchess_la-chess-player.lo `test -f 'chess-player.c' || echo './'`chess-player.c
libtool: compile:  x86_64-pc-linux-gnu-gcc "-DPACKAGE_NAME=\"GNOME Chess\"" -DPACKAGE_TARNAME=\"gnome-chess\" -DPACKAGE_VERSION=\"3.22.2\" "-DPACKAGE_STRING=\"GNOME Chess 3.22.2\"" -DPACKAGE_BUGREPORT=\"https://bugzilla.gnome.org/\" -DPACKAGE_URL=\"https://wiki.gnome.org/Apps/Chess\" -DPACKAGE=\"gnome-chess\" -DVERSION=\"3.22.2\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DLT_OBJDIR=\".libs/\" -DHAVE_LINUX_PRCTL_H=1 -DENABLE_NLS=1 -DHAVE_GETTEXT=1 -DHAVE_DCGETTEXT=1 -I. -pthread -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -DGETTEXT_PACKAGE=\"gnome-chess\" -w -march=core2 -O2 -pipe -c chess-player.c  -fPIC -DPIC -o .libs/libchess_la-chess-player.o
libtool: compile:  x86_64-pc-linux-gnu-gcc "-DPACKAGE_NAME=\"GNOME Chess\"" -DPACKAGE_TARNAME=\"gnome-chess\" -DPACKAGE_VERSION=\"3.22.2\" "-DPACKAGE_STRING=\"GNOME Chess 3.22.2\"" -DPACKAGE_BUGREPORT=\"https://bugzilla.gnome.org/\" -DPACKAGE_URL=\"https://wiki.gnome.org/Apps/Chess\" -DPACKAGE=\"gnome-chess\" -DVERSION=\"3.22.2\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DLT_OBJDIR=\".libs/\" -DHAVE_LINUX_PRCTL_H=1 -DENABLE_NLS=1 -DHAVE_GETTEXT=1 -DHAVE_DCGETTEXT=1 -I. -pthread -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -DGETTEXT_PACKAGE=\"gnome-chess\" -w -march=core2 -O2 -pipe -c chess-player.c -o libchess_la-chess-player.o >/dev/null 2>&1
/bin/sh ../libtool  --tag=CC   --mode=compile x86_64-pc-linux-gnu-gcc -DPACKAGE_NAME=\"GNOME\ Chess\" -DPACKAGE_TARNAME=\"gnome-chess\" -DPACKAGE_VERSION=\"3.22.2\" -DPACKAGE_STRING=\"GNOME\ Chess\ 3.22.2\" -DPACKAGE_BUGREPORT=\"https://bugzilla.gnome.org/\" -DPACKAGE_URL=\"https://wiki.gnome.org/Apps/Chess\" -DPACKAGE=\"gnome-chess\" -DVERSION=\"3.22.2\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DLT_OBJDIR=\".libs/\" -DHAVE_LINUX_PRCTL_H=1 -DENABLE_NLS=1 -DHAVE_GETTEXT=1 -DHAVE_DCGETTEXT=1 -I.  -pthread -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -DGETTEXT_PACKAGE=\"gnome-chess\"  -w -march=core2 -O2 -pipe -c -o libchess_la-chess-state.lo `test -f 'chess-state.c' || echo './'`chess-state.c
libtool: compile:  x86_64-pc-linux-gnu-gcc "-DPACKAGE_NAME=\"GNOME Chess\"" -DPACKAGE_TARNAME=\"gnome-chess\" -DPACKAGE_VERSION=\"3.22.2\" "-DPACKAGE_STRING=\"GNOME Chess 3.22.2\"" -DPACKAGE_BUGREPORT=\"https://bugzilla.gnome.org/\" -DPACKAGE_URL=\"https://wiki.gnome.org/Apps/Chess\" -DPACKAGE=\"gnome-chess\" -DVERSION=\"3.22.2\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DLT_OBJDIR=\".libs/\" -DHAVE_LINUX_PRCTL_H=1 -DENABLE_NLS=1 -DHAVE_GETTEXT=1 -DHAVE_DCGETTEXT=1 -I. -pthread -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -DGETTEXT_PACKAGE=\"gnome-chess\" -w -march=core2 -O2 -pipe -c chess-state.c  -fPIC -DPIC -o .libs/libchess_la-chess-state.o
libtool: compile:  x86_64-pc-linux-gnu-gcc "-DPACKAGE_NAME=\"GNOME Chess\"" -DPACKAGE_TARNAME=\"gnome-chess\" -DPACKAGE_VERSION=\"3.22.2\" "-DPACKAGE_STRING=\"GNOME Chess 3.22.2\"" -DPACKAGE_BUGREPORT=\"https://bugzilla.gnome.org/\" -DPACKAGE_URL=\"https://wiki.gnome.org/Apps/Chess\" -DPACKAGE=\"gnome-chess\" -DVERSION=\"3.22.2\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DLT_OBJDIR=\".libs/\" -DHAVE_LINUX_PRCTL_H=1 -DENABLE_NLS=1 -DHAVE_GETTEXT=1 -DHAVE_DCGETTEXT=1 -I. -pthread -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -DGETTEXT_PACKAGE=\"gnome-chess\" -w -march=core2 -O2 -pipe -c chess-state.c -o libchess_la-chess-state.o >/dev/null 2>&1
/bin/sh ../libtool  --tag=CC   --mode=link x86_64-pc-linux-gnu-gcc -w -march=core2 -O2 -pipe  -Wl,-O1 -Wl,--as-needed -o libchess.la  libchess_la-chess-bitboard.lo libchess_la-chess-clock.lo libchess_la-chess-game.lo libchess_la-chess-move.lo libchess_la-chess-pgn.lo libchess_la-chess-piece.lo libchess_la-chess-player.lo libchess_la-chess-state.lo -lgio-2.0 -lgobject-2.0 -lglib-2.0
libtool: link: x86_64-pc-linux-gnu-ar cru .libs/libchess.a .libs/libchess_la-chess-bitboard.o .libs/libchess_la-chess-clock.o .libs/libchess_la-chess-game.o .libs/libchess_la-chess-move.o .libs/libchess_la-chess-pgn.o .libs/libchess_la-chess-piece.o .libs/libchess_la-chess-player.o .libs/libchess_la-chess-state.o
libtool: link: x86_64-pc-linux-gnu-ranlib .libs/libchess.a
libtool: link: ( cd ".libs" && rm -f "libchess.la" && ln -s "../libchess.la" "libchess.la" )
make[1]: Leaving directory '/var/tmp/portage/games-board/gnome-chess-3.22.2/work/gnome-chess-3.22.2/lib'
Making all in src
make[1]: Entering directory '/var/tmp/portage/games-board/gnome-chess-3.22.2/work/gnome-chess-3.22.2/src'
make  all-am
make[2]: Entering directory '/var/tmp/portage/games-board/gnome-chess-3.22.2/work/gnome-chess-3.22.2/src'
x86_64-pc-linux-gnu-gcc -DPACKAGE_NAME=\"GNOME\ Chess\" -DPACKAGE_TARNAME=\"gnome-chess\" -DPACKAGE_VERSION=\"3.22.2\" -DPACKAGE_STRING=\"GNOME\ Chess\ 3.22.2\" -DPACKAGE_BUGREPORT=\"https://bugzilla.gnome.org/\" -DPACKAGE_URL=\"https://wiki.gnome.org/Apps/Chess\" -DPACKAGE=\"gnome-chess\" -DVERSION=\"3.22.2\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DLT_OBJDIR=\".libs/\" -DHAVE_LINUX_PRCTL_H=1 -DENABLE_NLS=1 -DHAVE_GETTEXT=1 -DHAVE_DCGETTEXT=1 -I.  -DVERSION=\"3.22.2\" -DGETTEXT_PACKAGE=\"gnome-chess\" -DPKGDATADIR=\"/usr/share/gnome-chess/\" -DLOCALEDIR=\"/usr/share/locale\" -DSYSCONFDIR=\"/etc\" -I../lib -pthread -I/usr/include/gtk-3.0 -I/usr/include/at-spi2-atk/2.0 -I/usr/include/at-spi-2.0 -I/usr/include/dbus-1.0 -I/usr/lib64/dbus-1.0/include -I/usr/include/gtk-3.0 -I/usr/include/gio-unix-2.0/ -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/harfbuzz -I/usr/include/pango-1.0 -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/librsvg-2.0 -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/cairo -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libdrm -I/usr/include/libpng16  -w -march=core2 -O2 -pipe -c -o gnome_chess-portability.o `test -f 'portability.c' || echo './'`portability.c
x86_64-pc-linux-gnu-gcc -DPACKAGE_NAME=\"GNOME\ Chess\" -DPACKAGE_TARNAME=\"gnome-chess\" -DPACKAGE_VERSION=\"3.22.2\" -DPACKAGE_STRING=\"GNOME\ Chess\ 3.22.2\" -DPACKAGE_BUGREPORT=\"https://bugzilla.gnome.org/\" -DPACKAGE_URL=\"https://wiki.gnome.org/Apps/Chess\" -DPACKAGE=\"gnome-chess\" -DVERSION=\"3.22.2\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DLT_OBJDIR=\".libs/\" -DHAVE_LINUX_PRCTL_H=1 -DENABLE_NLS=1 -DHAVE_GETTEXT=1 -DHAVE_DCGETTEXT=1 -I.  -DVERSION=\"3.22.2\" -DGETTEXT_PACKAGE=\"gnome-chess\" -DPKGDATADIR=\"/usr/share/gnome-chess/\" -DLOCALEDIR=\"/usr/share/locale\" -DSYSCONFDIR=\"/etc\" -I../lib -pthread -I/usr/include/gtk-3.0 -I/usr/include/at-spi2-atk/2.0 -I/usr/include/at-spi-2.0 -I/usr/include/dbus-1.0 -I/usr/lib64/dbus-1.0/include -I/usr/include/gtk-3.0 -I/usr/include/gio-unix-2.0/ -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/harfbuzz -I/usr/include/pango-1.0 -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/librsvg-2.0 -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/cairo -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libdrm -I/usr/include/libpng16  -w -march=core2 -O2 -pipe -c -o gnome_chess-gnome-chess.o `test -f 'gnome-chess.c' || echo './'`gnome-chess.c
gnome-chess.c: In function ‘chess_application_set_clock_type’:
gnome-chess.c:6522:18: error: conflicting types for ‘clock_type_changed_cb’
  G_MODULE_EXPORT clock_type_changed_cb (_tmp18_, self);
                  ^~~~~~~~~~~~~~~~~~~~~
gnome-chess.c:424:22: note: previous declaration of ‘clock_type_changed_cb’ was here
 void G_MODULE_EXPORT clock_type_changed_cb (GtkComboBox* combo, ChessApplication* self);
                      ^~~~~~~~~~~~~~~~~~~~~
gnome-chess.c: In function ‘chess_application_set_timer_increment’:
gnome-chess.c:6607:52: error: expected declaration specifiers or ‘...’ before ‘(’ token
  G_MODULE_EXPORT timer_increment_units_changed_cb ((GtkWidget*) _tmp23_, self);
                                                    ^
gnome-chess.c:6607:74: error: expected declaration specifiers or ‘...’ before ‘self’
  G_MODULE_EXPORT timer_increment_units_changed_cb ((GtkWidget*) _tmp23_, self);
                                                                          ^~~~
gnome-chess.c: At top level:
gnome-chess.c:7247:22: error: conflicting types for ‘clock_type_changed_cb’
 void G_MODULE_EXPORT clock_type_changed_cb (GtkComboBox* combo, ChessApplication* self) {
                      ^~~~~~~~~~~~~~~~~~~~~
gnome-chess.c:6522:18: note: previous declaration of ‘clock_type_changed_cb’ was here
  G_MODULE_EXPORT clock_type_changed_cb (_tmp18_, self);
                  ^~~~~~~~~~~~~~~~~~~~~
gnome-chess.c: In function ‘preferences_delete_event_cb’:
gnome-chess.c:7309:51: error: expected ‘)’ before ‘(’ token
  G_MODULE_EXPORT preferences_response_cb (_tmp0_, (gint) GTK_RESPONSE_CANCEL, self);
                                                   ^
make[2]: *** [Makefile:555: gnome_chess-gnome-chess.o] Error 1
make[2]: Leaving directory '/var/tmp/portage/games-board/gnome-chess-3.22.2/work/gnome-chess-3.22.2/src'
make[1]: *** [Makefile:412: all] Error 2
make[1]: Leaving directory '/var/tmp/portage/games-board/gnome-chess-3.22.2/work/gnome-chess-3.22.2/src'
make: *** [Makefile:431: all-recursive] Error 1
 * ERROR: games-board/gnome-chess-3.22.2::dantrell-gnome-3-22 failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=games-board/gnome-chess-3.22.2::dantrell-gnome-3-22'`,
 * the complete build log and the output of `emerge -pqv '=games-board/gnome-chess-3.22.2::dantrell-gnome-3-22'`.
 * The complete build log is located at '/var/tmp/portage/games-board/gnome-chess-3.22.2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/games-board/gnome-chess-3.22.2/temp/environment'.
 * Working directory: '/var/tmp/portage/games-board/gnome-chess-3.22.2/work/gnome-chess-3.22.2'
 * S: '/var/tmp/portage/games-board/gnome-chess-3.22.2/work/gnome-chess-3.22.2'




Code:

Portage 2.3.13 (python 3.4.5-final-0, !../../var/lib/layman/dantrell-gnome/profiles/default/amd64/3.20/extended, gcc-6.4.0, glibc-2.25-r9, 4.12.12-gentoo x86_64)
=================================================================
System uname: Linux-4.12.12-gentoo-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q9400_@_2.66GHz-with-gentoo-2.4.1
KiB Mem:     4045200 total,   3662248 free
KiB Swap:    4196348 total,   4196348 free
Timestamp of repository gentoo: Thu, 23 Nov 2017 02:30:01 +0000
Head commit of repository gentoo: 04ac1dc405357153c2c2cfa5ff703c5d2476034e
sh bash 4.3_p48-r1
ld GNU ld (Gentoo 2.29.1 p3) 2.29.1
app-shells/bash:          4.3_p48-r1::gentoo
dev-lang/perl:            5.24.3::gentoo
dev-lang/python:          2.7.14::gentoo, 3.4.5::gentoo
dev-util/cmake:           3.8.2::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.4.1-r2::gentoo
sys-apps/openrc:          0.29::gentoo
sys-apps/sandbox:         2.10-r4::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo
sys-devel/automake:       1.11.6-r2::gentoo, 1.15.1-r1::gentoo
sys-devel/binutils:       2.29.1-r1::gentoo
sys-devel/gcc:            6.4.0::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.4::gentoo (virtual/os-headers)
sys-libs/glibc:           2.25-r9::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-extra-opts:

dantrell-gnome-3-22
    location: /var/lib/layman/dantrell-gnome-3-22
    sync-type: laymansync
    sync-uri: https://github.com/dantrell/gentoo-overlay-dantrell-gnome-3-22.git
    masters: gentoo
    priority: 100

dantrell-gnome
    location: /var/lib/layman/dantrell-gnome
    sync-type: laymansync
    sync-uri: https://github.com/dantrell/gentoo-overlay-dantrell-gnome.git
    masters: gentoo
    priority: 150

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=core2 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync multilib-strict news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://gentoo.c3sl.ufpr.br/ rsync://gentoo.c3sl.ufpr.br/gentoo/ ftp://gentoo.c3sl.ufpr.br/gentoo/"
LANG="pt_BR.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS=""
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cdda cdr cli colord consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr eds encode evo exif fam flac fortran gdbm gif glamor gnome gnome-keyring gnome-online-accounts gpm gtk3 gtkstyle iconv introspection ipv6 jpeg lcms ldap libnotify libsecret mad mng modules mp3 mp4 mpeg multilib nautilus ncurses nls nptl ogg opengl openmp pam pango pcre pdf png policykit ppds pulseaudio readline sdl seccomp session spell ssl startup-notification svg tcpd tiff tracker truetype udev udisks unicode upower usb vorbis x264 xattr xcb xml xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx sse sse2 mmxext" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6 php7-0" POSTGRES_TARGETS="postgres9_5" PYTHON_SINGLE_TARGET="python3_4" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby22" USERLAND="GNU" VIDEO_CARDS="amdgpu fbdev intel nouveau radeon radeonsi vesa dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


Sorry for the log size.
I hope we can solve this little problem, my GNOME is only 3 packages away :lol:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 16, 17, 18, 19  Next
Page 17 of 19

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum