Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Driver video Nvidia
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
MarcoPerformance
n00b
n00b


Joined: 15 Jul 2015
Posts: 12

PostPosted: Wed Jul 15, 2015 6:19 pm    Post subject: Driver video Nvidia Reply with quote

Salve a tutti,

Questa è la mia prima installazione di Gentoo e quindi considerate il fatto di essere il più precisi possibili nelle risposte e non date nulla per scontato,grazie! :)

Dopo aver installato correttamente il sistema e aver installato Xorg(senza,però,configurarlo)ho riavviato la macchina e ho notato che dopo che il kernel si è avviato lo schermo si spegne letteralmente e,dopo l'avvenuta riaccensione,vedo solo la retro-illuminazione del monitor senza nessun messaggio da parte della macchina.
Ho guardato un po in rete e ho visto che durante la configurazione del Kernel il driver video(nouveau Nvidia)si deve selezionare come "modulo"(quindi con la "M" e non con lo *)io,invece,lo ho semplicemente selezionato.
Non vorrei che questo sia la causa della mancata accensione della macchina e vorrei,prima di andare a mettere le mani nel kernel,sapere da voi esperti di Gentoo quali potrebbero essere le altre possibili soluzioni a questo problema.

Premtetto che ho scelto SystemD come gestore degli avvii e la mia scheda video è una Nvidia e non ha mai dato problemi ne' con Debian,Ubuntu,Mint ne' con Arch Linux;quindi credo che questa sia solo una configurazione errata da parte mia.

Ringrazio anticipatamente coloro che mi risponderanno.

Se potesse essere utile qui c'è la configurazione del mio kernel http://pastebin.com/MvaFn1UN
Back to top
View user's profile Send private message
xdarma
l33t
l33t


Joined: 08 Dec 2003
Posts: 682
Location: tra veneto e friuli (italy)

PostPosted: Wed Jul 15, 2015 7:55 pm    Post subject: Re: Driver video Nvidia Reply with quote

MarcoPerformance wrote:
Dopo aver installato correttamente il sistema e aver installato Xorg(senza,però,configurarlo)ho riavviato la macchina e ho notato che dopo che il kernel si è avviato lo schermo si spegne letteralmente e,dopo l'avvenuta riaccensione,vedo solo la retro-illuminazione del monitor senza nessun messaggio da parte della macchina.
Ho guardato un po in rete e ho visto che durante la configurazione del Kernel il driver video(nouveau Nvidia)si deve selezionare come "modulo"(quindi con la "M" e non con lo *)io,invece,lo ho semplicemente selezionato.

Sul wiki dicono che i driver vengono installati con emerge, aggiornando la configurazione di make.conf. Ti ricordi di averli compilati?
Per controllare puoi usare "emerge -s nouveau" o "eix -I nouveau" (ocio che è una i maiuscola ;-)
Il fatto che non si veda nulla al boot, rende difficile da usare il sistema come desktop. Prova a ricompilare includendo almeno il VGA_CONSOLE.
Device Drivers -> Graphics support -> Console display driver support -> VGA text console [*]

Quote:
Premtetto che ho scelto SystemD come gestore degli avvii

Magari si limitasse a fare il gestore di init... :-)
Gentoo può funzionare anche senza, se vuoi provare: Gentoo Without systemd.
_________________
proud user of faKeDE-4.7.3
Back to top
View user's profile Send private message
MarcoPerformance
n00b
n00b


Joined: 15 Jul 2015
Posts: 12

PostPosted: Wed Jul 15, 2015 8:11 pm    Post subject: Re: Driver video Nvidia Reply with quote

xdarma wrote:
MarcoPerformance wrote:
Dopo aver installato correttamente il sistema e aver installato Xorg(senza,però,configurarlo)ho riavviato la macchina e ho notato che dopo che il kernel si è avviato lo schermo si spegne letteralmente e,dopo l'avvenuta riaccensione,vedo solo la retro-illuminazione del monitor senza nessun messaggio da parte della macchina.
Ho guardato un po in rete e ho visto che durante la configurazione del Kernel il driver video(nouveau Nvidia)si deve selezionare come "modulo"(quindi con la "M" e non con lo *)io,invece,lo ho semplicemente selezionato.

Sul wiki dicono che i driver vengono installati con emerge, aggiornando la configurazione di make.conf. Ti ricordi di averli compilati?
Per controllare puoi usare "emerge -s nouveau" o "eix -I nouveau" (ocio che è una i maiuscola ;-)
Il fatto che non si veda nulla al boot, rende difficile da usare il sistema come desktop. Prova a ricompilare includendo almeno il VGA_CONSOLE.
Device Drivers -> Graphics support -> Console display driver support -> VGA text console [*]

Quote:
Premtetto che ho scelto SystemD come gestore degli avvii

Magari si limitasse a fare il gestore di init... :-)
Gentoo può funzionare anche senza, se vuoi provare: Gentoo Without systemd.

Tutti che odiano SystemD...io sono comunque obbligato ad usarlo perchè altrimenti (il vecchio sistema di init)non rallenta le ventole e stanno a palla tutto il tempo...e comunque non utilizzerei mai Gentoo come server quindi non dovrei imbattersi in grossi problemi :)
Rimanendo in topic:
Io non ho "emegiato" nessun driver ho solo abilitato il modulo dalla configurazione nel Kernel. XD
Ok domani riprovo a riconfigurare il Kernel per l'ennesima volta...speriamo che riesca anche ad installare Xfce e chiudere questa discussione da Firefox :P
Back to top
View user's profile Send private message
Javaskit
n00b
n00b


Joined: 12 Jul 2012
Posts: 30

PostPosted: Wed Jul 15, 2015 9:23 pm    Post subject: Reply with quote

MarcoPerformance,

Nel file /etc/portage/make.conf hai impostato la variabile VIDEO_CARDS ?

/etc/portage/make.conf:

VIDEO_CARDS="nouveau"


Se lo hai fatto allora portage automaticamente ti avrà installato i drivers corretti. Come conferma esegui i comandi che ti ha detto xdarma.



Java
_________________
"We can scarcely avoid the conclusion that light consists in the transverse undulations of the same medium which is the cause of electric and magnetic phenomena."
Back to top
View user's profile Send private message
xdarma
l33t
l33t


Joined: 08 Dec 2003
Posts: 682
Location: tra veneto e friuli (italy)

PostPosted: Thu Jul 16, 2015 6:17 am    Post subject: Re: Driver video Nvidia Reply with quote

MarcoPerformance wrote:
Tutti che odiano SystemD...io sono comunque obbligato ad usarlo perchè altrimenti (il vecchio sistema di init)non rallenta le ventole e stanno a palla tutto il tempo...e comunque non utilizzerei mai Gentoo come server quindi non dovrei imbattersi in grossi problemi :)

Boh, direi che quelli di systemd sembrano farne un punto d'orgoglio quello di andare contro il preesistente, quindi direi che ottengono quello cercano.
Mi sembra strano che sia "colpa" o "merito" di un sistema di init il controllo (o mancato controllo) del funzionamento delle ventole.
Credo che il problema sia legato a qualcos'altro. IMO.
_________________
proud user of faKeDE-4.7.3
Back to top
View user's profile Send private message
MarcoPerformance
n00b
n00b


Joined: 15 Jul 2015
Posts: 12

PostPosted: Thu Jul 16, 2015 7:58 am    Post subject: Re: Driver video Nvidia Reply with quote

xdarma wrote:
MarcoPerformance wrote:
Tutti che odiano SystemD...io sono comunque obbligato ad usarlo perchè altrimenti (il vecchio sistema di init)non rallenta le ventole e stanno a palla tutto il tempo...e comunque non utilizzerei mai Gentoo come server quindi non dovrei imbattersi in grossi problemi :)

Boh, direi che quelli di systemd sembrano farne un punto d'orgoglio quello di andare contro il preesistente, quindi direi che ottengono quello cercano.
Mi sembra strano che sia "colpa" o "merito" di un sistema di init il controllo (o mancato controllo) del funzionamento delle ventole.
Credo che il problema sia legato a qualcos'altro. IMO.


Io invece credo sia proprio il sistema di Init...anche perchè quando Debian (wheezy)aveva il vecchio le ventole erano sempre a manetta ed ero costretto ad utilizzare tool aggiuntivi per rallentare.
Da quando Debian(Jessie 8) è passato a SystemD questo problema non esiste più.
Credo che sia un problema legato all'hardware non perfettamente compatibile con i driver...altrimenti non saprei darmi altre risposte.
Back to top
View user's profile Send private message
MarcoPerformance
n00b
n00b


Joined: 15 Jul 2015
Posts: 12

PostPosted: Thu Jul 16, 2015 10:49 am    Post subject: Reply with quote

Aggiornamento:

Ho provato a ricompilare il Kernel ma il problema persiste.
Oltretutto non riesco a trovare la voce VGA_CONSOLE dentro alla sua sezione..visto che sono un pò(parecchio) inesperto con la configurazione del Kernel potrei scaricare un file di configurazione fatto da qualcuno più esperto di me e,successivamente, adattarlo alle mi esigenze.
Anche se non ne ho trovato uno(di .config)fatto bene..
Back to top
View user's profile Send private message
ivanbag
n00b
n00b


Joined: 13 Oct 2013
Posts: 10

PostPosted: Thu Jul 16, 2015 2:37 pm    Post subject: Reply with quote

MarcoPerformance wrote:
Aggiornamento:

Ho provato a ricompilare il Kernel ma il problema persiste.
Oltretutto non riesco a trovare la voce VGA_CONSOLE dentro alla sua sezione..visto che sono un pò(parecchio) inesperto con la configurazione del Kernel potrei scaricare un file di configurazione fatto da qualcuno più esperto di me e,successivamente, adattarlo alle mi esigenze.
Anche se non ne ho trovato uno(di .config)fatto bene..


Potresti provare con genkernel.

Comunque l'importante, come ti hanno detto, è il VIDEO_CARDS="nouveau" nel make.conf.

Ciao
Ivan
_________________
Ho fatto un sogno orribile: c'erano 0 e 1 dappertutto. Ho creduto di aver visto un 2! (Bender)
Back to top
View user's profile Send private message
MarcoPerformance
n00b
n00b


Joined: 15 Jul 2015
Posts: 12

PostPosted: Thu Jul 16, 2015 6:17 pm    Post subject: Reply with quote

Ho provato a ricompilare il kernel per l'ennesima volta cercando di includere tutto ma mantenendo il tutto leggero.
Il problema è che è emerso(moolto stranamente)che non sono molto esperto nella configurazione di un Kernel ad hoc per il mio sistema,in quanto ho notato che oltre alla scheda video ci sono problemi riguardanti la scheda di rete e la scheda audio.
Quindi credo che sia meglio se prima imparo a configurarmi un kernel funzionante e poi lo metta dentro alla cartella /boot di Gentoo,però non vorrei eliminare tutto il sistema installato e buttare via tutte le ore passate a compilare.
E' possibile utilizzare un Kernel precompilato per Gentoo?
Non mi interessa se ne risentiranno le prestazioni oppure il boot durerà qualche secondo in più,vorrei iniziare ad utilizzare portage e,successivamente,potrei tranquillamente installare il nuovo Kernel configurato in base alle mie esigenze.
Il problema è che non trovo Kernel "generici" adatti a qualunque PC,qualche consiglio?

Ho visto che il Kernel del livecd va discretamente bene,non c'è mica modo di esportarlo dentro al sistema appena installato?
Grazie ancora :)
Back to top
View user's profile Send private message
xdarma
l33t
l33t


Joined: 08 Dec 2003
Posts: 682
Location: tra veneto e friuli (italy)

PostPosted: Thu Jul 16, 2015 7:00 pm    Post subject: Reply with quote

MarcoPerformance wrote:
Ho provato a ricompilare il kernel per l'ennesima volta cercando di includere tutto ma mantenendo il tutto leggero.

Delle due l'una: o includi tutto o mantieni leggero.
O se preferisci: "make allyesconfig" è diverso da "make defconfig"

Quote:
Quindi credo che sia meglio se prima imparo a configurarmi un kernel funzionante e poi lo metta dentro alla cartella /boot di Gentoo,però non vorrei eliminare tutto il sistema installato e buttare via tutte le ore passate a compilare.
E' possibile utilizzare un Kernel precompilato per Gentoo?

Tra la documentazione che ti ostini ad ignorare c'è:
Kernel
Kernel/Configuration
Kernel/Gentoo Kernel Configuration Guide
Kernel/Configuration/Kernel Seeds

Quote:
Il problema è che non trovo Kernel "generici" adatti a qualunque PC,qualche consiglio?
Ho visto che il Kernel del livecd va discretamente bene,non c'è mica modo di esportarlo dentro al sistema appena installato?
Grazie ancora :)

Se il kernel è compilato in maniera "fair", genererà il file /proc/config.gz
Se lo leggerai con "zless /proc/config.gz" ti accorgerai che è un file di configurazione del kernel.
Che potrai riciclare per la tua configurazione.
_________________
proud user of faKeDE-4.7.3
Back to top
View user's profile Send private message
sabayonino
l33t
l33t


Joined: 03 Jan 2012
Posts: 670

PostPosted: Thu Jul 16, 2015 9:55 pm    Post subject: Reply with quote

Titolo del topic "Drivers video Nvidia" ..... molto generico

generica sarà pure la risposta

:roll:
_________________
BOINC ed il calcolo distribuito
Back to top
View user's profile Send private message
MarcoPerformance
n00b
n00b


Joined: 15 Jul 2015
Posts: 12

PostPosted: Fri Jul 17, 2015 7:08 pm    Post subject: Reply with quote

Domani riprovo ad applicare i consigli che mi avete dato,in questi giorni non ho avuto tempo.

Quote:
Titolo del topic "Drivers video Nvidia" ..... molto generico

generica sarà pure la risposta


La mia domanda non era generica,ho spiegato tutto quello che la macchina poteva dirmi ossia nulla,visto che lo schermo rimaneva nero.
Ma tanto il problema è la configurazione del kernel,domani proverò a farne un altro(partendo da zero)oppure copiando,momentaneamente,la configurazione di quello del livecd.

:)
Back to top
View user's profile Send private message
Javaskit
n00b
n00b


Joined: 12 Jul 2012
Posts: 30

PostPosted: Sat Jul 18, 2015 7:20 am    Post subject: Reply with quote

MarcoPerformance,

MarcoPerformance wrote:
Ma tanto il problema è la configurazione del kernel


Potresti anche provare ad usare genkernel per configurare il kernel. I dettagli stanno nel capitolo Configurazione del kernel Linux nella sezione Alternativa: Usare genkernel dell'handbook ufficiale.




Java
_________________
"We can scarcely avoid the conclusion that light consists in the transverse undulations of the same medium which is the cause of electric and magnetic phenomena."
Back to top
View user's profile Send private message
MarcoPerformance
n00b
n00b


Joined: 15 Jul 2015
Posts: 12

PostPosted: Sun Jul 19, 2015 4:54 pm    Post subject: Reply with quote

Buonasera a tutti,

Seguendo la documentazione che mi avete linkato ho fatto un Kernel ad Hoc per il mio computer,il quale va senza alcun problema.
L'unico difetto che ho trovato è che non va la rete, mi spiegò meglio:
DHCPD è configurato e funzionante, ma se provò a pingare google mi restituisce : "unknow host www.google.com", a questo punto non pensò che dipenda dal Kernel visto che ho seguito la documentazione senza commettere apparenti errori.
Come è possibile tutto ciò?
Dando ifconfig viene restituito solo l'interfaccia " lo" e nient'altro.

Mi scuso se stò portando questo topic per le lunghe e ringraziò anticipatamente chi mi aiuterá.
Back to top
View user's profile Send private message
Massimog
Apprentice
Apprentice


Joined: 04 Nov 2011
Posts: 152
Location: Osimo(AN)

PostPosted: Wed Jul 22, 2015 8:10 pm    Post subject: Reply with quote

MarcoPerformance wrote:
Buonasera a tutti,

Seguendo la documentazione che mi avete linkato ho fatto un Kernel ad Hoc per il mio computer,il quale va senza alcun problema.
L'unico difetto che ho trovato è che non va la rete, mi spiegò meglio:
DHCPD è configurato e funzionante, ma se provò a pingare google mi restituisce : "unknow host www.google.com", a questo punto non pensò che dipenda dal Kernel visto che ho seguito la documentazione senza commettere apparenti errori.
Come è possibile tutto ciò?
Dando ifconfig viene restituito solo l'interfaccia " lo" e nient'altro.

Mi scuso se stò portando questo topic per le lunghe e ringraziò anticipatamente chi mi aiuterá.

usa networkmanager e non ti complicare la vita https://wiki.gentoo.org/wiki/NetworkManager
_________________
Distribuzione: Gentoo x86_64
Desktop: GNOME 3.30.2
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum