Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
pulseaudio on client
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
mounty1
l33t
l33t


Joined: 06 Jul 2006
Posts: 844
Location: Queensland

PostPosted: Sun Jul 12, 2015 10:19 pm    Post subject: pulseaudio on client Reply with quote

Hello, following the instructions at https://wiki.gentoo.org/wiki/PulseAudio#Headless_server works alright for the server as far as I can tell but when on the client I run
pacmd load-module module-tunnel-sink server=soundserver:
No PulseAudio daemon running, or not running as session daemon.
Is it necessary to enable system-wide on the client as well? The instructions do not say to do so but /usr/lib/systemd/system/pulseaudio.service exists on the server (and systemctl enable pulseaudio works) but on the client, that service file does not exist and
systemctl enable pulseaudio:
Failed to execute operation: No such file or directory
Thanks in expectation of any help.

The situation (use case in amerikanspeak) is that the client is a headless KVM instance running on OmniOS and the server is a Wyse thin client running X. Session startup via XDMCP. Both client and server are running Gentoo.

Could I kindly request that you do not answer unless you are answering the question. Matters such as why I am using PulseAudio, the parentage of Lennart Poettering, comparison with Jack etc. are not of interest. Please start your own thread or use a private message. Thank you.
_________________
Michael Mounteney
Back to top
View user's profile Send private message
davidm
Guru
Guru


Joined: 26 Apr 2009
Posts: 557
Location: US

PostPosted: Mon Jul 13, 2015 12:12 am    Post subject: Reply with quote

Hi, I haven't done it in a while and when I did it was when I was using Arch but I wonder just how complete and up to date those instructions on the wiki are. When I last messed with using pulseaudio over a network I remember have to mess with a special authentication cookie.

You might want to take a look at Arch's documentation -- especially since you also seem to be running systemd. It seems to be more complete.

https://wiki.archlinux.org/index.php/PulseAudio/Configuration



For example I see this:

Quote:

Connection & authentication

Since PulseAudio runs as a daemon as the current user, clients needs to know where to find the daemon socket to connect to it as well as a shared random cookie file clients use to authenticate with it. By default, clients should be able to locate the daemon without problem using environment variables, X11 root window properties and finally by trying the default location (unix:/run/user/$ID/pulse/native). However, if you have clients that needs to access PulseAudio outside of your X11 session like mpd running as a different user, you will need to tell it how to connect to your PulseAudio instance. See PulseAudio/Examples#TODO for a complete example. An authentication cookie containing random bytes is enabled by default to ensure audio does not leak from one user to another on a multi-user system. If you already control who can access the server using user/group permissions, you can disable the cookie by passing auth-cookie-enabled=0 to module-native-protocol-unix.


(Btw, if you find the wiki isn't complete, you can fix it yourself by editing or if you want just let me know what is missing and what worked for you and I will add it to the wiki since I have an account already set up)
Back to top
View user's profile Send private message
mounty1
l33t
l33t


Joined: 06 Jul 2006
Posts: 844
Location: Queensland

PostPosted: Mon Jul 13, 2015 1:10 am    Post subject: Reply with quote

Thanks for the reply. It would be a pity if the wiki, with its statement that this is definitely the right thing to do despite the warnings, is wrong.

I thought the whole point of Pulseaudio was network-transparent sound transport so I don't understand why this is such a black art.
_________________
Michael Mounteney
Back to top
View user's profile Send private message
davidm
Guru
Guru


Joined: 26 Apr 2009
Posts: 557
Location: US

PostPosted: Mon Jul 13, 2015 1:23 am    Post subject: Reply with quote

mounty1 wrote:
Thanks for the reply. It would be a pity if the wiki, with its statement that this is definitely the right thing to do despite the warnings, is wrong.

I thought the whole point of Pulseaudio was network-transparent sound transport so I don't understand why this is such a black art.


I don't believe the network sound capabilities get a lot of use from people. At least I got that sense when I was experimenting with it and going through the documentation.

Also check out this section:

https://wiki.archlinux.org/index.php/PulseAudio/Examples#PulseAudio_over_network

It looks like the Gentoo Wiki is suggesting something like the part "TCP support with anonymous clients" only it appears to be missing the "auth-anonymous=1" portion. (Note: the Gentoo wiki doesn't appear to have many recent edits to that section so I fear it may not be up to date)

The "Zeroconf (Avahi) publishing" option spoken of on the Arch Wiki appears to be the most user friendly way but I'm not sure that is an option at all for your use case.

I'm almost certain that you probably need pulseaudio on the client (of course) as well for it to work but not necessarily the full server system install (on the client). Sorry I cannot help more. It's been a while since I did this and I currently only have one computer so I cannot attempt to set it up myself at the moment.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum