Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problem login to edX Internet site
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
Eagle_
Tux's lil' helper
Tux's lil' helper


Joined: 19 Jun 2004
Posts: 119

PostPosted: Sun Jul 12, 2015 9:03 am    Post subject: Problem login to edX Internet site Reply with quote

Hi To all,

since i reinstall my Gentoo i am facing the problem of unable to login the Internet Site http://www.edx.org (before the reinstall i was able to loging using Firefox)

I tried the following this:
- Tried different Internet Browsers (Firefox\Opera\Chrome)
- Conntact edX support:
We do not technically support Linux so we may not have a solution for you. It does seem there is an issue with the internet settings, security software or browser settings causing this
- Test that my Firefox browser support Java Script
Result:
Your web browser supports JavaScript version 1.5
Your web browser is Firefox version 38.0


What else could block me?

Hope you could help me

Regards
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Sun Jul 12, 2015 9:18 am    Post subject: Reply with quote

Any plugins enabled / installed?

adblocker
java blocker
flash blocker

flash installed?
javascript not blocked?

did you checked those settings? for flash / javascript / security / whatever can be changed in your browser?

Clean home directory?

worth making a new user with a fresh homedirectory and try it there.


did you checked those? usually you need some sort of java thingy, as see below ...
Code:
localhost roman # eselect java-vm list
Available Java Virtual Machines:
  [1]   icedtea-bin-6
  [2]   icedtea-bin-7  system-vm

localhost roman # eselect java-nsplugins list
!!! Error: Can't load module java-nsplugins
exiting
localhost roman # eselect java-nsplugins show
!!! Error: Can't load module java-nsplugins
exiting


funny statement of this homepage

https://www.edx.org/about-us
Quote:
Our goals

Expand access to education for everyone
Enhance teaching and learning on campus and online
Advance teaching and learning through research

Our principles

Nonprofit
Open source platform
Collaborative
Financially sustainable
Back to top
View user's profile Send private message
Eagle_
Tux's lil' helper
Tux's lil' helper


Joined: 19 Jun 2004
Posts: 119

PostPosted: Sun Jul 12, 2015 11:10 am    Post subject: Reply with quote

Ho tw04l124,

thank for your replay.

here is my java-nsplugin output:

Code:
# eselect java-nsplugin list
Available 32-bit Java browser plugins
Available 64-bit Java browser plugins
  [1]   icedtea-web@icedtea-7
  [2]   icedtea-web@icedtea-8  current
  [3]   icedtea-web@icedtea-bin-6



here is my java-vm output:
Code:
# eselect java-vm list
Available Java Virtual Machines:
  [1]   icedtea-7
  [2]   icedtea-8  system-vm
  [3]   icedtea-bin-6


As you suggested, i have created a new account and i am facing the same problems...
By doing this, i have tested my firefox without plugins\blockers and with a clean home directory as you suggested.

As i wrote in my privies post, i have tested for JavaScript and i got that it is active(Your web browser supports JavaScript version 1.5).
Concerning Flash, i need to except activating it.

Regards
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Sun Jul 12, 2015 11:17 am    Post subject: Reply with quote

well no idea whats next but

Code:
eix wireshark
* net-analyzer/wireshark
     Available versions:  1.12.4(0/1.12.4) 1.12.5(0/1.12.5) 1.12.6(0/1.12.6) **1.99.7(0/1.99.7) **99999999(0/99999999) {adns +caps crypt doc doc-pdf +filecaps geoip +gtk3 ipv6 kerberos lua +netlink +pcap portaudio +qt4 qt5 sbc selinux smi ssl zlib CPU_FLAGS_X86="sse4_2"}
     Homepage:            http://www.wireshark.org/
     Description:         A network protocol analyzer formerly known as ethereal


I used etherreal a lot in the past. You may be able to sniff whats go in and out and see if you get a hint.

Turn on the sniffer and check out whats handled. when its https, you may be out of luck.

I told you the obvious ideas anything else needs heavily reading or trying around at the box in question where the error happens.

USE-Flags

binary firefox or firefox build from source with use-flags?
and also check those webkit-gtk and other crap which afaik is needed by those browsers.

Quote:
* net-libs/webkit-gtk
Available versions:
(3) 2.4.8(3/25) 2.4.9(3/25)
(2) 2.4.8-r200 2.4.9-r200
(4) 2.6.5(4/37) 2.6.6(4/37) (~)2.8.3(4/37)
{(+)X aqua coverage debug doc +egl +geoloc gles2 +gstreamer +introspection +jit libsecret +opengl spell test wayland +webgl}
Homepage: http://www.webkitgtk.org/
Description: Open source web browser engine


Quote:
[U] dev-qt/qtwebkit
Available versions:
(4) 4.8.5 4.8.6-r1 (~)4.8.7
(5) (~)5.4.2^mt
{aqua debug +exceptions (+)gstreamer gstreamer010 icu +jit multimedia opengl pch printsupport qml test udev webp ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32"}
Installed versions: 4.8.7(4)(14:36:55 27.05.2015)(exceptions icu jit -aqua -debug -gstreamer -pch ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="32 64 -x32")
Homepage: https://www.qt.io/
Description: WebKit rendering library for the Qt5 framework

...

And also try different Distro. I usually install a backup distro before I install gentoo. So I have e.g. archlinux / linuxmint on any of my boxes and can boot that up and try it from there. to see if its current firefox or screwed up use-flags / settings / config files / cruft in home directory.

I will watch your topic but I can not give you any more useful hints now...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum