Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
missing keyboard keys after xfce upgrade
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
lordalbert
l33t
l33t


Joined: 26 Nov 2006
Posts: 832
Location: Italy

PostPosted: Thu Jul 09, 2015 8:57 pm    Post subject: missing keyboard keys after xfce upgrade Reply with quote

Hi, after upgrading xfce, some keyboard keys don't work! I type them, but it doesn't write/diplay nothing.

The keys are: b, f,m, t

The problem is only when i start xfce. If i type them in terminal (with X don't started), they works. Also, if i use i3wm the works perfectly.

I tryed changing layout in keyboard settings, but the problem is not solved. If i check "use system defaults" under layout tab and then restart, i can write the first missing key. So, for example, the first "m" i type, it is showed. But if i type that key other time, it stop to work.

I'm using "Generic 105 keys" layout, but also if i change it, nothing solved.

Are you any idea how i could solve? Thank you! :)
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Fri Jul 10, 2015 7:10 pm    Post subject: Reply with quote

Quote:
xev - print contents of X events


Well no idea where to start but xev shows those Events, for mouse and keyboards afaik and mayboe more, and than its up to dhe Desktop environment how they are handled...

force a layout with xorg.conf ...

first i would check if every hit generates an event, could be a hardware issue too
Back to top
View user's profile Send private message
lordalbert
l33t
l33t


Joined: 26 Nov 2006
Posts: 832
Location: Italy

PostPosted: Sun Jul 12, 2015 9:13 pm    Post subject: Reply with quote

Ok, when i press a working key, for example "a", xev return me:

Code:

KeyPress event, serial 37, synthetic NO, window 0x2800001,
    root 0x91, subw 0x0, time 671025, (-296,276), root:(415,661),
    state 0x0, keycode 38 (keysym 0x61, a), same_screen YES,
    XLookupString gives 1 bytes: (61) "a"
    XmbLookupString gives 1 bytes: (61) "a"
    XFilterEvent returns: False

KeyRelease event, serial 37, synthetic NO, window 0x2800001,
    root 0x91, subw 0x0, time 671160, (-296,276), root:(415,661),
    state 0x0, keycode 38 (keysym 0x61, a), same_screen YES,
    XLookupString gives 1 bytes: (61) "a"
    XFilterEvent returns: False


now press the "m" key, don't working, xev return me:

Code:

FocusOut event, serial 37, synthetic NO, window 0x2800001,
    mode NotifyGrab, detail NotifyAncestor

FocusIn event, serial 37, synthetic NO, window 0x2800001,
    mode NotifyUngrab, detail NotifyAncestor

KeymapNotify event, serial 37, synthetic NO, window 0x0,
    keys:  87  0   0   0   0   0   0   0   0   0   0   0   0   0   0   0
           0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0




EDIT: I googled and i found the problem: I enabled hotkeys for that letters. Hotkey are: AltGr + {m,f,t,b}. If i set hotkeys with anoter "special key" (for example Ctrl +m ) it works.
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Mon Jul 13, 2015 10:48 am    Post subject: Reply with quote

oh you talked about hotkeys.

they hardly worked for myself

my 6 years old asus notebook has some extra keys which generate weird keycodes which are "unsupported" in my point of view.

only thing that you can remap them to control key and an ordinary letter, thats it.

everything with altgr, function (called fn on keyboard), and such bareley works.
Back to top
View user's profile Send private message
lordalbert
l33t
l33t


Joined: 26 Nov 2006
Posts: 832
Location: Italy

PostPosted: Mon Jul 13, 2015 10:08 pm    Post subject: Reply with quote

they are working unti xfce 4.10.
Now, hotkeys with AltGr stop working. I don't know the reason.... :(
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Tue Jul 14, 2015 9:59 am    Post subject: Reply with quote

well you could narrow it down and than file a bug request.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum