Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
xfce4-power-manager-1.5.2 want upower
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
szczerb
Veteran
Veteran


Joined: 24 Feb 2007
Posts: 1700
Location: Poland => Lodz

PostPosted: Tue Jul 07, 2015 10:19 pm    Post subject: xfce4-power-manager-1.5.2 want upower Reply with quote

I'm trying to update my work laptop after several weeks (or few months?) and got hit by this block:
Code:
[blocks B      ] sys-power/upower ("sys-power/upower" is blocking sys-power/upower-pm-utils-0.9.23-r2)

...

  (sys-power/upower-0.99.2-r1:0/3::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-power/upower-0.99.0 required by (xfce-extra/xfce4-power-manager-1.5.2:0/0::gentoo, ebuild scheduled for merge)

  (sys-power/upower-pm-utils-0.9.23-r2:0/0::gentoo, installed) pulled in by
    sys-power/upower-pm-utils required by (net-misc/networkmanager-1.0.2-r1:0/0::gentoo, ebuild scheduled for merge)
    sys-power/upower-pm-utils required by (xfce-base/xfce4-session-4.12.1:0/0::gentoo, ebuild scheduled for merge)
    sys-power/upower-pm-utils required by (xfce-base/xfce4-settings-4.12.0:0/0::gentoo, ebuild scheduled for merge)
    >=sys-power/upower-pm-utils-0.9.23 required by (net-im/telepathy-mission-control-5.16.3:0/0::gentoo, installed)


Seems sensible since upower-pm-utils should give us a non-systemd upower.

In the build there are hard deps on both upower and pm-utils.
Code:
        >=sys-power/upower-0.99.0
        sys-power/pm-utils


In the 4.12 announcement I clearly see
Quote:
Our session manager was updated to use logind and/or upower if available for hibernate/suspend support. For portability and to respect our users' choices, fallback modes were implemented relying on os-specific backends.
but also
Quote:
Power management was not forgotten: A new panel plugin was created, logind/upower support was added to handle battery/lid/brightness events, and locking via light-locker was implemented. The settings dialog was also revamped, and support for X11 screenblanking was added.


So can I still use the xfce power manager without systemd? Is it just a bug in the ebuild?
Back to top
View user's profile Send private message
schwarzygesetzlos
Tux's lil' helper
Tux's lil' helper


Joined: 11 Dec 2004
Posts: 131
Location: Funeralopolis

PostPosted: Wed Jul 08, 2015 8:19 pm    Post subject: Reply with quote

Any version above xfce-extra/xfce4-power-manager-1.5.0 requires >=sys-power/upower-0.99.0.

The blocking package is in your case net-im/telepathy-mission-control. If you can unmerge it the rest of the system will update properly.

Or you could solve this by masking >=xfce-extra/xfce4-power-manager-1.5.0 in /ets/portage/package.mask. XFCE should run just fine with version 1.4.4.
Back to top
View user's profile Send private message
szczerb
Veteran
Veteran


Joined: 24 Feb 2007
Posts: 1700
Location: Poland => Lodz

PostPosted: Wed Jul 08, 2015 9:37 pm    Post subject: Reply with quote

Thanks for the reply.

To late to start messing with it today. Will check tomorrow after work.

Just one thing - upower has 'inherit eutils systemd' in the ebuild so it'd drag systemd with it? That's really not an option.

If so, then I'm still confused by what was written in the 4.12 announcement.
Back to top
View user's profile Send private message
schwarzygesetzlos
Tux's lil' helper
Tux's lil' helper


Joined: 11 Dec 2004
Posts: 131
Location: Funeralopolis

PostPosted: Wed Jul 08, 2015 10:51 pm    Post subject: Reply with quote

It is not necessary to use systemd for an XFCE 4 install. I had it running with upower/consolekit + openrc.
Back to top
View user's profile Send private message
szczerb
Veteran
Veteran


Joined: 24 Feb 2007
Posts: 1700
Location: Poland => Lodz

PostPosted: Thu Jul 09, 2015 8:30 am    Post subject: Reply with quote

Sure, I'm just wondering about the 1.5 power manager. Since it wants upower. Although the release announcement says that it's optional.
Back to top
View user's profile Send private message
ct85711
Veteran
Veteran


Joined: 27 Sep 2005
Posts: 1691

PostPosted: Thu Jul 09, 2015 9:10 am    Post subject: Reply with quote

Going through the release announcement, it doesn't say anywhere that upower is an optional dependency for power-manager. The release does day upower is an optional dep for xfce4-session and xfce4-settings

Quote:
Xfce 4.12 Changelog

Note: the changelogs shown here are since the version of the components that shipped with Xfce 4.10.
Dependency changes

GTK+ dependency >= 2.24 and GLib >= 2.30.
Garcon has a new libxfce4ui dependency.
Libxfce4ui has an optional dependency on GTK+3.
Libxfce4util major library version was bumped, some symbols were dropped.
Xfce4-panel can be optionally built against GTK+3.
Xfce4-appfinder now uses GDbus instead of dbus-glib, and can be potentially built against GTK+3.
Xfce4-session has an optional dependency on upower.
Xfce4-power-manager has a new dependency on upower, and can build a battery plugin for Xfce4-panel and LXPanel
Xfce4-settings has an optional dependency on libinput Xorg driver and upower.
Xfwm4 has an optional dependency on libdrm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum