Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
elantech touchpad uses evdev instead of synaptics
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Ryba
n00b
n00b


Joined: 24 Dec 2010
Posts: 18

PostPosted: Tue Jul 07, 2015 6:52 pm    Post subject: elantech touchpad uses evdev instead of synaptics Reply with quote

Im trying to configure my touchpad to use synaptics, but no matter what i do i still end up getting something like this:

/var/log/Xorg.0.log:
Code:

[     4.204]
X.Org X Server 1.17.1
Release Date: 2015-02-10
[     4.204] X Protocol Version 11, Revision 0
[     4.204] Build Operating System: Linux 3.13.0-37-generic x86_64 Gentoo
[     4.204] Current Operating System: Linux localhost 4.0.5-gentoo #2 SMP PREEMPT Tue Jul 7 17:39:17 2015 x86_64
[     4.204] Kernel command line: BOOT_IMAGE=/boot/kernel root=/dev/sda3 ro
[     4.204] Build Date: 09 March 2015  07:59:34PM
[     4.204] 
[     4.204] Current version of pixman: 0.32.6
[     4.204]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[     4.204] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[     4.204] (==) Log file: "/var/log/Xorg.0.log", Time: Tue Jul  7 20:20:59 2015
[     4.205] (==) Using config directory: "/etc/X11/xorg.conf.d"
[     4.205] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[     4.206] (==) No Layout section.  Using the first Screen section.
[     4.207] (==) No screen section available. Using defaults.
[     4.207] (**) |-->Screen "Default Screen Section" (0)
[     4.207] (**) |   |-->Monitor "<default monitor>"
[     4.207] (==) No device specified for screen "Default Screen Section".
   Using the first device section listed.
[     4.207] (**) |   |-->Device "nvidia"
[     4.207] (==) No monitor specified for screen "Default Screen Section".
   Using a default monitor configuration.
[     4.207] (==) Automatically adding devices
[     4.207] (==) Automatically enabling devices
[     4.207] (==) Automatically adding GPU devices
[     4.209] (==) FontPath set to:
   /usr/share/fonts/misc/,
   /usr/share/fonts/TTF/,
   /usr/share/fonts/OTF/,
   /usr/share/fonts/Type1/,
   /usr/share/fonts/100dpi/,
   /usr/share/fonts/75dpi/
[     4.209] (**) ModulePath set to "/usr/lib64/opengl/nvidia,/usr/lib64/xorg/modules"
[     4.209] (II) The server relies on udev to provide the list of input devices.
   If no devices become available, reconfigure udev or disable AutoAddDevices.
[     4.209] (II) Loader magic: 0x80dc80
[     4.209] (II) Module ABI versions:
[     4.209]    X.Org ANSI C Emulation: 0.4
[     4.209]    X.Org Video Driver: 19.0
[     4.209]    X.Org XInput driver : 21.0
[     4.209]    X.Org Server Extension : 9.0
[     4.209] (II) xfree86: Adding drm device (/dev/dri/card0)
[     4.210] (--) PCI:*(0:1:0:0) 10de:13d7:1043:22da rev 161, Mem @ 0xec000000/16777216, 0xc0000000/268435456, 0xd0000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x????????/524288
[     4.211] (II) LoadModule: "glx"
[     4.212] (II) Loading /usr/lib64/opengl/nvidia/extensions/libglx.so
[     4.289] (II) Module glx: vendor="NVIDIA Corporation"
[     4.289]    compiled for 4.0.2, module version = 1.0.0
[     4.289]    Module class: X.Org Server Extension
[     4.289] (II) NVIDIA GLX Module  352.21  Tue Jun  9 21:22:54 PDT 2015
[     4.290] (II) LoadModule: "nvidia"
[     4.292] (II) Loading /usr/lib64/xorg/modules/drivers/nvidia_drv.so
[     4.297] (II) Module nvidia: vendor="NVIDIA Corporation"
[     4.297]    compiled for 4.0.2, module version = 1.0.0
[     4.297]    Module class: X.Org Video Driver
[     4.297] (II) NVIDIA dlloader X Driver  352.21  Tue Jun  9 20:58:55 PDT 2015
[     4.297] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[     4.298] (++) using VT number 7

[     4.305] (II) Loading sub module "fb"
[     4.305] (II) LoadModule: "fb"
[     4.305] (II) Loading /usr/lib64/xorg/modules/libfb.so
[     4.306] (II) Module fb: vendor="X.Org Foundation"
[     4.306]    compiled for 1.17.1, module version = 1.0.0
[     4.306]    ABI class: X.Org ANSI C Emulation, version 0.4
[     4.306] (II) Loading sub module "wfb"
[     4.306] (II) LoadModule: "wfb"
[     4.306] (II) Loading /usr/lib64/xorg/modules/libwfb.so
[     4.307] (II) Module wfb: vendor="X.Org Foundation"
[     4.307]    compiled for 1.17.1, module version = 1.0.0
[     4.307]    ABI class: X.Org ANSI C Emulation, version 0.4
[     4.307] (II) Loading sub module "ramdac"
[     4.307] (II) LoadModule: "ramdac"
[     4.307] (II) Module "ramdac" already built-in
[     4.309] (II) NVIDIA(0): Creating default Display subsection in Screen section
   "Default Screen Section" for depth/fbbpp 24/32
[     4.309] (==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
[     4.309] (==) NVIDIA(0): RGB weight 888
[     4.309] (==) NVIDIA(0): Default visual is TrueColor
[     4.309] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[     4.309] (**) NVIDIA(0): Enabling 2D acceleration
[     4.944] (II) NVIDIA: Allocated GPU:0 (GPU-f6b41e2f-28d7-fa99-26b4-c0ff84a38de8) @
[     4.944] (II) NVIDIA:     PCI:0000:01:00.0
[     4.948] (--) NVIDIA(0): Valid display device(s) on GPU-0 at PCI:1:0:0
[     4.948] (--) NVIDIA(0):     CRT-0
[     4.948] (--) NVIDIA(0):     DFP-0
[     4.948] (--) NVIDIA(0):     DFP-1
[     4.948] (--) NVIDIA(0):     DFP-2 (boot)
[     4.948] (--) NVIDIA(0):     DFP-3
[     4.949] (--) NVIDIA(0): CRT-0: disconnected
[     4.949] (--) NVIDIA(0): CRT-0: 400.0 MHz maximum pixel clock
[     4.949] (--) NVIDIA(0):
[     4.949] (--) NVIDIA(0): DFP-0: disconnected
[     4.949] (--) NVIDIA(0): DFP-0: Internal DisplayPort
[     4.949] (--) NVIDIA(0): DFP-0: 960.0 MHz maximum pixel clock
[     4.949] (--) NVIDIA(0):
[     4.949] (--) NVIDIA(0): DFP-1: disconnected
[     4.949] (--) NVIDIA(0): DFP-1: Internal TMDS
[     4.949] (--) NVIDIA(0): DFP-1: 165.0 MHz maximum pixel clock
[     4.949] (--) NVIDIA(0):
[     4.949] (--) NVIDIA(0): DFP-2: disconnected
[     4.949] (--) NVIDIA(0): DFP-2: Internal DisplayPort
[     4.949] (--) NVIDIA(0): DFP-2: 480.0 MHz maximum pixel clock
[     4.949] (--) NVIDIA(0):
[     4.949] (--) NVIDIA(0): DFP-3: disconnected
[     4.949] (--) NVIDIA(0): DFP-3: Internal TMDS
[     4.949] (--) NVIDIA(0): DFP-3: 165.0 MHz maximum pixel clock
[     4.949] (--) NVIDIA(0):
[     4.949] (II) NVIDIA(GPU-0): Found DRM driver nvidia-drm (20150116)
[     4.949] (II) NVIDIA(0): NVIDIA GPU GeForce GTX 980M (GM204-A) at PCI:1:0:0 (GPU-0)
[     4.949] (--) NVIDIA(0): Memory: 4194304 kBytes
[     4.949] (--) NVIDIA(0): VideoBIOS: 84.04.1f.00.46
[     4.949] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[     5.216] (--) NVIDIA(GPU-0): LGD (DFP-2): connected
[     5.216] (--) NVIDIA(GPU-0): LGD (DFP-2): Internal DisplayPort
[     5.216] (--) NVIDIA(GPU-0): LGD (DFP-2): 480.0 MHz maximum pixel clock
[     5.216] (--) NVIDIA(GPU-0):
[     5.216] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
[     5.216] (**) NVIDIA(0):     device LGD (DFP-2) (Using EDID frequencies has been
[     5.216] (**) NVIDIA(0):     enabled on all display devices.)
[     5.217] (==) NVIDIA(0):
[     5.217] (==) NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
[     5.217] (==) NVIDIA(0):     will be used as the requested mode.
[     5.217] (==) NVIDIA(0):
[     5.217] (II) NVIDIA(0): Validated MetaModes:
[     5.217] (II) NVIDIA(0):     "DFP-2:nvidia-auto-select"
[     5.217] (II) NVIDIA(0): Virtual screen size determined to be 1920 x 1080
[     5.220] (--) NVIDIA(0): DPI set to (128, 130); computed from "UseEdidDpi" X config
[     5.220] (--) NVIDIA(0):     option
[     5.220] (--) Depth 24 pixmap format is 32 bpp
[     5.220] (II) NVIDIA: Using 3072.00 MB of virtual memory for indirect memory
[     5.220] (II) NVIDIA:     access.
[     5.237] (II) NVIDIA(0): ACPI: failed to connect to the ACPI event daemon; the daemon
[     5.237] (II) NVIDIA(0):     may not be running or the "AcpidSocketPath" X
[     5.237] (II) NVIDIA(0):     configuration option may not be set correctly.  When the
[     5.237] (II) NVIDIA(0):     ACPI event daemon is available, the NVIDIA X driver will
[     5.237] (II) NVIDIA(0):     try to use it to receive ACPI event notifications.  For
[     5.237] (II) NVIDIA(0):     details, please see the "ConnectToAcpid" and
[     5.237] (II) NVIDIA(0):     "AcpidSocketPath" X configuration options in Appendix B: X
[     5.237] (II) NVIDIA(0):     Config Options in the README.
[     5.306] (II) NVIDIA(0): Setting mode "DFP-2:nvidia-auto-select"
[     6.442] (==) NVIDIA(0): Disabling shared memory pixmaps
[     6.442] (==) NVIDIA(0): Backing store enabled
[     6.442] (==) NVIDIA(0): Silken mouse enabled
[     6.443] (==) NVIDIA(0): DPMS enabled
[     6.443] (II) Loading sub module "dri2"
[     6.443] (II) LoadModule: "dri2"
[     6.443] (II) Module "dri2" already built-in
[     6.443] (II) NVIDIA(0): [DRI2] Setup complete
[     6.443] (II) NVIDIA(0): [DRI2]   VDPAU driver: nvidia
[     6.444] (--) RandR disabled
[     6.444] (II) Initializing extension GLX
[     6.444] (II) Indirect GLX disabled.(II) config/udev: Adding input device Power Button (/dev/input/event2)
[     6.535] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[     6.535] (**) Power Button: Applying InputClass "Keyboard1"
[     6.535] (II) LoadModule: "evdev"
[     6.535] (II) Loading /usr/lib64/xorg/modules/input/evdev_drv.so
[     6.536] (II) Module evdev: vendor="X.Org Foundation"
[     6.536]    compiled for 1.17.1, module version = 2.9.2
[     6.536]    Module class: X.Org XInput Driver
[     6.536]    ABI class: X.Org XInput driver, version 21.0
[     6.536] (II) Using input driver 'evdev' for 'Power Button'
[     6.536] (**) Power Button: always reports core events
[     6.536] (**) evdev: Power Button: Device: "/dev/input/event2"
[     6.536] (--) evdev: Power Button: Vendor 0 Product 0x1
[     6.536] (--) evdev: Power Button: Found keys
[     6.536] (II) evdev: Power Button: Configuring as keyboard
[     6.536] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input2/event2"
[     6.536] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
[     6.536] (**) Option "xkb_rules" "evdev"
[     6.536] (**) Option "xkb_model" "asus-laptop"
[     6.536] (**) Option "xkb_layout" "pl"
[     6.548] (II) config/udev: Adding input device Video Bus (/dev/input/event3)
[     6.548] (**) Video Bus: Applying InputClass "evdev keyboard catchall"
[     6.548] (**) Video Bus: Applying InputClass "Keyboard1"
[     6.548] (II) Using input driver 'evdev' for 'Video Bus'
[     6.548] (**) Video Bus: always reports core events
[     6.548] (**) evdev: Video Bus: Device: "/dev/input/event3"
[     6.548] (--) evdev: Video Bus: Vendor 0 Product 0x6
[     6.548] (--) evdev: Video Bus: Found keys
[     6.548] (II) evdev: Video Bus: Configuring as keyboard
[     6.548] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:60/LNXVIDEO:00/input/input3/event3"
[     6.548] (II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD, id 7)
[     6.548] (**) Option "xkb_rules" "evdev"
[     6.548] (**) Option "xkb_model" "asus-laptop"
[     6.549] (**) Option "xkb_layout" "pl"
[     6.549] (II) config/udev: Adding input device Lid Switch (/dev/input/event0)
[     6.549] (**) Lid Switch: Applying InputClass "Keyboard1"
[     6.549] (II) Using input driver 'evdev' for 'Lid Switch'
[     6.549] (**) Lid Switch: always reports core events
[     6.549] (**) evdev: Lid Switch: Device: "/dev/input/event0"
[     6.549] (--) evdev: Lid Switch: Vendor 0 Product 0x5
[     6.549] (WW) evdev: Lid Switch: Don't know how to use device
[     6.564] (EE) PreInit returned 8 for "Lid Switch"
[     6.564] (II) UnloadModule: "evdev"
[     6.564] (II) config/udev: Adding input device Sleep Button (/dev/input/event1)
[     6.564] (**) Sleep Button: Applying InputClass "evdev keyboard catchall"
[     6.564] (**) Sleep Button: Applying InputClass "Keyboard1"
[     6.564] (II) Using input driver 'evdev' for 'Sleep Button'
[     6.564] (**) Sleep Button: always reports core events
[     6.564] (**) evdev: Sleep Button: Device: "/dev/input/event1"
[     6.564] (--) evdev: Sleep Button: Vendor 0 Product 0x3
[     6.564] (--) evdev: Sleep Button: Found keys
[     6.564] (II) evdev: Sleep Button: Configuring as keyboard
[     6.564] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0E:00/input/input1/event1"
[     6.564] (II) XINPUT: Adding extended input device "Sleep Button" (type: KEYBOARD, id 8)
[     6.564] (**) Option "xkb_rules" "evdev"
[     6.564] (**) Option "xkb_model" "asus-laptop"
[     6.564] (**) Option "xkb_layout" "pl"
[     6.565] (II) config/udev: Adding input device HDA NVidia HDMI (/dev/input/event6)
[     6.565] (**) HDA NVidia HDMI: Applying InputClass "Keyboard1"
[     6.565] (II) Using input driver 'evdev' for 'HDA NVidia HDMI'
[     6.565] (**) HDA NVidia HDMI: always reports core events
[     6.565] (**) evdev: HDA NVidia HDMI: Device: "/dev/input/event6"
[     6.565] (--) evdev: HDA NVidia HDMI: Vendor 0 Product 0
[     6.565] (WW) evdev: HDA NVidia HDMI: Don't know how to use device
[     6.579] (EE) PreInit returned 8 for "HDA NVidia HDMI"
[     6.579] (II) UnloadModule: "evdev"
[     6.579] (II) config/udev: Adding input device HDA NVidia HDMI (/dev/input/event7)
[     6.579] (**) HDA NVidia HDMI: Applying InputClass "Keyboard1"
[     6.579] (II) Using input driver 'evdev' for 'HDA NVidia HDMI'
[     6.579] (**) HDA NVidia HDMI: always reports core events
[     6.579] (**) evdev: HDA NVidia HDMI: Device: "/dev/input/event7"
[     6.579] (--) evdev: HDA NVidia HDMI: Vendor 0 Product 0
[     6.579] (WW) evdev: HDA NVidia HDMI: Don't know how to use device
[     6.591] (EE) PreInit returned 8 for "HDA NVidia HDMI"
[     6.591] (II) UnloadModule: "evdev"
[     6.591] (II) config/udev: Adding input device HDA Intel PCH Mic (/dev/input/event4)
[     6.591] (**) HDA Intel PCH Mic: Applying InputClass "Keyboard1"
[     6.591] (II) Using input driver 'evdev' for 'HDA Intel PCH Mic'
[     6.591] (**) HDA Intel PCH Mic: always reports core events
[     6.591] (**) evdev: HDA Intel PCH Mic: Device: "/dev/input/event4"
[     6.591] (--) evdev: HDA Intel PCH Mic: Vendor 0 Product 0
[     6.591] (WW) evdev: HDA Intel PCH Mic: Don't know how to use device
[     6.603] (EE) PreInit returned 8 for "HDA Intel PCH Mic"
[     6.603] (II) UnloadModule: "evdev"
[     6.603] (II) config/udev: Adding input device HDA Intel PCH Line Out (/dev/input/event5)
[     6.603] (**) HDA Intel PCH Line Out: Applying InputClass "Keyboard1"
[     6.603] (II) Using input driver 'evdev' for 'HDA Intel PCH Line Out'
[     6.603] (**) HDA Intel PCH Line Out: always reports core events
[     6.603] (**) evdev: HDA Intel PCH Line Out: Device: "/dev/input/event5"
[     6.603] (--) evdev: HDA Intel PCH Line Out: Vendor 0 Product 0
[     6.603] (WW) evdev: HDA Intel PCH Line Out: Don't know how to use device
[     6.615] (EE) PreInit returned 8 for "HDA Intel PCH Line Out"
[     6.615] (II) UnloadModule: "evdev"
[     6.615] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event10)
[     6.615] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
[     6.615] (**) AT Translated Set 2 keyboard: Applying InputClass "Keyboard1"
[     6.615] (II) Using input driver 'evdev' for 'AT Translated Set 2 keyboard'
[     6.615] (**) AT Translated Set 2 keyboard: always reports core events
[     6.615] (**) evdev: AT Translated Set 2 keyboard: Device: "/dev/input/event10"
[     6.615] (--) evdev: AT Translated Set 2 keyboard: Vendor 0x1 Product 0x1
[     6.615] (--) evdev: AT Translated Set 2 keyboard: Found keys
[     6.615] (II) evdev: AT Translated Set 2 keyboard: Configuring as keyboard
[     6.615] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio0/input/input10/event10"
[     6.615] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD, id 9)
[     6.615] (**) Option "xkb_rules" "evdev"
[     6.615] (**) Option "xkb_model" "asus-laptop"
[     6.615] (**) Option "xkb_layout" "pl"
[     6.616] (II) config/udev: Adding input device ETPS/2 Elantech Touchpad (/dev/input/event12)
[     6.616] (**) ETPS/2 Elantech Touchpad: Applying InputClass "touchpad catchall"
[     6.616] (**) ETPS/2 Elantech Touchpad: Applying InputClass "Default clickpad buttons"
[     6.616] (**) ETPS/2 Elantech Touchpad: Applying InputClass "touchpad catchall synaptics"
[     6.616] (**) ETPS/2 Elantech Touchpad: Applying InputClass "Keyboard1"
[     6.616] (II) Using input driver 'evdev' for 'ETPS/2 Elantech Touchpad'
[     6.616] (**) ETPS/2 Elantech Touchpad: always reports core events
[     6.616] (**) evdev: ETPS/2 Elantech Touchpad: Device: "/dev/input/event12"
[     6.616] (--) evdev: ETPS/2 Elantech Touchpad: Vendor 0x2 Product 0xe
[     6.616] (--) evdev: ETPS/2 Elantech Touchpad: Found 3 mouse buttons
[     6.616] (--) evdev: ETPS/2 Elantech Touchpad: Found absolute axes
[     6.616] (--) evdev: ETPS/2 Elantech Touchpad: Found absolute multitouch axes
[     6.616] (--) evdev: ETPS/2 Elantech Touchpad: Found x and y absolute axes
[     6.616] (--) evdev: ETPS/2 Elantech Touchpad: Found absolute touchpad.
[     6.616] (II) evdev: ETPS/2 Elantech Touchpad: Configuring as touchpad
[     6.616] (**) evdev: ETPS/2 Elantech Touchpad: YAxisMapping: buttons 4 and 5
[     6.616] (**) evdev: ETPS/2 Elantech Touchpad: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[     6.616] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio4/input/input19/event12"
[     6.616] (II) XINPUT: Adding extended input device "ETPS/2 Elantech Touchpad" (type: TOUCHPAD, id 10)
[     6.616] (II) evdev: ETPS/2 Elantech Touchpad: initialized for absolute axes.
[     6.616] (**) ETPS/2 Elantech Touchpad: (accel) keeping acceleration scheme 1
[     6.616] (**) ETPS/2 Elantech Touchpad: (accel) acceleration profile 0
[     6.616] (**) ETPS/2 Elantech Touchpad: (accel) acceleration factor: 2.000
[     6.616] (**) ETPS/2 Elantech Touchpad: (accel) acceleration threshold: 4
[     6.616] (II) config/udev: Adding input device ETPS/2 Elantech Touchpad (/dev/input/mouse1)
[     6.616] (**) ETPS/2 Elantech Touchpad: Ignoring device from InputClass "touchpad ignore duplicates"
[    12.338] (--) NVIDIA(GPU-0): CRT-0: disconnected
[    12.338] (--) NVIDIA(GPU-0): CRT-0: 400.0 MHz maximum pixel clock
[    12.338] (--) NVIDIA(GPU-0):
[    12.338] (--) NVIDIA(GPU-0): DFP-0: disconnected
[    12.338] (--) NVIDIA(GPU-0): DFP-0: Internal DisplayPort
[    12.338] (--) NVIDIA(GPU-0): DFP-0: 960.0 MHz maximum pixel clock
[    12.338] (--) NVIDIA(GPU-0):
[    12.338] (--) NVIDIA(GPU-0): DFP-1: disconnected
[    12.338] (--) NVIDIA(GPU-0): DFP-1: Internal TMDS
[    12.338] (--) NVIDIA(GPU-0): DFP-1: 330.0 MHz maximum pixel clock
[    12.338] (--) NVIDIA(GPU-0):
[    12.338] (--) NVIDIA(GPU-0): LGD (DFP-2): connected
[    12.338] (--) NVIDIA(GPU-0): LGD (DFP-2): Internal DisplayPort
[    12.338] (--) NVIDIA(GPU-0): LGD (DFP-2): 480.0 MHz maximum pixel clock
[    12.338] (--) NVIDIA(GPU-0):
[    12.338] (--) NVIDIA(GPU-0): DFP-3: disconnected
[    12.338] (--) NVIDIA(GPU-0): DFP-3: Internal TMDS
[    12.338] (--) NVIDIA(GPU-0): DFP-3: 330.0 MHz maximum pixel clock
[    12.338] (--) NVIDIA(GPU-0):
[    12.634] (--) NVIDIA(GPU-0): CRT-0: disconnected
[    12.634] (--) NVIDIA(GPU-0): CRT-0: 400.0 MHz maximum pixel clock
[    12.634] (--) NVIDIA(GPU-0):
[    12.634] (--) NVIDIA(GPU-0): DFP-0: disconnected
[    12.634] (--) NVIDIA(GPU-0): DFP-0: Internal DisplayPort
[    12.634] (--) NVIDIA(GPU-0): DFP-0: 960.0 MHz maximum pixel clock
[    12.634] (--) NVIDIA(GPU-0):
[    12.634] (--) NVIDIA(GPU-0): DFP-1: disconnected
[    12.634] (--) NVIDIA(GPU-0): DFP-1: Internal TMDS
[    12.634] (--) NVIDIA(GPU-0): DFP-1: 330.0 MHz maximum pixel clock
[    12.634] (--) NVIDIA(GPU-0):
[    12.635] (--) NVIDIA(GPU-0): LGD (DFP-2): connected
[    12.635] (--) NVIDIA(GPU-0): LGD (DFP-2): Internal DisplayPort
[    12.635] (--) NVIDIA(GPU-0): LGD (DFP-2): 480.0 MHz maximum pixel clock
[    12.635] (--) NVIDIA(GPU-0):
[    12.635] (--) NVIDIA(GPU-0): DFP-3: disconnected
[    12.635] (--) NVIDIA(GPU-0): DFP-3: Internal TMDS
[    12.635] (--) NVIDIA(GPU-0): DFP-3: 330.0 MHz maximum pixel clock
[    12.635] (--) NVIDIA(GPU-0):
[    22.119] (II) config/udev: Adding input device Logitech USB Receiver (/dev/input/mouse0)
[    22.119] (**) Logitech USB Receiver: Applying InputClass "Keyboard1"
[    22.119] (II) Using input driver 'evdev' for 'Logitech USB Receiver'
[    22.119] (**) Logitech USB Receiver: always reports core events
[    22.119] (**) evdev: Logitech USB Receiver: Device: "/dev/input/mouse0"
[    22.119] (EE) evdev: Logitech USB Receiver: Unable to query fd: Inappropriate ioctl for device
[    22.143] (EE) PreInit returned 2 for "Logitech USB Receiver"
[    22.143] (II) UnloadModule: "evdev"
[    22.143] (II) config/udev: Adding input device ASUS ASUS ROG Macrokey (/dev/input/event11)
[    22.143] (**) ASUS ASUS ROG Macrokey: Applying InputClass "evdev keyboard catchall"
[    22.143] (**) ASUS ASUS ROG Macrokey: Applying InputClass "Keyboard1"
[    22.143] (II) Using input driver 'evdev' for 'ASUS ASUS ROG Macrokey'
[    22.143] (**) ASUS ASUS ROG Macrokey: always reports core events
[    22.143] (**) evdev: ASUS ASUS ROG Macrokey: Device: "/dev/input/event11"
[    22.143] (--) evdev: ASUS ASUS ROG Macrokey: Vendor 0xb05 Product 0x17fd
[    22.143] (--) evdev: ASUS ASUS ROG Macrokey: Found keys
[    22.143] (II) evdev: ASUS ASUS ROG Macrokey: Configuring as keyboard
[    22.143] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:14.0/usb1/1-10/1-10:1.0/0003:0B05:17FD.0004/input/input12/event11"
[    22.143] (II) XINPUT: Adding extended input device "ASUS ASUS ROG Macrokey" (type: KEYBOARD, id 11)
[    22.143] (**) Option "xkb_rules" "evdev"
[    22.143] (**) Option "xkb_model" "asus-laptop"
[    22.143] (**) Option "xkb_layout" "pl"
[    22.158] (II) config/udev: Adding input device Logitech USB Receiver (/dev/input/event8)
[    22.158] (**) Logitech USB Receiver: Applying InputClass "evdev keyboard catchall"
[    22.158] (**) Logitech USB Receiver: Applying InputClass "Keyboard1"
[    22.158] (II) Using input driver 'evdev' for 'Logitech USB Receiver'
[    22.158] (**) Logitech USB Receiver: always reports core events
[    22.158] (**) evdev: Logitech USB Receiver: Device: "/dev/input/event8"
[    22.158] (--) evdev: Logitech USB Receiver: Vendor 0x46d Product 0xc52b
[    22.158] (--) evdev: Logitech USB Receiver: Found keys
[    22.158] (II) evdev: Logitech USB Receiver: Configuring as keyboard
[    22.158] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:14.0/usb1/1-3/1-3:1.0/0003:046D:C52B.0001/input/input8/event8"
[    22.158] (II) XINPUT: Adding extended input device "Logitech USB Receiver" (type: KEYBOARD, id 12)
[    22.158] (**) Option "xkb_rules" "evdev"
[    22.158] (**) Option "xkb_model" "asus-laptop"
[    22.158] (**) Option "xkb_layout" "pl"
[    22.163] (II) config/udev: Adding input device Logitech USB Receiver (/dev/input/event9)
[    22.163] (**) Logitech USB Receiver: Applying InputClass "evdev pointer catchall"
[    22.163] (**) Logitech USB Receiver: Applying InputClass "evdev keyboard catchall"
[    22.163] (**) Logitech USB Receiver: Applying InputClass "Keyboard1"
[    22.163] (II) Using input driver 'evdev' for 'Logitech USB Receiver'
[    22.163] (**) Logitech USB Receiver: always reports core events
[    22.163] (**) evdev: Logitech USB Receiver: Device: "/dev/input/event9"
[    22.163] (--) evdev: Logitech USB Receiver: Vendor 0x46d Product 0xc52b
[    22.163] (--) evdev: Logitech USB Receiver: Found 20 mouse buttons
[    22.163] (--) evdev: Logitech USB Receiver: Found scroll wheel(s)
[    22.163] (--) evdev: Logitech USB Receiver: Found relative axes
[    22.163] (--) evdev: Logitech USB Receiver: Found x and y relative axes
[    22.163] (--) evdev: Logitech USB Receiver: Found absolute axes
[    22.163] (II) evdev: Logitech USB Receiver: Forcing absolute x/y axes to exist.
[    22.163] (--) evdev: Logitech USB Receiver: Found keys
[    22.163] (II) evdev: Logitech USB Receiver: Configuring as mouse
[    22.163] (II) evdev: Logitech USB Receiver: Configuring as keyboard
[    22.163] (II) evdev: Logitech USB Receiver: Adding scrollwheel support
[    22.163] (**) evdev: Logitech USB Receiver: YAxisMapping: buttons 4 and 5
[    22.163] (**) evdev: Logitech USB Receiver: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[    22.163] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:14.0/usb1/1-3/1-3:1.1/0003:046D:C52B.0002/input/input9/event9"
[    22.163] (II) XINPUT: Adding extended input device "Logitech USB Receiver" (type: KEYBOARD, id 13)
[    22.163] (**) Option "xkb_rules" "evdev"
[    22.163] (**) Option "xkb_model" "asus-laptop"
[    22.163] (**) Option "xkb_layout" "pl"
[    22.163] (II) evdev: Logitech USB Receiver: initialized for relative axes.
[    22.163] (WW) evdev: Logitech USB Receiver: ignoring absolute axes.
[    22.163] (**) Logitech USB Receiver: (accel) keeping acceleration scheme 1
[    22.163] (**) Logitech USB Receiver: (accel) acceleration profile 0
[    22.163] (**) Logitech USB Receiver: (accel) acceleration factor: 2.000
[    22.163] (**) Logitech USB Receiver: (accel) acceleration threshold: 4

Which makes my touchpad not work (only buttons work)

Here is my setup and configuration:

xinput -list
Code:

⎡ Virtual core pointer                       id=2   [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                 id=4   [slave  pointer  (2)]
⎜   ↳ ETPS/2 Elantech Touchpad                   id=10   [slave  pointer  (2)]
⎜   ↳ Logitech USB Receiver                      id=13   [slave  pointer  (2)]
⎣ Virtual core keyboard                      id=3   [master keyboard (2)]
    ↳ Virtual core XTEST keyboard                id=5   [slave  keyboard (3)]
    ↳ Power Button                               id=6   [slave  keyboard (3)]
    ↳ Video Bus                                  id=7   [slave  keyboard (3)]
    ↳ Sleep Button                               id=8   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard               id=9   [slave  keyboard (3)]
    ↳ ASUS ASUS ROG Macrokey                     id=11   [slave  keyboard (3)]
    ↳ Logitech USB Receiver                      id=12   [slave  keyboard (3)]


/etc/X11/xorg.conf.d/1-synaptics.conf
Code:

#Section "Module"
#   Identifier "load synaptics"
#   Load "synaptics"
#EndSection

Section "InputClass"
   Identifier "touchpad catchall synaptics"
   Driver "synaptics"
   MatchIsTouchpad "on"
   MatchDevicePath "/dev/input/event12"
EndSection

Section "InputClass"
        Identifier "touchpad ignore duplicates"
        MatchIsTouchpad "on"
        MatchOS "Linux"
        MatchDevicePath "/dev/input/mouse*"
        Option "Ignore" "on"
EndSection


/etc/X11/xorg.conf.d/99keyboard.conf
Code:

Section "InputClass"
   Identifier "Keyboard1"
   Driver "evdev"
   Option "XkbLayout" "pl"
   Option "XkbModel" "asus-laptop"
EndSection
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2583

PostPosted: Wed Jul 08, 2015 6:13 am    Post subject: Reply with quote

What about your setting for INPUT_DEVICES and Kernel options?

For comparison (why do you think you need two sections "InputClass"?):
Code:
$ cat /etc/X11/xorg.conf.d/synaptics.conf
Section "InputClass"
        Identifier "touchpad catchall"
        Driver "synaptics"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"


        Option "VertEdgeScroll" "on"
        Option "TapButton1" "1"
EndSection
Back to top
View user's profile Send private message
MarioCorleone
Guru
Guru


Joined: 29 Jun 2003
Posts: 327

PostPosted: Wed Jul 08, 2015 8:07 am    Post subject: Reply with quote

What modlules do you have loaded? lsmod

Have you tried synaptiks?
_________________
-Mario
Back to top
View user's profile Send private message
Ryba
n00b
n00b


Joined: 24 Dec 2010
Posts: 18

PostPosted: Wed Jul 08, 2015 4:40 pm    Post subject: Reply with quote

INPUT_DEVICES="synaptics evdev"

lsmod:
Code:

Module                  Size  Used by
btusb                  28345  0
nvidia               8507049  60
psmouse                95658  0
atkbd                  15822  0
x86_pkg_temp_thermal     4591  0
iwlmvm                170510  0
libps2                  4155  2 atkbd,psmouse
iwlwifi                97882  1 iwlmvm

kernel .config:
http://pastebin.com/yaxXesdB

Quote:
Have you tried synaptiks?


won't work because:
Code:

synclient -l
Couldn't find synaptics properties. No synaptics driver loaded?


Quote:

For comparison (why do you think you need two sections "InputClass"?):


I don't. I tried every combination of every seemingly relevant solution i've found on the internet. "touchpad ignore duplicates" is just a leftover i forgot to remove.
Back to top
View user's profile Send private message
Fitap
Apprentice
Apprentice


Joined: 13 Mar 2011
Posts: 210
Location: Rosario, Argentina

PostPosted: Sun Nov 15, 2015 7:46 pm    Post subject: Reply with quote

I have the same issue with synaptics, I can notice me because the behavior of touchpad without touch them, just only watch a movie or scroll up in a terminal, the pointer mouse appears/get in focus in movies player and in the terminal screen scroll going down without I do anything.

Here is the output of Xorg.log

Code:


fitap@gentoo-Asus-k52f ~ $ tail /var/log/Xorg.0.log

[    33.530] (EE) synaptics: ETPS/2 Elantech Touchpad: Synaptics driver unable to detect protocol
[    33.530] (EE) PreInit returned 11 for "ETPS/2 Elantech Touchpad"
[    33.530] (II) UnloadModule: "synaptics"
[    33.530] (II) config/udev: Adding input device PC Speaker (/dev/input/event6)
[    33.530] (II) No input driver specified, ignoring this device.
[    33.530] (II) This device may have been added with another device file.
[    54.034] (II) intel(0): EDID vendor "CMO", prod id 5523
[    54.034] (II) intel(0): Printing DDC gathered Modelines:
[    54.034] (II) intel(0): Modeline "1366x768"x0.0   69.30  1366 1382 1416 1466  768 770 776 788 -hsync -vsync (47.3 kHz eP)
[  2409.526] (II) intel(0): switch to mode 1366x768@60.0 on LVDS1 using pipe 0, position (0, 0), rotation normal, reflection none




My xorg config is located by default at /usr/share/X11/xorg.conf.d I don't know if must create into etc directory.

Code:


fitap@gentoo-Asus-k52f /usr/share/X11/xorg.conf.d $ cat 50-synaptics.conf

Section "InputClass"
        Identifier                    "touchpad catchall"
        Driver                        "synaptics"
        MatchIsTouchpad               "on"
        Option "SHMConfig"            "false"
        Option "LeftEdge"             "0"
        Option "TopEdge"              "0"
        Option "RightEdge"            "1200"
        Option "BottomEdge"           "700"
        Option "VertEdgeScroll"       "true"
        Option "HorizEdgeScroll"      "true"
        Option "VertTwoFingerScroll"  "false"
        Option "HorizTwoFingerScroll" "false"
        Option "CircularScrolling"    "false"
        Option "VertScrollDelta"      "40"
        Option "HorizScrollDelta"     "40"
        Option "MaxTapMove"           "220"
        Option "FingerLow"            "25"
        Option "FingerHigh"           "30"
        Option "MaxTapTime"           "180"
        Option "MinSpeed"             "0.48"
        Option "MaxSpeed"             "1.00"
        Option "AccelFactor"          "0.010"
        Option "TapButton1"           "1"
        Option "ConstantDPI"          "True"
        Option "DPI"                  "96,0 x 96,0"
EndSection



Here you are the kernel setup

Code:


fitap@gentoo-Asus-k52f ~ $ cat /usr/src/linux/.config | grep PS2

CONFIG_MOUSE_PS2=y
CONFIG_MOUSE_PS2_ALPS=y
CONFIG_MOUSE_PS2_LOGIPS2PP=y
CONFIG_MOUSE_PS2_SYNAPTICS=y
CONFIG_MOUSE_PS2_CYPRESS=y
CONFIG_MOUSE_PS2_LIFEBOOK=y
CONFIG_MOUSE_PS2_TRACKPOINT=y
CONFIG_MOUSE_PS2_ELANTECH=y
CONFIG_MOUSE_PS2_SENTELIC=y
CONFIG_MOUSE_PS2_TOUCHKIT=y
CONFIG_MOUSE_PS2_FOCALTECH=y
CONFIG_SERIO_PCIPS2=m
CONFIG_SERIO_LIBPS2=y
# CONFIG_SERIO_ALTERA_PS2 is not set
# CONFIG_SERIO_PS2MULT is not set
# CONFIG_SERIO_ARC_PS2 is not set



And here the output of xinput

Code:


fitap@gentoo-Asus-k52f ~ $ xinput

⎡ Virtual core pointer                       id=2   [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                 id=4   [slave  pointer  (2)]
⎜   ↳ ETPS/2 Elantech Touchpad                   id=11   [slave  pointer  (2)]
⎣ Virtual core keyboard                      id=3   [master keyboard (2)]
    ↳ Virtual core XTEST keyboard                id=5   [slave  keyboard (3)]
    ↳ Power Button                               id=6   [slave  keyboard (3)]
    ↳ Video Bus                                  id=7   [slave  keyboard (3)]
    ↳ Sleep Button                               id=8   [slave  keyboard (3)]
    ↳ Asus Laptop extra buttons                  id=9   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard               id=10   [slave  keyboard (3)]



Sorry for my english and best regards.
Back to top
View user's profile Send private message
Fitzcarraldo
Veteran
Veteran


Joined: 30 Aug 2008
Posts: 1635
Location: United Kingdom

PostPosted: Mon Nov 16, 2015 8:52 am    Post subject: Reply with quote

Ryba, have you checked if any of the xorg.conf files in /usr/share/X11/xorg.conf.d/ are causing the problem?
Code:
$ locate xorg.conf.d
/etc/X11/xorg.conf.d
/etc/X11/xorg.conf.d/10-evdev.conf
/etc/X11/xorg.conf.d/30-keyboard.conf
/etc/X11/xorg.conf.d/50-synaptics.conf
/usr/share/X11/xorg.conf.d
/usr/share/X11/xorg.conf.d/10-evdev.conf
/usr/share/X11/xorg.conf.d/10-quirks.conf
/usr/share/X11/xorg.conf.d/50-nvidia-drm-outputclass.conf
/usr/share/X11/xorg.conf.d/50-synaptics.conf
/usr/share/man/man5/xorg.conf.d.5

I had some trouble with those files in the past: Fixing unperceived errors in my X Windows configuration.
_________________
Clevo W230SS: amd64 OpenRC elogind nvidia-drivers & xf86-video-intel.
Compal NBLB2: ~amd64 OpenRC elogind xf86-video-ati. Dual boot Win 7 Pro 64-bit.
KDE on both.

Fitzcarraldo's blog
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum