Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
kdelibs-4.14.* failing (compile hanging) with qt-4.8.7
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Mon Jul 06, 2015 4:01 am    Post subject: kdelibs-4.14.* failing (compile hanging) with qt-4.8.7 Reply with quote

Hi guys,


the compilation is hanging for a pretty long time

at

Quote:
"KConfigIni: In file /var/tmp/portage/kde-base/kdelibs-4.14.9/homedir/.kde4/share/config/kio_help4rc, line 2: " Invalid entry (empty key)
kio_help4(30138): ""CurrencySuspendedDate" - conversion of "" to QDate failed" " (wrong format: expected 3 items, got 1)"
kio_help4(30138): ""CurrencyWithdrawnDate" - conversion of "" to QDate failed" " (wrong format: expected 3 items, got 1)"
kio_help4(30138): ""CurrencySuspendedDate" - conversion of "" to QDate failed" " (wrong format: expected 3 items, got 1)"
kio_help4(30138): ""CurrencyWithdrawnDate" - conversion of "" to QDate failed" " (wrong format: expected 3 items, got 1)"


and I doubt that it will succeed,

since it's hot here - I left the compilation only for around 30 minutes and it stayed there :(


Any idea how to "fix" it ?
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
i4dnf
Apprentice
Apprentice


Joined: 18 Sep 2005
Posts: 265
Location: Bucharest, Romania

PostPosted: Mon Jul 06, 2015 8:57 am    Post subject: Reply with quote

Hmm, it built fine over here, with my dev-qt/qtcore-4.8.7 having the following use settings:
Code:
exceptions glib iconv pch qt3support ssl -aqua -debug -icu

_________________
"The only difference between me and a madman is that I am not MAD" (SALVATOR DALI)
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Tue Jul 07, 2015 11:59 am    Post subject: Reply with quote

Thanks, i4dnf,

it worked before but I adapted my use-flags and it is still failing


I took a look at

/var/tmp/portage/kde-base/kdelibs-4.14.9/homedir/.kde4/share/config/kio_help4rc

and it, indeed,

has some strange content:

Code:
[Locale]
=
FracDigits=


then I found out that

Code:
eselect locale


wasn't set - that shouldn't be a problem since I had set up

/etc/env.d/02locale

a long time ago during installation of this Gentoo installation - but there were also issues

not sure how that suddenly did happen :lol:


So I set it via eselect locale

and then manually modified it.


Hopefully it compiles fine now :?


Edit:

Still empty - I don't get it :roll:
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Tue Jul 07, 2015 3:01 pm    Post subject: Reply with quote

Well,


don't you love it - when everything worked - and suddenly it doesn't

and the error (and exception) handling says nothing.


Whisper me sweet nothings - you ... darling :roll:



Argh

at least after an dev-libs/icu update

it now shows a meaningful error

which might have led me onto the right track:

Code:
Unable to open locale C in ICU, error code 1
"KConfigIni: In file /var/tmp/portage/kde-base/kdelibs-4.14.10/homedir/.kde4/share/config/kio_help4rc, line 2: " Invalid entry (empty key)



ba-zing !

Thank you :oops:



Well, wrong permissions on /etc/env.d/02locale 8O


Quote:
chmod 644 /etc/env.d/02locale




I Dare you! I double Dare you!!

to fail again




Morale of the story:

permissions do (still ?) tend to change in miraculous ways on Btrfs filesystems

(well - at least on my root partition)
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Tue Jul 07, 2015 3:09 pm    Post subject: Reply with quote

Still failing :evil:


This is getting ridiculous.



Help - anyone ?


edit:


hm, related to handbook

Code:
cd /var/tmp/portage/kde-base/kdelibs-4.14.10/work/kdelibs-4.14.10/doc/kioslave/data && /var/tmp/portage/kde-base/kdelibs-4.14.10/work/kdelibs-4.14.10_build/bin/meinproc4.shell --check --srcdir=/var/tmp/portage/kde-base/kdelibs-4.14.10/work/kdelibs-4.14.10_build/kdoctools/ --cache /var/tmp/portage/kde-base/kdelibs-4.14.10/work/kdelibs-4.14.10_build/doc/kioslave/data/index.cache.bz2 /var/tmp/portage/kde-base/kdelibs-4.14.10/work/kdelibs-4.14.10/doc/kioslave/data/index.docbook
Unable to open locale C in ICU, error code 1
kio_help4(18063): ""CurrencySuspendedDate" - conversion of "" to QDate failed" " (wrong format: expected 3 items, got 1)"
kio_help4(18063): ""CurrencyWithdrawnDate" - conversion of "" to QDate failed" " (wrong format: expected 3 items, got 1)"
kio_help4(18063): ""CurrencySuspendedDate" - conversion of "" to QDate failed" " (wrong format: expected 3 items, got 1)"
kio_help4(18063): ""CurrencyWithdrawnDate" - conversion of "" to QDate failed" " (wrong format: expected 3 items, got 1)"
"KConfigIni: In file /var/tmp/portage/kde-base/kdelibs-4.14.10/homedir/.kde4/share/config/kio_help4rc, line 2: " Invalid entry (empty key)



Away with you !
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
i4dnf
Apprentice
Apprentice


Joined: 18 Sep 2005
Posts: 265
Location: Bucharest, Romania

PostPosted: Tue Jul 07, 2015 9:59 pm    Post subject: Reply with quote

What's your LINGUAS set to ? Also did you try to rerun locale-gen
_________________
"The only difference between me and a madman is that I am not MAD" (SALVATOR DALI)
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Wed Jul 08, 2015 8:36 am    Post subject: Reply with quote

Code:
LINGUAS="en de"



locale-gen has been re-run


The locales are available and the permissions seem to be alright.


Thanks :)


It's still failing - all this mess seems to have started since bigger parts of the system have been compiled with GCC 5.1 :cry:


or there's something behind all that trouble that I - right now - can't pinpoint to.


I'm starting to re-compile things with gcc 4.9.2


Wish me luck :lol:
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Wed Jul 08, 2015 12:34 pm    Post subject: Reply with quote

No idea why this problem is still there but at least the apps somehow work again:


Quote:
okular
Unable to open locale en-US in ICU, error code 1
Fontconfig warning: "/etc/fonts/conf.d/44-wqy-zenhei.conf", line 11: Having multiple values in <test> isn't supported and may not work as expected
"KConfigIni: In file /home/user/.kde4/share/config/okularrc, line 2: " Invalid entry (empty key)
"KConfigIni: In file /home/user/.kde4/share/config/okularrc, line 2: " Invalid entry (empty key)
"KConfigIni: In file /home/user/.kde4/share/config/okularrc, line 2: " Invalid entry (empty key)
okular(9228)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
okular(9228)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
okular(9228)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
okular(9228)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
okular(9228)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:



this is with kdelibs, dev-libs/icu and other packages compiled

with GCC 4.9.2

so it's not GCC 5.1.0 (at least not fully - it seems)


content of .kde4/share/config/okularrc

Code:
[Desktop Entry]
FullScreen=false

[MainWindow]
State=AAAA/wAAAAD9AAAAAAAABQAAAAKOAAAABAAAAAQAAAAIAAAACPwAAAABAAAAAgAAAAEAAAAWAG
0AYQBpAG4AVABvAG8AbABCAGEAcgEAAAAA/////wAAAAAAAAAA
ToolBarsMovable=Disabled





Is the content of this file somehow different for you ?

are any entries missing ?
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
i4dnf
Apprentice
Apprentice


Joined: 18 Sep 2005
Posts: 265
Location: Bucharest, Romania

PostPosted: Wed Jul 08, 2015 6:37 pm    Post subject: Reply with quote

Is that "State=" line-break actually there, or you added it for formatting purposes?
Other than that, that looks fine for a first run. Probably ICU getting confused by something.
_________________
"The only difference between me and a madman is that I am not MAD" (SALVATOR DALI)
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Wed Jul 08, 2015 7:16 pm    Post subject: Reply with quote

If I remember correctly - it was the first run after wiping out the ~/.kde4 directory

so it was put there by okular (or some KDE4 part) itself.

No modification by myself


here's the file after a new start and having deleted it:

Code:
[MainWindow]
State=AAAA/wAAAAD9AAAAAAAABQAAAAKdAAAABAAAAAQAAAAIAAAACPwAAAABAAAAAgAAAAEAAAAWAG0AYQBpAG4AVABvAG8AbABCAGEAcgEAAAAA/////wAAAAAAAAAA
ToolBarsMovable=Disabled

_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4403

PostPosted: Wed Jul 08, 2015 7:29 pm    Post subject: Reply with quote

State comes from QMainWindow::saveState, it is used in restoreState to - restore the state of the main window ;)
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Wed Jul 08, 2015 8:18 pm    Post subject: Reply with quote

franzf wrote:
State comes from QMainWindow::saveState, it is used in restoreState to - restore the state of the main window ;)


okay - so the issue was more on the side of QT rather than kde - and something in the way QT was compiled was screwing things up.

Not sure why GCC 5.1 caused such a difference in error and behavior :(

There's at least one internal compile error in GCC that can be triggered with attempting to compile QT libraries with -mno-align-stringops -minline-stringops-dynamically

which I now removed from my compiler flags - for good :roll:


The ICU error message is still there but the apps seem to work fine again (gcc 4.9.2 compiled)

well, at least from the little usage that I put into them - from what I can tell

(okular, rekonq, akregator, konqueror, kwin, systemsettings)


Thanks !
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum