Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
The notification of brightness change miss icons in xfce4
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
twime
n00b
n00b


Joined: 16 Aug 2014
Posts: 6

PostPosted: Sat Jul 04, 2015 9:52 am    Post subject: The notification of brightness change miss icons in xfce4 Reply with quote

1.When I press fn key to control brightness level,there are only one tiny line on notification windows without icons.
2,The change of brightness level is slow using FN key.
Back to top
View user's profile Send private message
fabalthazar
n00b
n00b


Joined: 26 May 2015
Posts: 16
Location: France

PostPosted: Tue Jul 14, 2015 3:47 pm    Post subject: Reply with quote

Hello,

I think that I have the same problem. Just to be sure, my brightness notification looks like the one shown here (tiny box under the volume notification):
http://askubuntu.com/questions/451096/brightness-notification-on-xubuntu-shrunk-after-update

This problem appeared since the 4.10 to 4.12 stable Xfce4 update.
I have two graphics cards on my system: discrete Nvidia and integrated Intel, with the Optimus technology.

Since the update mentionned above, xfce-power-manager comes with upower, which I think makes several interfaces to backlight devices in /sys/class/backlight. In my case, I have these three ones:
Code:
acpi_video0 -> ../../devices/pci0000:00/0000:00:01.0/0000:01:00.0/backlight/acpi_video0
acpi_video1 -> ../../devices/pci0000:00/0000:00:02.0/backlight/acpi_video1
lintel_backlight -> ../../devices/pci0000:00/0000:00:02.0/drm/card0/card0-LVDS-1/intel_backlight


These links point to the two GPUs: acpi_video0 to the Nvidia one at the 01:00.0 address and acpi_video1 & lintel_backlight to the Intel one at the 00:02.0 address.
By pressing the fn+F5/F6 hotkeys, the brightness is correctly changed, but Xfce shows this nonsense notification box.

My think is Xfce doesn't "listen" to the right interface...?

Does any Xfce guy has an idea on this weird thing on mixed GPUs laptops?

Cheers.
Back to top
View user's profile Send private message
nshibalov
n00b
n00b


Joined: 14 Aug 2015
Posts: 16

PostPosted: Wed Aug 19, 2015 8:25 am    Post subject: Reply with quote

Hi, i have same problem, brightness notification looks exactly like in the link.
Additional information is then i run xfce4-power-manager --no-daemon --debug --dum and press brightness button, there is warning:
Code:
** (xfce4-power-manager:18866): WARNING **: Unable to load icon : xfpm-brightness-lcd
Back to top
View user's profile Send private message
fabalthazar
n00b
n00b


Joined: 26 May 2015
Posts: 16
Location: France

PostPosted: Thu Aug 27, 2015 10:07 am    Post subject: Reply with quote

Hi,
Do you have a multi-GPU system (eg. Intel+Nvidia/Intel+AMD)?
(To see if this depends on multi-GPU systems and xfce-power-manager).
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum