Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Convert from Nouveau to Radeon [SOLVED]
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
phobos13013
Apprentice
Apprentice


Joined: 22 Sep 2004
Posts: 255
Location: NOLA

PostPosted: Fri Jul 03, 2015 4:57 pm    Post subject: Convert from Nouveau to Radeon [SOLVED] Reply with quote

OK, this is going to sound strange... but I want to convert my system from nouveau to radeon.

I had old MB with an nvidia pci-e card but have recently upgraded MB and all components but I am trying to convert the kernel and software from the old install. I changed make.conf from VIDEO_CARDS="nouveau" to VIDEO_CARDS="radeon"; changed settings in kernel to radeon and installed radeon-ucode, but I still do not have a working X.

I rebuilt xorg-server will i need to re-emerge any other pkgs with the new make.conf settings? Is there anything else that would prevent the new configuration from working? Any info is appreciated!
_________________
...and it should be known by now


Last edited by phobos13013 on Mon Aug 17, 2015 2:43 am; edited 1 time in total
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 42588
Location: 56N 3W

PostPosted: Fri Jul 03, 2015 5:30 pm    Post subject: Reply with quote

phobos13013,

Show us what
Quote:
I still do not have a working X.
actually means.
Make friends with wgetpaste and put /var/log/Xorg.0.log onto a pastebin.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
phobos13013
Apprentice
Apprentice


Joined: 22 Sep 2004
Posts: 255
Location: NOLA

PostPosted: Fri Jul 03, 2015 6:51 pm    Post subject: Reply with quote

I can post the log if its needed, but the quick answer is that the current Xorg is still loading the nouveau configuration. I am currently trying to get xf86-video-ati installed so I can generate a new xorg.conf with the proper settings, but the install complained of an inability to resolve xorg.freedesktop.org.... my NIC is having major issues which I am documenting here: https://forums.gentoo.org/viewtopic-p-7773680.html#7773680

I am assuming I can get the xorg issues resolved if I can maintain a working network.
_________________
...and it should be known by now
Back to top
View user's profile Send private message
phobos13013
Apprentice
Apprentice


Joined: 22 Sep 2004
Posts: 255
Location: NOLA

PostPosted: Fri Jul 03, 2015 9:17 pm    Post subject: Reply with quote

OK,
I have stumbled through updating at least the system recognized packages (by emerge --changed-use and associated preserved-rebuild, etc) despite network issues which i am deferring for now until I have a working X. I have Xorg looking for the ati configuration.... but I get an error that the number of created screens does not match those detected by the device.

/var/log/Xorg.0.log:

https://bpaste.net/show/49c2863d1a7b
_________________
...and it should be known by now
Back to top
View user's profile Send private message
phobos13013
Apprentice
Apprentice


Joined: 22 Sep 2004
Posts: 255
Location: NOLA

PostPosted: Fri Jul 03, 2015 9:26 pm    Post subject: Reply with quote

OK, and then I removed .Xauthority from my users home directory to reset and now I get this:

https://bpaste.net/show/985cd6fa7dc7

trying to find nouveau again.
_________________
...and it should be known by now
Back to top
View user's profile Send private message
phobos13013
Apprentice
Apprentice


Joined: 22 Sep 2004
Posts: 255
Location: NOLA

PostPosted: Fri Jul 03, 2015 9:30 pm    Post subject: Reply with quote

So the difference between the two is that just typing startx yields the error of the second kind

whereas typing Xorg :0 -configure generates the error of the first kind.....

Do I still have mismatching packages? I removed xf86-video-nouveau and preserved-rebuild after that with the new ati settings... but i seem to have a foot in both doors with both video card settings.
_________________
...and it should be known by now
Back to top
View user's profile Send private message
phobos13013
Apprentice
Apprentice


Joined: 22 Sep 2004
Posts: 255
Location: NOLA

PostPosted: Fri Jul 03, 2015 11:07 pm    Post subject: Reply with quote

Further down the rabbit hole.... dmesg shows there is trouble with the firmware... cannot post a bpaste because my network is failed again and I cannot get it to come back up. But in dmesg, I get ouput that says it cannot load ARUBA_pfp.bin and probe of the device failed.

I had the radeon-ucode firmaware drivers installed but removed that and added the full boat of linux-firmware drivers.

I had the driver built-in to the kernel but couldnt get it to build when I pointed it to the lib/firmware/driver suite... so I just try it as module and it still gives me the same error in dmesg....

HELP!
_________________
...and it should be known by now
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 42588
Location: 56N 3W

PostPosted: Sat Jul 04, 2015 9:17 am    Post subject: Reply with quote

phobos13013,

One of your logs returns a 404 error
The other contains
Code:
[  7908.699] (++) Using config file: "/root/xorg.conf.new"


A few things ...
Never run X as root. Some things deliberately fail to start that way.
As you are using all open source drivers, you don't need an xorg.conf at all to get Xorg to start.
The defaults are all USA centric ... including the keymap. Rename any/all xorg.conf you have so that they are not found.

Do not use
Code:
Xorg :0 -configure
its no longer required and mostly doesn't work.

Failing to load firmware is not fatal, you will not have any 3D hardware acceleration, so if we fix that along the way, fine but if not, we can fix it after Xorg starts.

For your network, you do not need to post from the live system. Put the files and command output somewhere another OS or anothr system can find them and post them that way.
That allows us to help with your network problem too.

Lastly, pick one problem, we will work that one first.
We well all get confused if we try to work two or more problems at the same time.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
phobos13013
Apprentice
Apprentice


Joined: 22 Sep 2004
Posts: 255
Location: NOLA

PostPosted: Wed Jul 08, 2015 2:29 pm    Post subject: Reply with quote

Thanks Neddy, all rrally good info!!

Unfortunately I am out of commission as my building caught fire andni am not able to stay there.... May be a month or two until i am back at that box with power. Will try those recommends when time comes thanks again!
_________________
...and it should be known by now
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 42588
Location: 56N 3W

PostPosted: Wed Jul 08, 2015 4:50 pm    Post subject: Reply with quote

phobos13013,

As long as you and yours are safe.
Next time you post here, it will appear in my "your posts" seach, so I will see it.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
phobos13013
Apprentice
Apprentice


Joined: 22 Sep 2004
Posts: 255
Location: NOLA

PostPosted: Sun Aug 16, 2015 7:36 pm    Post subject: Reply with quote

Neddy, thanks for the well-wishes!

I am back in my place with power; still some infrastructure issues with this place, but I am occupying it at least. My internet is down until the end of the month tho; I'd still like to get this box working at least with the video which shouldnt require any internet at this time.

So I am revisiting this issue. Here are some questions from your 2nd to last post, Neddy (or anyone who happens to read or follow the thread):

It is confusing and alarming that I am asking to run X as root.... I do not know how that has become enabled, but where is this happening? I am always starting X as a user; why is it seeking to run this config file (just looking in all places?)

I have gone through and removed or renamed every xorg.conf/new file on the system, but X still has the failed start.

Any hints of what to do to get X? I have a feeling it is an issue with the hardware/kernel interaction....
_________________
...and it should be known by now
Back to top
View user's profile Send private message
phobos13013
Apprentice
Apprentice


Joined: 22 Sep 2004
Posts: 255
Location: NOLA

PostPosted: Sun Aug 16, 2015 7:57 pm    Post subject: Reply with quote

Oh and here is the latest Xorg.0.log to corroborate:

Quote:
[144038.200]
X.Org X Server 1.16.4
Release Date: 2014-12-20
[144038.200] X Protocol Version 11, Revision 0
[144038.201] Build Operating System: Linux 4.0.5-gentoo x86_64 Gentoo
[144038.201] Current Operating System: Linux localhost 4.0.5-gentoo #3 SMP PREEMPT Thu Jul 2 15:15:16 PDT 2015 x86_64
[144038.201] Kernel command line: BOOT_IMAGE=/vmlinuz-4.0.5-gentoo root=/dev/sda5 ro
[144038.201] Build Date: 03 July 2015 10:45:58PM
[144038.201]
[144038.201] Current version of pixman: 0.32.6
[144038.202] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[144038.202] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[144038.203] (==) Log file: "/var/log/Xorg.0.log", Time: Sun Aug 16 20:43:19 2015
[144038.203] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[144038.203] (==) No Layout section. Using the first Screen section.
[144038.203] (==) No screen section available. Using defaults.
[144038.203] (**) |-->Screen "Default Screen Section" (0)
[144038.203] (**) | |-->Monitor "<default monitor>"
[144038.203] (==) No monitor specified for screen "Default Screen Section".
Using a default monitor configuration.
[144038.203] (==) Automatically adding devices
[144038.203] (==) Automatically enabling devices
[144038.203] (==) Automatically adding GPU devices
[144038.203] (==) FontPath set to:
/usr/share/fonts/misc/,
/usr/share/fonts/TTF/,
/usr/share/fonts/OTF/,
/usr/share/fonts/Type1/,
/usr/share/fonts/100dpi/,
/usr/share/fonts/75dpi/
[144038.203] (==) ModulePath set to "/usr/lib64/xorg/modules"
[144038.203] (II) The server relies on udev to provide the list of input devices.
If no devices become available, reconfigure udev or disable AutoAddDevices.
[144038.203] (II) Loader magic: 0x803c80
[144038.203] (II) Module ABI versions:
[144038.203] X.Org ANSI C Emulation: 0.4
[144038.203] X.Org Video Driver: 18.0
[144038.203] X.Org XInput driver : 21.0
[144038.203] X.Org Server Extension : 8.0
[144038.204] (--) PCI:*(0:0:1:0) 1002:9996:1458:d000 rev 0, Mem @ 0xd0000000/268435456, 0xfef00000/262144, I/O @ 0x0000f000/256
[144038.204] (II) LoadModule: "glx"
[144038.204] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[144038.205] (II) Module glx: vendor="X.Org Foundation"
[144038.205] compiled for 1.16.4, module version = 1.0.0
[144038.205] ABI class: X.Org Server Extension, version 8.0
[144038.205] (==) AIGLX enabled
[144038.205] (==) Matched ati as autoconfigured driver 0
[144038.205] (==) Matched modesetting as autoconfigured driver 1
[144038.205] (==) Matched fbdev as autoconfigured driver 2
[144038.205] (==) Matched vesa as autoconfigured driver 3
[144038.205] (==) Assigned the driver to the xf86ConfigLayout
[144038.205] (II) LoadModule: "ati"
[144038.205] (II) Loading /usr/lib64/xorg/modules/drivers/ati_drv.so
[144038.205] (II) Module ati: vendor="X.Org Foundation"
[144038.205] compiled for 1.16.4, module version = 7.5.0
[144038.205] Module class: X.Org Video Driver
[144038.205] ABI class: X.Org Video Driver, version 18.0
[144038.205] (II) LoadModule: "radeon"
[144038.205] (II) Loading /usr/lib64/xorg/modules/drivers/radeon_drv.so
[144038.206] (II) Module radeon: vendor="X.Org Foundation"
[144038.206] compiled for 1.16.4, module version = 7.5.0
[144038.206] Module class: X.Org Video Driver
[144038.206] ABI class: X.Org Video Driver, version 18.0
[144038.206] (II) LoadModule: "modesetting"
[144038.206] (WW) Warning, couldn't open module modesetting
[144038.206] (II) UnloadModule: "modesetting"
[144038.206] (II) Unloading modesetting
[144038.206] (EE) Failed to load module "modesetting" (module does not exist, 0)
[144038.206] (II) LoadModule: "fbdev"
[144038.206] (WW) Warning, couldn't open module fbdev
[144038.206] (II) UnloadModule: "fbdev"
[144038.206] (II) Unloading fbdev
[144038.206] (EE) Failed to load module "fbdev" (module does not exist, 0)
[144038.206] (II) LoadModule: "vesa"
[144038.206] (WW) Warning, couldn't open module vesa
[144038.206] (II) UnloadModule: "vesa"
[144038.206] (II) Unloading vesa
[144038.206] (EE) Failed to load module "vesa" (module does not exist, 0)
[144038.206] (II) RADEON: Driver for ATI Radeon chipsets:
ATI Radeon Mobility X600 (M24) 3150 (PCIE), ATI FireMV 2400 (PCI),
ATI Radeon Mobility X300 (M24) 3152 (PCIE),
ATI FireGL M24 GL 3154 (PCIE), ATI FireMV 2400 3155 (PCI),
ATI Radeon X600 (RV380) 3E50 (PCIE),
ATI FireGL V3200 (RV380) 3E54 (PCIE), ATI Radeon IGP320 (A3) 4136,
ATI Radeon IGP330/340/350 (A4) 4137, ATI Radeon 9500 AD (AGP),
ATI Radeon 9500 AE (AGP), ATI Radeon 9600TX AF (AGP),
ATI FireGL Z1 AG (AGP), ATI Radeon 9800SE AH (AGP),
ATI Radeon 9800 AI (AGP), ATI Radeon 9800 AJ (AGP),
ATI FireGL X2 AK (AGP), ATI Radeon 9600 AP (AGP),
ATI Radeon 9600SE AQ (AGP), ATI Radeon 9600XT AR (AGP),
ATI Radeon 9600 AS (AGP), ATI FireGL T2 AT (AGP), ATI Radeon 9650,
ATI FireGL RV360 AV (AGP), ATI Radeon 7000 IGP (A4+) 4237,
ATI Radeon 8500 AIW BB (AGP), ATI Radeon IGP320M (U1) 4336,
ATI Radeon IGP330M/340M/350M (U2) 4337,
ATI Radeon Mobility 7000 IGP 4437, ATI Radeon 9000/PRO If (AGP/PCI),
ATI Radeon 9000 Ig (AGP/PCI), ATI Radeon X800 (R420) JH (AGP),
ATI Radeon X800PRO (R420) JI (AGP),
ATI Radeon X800SE (R420) JJ (AGP), ATI Radeon X800 (R420) JK (AGP),
ATI Radeon X800 (R420) JL (AGP), ATI FireGL X3 (R420) JM (AGP),
ATI Radeon Mobility 9800 (M18) JN (AGP),
ATI Radeon X800 SE (R420) (AGP), ATI Radeon X800XT (R420) JP (AGP),
ATI Radeon X800 VE (R420) JT (AGP), ATI Radeon X850 (R480) (AGP),
ATI Radeon X850 XT (R480) (AGP), ATI Radeon X850 SE (R480) (AGP),
ATI Radeon X850 PRO (R480) (AGP), ATI Radeon X850 XT PE (R480) (AGP),
ATI Radeon Mobility M7 LW (AGP),
ATI Mobility FireGL 7800 M7 LX (AGP),
ATI Radeon Mobility M6 LY (AGP), ATI Radeon Mobility M6 LZ (AGP),
ATI FireGL Mobility 9000 (M9) Ld (AGP),
ATI Radeon Mobility 9000 (M9) Lf (AGP),
ATI Radeon Mobility 9000 (M9) Lg (AGP), ATI FireMV 2400 PCI,
ATI Radeon 9700 Pro ND (AGP), ATI Radeon 9700/9500Pro NE (AGP),
ATI Radeon 9600TX NF (AGP), ATI FireGL X1 NG (AGP),
ATI Radeon 9800PRO NH (AGP), ATI Radeon 9800 NI (AGP),
ATI FireGL X2 NK (AGP), ATI Radeon 9800XT NJ (AGP),
ATI Radeon Mobility 9600/9700 (M10/M11) NP (AGP),
ATI Radeon Mobility 9600 (M10) NQ (AGP),
ATI Radeon Mobility 9600 (M11) NR (AGP),
ATI Radeon Mobility 9600 (M10) NS (AGP),
ATI FireGL Mobility T2 (M10) NT (AGP),
ATI FireGL Mobility T2e (M11) NV (AGP), ATI Radeon QD (AGP),
ATI Radeon QE (AGP), ATI Radeon QF (AGP), ATI Radeon QG (AGP),
ATI FireGL 8700/8800 QH (AGP), ATI Radeon 8500 QL (AGP),
ATI Radeon 9100 QM (AGP), ATI Radeon 7500 QW (AGP/PCI),
ATI Radeon 7500 QX (AGP/PCI), ATI Radeon VE/7000 QY (AGP/PCI),
ATI Radeon VE/7000 QZ (AGP/PCI), ATI ES1000 515E (PCI),
ATI Radeon Mobility X300 (M22) 5460 (PCIE),
ATI Radeon Mobility X600 SE (M24C) 5462 (PCIE),
ATI FireGL M22 GL 5464 (PCIE), ATI Radeon X800 (R423) UH (PCIE),
ATI Radeon X800PRO (R423) UI (PCIE),
ATI Radeon X800LE (R423) UJ (PCIE),
ATI Radeon X800SE (R423) UK (PCIE),
ATI Radeon X800 XTP (R430) (PCIE), ATI Radeon X800 XL (R430) (PCIE),
ATI Radeon X800 SE (R430) (PCIE), ATI Radeon X800 (R430) (PCIE),
ATI FireGL V7100 (R423) (PCIE), ATI FireGL V5100 (R423) UQ (PCIE),
ATI FireGL unknown (R423) UR (PCIE),
ATI FireGL unknown (R423) UT (PCIE),
ATI Mobility FireGL V5000 (M26) (PCIE),
ATI Mobility FireGL V5000 (M26) (PCIE),
ATI Mobility Radeon X700 XL (M26) (PCIE),
ATI Mobility Radeon X700 (M26) (PCIE),
ATI Mobility Radeon X700 (M26) (PCIE),
ATI Radeon X550XTX 5657 (PCIE), ATI Radeon 9100 IGP (A5) 5834,
ATI Radeon Mobility 9100 IGP (U3) 5835,
ATI Radeon XPRESS 200 5954 (PCIE),
ATI Radeon XPRESS 200M 5955 (PCIE), ATI Radeon 9250 5960 (AGP),
ATI Radeon 9200 5961 (AGP), ATI Radeon 9200 5962 (AGP),
ATI Radeon 9200SE 5964 (AGP), ATI FireMV 2200 (PCI),
ATI ES1000 5969 (PCI), ATI Radeon XPRESS 200 5974 (PCIE),
ATI Radeon XPRESS 200M 5975 (PCIE),
ATI Radeon XPRESS 200 5A41 (PCIE),
ATI Radeon XPRESS 200M 5A42 (PCIE),
ATI Radeon XPRESS 200 5A61 (PCIE),
ATI Radeon XPRESS 200M 5A62 (PCIE),
ATI Radeon X300 (RV370) 5B60 (PCIE),
ATI Radeon X600 (RV370) 5B62 (PCIE),
ATI Radeon X550 (RV370) 5B63 (PCIE),
ATI FireGL V3100 (RV370) 5B64 (PCIE),
ATI FireMV 2200 PCIE (RV370) 5B65 (PCIE),
ATI Radeon Mobility 9200 (M9+) 5C61 (AGP),
ATI Radeon Mobility 9200 (M9+) 5C63 (AGP),
ATI Mobility Radeon X800 XT (M28) (PCIE),
ATI Mobility FireGL V5100 (M28) (PCIE),
ATI Mobility Radeon X800 (M28) (PCIE), ATI Radeon X850 5D4C (PCIE),
ATI Radeon X850 XT PE (R480) (PCIE),
ATI Radeon X850 SE (R480) (PCIE), ATI Radeon X850 PRO (R480) (PCIE),
ATI unknown Radeon / FireGL (R480) 5D50 (PCIE),
ATI Radeon X850 XT (R480) (PCIE),
ATI Radeon X800XT (R423) 5D57 (PCIE),
ATI FireGL V5000 (RV410) (PCIE), ATI Radeon X700 XT (RV410) (PCIE),
ATI Radeon X700 PRO (RV410) (PCIE),
ATI Radeon X700 SE (RV410) (PCIE), ATI Radeon X700 (RV410) (PCIE),
ATI Radeon X700 SE (RV410) (PCIE), ATI Radeon X1800,
ATI Mobility Radeon X1800 XT, ATI Mobility Radeon X1800,
ATI Mobility FireGL V7200, ATI FireGL V7200, ATI FireGL V5300,
ATI Mobility FireGL V7100, ATI Radeon X1800, ATI Radeon X1800,
ATI Radeon X1800, ATI Radeon X1800, ATI Radeon X1800,
ATI FireGL V7300, ATI FireGL V7350, ATI Radeon X1600, ATI RV505,
ATI Radeon X1300/X1550, ATI Radeon X1550, ATI M54-GL,
ATI Mobility Radeon X1400, ATI Radeon X1300/X1550,
ATI Radeon X1550 64-bit, ATI Mobility Radeon X1300,
ATI Mobility Radeon X1300, ATI Mobility Radeon X1300,
ATI Mobility Radeon X1300, ATI Radeon X1300, ATI Radeon X1300,
ATI RV505, ATI RV505, ATI FireGL V3300, ATI FireGL V3350,
ATI Radeon X1300, ATI Radeon X1550 64-bit, ATI Radeon X1300/X1550,
ATI Radeon X1600, ATI Radeon X1300/X1550, ATI Mobility Radeon X1450,
ATI Radeon X1300/X1550, ATI Mobility Radeon X2300,
ATI Mobility Radeon X2300, ATI Mobility Radeon X1350,
ATI Mobility Radeon X1350, ATI Mobility Radeon X1450,
ATI Radeon X1300, ATI Radeon X1550, ATI Mobility Radeon X1350,
ATI FireMV 2250, ATI Radeon X1550 64-bit, ATI Radeon X1600,
ATI Radeon X1650, ATI Radeon X1600, ATI Radeon X1600,
ATI Mobility FireGL V5200, ATI Mobility Radeon X1600,
ATI Radeon X1650, ATI Radeon X1650, ATI Radeon X1600,
ATI Radeon X1300 XT/X1600 Pro, ATI FireGL V3400,
ATI Mobility FireGL V5250, ATI Mobility Radeon X1700,
ATI Mobility Radeon X1700 XT, ATI FireGL V5200,
ATI Mobility Radeon X1700, ATI Radeon X2300HD,
ATI Mobility Radeon HD 2300, ATI Mobility Radeon HD 2300,
ATI Radeon X1950, ATI Radeon X1900, ATI Radeon X1950,
ATI Radeon X1900, ATI Radeon X1900, ATI Radeon X1900,
ATI Radeon X1900, ATI Radeon X1900, ATI Radeon X1900,
ATI Radeon X1900, ATI Radeon X1900, ATI Radeon X1900,
ATI AMD Stream Processor, ATI Radeon X1900, ATI Radeon X1950,
ATI RV560, ATI RV560, ATI Mobility Radeon X1900, ATI RV560,
ATI Radeon X1950 GT, ATI RV570, ATI RV570, ATI FireGL V7400,
ATI RV560, ATI Radeon X1650, ATI Radeon X1650, ATI RV560,
ATI Radeon 9100 PRO IGP 7834, ATI Radeon Mobility 9200 IGP 7835,
ATI Radeon X1200, ATI Radeon X1200, ATI Radeon X1200,
ATI Radeon X1200, ATI Radeon X1200, ATI RS740, ATI RS740M, ATI RS740,
ATI RS740M, ATI Radeon HD 2900 XT, ATI Radeon HD 2900 XT,
ATI Radeon HD 2900 XT, ATI Radeon HD 2900 Pro, ATI Radeon HD 2900 GT,
ATI FireGL V8650, ATI FireGL V8600, ATI FireGL V7600,
ATI Radeon 4800 Series, ATI Radeon HD 4870 x2,
ATI Radeon 4800 Series, ATI Radeon HD 4850 x2,
ATI FirePro V8750 (FireGL), ATI FirePro V7760 (FireGL),
ATI Mobility RADEON HD 4850, ATI Mobility RADEON HD 4850 X2,
ATI Radeon 4800 Series, ATI FirePro RV770, AMD FireStream 9270,
AMD FireStream 9250, ATI FirePro V8700 (FireGL),
ATI Mobility RADEON HD 4870, ATI Mobility RADEON M98,
ATI Mobility RADEON HD 4870, ATI Radeon 4800 Series,
ATI Radeon 4800 Series, ATI FirePro M7750, ATI M98, ATI M98, ATI M98,
ATI Mobility Radeon HD 4650, ATI Radeon RV730 (AGP),
ATI Mobility Radeon HD 4670, ATI FirePro M5750,
ATI Mobility Radeon HD 4670, ATI Radeon RV730 (AGP),
ATI RV730XT [Radeon HD 4670], ATI RADEON E4600,
ATI Radeon HD 4600 Series, ATI RV730 PRO [Radeon HD 4650],
ATI FirePro V7750 (FireGL), ATI FirePro V5700 (FireGL),
ATI FirePro V3750 (FireGL), ATI Mobility Radeon HD 4830,
ATI Mobility Radeon HD 4850, ATI FirePro M7740, ATI RV740,
ATI Radeon HD 4770, ATI Radeon HD 4700 Series, ATI Radeon HD 4770,
ATI FirePro M5750, ATI RV610, ATI Radeon HD 2400 XT,
ATI Radeon HD 2400 Pro, ATI Radeon HD 2400 PRO AGP, ATI FireGL V4000,
ATI RV610, ATI Radeon HD 2350, ATI Mobility Radeon HD 2400 XT,
ATI Mobility Radeon HD 2400, ATI RADEON E2400, ATI RV610,
ATI FireMV 2260, ATI RV670, ATI Radeon HD3870,
ATI Mobility Radeon HD 3850, ATI Radeon HD3850,
ATI Mobility Radeon HD 3850 X2, ATI RV670,
ATI Mobility Radeon HD 3870, ATI Mobility Radeon HD 3870 X2,
ATI Radeon HD3870 X2, ATI FireGL V7700, ATI Radeon HD3850,
ATI Radeon HD3690, AMD Firestream 9170, ATI Radeon HD 4550,
ATI Radeon RV710, ATI Radeon RV710, ATI Radeon RV710,
ATI Radeon HD 4350, ATI Mobility Radeon 4300 Series,
ATI Mobility Radeon 4500 Series, ATI Mobility Radeon 4500 Series,
ATI FirePro RG220, ATI Mobility Radeon 4330, ATI RV630,
ATI Mobility Radeon HD 2600, ATI Mobility Radeon HD 2600 XT,
ATI Radeon HD 2600 XT AGP, ATI Radeon HD 2600 Pro AGP,
ATI Radeon HD 2600 XT, ATI Radeon HD 2600 Pro, ATI Gemini RV630,
ATI Gemini Mobility Radeon HD 2600 XT, ATI FireGL V5600,
ATI FireGL V3600, ATI Radeon HD 2600 LE,
ATI Mobility FireGL Graphics Processor, ATI Radeon HD 3470,
ATI Mobility Radeon HD 3430, ATI Mobility Radeon HD 3400 Series,
ATI Radeon HD 3450, ATI Radeon HD 3450, ATI Radeon HD 3430,
ATI Radeon HD 3450, ATI FirePro V3700, ATI FireMV 2450,
ATI FireMV 2260, ATI FireMV 2260, ATI Radeon HD 3600 Series,
ATI Radeon HD 3650 AGP, ATI Radeon HD 3600 PRO,
ATI Radeon HD 3600 XT, ATI Radeon HD 3600 PRO,
ATI Mobility Radeon HD 3650, ATI Mobility Radeon HD 3670,
ATI Mobility FireGL V5700, ATI Mobility FireGL V5725,
ATI Radeon HD 3200 Graphics, ATI Radeon 3100 Graphics,
ATI Radeon HD 3200 Graphics, ATI Radeon 3100 Graphics,
ATI Radeon HD 3300 Graphics, ATI Radeon HD 3200 Graphics,
ATI Radeon 3000 Graphics, SUMO, SUMO, SUMO2, SUMO2, SUMO2, SUMO2,
SUMO, SUMO, SUMO2, SUMO, SUMO, SUMO, SUMO, SUMO, ATI Radeon HD 4200,
ATI Radeon 4100, ATI Mobility Radeon HD 4200,
ATI Mobility Radeon 4100, ATI Radeon HD 4290, ATI Radeon HD 4250,
AMD Radeon HD 6310 Graphics, AMD Radeon HD 6310 Graphics,
AMD Radeon HD 6250 Graphics, AMD Radeon HD 6250 Graphics,
AMD Radeon HD 6300 Series Graphics,
AMD Radeon HD 6200 Series Graphics, PALM, PALM, PALM, CYPRESS,
ATI FirePro (FireGL) Graphics Adapter,
ATI FirePro (FireGL) Graphics Adapter,
ATI FirePro (FireGL) Graphics Adapter, AMD Firestream 9370,
AMD Firestream 9350, ATI Radeon HD 5800 Series,
ATI Radeon HD 5800 Series, ATI Radeon HD 5800 Series,
ATI Radeon HD 5800 Series, ATI Radeon HD 5900 Series,
ATI Radeon HD 5900 Series, ATI Mobility Radeon HD 5800 Series,
ATI Mobility Radeon HD 5800 Series,
ATI FirePro (FireGL) Graphics Adapter,
ATI FirePro (FireGL) Graphics Adapter,
ATI Mobility Radeon HD 5800 Series, ATI Radeon HD 5700 Series,
ATI Radeon HD 5700 Series, ATI Radeon HD 6700 Series,
ATI Radeon HD 5700 Series, ATI Radeon HD 6700 Series,
ATI Mobility Radeon HD 5000 Series,
ATI Mobility Radeon HD 5000 Series, ATI Mobility Radeon HD 5570,
ATI FirePro (FireGL) Graphics Adapter,
ATI FirePro (FireGL) Graphics Adapter, ATI Radeon HD 5670,
ATI Radeon HD 5570, ATI Radeon HD 5500 Series, REDWOOD,
ATI Mobility Radeon HD 5000 Series,
ATI Mobility Radeon HD 5000 Series, ATI Mobility Radeon Graphics,
ATI Mobility Radeon Graphics, CEDAR,
ATI FirePro (FireGL) Graphics Adapter,
ATI FirePro (FireGL) Graphics Adapter, ATI FirePro 2270, CEDAR,
ATI Radeon HD 5450, CEDAR, CEDAR, CAYMAN, CAYMAN, CAYMAN, CAYMAN,
CAYMAN, CAYMAN, CAYMAN, CAYMAN, CAYMAN, CAYMAN,
AMD Radeon HD 6900 Series, AMD Radeon HD 6900 Series, CAYMAN, CAYMAN,
CAYMAN, AMD Radeon HD 6900M Series, Mobility Radeon HD 6000 Series,
BARTS, BARTS, Mobility Radeon HD 6000 Series,
Mobility Radeon HD 6000 Series, BARTS, BARTS, BARTS, BARTS,
AMD Radeon HD 6800 Series, AMD Radeon HD 6800 Series,
AMD Radeon HD 6700 Series, TURKS, TURKS, TURKS, TURKS, TURKS, TURKS,
TURKS, TURKS, TURKS, TURKS, TURKS, TURKS, TURKS, TURKS, TURKS, TURKS,
TURKS, TURKS, TURKS, TURKS, TURKS, TURKS, TURKS, TURKS, TURKS, TURKS,
CAICOS, CAICOS, CAICOS, CAICOS, CAICOS, CAICOS, CAICOS, CAICOS,
CAICOS, CAICOS, CAICOS, CAICOS, CAICOS, CAICOS, CAICOS, ARUBA, ARUBA,
ARUBA, ARUBA, ARUBA, ARUBA, ARUBA, ARUBA, ARUBA, ARUBA, ARUBA, ARUBA,
ARUBA, ARUBA, ARUBA, ARUBA, ARUBA, ARUBA, ARUBA, ARUBA, ARUBA, ARUBA,
ARUBA, ARUBA, ARUBA, ARUBA, ARUBA, ARUBA, ARUBA, ARUBA, ARUBA, ARUBA,
ARUBA, ARUBA, ARUBA, ARUBA, ARUBA, TAHITI, TAHITI, TAHITI, TAHITI,
TAHITI, TAHITI, TAHITI, TAHITI, TAHITI, TAHITI, TAHITI, TAHITI,
TAHITI, PITCAIRN, PITCAIRN, PITCAIRN, PITCAIRN, PITCAIRN, PITCAIRN,
PITCAIRN, PITCAIRN, PITCAIRN, PITCAIRN, PITCAIRN, PITCAIRN, PITCAIRN,
VERDE, VERDE, VERDE, VERDE, VERDE, VERDE, VERDE, VERDE, VERDE, VERDE,
VERDE, VERDE, VERDE, VERDE, VERDE, VERDE, VERDE, VERDE, VERDE, VERDE,
VERDE, VERDE, VERDE, VERDE, OLAND, OLAND, OLAND, OLAND, OLAND, OLAND,
OLAND, OLAND, OLAND, OLAND, OLAND, OLAND, OLAND, OLAND, OLAND, OLAND,
HAINAN, HAINAN, HAINAN, HAINAN, HAINAN, HAINAN, BONAIRE, BONAIRE,
BONAIRE, BONAIRE, BONAIRE, BONAIRE, BONAIRE, BONAIRE, BONAIRE,
BONAIRE, KABINI, KABINI, KABINI, KABINI, KABINI, KABINI, KABINI,
KABINI, KABINI, KABINI, KABINI, KABINI, KABINI, KABINI, KABINI,
KABINI, MULLINS, MULLINS, MULLINS, MULLINS, MULLINS, MULLINS,
MULLINS, MULLINS, MULLINS, MULLINS, MULLINS, MULLINS, MULLINS,
MULLINS, MULLINS, MULLINS, KAVERI, KAVERI, KAVERI, KAVERI, KAVERI,
KAVERI, KAVERI, KAVERI, KAVERI, KAVERI, KAVERI, KAVERI, KAVERI,
KAVERI, KAVERI, KAVERI, KAVERI, KAVERI, KAVERI, KAVERI, KAVERI,
KAVERI, HAWAII, HAWAII, HAWAII, HAWAII, HAWAII, HAWAII, HAWAII,
HAWAII, HAWAII, HAWAII, HAWAII, HAWAII
[144038.210] (--) using VT number 7

[144038.213] (II) [KMS] drm report modesetting isn't supported.
[144038.213] (EE) Screen 0 deleted because of no matching config section.
[144038.213] (II) UnloadModule: "radeon"
[144038.213] (EE) Device(s) detected, but none match those in the config file.
[144038.213] (EE)
Fatal server error:
[144038.213] (EE) no screens found(EE)
[144038.213] (EE)
Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
[144038.213] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[144038.213] (EE)
[144038.215] (EE) Server terminated with error (1). Closing log file.


Sorry for length and not being on a bpaste site, but I am having to air gap transfer the output from the box to a device with internet....
_________________
...and it should be known by now
Back to top
View user's profile Send private message
Buffoon
Veteran
Veteran


Joined: 17 Jun 2015
Posts: 1074
Location: EU or US

PostPosted: Sun Aug 16, 2015 8:00 pm    Post subject: Reply with quote

Code:
[144038.213] (II) [KMS] drm report modesetting isn't supported.


That's your problem right there. You either misconfigured your new kernel or you didn't install it properly. (Not mounting /boot is a popular cause.)
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 42588
Location: 56N 3W

PostPosted: Sun Aug 16, 2015 8:18 pm    Post subject: Reply with quote

phobos13013,

To add to what Buffoon said, check the date/time in
Code:
uname -a
thats the build date/time of the running kernel.
It should match your recollection of your most recent kernel build.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
phobos13013
Apprentice
Apprentice


Joined: 22 Sep 2004
Posts: 255
Location: NOLA

PostPosted: Sun Aug 16, 2015 8:51 pm    Post subject: Reply with quote

Ok, thanks for the quick replies! So, I have confirmed that uname is pointing to the correct kernel, eselect also selects it, and boot is mounted with the vmlinuz file copied; however config and System.map are not there for that kernel version (4.0.5). Did i do a bad kernel conversion from 3.9 to 4.0?

Do i just rebuild the kernel and copy ALL output to /boot? How do I get config and System.map there?

Thanks
_________________
...and it should be known by now
Back to top
View user's profile Send private message
Buffoon
Veteran
Veteran


Joined: 17 Jun 2015
Posts: 1074
Location: EU or US

PostPosted: Sun Aug 16, 2015 8:58 pm    Post subject: Reply with quote

You do not need .config and System.map to run your kernel.

You say uname -a prints the date and time you expect for your latest kernel?

If so, please use wgetpaste to pastebin your kernel .config.
Back to top
View user's profile Send private message
phobos13013
Apprentice
Apprentice


Joined: 22 Sep 2004
Posts: 255
Location: NOLA

PostPosted: Sun Aug 16, 2015 10:51 pm    Post subject: Reply with quote

OK, I just pasted it manually, so got it to work. Kernel config here:

https://bpaste.net/show/91c7e52948b6
_________________
...and it should be known by now
Back to top
View user's profile Send private message
Tony0945
Advocate
Advocate


Joined: 25 Jul 2006
Posts: 2887
Location: Illinois, USA

PostPosted: Sun Aug 16, 2015 11:14 pm    Post subject: Reply with quote

Quote:

CONFIG_DRM_RADEON=y


Should be "=m" not "=y" Don't know why, but the video cards only work as modules, don't know why there is a choice of built-in.
Back to top
View user's profile Send private message
phobos13013
Apprentice
Apprentice


Joined: 22 Sep 2004
Posts: 255
Location: NOLA

PostPosted: Mon Aug 17, 2015 12:18 am    Post subject: Reply with quote

Well, I had switched that around a few times I think, so ended up on the wrong setting although I didnt know that was a requirement for radeon (been using nvidia for over a decade). Anyhoo, I rebuild that kernel with module built-in and i find out uname is pointing to the same kernel as before (which I am beginning to think was not the latest and greatest even then). The kernel version is right but not the build date. What am i missing...?
_________________
...and it should be known by now
Back to top
View user's profile Send private message
phobos13013
Apprentice
Apprentice


Joined: 22 Sep 2004
Posts: 255
Location: NOLA

PostPosted: Mon Aug 17, 2015 12:24 am    Post subject: Reply with quote

OK, found the problem.... eselect reports my kernel as 4.0.5 (only one availabile), /usr/src/linux only reports up to 4.0.5, no mention anywhere of 4.1.0 in directory, but menuconfig is configuring for 4.1.0... I do not have internet access to repositories, is there a way to fix this ghost kernel offline?! I do not understand how this happened...
_________________
...and it should be known by now
Back to top
View user's profile Send private message
Tony0945
Advocate
Advocate


Joined: 25 Jul 2006
Posts: 2887
Location: Illinois, USA

PostPosted: Mon Aug 17, 2015 1:08 am    Post subject: Reply with quote

ls -l /usr/src to see what you have and which one the symlink is pointing to. Set the symlink manually to the one you want.

Quote:
X3 ~ # cat `which buildmykernel`
#!

cd /usr/src/linux
zcat /proc/config.gz >.config

# At this point we should compare kernel versions and make oldconfig if the base version has updated

make menuconfig # you can always just save or quit


make -j7

#cp /usr/src/linux/drivers/usb/common/usb-common.ko /usr/src/initramfs/lib/modules
#cp /usr/src/linux/drivers/usb/core/usbcore.ko /usr/src/initramfs/lib/modules
#cp /usr/src/linux/drivers/hid/usbhid/usbhid.ko /usr/src/initramfs/lib/modules
#touch /usr/src/initramfs

#make again to update initramfs
#make -j7

make -j7 modules_install

make -j7 install



echo "Don't forget to update boot loader menu"



I've mutated this script as I went from internal initramfs to no initramfs. The "j7" is because I'm running a Phenom II X6. Make it what you want or omit it. I intend to steal some code from genkernel to automatcally update /boot/grub/grub.conf but for now you have to manually edit the file.
Back to top
View user's profile Send private message
phobos13013
Apprentice
Apprentice


Joined: 22 Sep 2004
Posts: 255
Location: NOLA

PostPosted: Mon Aug 17, 2015 1:21 am    Post subject: Reply with quote

So that is the thing... symlink, eselect, /usr/src/ all of them only list or point to linux-4.0.5, uname reports it I suspect as of the last time I built under that kernel. Somehow, this ghost kernel, 4.1.0 got on my system and I upgraded to it, but its not there... maybe I need an emerge sync, altho i cannot do that since I am offline to that box atm.

Any idea how to get menuconfig from thinking its in 4.1.0 when every thing else says 4.0.5?
_________________
...and it should be known by now
Back to top
View user's profile Send private message
phobos13013
Apprentice
Apprentice


Joined: 22 Sep 2004
Posts: 255
Location: NOLA

PostPosted: Mon Aug 17, 2015 1:47 am    Post subject: Reply with quote

Oh no, please ignore me about the kernel version, I was confused in menuconfig about where i saw the version number, it is in fact 4.0.5 systemwide... its just that uname still lists a kernel built back in July even though I just rebuilt it. Where is the disconnect?

To add some fuel to the fire, this is the radeon output of dmesg:

Quote:
[ 0.471956] [drm] radeon kernel modesetting enabled.
[ 0.473024] radeon 0000:00:01.0: VRAM: 768M 0x0000000000000000 - 0x000000002FFFFFFF (768M used)
[ 0.473202] radeon 0000:00:01.0: GTT: 1024M 0x0000000030000000 - 0x000000006FFFFFFF
[ 0.473947] [drm] radeon: 768M of VRAM memory ready
[ 0.474051] [drm] radeon: 1024M of GTT memory ready.
[ 0.474277] radeon 0000:00:01.0: Direct firmware load for radeon/ARUBA_pfp.bin failed with error -2
[ 0.474430] ni_cp: Failed to load firmware "radeon/ARUBA_pfp.bin"
[ 0.474631] radeon 0000:00:01.0: Fatal error during GPU init
[ 0.474737] [drm] radeon: finishing device.
[ 0.484522] [drm] radeon: ttm finalized
[ 0.484921] radeon: probe of 0000:00:01.0 failed with error -2

_________________
...and it should be known by now
Back to top
View user's profile Send private message
Tony0945
Advocate
Advocate


Joined: 25 Jul 2006
Posts: 2887
Location: Illinois, USA

PostPosted: Mon Aug 17, 2015 2:22 am    Post subject: Reply with quote

phobos13013 wrote:
] its just that uname still lists a kernel built back in July even though I just rebuilt it. Where is the disconnect?



echo "Don't forget to update boot loader menu"
Back to top
View user's profile Send private message
phobos13013
Apprentice
Apprentice


Joined: 22 Sep 2004
Posts: 255
Location: NOLA

PostPosted: Mon Aug 17, 2015 2:33 am    Post subject: Reply with quote

As in grub2-mkconfig? That is done I am sure it is being installed.... what else is there?
_________________
...and it should be known by now
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum