Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Chromium open uki failed on multiple ati cards
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
s1341r
n00b
n00b


Joined: 29 Jun 2015
Posts: 1

PostPosted: Mon Jun 29, 2015 8:17 am    Post subject: Chromium open uki failed on multiple ati cards Reply with quote

Hi,

I'm using chromium on gentoo amd64. I have two ati display cards driving multiple monitors each. I'm running ati-drivers version 14.12-r3.

When starting chromium (version 44.0.2403.30) I get the following output:
Code:

$ chromium
Xlib:  extension "RANDR" missing on display ":0".
Xlib:  extension "RANDR" missing on display ":0".
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libGL error: open uki failed (Operation not permitted)
libGL error: reverting to (slow) indirect rendering


Chromium seems to work fine so long as its window is on one of the monitors driven by the first ati card. Moving the window to a monitor driven by the second card results in the window being 'garbled'.

This behavior is new (since a recent update). I checked and the behavior is the same when using the binary package google-chrome (version 43.0.2357.130_p).

I tried running with LIBGL_DEBUG set to verbose, and got the following output:
Code:

$ LIBGL_DEBUG=verbose chromium
Xlib:  extension "RANDR" missing on display ":0".
Xlib:  extension "RANDR" missing on display ":0".
libGL: AtiGetClientDriverName: 14.50.2 fglrx (screen 0)
libGL: OpenDriver: trying /usr/lib64/dri/fglrx_dri.so
ukiDynamicMajor: found major device number 249
ukiDynamicMajor: found major device number 249
ukiDynamicMajor: found major device number 249
ukiOpenDevice: node name is /dev/ati/card0
ukiOpenDevice: open result is 14, (OK)
ukiGetBusid returned 'PCI:3:0:0'
ukiOpenDevice: node name is /dev/ati/card1
ukiOpenDevice: open result is 14, (OK)
ukiGetBusid returned 'PCI:4:0:0'
ukiOpenDevice: node name is /dev/ati/card2
ukiOpenDevice: UKI_ERR_NOT_ROOT
ukiOpenDevice: node name is /dev/ati/card3
ukiOpenDevice: UKI_ERR_NOT_ROOT
ukiOpenDevice: node name is /dev/ati/card4
ukiOpenDevice: UKI_ERR_NOT_ROOT
ukiOpenDevice: node name is /dev/ati/card5
ukiOpenDevice: UKI_ERR_NOT_ROOT
ukiOpenDevice: node name is /dev/ati/card6
ukiOpenDevice: UKI_ERR_NOT_ROOT
ukiOpenDevice: node name is /dev/ati/card7
ukiOpenDevice: UKI_ERR_NOT_ROOT
ukiOpenDevice: node name is /dev/ati/card8
ukiOpenDevice: UKI_ERR_NOT_ROOT
ukiOpenDevice: node name is /dev/ati/card9
ukiOpenDevice: UKI_ERR_NOT_ROOT
ukiOpenDevice: node name is /dev/ati/card10
ukiOpenDevice: UKI_ERR_NOT_ROOT
ukiOpenDevice: node name is /dev/ati/card11
ukiOpenDevice: UKI_ERR_NOT_ROOT
ukiOpenDevice: node name is /dev/ati/card12
ukiOpenDevice: UKI_ERR_NOT_ROOT
ukiOpenDevice: node name is /dev/ati/card13
ukiOpenDevice: UKI_ERR_NOT_ROOT
ukiOpenDevice: node name is /dev/ati/card14
ukiOpenDevice: UKI_ERR_NOT_ROOT
ukiOpenDevice: node name is /dev/ati/card15
ukiOpenDevice: UKI_ERR_NOT_ROOT
ukiDynamicMajor: found major device number 249
ukiOpenByBusid: Searching for BusID PCI:3:0:0
ukiOpenDevice: node name is /dev/ati/card0
ukiOpenDevice: open result is 14, (OK)
ukiOpenByBusid: ukiOpenMinor returns 14
ukiOpenByBusid: ukiGetBusid reports PCI:3:0:0
ukiDynamicMajor: found major device number 249
ukiDynamicMajor: found major device number 249
ukiOpenByBusid: Searching for BusID PCI:3:0:0
ukiOpenDevice: node name is /dev/ati/card0
ukiOpenDevice: open result is 15, (OK)
ukiOpenByBusid: ukiOpenMinor returns 15
ukiOpenByBusid: ukiGetBusid reports PCI:3:0:0
ukiDynamicMajor: found major device number 249
ukiDynamicMajor: found major device number 249
ukiOpenByBusid: Searching for BusID PCI:4:0:0
ukiOpenDevice: node name is /dev/ati/card0
ukiOpenDevice: open result is 16, (OK)
ukiOpenByBusid: ukiOpenMinor returns 16
ukiOpenByBusid: ukiGetBusid reports PCI:3:0:0
ukiOpenDevice: node name is /dev/ati/card1
ukiOpenDevice: open result is 16, (OK)
ukiOpenByBusid: ukiOpenMinor returns 16
ukiOpenByBusid: ukiGetBusid reports PCI:4:0:0
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
ukiDynamicMajor: found major device number 249
ukiDynamicMajor: found major device number 249
ukiDynamicMajor: found major device number 249
ukiOpenDevice: node name is /dev/ati/card0
ukiOpenDevice: open result is 23, (OK)
ukiGetBusid returned 'PCI:3:0:0'
ukiOpenDevice: node name is /dev/ati/card1
ukiOpenDevice: open result is 23, (OK)
ukiGetBusid returned 'PCI:4:0:0'
ukiOpenDevice: node name is /dev/ati/card2
ukiOpenDevice: UKI_ERR_NOT_ROOT
ukiOpenDevice: node name is /dev/ati/card3
ukiOpenDevice: UKI_ERR_NOT_ROOT
ukiOpenDevice: node name is /dev/ati/card4
ukiOpenDevice: UKI_ERR_NOT_ROOT
ukiOpenDevice: node name is /dev/ati/card5
ukiOpenDevice: UKI_ERR_NOT_ROOT
ukiOpenDevice: node name is /dev/ati/card6
ukiOpenDevice: UKI_ERR_NOT_ROOT
ukiOpenDevice: node name is /dev/ati/card7
ukiOpenDevice: UKI_ERR_NOT_ROOT
ukiOpenDevice: node name is /dev/ati/card8
ukiOpenDevice: UKI_ERR_NOT_ROOT
ukiOpenDevice: node name is /dev/ati/card9
ukiOpenDevice: UKI_ERR_NOT_ROOT
ukiOpenDevice: node name is /dev/ati/card10
ukiOpenDevice: UKI_ERR_NOT_ROOT
ukiOpenDevice: node name is /dev/ati/card11
ukiOpenDevice: UKI_ERR_NOT_ROOT
ukiOpenDevice: node name is /dev/ati/card12
ukiOpenDevice: UKI_ERR_NOT_ROOT
ukiOpenDevice: node name is /dev/ati/card13
ukiOpenDevice: UKI_ERR_NOT_ROOT
ukiOpenDevice: node name is /dev/ati/card14
ukiOpenDevice: UKI_ERR_NOT_ROOT
ukiOpenDevice: node name is /dev/ati/card15
ukiOpenDevice: UKI_ERR_NOT_ROOT
ukiDynamicMajor: found major device number 249
ukiOpenByBusid: Searching for BusID PCI:3:0:0
ukiOpenDevice: node name is /dev/ati/card0
ukiOpenDevice: open result is 23, (OK)
ukiOpenByBusid: ukiOpenMinor returns 23
ukiOpenByBusid: ukiGetBusid reports PCI:3:0:0
libGL: AtiGetClientDriverName: 14.50.2 fglrx (screen 0)
ukiDynamicMajor: failed to open /proc/ati/major
ukiDynamicMajor: failed to open /proc/ati/major
libGL error: open uki failed (Operation not permitted)
libGL error: reverting to (slow) indirect rendering


I've searched for references to "open uki failed" without success. I'd appreciate any help.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum