Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
gvfs broken, applications take long to load
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
avx
Advocate
Advocate


Joined: 21 Jun 2004
Posts: 2150

PostPosted: Fri Jun 26, 2015 11:49 am    Post subject: gvfs broken, applications take long to load Reply with quote

Some update lately seems to have gone majorly wrong, as pretty much any GUI application (tried: firefox, chromium, gimp, claws, thunar, keepass - keepassx works normally, though) now takes roughly 30s to load until some timeout has been reached, from then on, they work normal until I need to open a filedialog.

Whenever an application finally loads, an entry like these gets added to `dmesg`
Code:
[81969.045867] traps: gvfsd[21759] trap int3 ip:7f62aae65c60 sp:7fffd2f266f0 error:0
[81976.731871] traps: gvfsd[21797] trap int3 ip:7f3e0912fc60 sp:7ffc5a144180 error:0
[82086.824117] traps: gvfsd[21809] trap int3 ip:7f2aba799c60 sp:7ffee1778180 error:0


First I thought it was related to updating the kernel to 4.1, but rolling back to 4.0.4 showed the same problem. I rebuild gvfs and even ran `emerge -e @world`, no change to the positive. The disk itself seems to be fine according to SMART data and a quick self-test, also access via normal shell tools shows no slowdown at all.

Question is, what is broken? The only hint I found on Google is from 2012 and says it's been fixed and was related to gnome-settings daemon not running. I'm using pure FVWM here, ~amd64. Thanks for any help.
_________________
++++++++++[>+++++++>++++++++++>+++>+<<<<-]>++.>+.+++++++..+++.>++.<<+++++++++++++++.>.+++.------.--------.>+.>.
Back to top
View user's profile Send private message
jwm224
Tux's lil' helper
Tux's lil' helper


Joined: 27 May 2015
Posts: 118
Location: Pennsylvania

PostPosted: Fri Jun 26, 2015 12:17 pm    Post subject: Reply with quote

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=696219

I found this in a search. A Debian post: the fix here has to do with gsettings-daemon not running.
This is probably the same post you found...
Back to top
View user's profile Send private message
jwm224
Tux's lil' helper
Tux's lil' helper


Joined: 27 May 2015
Posts: 118
Location: Pennsylvania

PostPosted: Fri Jun 26, 2015 12:25 pm    Post subject: Reply with quote

The dev-libs/glib package that contains gsettings was updated today:
https://packages.gentoo.org/package/dev-libs/glib
Can you roll back to an earlier version of this package?

I could be in left field with this.
Back to top
View user's profile Send private message
avx
Advocate
Advocate


Joined: 21 Jun 2004
Posts: 2150

PostPosted: Fri Jun 26, 2015 12:43 pm    Post subject: Reply with quote

Thanks for the hint, will try merging an older version, will report back in a few minutes.

Edit, seems I need to downgrade and mask quite a few packages to try this, will take me a while to find the inter-deps.

Edit2, seems more complex than I thought, damn interlocked GNOME stuff, all Qt apps work fine as far as I can see. :evil:
_________________
++++++++++[>+++++++>++++++++++>+++>+<<<<-]>++.>+.+++++++..+++.>++.<<+++++++++++++++.>.+++.------.--------.>+.>.
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 6968

PostPosted: Fri Jun 26, 2015 1:24 pm    Post subject: Reply with quote

remind me an old trouble i had with it times ago, at least it's easier to try, just disable udisks useflag and rebuild gvfs
Back to top
View user's profile Send private message
avx
Advocate
Advocate


Joined: 21 Jun 2004
Posts: 2150

PostPosted: Fri Jun 26, 2015 1:31 pm    Post subject: Reply with quote

Quote:
at least it's easier to try, just disable udisks useflag and rebuild gvfs
USE=-udisks is default in my setup, so that's not it.
_________________
++++++++++[>+++++++>++++++++++>+++>+<<<<-]>++.>+.+++++++..+++.>++.<<+++++++++++++++.>.+++.------.--------.>+.>.
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 6968

PostPosted: Fri Jun 26, 2015 1:41 pm    Post subject: Reply with quote

avx wrote:
Quote:
at least it's easier to try, just disable udisks useflag and rebuild gvfs
USE=-udisks is default in my setup, so that's not it.

my next suggest is then look at localhost resolution, i remember delay while app are waiting timeout to fail for some dns resolution.
Back to top
View user's profile Send private message
avx
Advocate
Advocate


Joined: 21 Jun 2004
Posts: 2150

PostPosted: Fri Jun 26, 2015 1:58 pm    Post subject: Reply with quote

How would I test that? SSH to localhost works if that would be a way to test.

From a quick glance through #gentoo it might be that others have the same problem, still crawling through all the unrelated stuff in there, though, so no clue.
_________________
++++++++++[>+++++++>++++++++++>+++>+<<<<-]>++.>+.+++++++..+++.>++.<<+++++++++++++++.>.+++.------.--------.>+.>.
Back to top
View user's profile Send private message
avx
Advocate
Advocate


Joined: 21 Jun 2004
Posts: 2150

PostPosted: Fri Jun 26, 2015 2:22 pm    Post subject: Reply with quote

Took a long time of rebuilding, disecting and try & error, but with

Code:
>dev-libs/glib-2.42.2
>dev-util/gdbus-codegen-2.42
>=net-libs/glib-networking-2.44.0


this in package.mask and rebuilding stuff it works(for now). Still not sure who/what the culprit is...so not reporting a bug, yet.
_________________
++++++++++[>+++++++>++++++++++>+++>+<<<<-]>++.>+.+++++++..+++.>++.<<+++++++++++++++.>.+++.------.--------.>+.>.
Back to top
View user's profile Send private message
SylaSebas
n00b
n00b


Joined: 07 Aug 2013
Posts: 48

PostPosted: Wed Sep 09, 2015 7:17 am    Post subject: Reply with quote

hi there

were you able to resolve the problem? I got the same one since yesterday:

Code:

[   76.514297] traps: gvfsd[2987] trap int3 ip:7fd9052e057a sp:7ffe9a93d5d0 error:0
[   83.522793] traps: gvfsd[2996] trap int3 ip:7f69d32ba57a sp:7ffc2765d210 error:0
[   85.409618] traps: gvfsd[3065] trap int3 ip:7f496f4f057a sp:7ffff3838cc0 error:0
[   87.007991] traps: gvfsd[3094] trap int3 ip:7fd6fed9d57a sp:7ffded5285b0 error:0
[   92.175231] traps: gvfsd[3131] trap int3 ip:7ffbb55b257a sp:7fff005562b0 error:0


from the packages above, I updated from gvfs-1.22.4 to gvfs-1.24.2 and from glib-networking-2.42.1 to glib-networking-2.44.0
gdbus-codegen stayed at version 2.44.1 (since june) and glib at 2.44.1 as well ...

also, I never had gnome-settings-daemon installed at all...

any help with this would be appreciated! :)

thanks so much and best regards
Back to top
View user's profile Send private message
fidel
Guru
Guru


Joined: 16 Jul 2004
Posts: 407
Location: CH

PostPosted: Fri Sep 11, 2015 7:16 am    Post subject: Reply with quote

This problem stll exists! I cannot downgrade - resp. I already begun, resulting in an awful mess, since about everything depends on =dev-libs/glib-2.44.1 (what seems to be the problem). Now my system is not usable any more. Any ideas how to come out there? Does this by incidence have anything to do with consolekit, policykit, udisks, upower... ? Since I have none of those installed and would like to keep it that way, if possible.

Thanks for any hints!
Back to top
View user's profile Send private message
fidel
Guru
Guru


Joined: 16 Jul 2004
Posts: 407
Location: CH

PostPosted: Fri Sep 11, 2015 1:23 pm    Post subject: Reply with quote

Ok, masking gvfs works here, I masked =gnome-base/gvfs-1.24.2 and things are fine again.
Back to top
View user's profile Send private message
SylaSebas
n00b
n00b


Joined: 07 Aug 2013
Posts: 48

PostPosted: Sun Sep 13, 2015 12:53 pm    Post subject: Reply with quote

Well that works! Thank you! :)
Back to top
View user's profile Send private message
HansMeier
n00b
n00b


Joined: 25 Jun 2015
Posts: 8

PostPosted: Fri Sep 18, 2015 5:54 am    Post subject: same issue here - solved - Reply with quote

The hint with masking =gnome-base/gvfs-1.24.2 and remerge gnome-base/gvfs (gives: 1.22.4) works fine.
The system is now usable again.

Thanks
Back to top
View user's profile Send private message
berferd
Tux's lil' helper
Tux's lil' helper


Joined: 13 May 2004
Posts: 95

PostPosted: Sun Nov 01, 2015 10:44 pm    Post subject: Reply with quote

FWIW, enabling the udisks use flag fixed this problem for me as well. This thread is useful if you're thinking about taking this approach:

https://forums.gentoo.org/viewtopic-t-956642.html
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum