Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KRDC no longer working for RDP?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
The_Great_Sephiroth
Veteran
Veteran


Joined: 03 Oct 2014
Posts: 1342
Location: Fayetteville, NC, USA

PostPosted: Fri Jun 19, 2015 5:58 pm    Post subject: KRDC no longer working for RDP? Reply with quote

I updated a while back and since then KRDC has not worked for my RDP connections. It allows me to enter my credentials then sits on a blue screen. Using the core "rdesktop" command from the command-line works flawlessly. I have found threads on other forums about this exact issue, but it is supposedly fixed by 4.13. This may not be the case in Gentoo. A thread I found on another forum (Slackware IIRC) stated that either KRDC or FreeRDP had changed the way parameters were used and that was the issue. A patch was provided for that distro and all was good. I will try to find the thread again. In the meantime, what is going on here?
Code:

krdc -v
Qt: 4.8.6
KDE Development Platform: 4.14.8
KRDC: 4.14.3

rdesktop
rdesktop: A Remote Desktop Protocol client.
Version 1.8.3. Copyright (C) 1999-2011 Matthew Chapman et al.
See http://www.rdesktop.org/ for more information.

So what should I look at next? KRDC was built with the "rdesktop" USE flag.
_________________
Ever picture systemd as what runs "The Borg"?
Back to top
View user's profile Send private message
mrbassie
Guru
Guru


Joined: 31 May 2013
Posts: 525

PostPosted: Sun Jun 21, 2015 2:58 pm    Post subject: Reply with quote

Works perfectly for me. Same version.

If you're connecting to a domain try
Code:
domain\user\ip-address
in the address field.

I have had connections which stopped working.
Back to top
View user's profile Send private message
Sharp_Rulez
n00b
n00b


Joined: 17 Sep 2006
Posts: 34

PostPosted: Sun Jul 19, 2015 5:18 pm    Post subject: Reply with quote

Actually, I was struggling with the same issue here.

First, it turns out that KRDC stopped to use rdesktop, so i realized that testing rdesktop wouldnt not help. So even though KRDC was built with +rdesktop, it doesnt use it but use freerdb instead.

Then i put krdc in debugmode via kdebugdialog, and started krdc in command line. I realize that it didnt built up the command line for freerdp correctly.

After playing around i saw that the issue was related with the sound output.

If I pick "remote sound", than the command line is fine and it is working; however most of the time, i use "disable sound" as I dont want to transfer audio eitherway, which generates a buggy commandline:

Code:

krdc(25273)/krdc (RDP backend) RdpView::start: Is LDAP login: true "dom\user.name"
krdc(25273)/krdc (RDP backend) RdpView::start: Starting xfreerdp with arguments: ("-decorations", "/w:1680", "/h:1050", "/kbd:0x00000409", "/d:dom", "/u:user.name", "/parent-window:8388645", "/bpp:16", "udio-mode:", "/network:broadband", "/rfx", "/cert-ignore", "/clipboard", "/port:3389", "/v:IP.ADDR")


Look at the "udio-mode:" (the "a" of audio is missing).

This is therefore truly a KRDC bug here.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum