Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
font_gentoo problem.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
ryokashi
n00b
n00b


Joined: 15 Jun 2015
Posts: 16

PostPosted: Fri Jun 19, 2015 7:07 am    Post subject: font_gentoo problem. Reply with quote

while trying to solve old problems newly appear- fonts. repository have sazanami and vlgothic. but when emerge they did not show japan keymaps and symbols, not standart nor gothic. none of this can be displayed when typing and in browser tabs. how to set japan layout with this fonts? and, bonus task- is it true, that terminus does not set as default font for all network webpages in java.css (need to change font in pages and in interface browser, lynx will work, i shure, but what about qt or webkit browsers)? maybe someone know very similar font to terminus, which can be set to pages.

Last edited by ryokashi on Fri Jun 19, 2015 6:39 pm; edited 1 time in total
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7901
Location: ~Brussels - Belgique

PostPosted: Fri Jun 19, 2015 12:06 pm    Post subject: Reply with quote

Hi!

Would you please create meaningful thread titles?
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
AndrewAmmerlaan
Tux's lil' helper
Tux's lil' helper


Joined: 25 Jun 2014
Posts: 143
Location: Lent

PostPosted: Fri Jun 19, 2015 2:38 pm    Post subject: Reply with quote

If I understand correctly you want to use a certain font, you could use fontconfig for that (eselect fontconfig), after you have emerged that font of course, for more information: https://wiki.gentoo.org/wiki/Fontconfig
Also some applications use separate settings, so you should set those in the config for that application.
_________________
OS: Gentoo KDE x86_64 (~amd64, 4.20.7-gentoo)
MB: MSI Z370-A PRO
CPU: Intel Core i7-8700K
GPU: NVIDIA GTX 1060 6GB & Intel UHD Graphics 630
SSD: Samsung 970 Pro 512GB
RAM: Crucial Ballistix 32GB DDR4-2400
Back to top
View user's profile Send private message
ryokashi
n00b
n00b


Joined: 15 Jun 2015
Posts: 16

PostPosted: Fri Jun 19, 2015 6:48 pm    Post subject: Reply with quote

AndrewAmmerlaan wrote:
If I understand correctly you want to use a certain font, you could use fontconfig for that (eselect fontconfig), after you have emerged that font of course, for more information: https://wiki.gentoo.org/wiki/Fontconfig
Also some applications use separate settings, so you should set those in the config for that application.



eh, if all was so easy. first of all i like terminus. in that case not opera nor another cannot set this as a basic-main for all pages. in gtk-applications like geany- you cannot set terminus as main in titles and buttons. arial- ok, but not terminus. and, even in console you can set this, but need to set sazanami- to write with 期. it can not. that is the problem.
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6193

PostPosted: Fri Jun 19, 2015 7:27 pm    Post subject: Reply with quote

First of all, the original poster needs to work on their English.
Second, while I don't know the language, I'm partial to media-fonts/ipamonafont.

Now, let's try to figure out what the question is...
OP seems to misunderstand how fontconfig works. Well, that's not that bad, rarely anyone goes beyond basics (and that's pretty much how it should work).
As long as the webpage is properly written (that is has encoding information), any qt/gtk+ based browser should display it correctly.

Therefore, unlike in the usual case, some screenshots might be useful. Also, a more detailed description of what the problem is and how is it triggered is necessary.
Back to top
View user's profile Send private message
ryokashi
n00b
n00b


Joined: 15 Jun 2015
Posts: 16

PostPosted: Fri Jun 19, 2015 10:16 pm    Post subject: Reply with quote

VoidMage wrote:
First of all, the original poster needs to work on their English.
Second, while I don't know the language, I'm partial to media-fonts/ipamonafont.

Now, let's try to figure out what the question is...
OP seems to misunderstand how fontconfig works. Well, that's not that bad, rarely anyone goes beyond basics (and that's pretty much how it should work).
As long as the webpage is properly written (that is has encoding information), any qt/gtk+ based browser should display it correctly.

Therefore, unlike in the usual case, some screenshots might be useful. Also, a more detailed description of what the problem is and how is it triggered is necessary.



so, example. start system. set xkbmap layout to japan (jp) language. in terminal it looks like this-
http://s10.postimg.org/4u7sx1awn/2015_06_20_010149_3046x1050_scrot.png
you see- very close to each other and not as https://encrypted-tbn0.gstatic.com/images?q=tbn:ANd9GcROxu0hWEJJ9gLMJ-9kKECsuDEk8T-Mr0ftDwV-ZUL0pDPCNEoVq7WWkmk . so need to change font or size or i do not know what. the second-fontconfig setting to terminus make globally mistake- it is set font to small size, so all letters are fully unvisible (in conky, calendar, rss news). not cancelled, even after remove programm. and, third- opera browser. headlines of sites, tabs, config elements- not set to terminus (arial yes, even vlgothic- but without gothics venzels and symbols).
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6193

PostPosted: Sat Jun 20, 2015 9:55 am    Post subject: Reply with quote

To make a certain detail clear:

  • 日本語
  • 攻略


(OK, that's a bit random :shrug:)

So, I don't know the language - doesn't mean I don't know what I'm talking about.

Anyway, I don't see how screenshot one relates to screenshot two.
The OP is confusing locale, input keymap and fonts.
As for console vs xserver, that's somewhat painful and a topic I haven't really touched (on console side of the problem) wrt. CJK (though as long as locale is properly set, at least kana in console shouldn't be all that hard to get).

So:
- what is your locale ?
- which IME are you using/planing to use ?

Also, yes, the default font size in most browsers is a bit too small for kanji to be readable, but that's a completely different matter.
Back to top
View user's profile Send private message
tclover
Guru
Guru


Joined: 10 Apr 2011
Posts: 516

PostPosted: Sat Jun 20, 2015 10:43 am    Post subject: Reply with quote

Come on VoidMage... try to help instead of...

First, as VoidMage rightly put it, you should not confuse font, keymap and locale settings because there're really different things.

Second, it seems you want to be able to have use East Asian locales, fonts and keymaps. You should first set up bidi, cjk and unicode USE flags globally in `/etc/portage/make.conf'. See this topic about the use flags and fonts for more info.
/etc/portage/make.conf:
USE="[...] bidi cjk unicode [...]

And then rebuild the appropriate packages with `emerge -avDN @world' for your changes to have some effect.

Third, you should set up the locales accordingly by editing `/etc/locale.gen'.
/etc/locale.gen:
en_GB ISO-8859-1
en_GB ISO-8859-1
en_US.UTF-8 UTF-8
en_US.UTF-8 UTF-8
ja_JP.EUC-JP EUC-JP
ja_JP.UTF-8 UTF-8
ja_JP EUC-JP
# et al.

And then generate the locales accordingly with running `locale-gen' as root.

The keymap is entirely a different thing... if you're using OpenRC you can set up console font and keymap with `/etc/conf.d/{consolefont,keymaps}'. Do not forget to set up an utf-8 compatible font to be able to get Asian glyphs displayed properly in the console. Virtual terminal such as Rxvt-nicode or XTerm pick the font to use with... with `~/.Xresources'. You can find many resources online like wiki. And Terminus packages has many localazied font that support particular glyphs. Check this out if necessary.
When being in X session, simplest way to change keymap reliably and independently from Desktop Environment is... using `xsetxkbmap' like
~/.xinit:
setxkbmap -model pc105 -layout fr -variant ,oss,latin9,oss_latin9 \
   -option grp:shift_caps_toggle,keypad:future,terminate:ctrl_alt_bksp

or
/etc/X11/xorg.conf.d/30-keyboard.conf:
Section "InputClass"
   Identifier "Keyboard"
   Driver "evdev"
   MatchIsKeyboard "True"
   Option "XkbRules" "xfree86"
   Option "XkbModel" "pc102"
   Option "XkbLayout" "fr"
   Option "XkbVariant" ",oss,latin9,oss_latin9"
   Option "XkbOptions" "grp:shift_caps_toggle,keypad:future,terminate:ctrl_alt_bksp"
EndSection

to be able to switch smoothly your usual layout with ease.

Last, but not least, is the font configuration settings. You should use infinality USE flag in order to have good looking anti-aliased fonts. You may add cleartype, fontconfig and truetype in your global USE flags in `/etc/portage/make.conf'. There various threads in the forums for that and maybe a wiki page. This last step is not necessary because your issue is locale settings... first.
_________________
home/:mkinitramfs-ll/:supervision/:e-gtk-theme/:overlay/
Back to top
View user's profile Send private message
ryokashi
n00b
n00b


Joined: 15 Jun 2015
Posts: 16

PostPosted: Sat Jun 20, 2015 6:51 pm    Post subject: Reply with quote

tclover wrote:

Last, but not least, is the font configuration settings. You should use infinality USE flag in order to have good looking anti-aliased fonts. You may add cleartype, fontconfig and truetype in your global USE flags in `/etc/portage/make.conf'. There various threads in the forums for that and maybe a wiki page. This last step is not necessary because your issue is locale settings... first.



see, yours see what i see- http://postimg.org/image/al4vj823n/full/ in upper corner dwm. on place,where tabs- not work japan symbols. and, some space down you see conky- works japan only with vlgothic font. but me needs terminus. it is first part.
remerge dwm and terminal with USE truetype and clearype. add near 388 locales. as a result adds new fonts. but in terminal. command:
setxkbmap -layout gb,am,jp -option grp:caps_toggle
work only gb and sometimes am. jp is not start to type symbols at all. make the default font vlgothic (definitely-it is japan font) . but nothing. maybe my laptop is badly old or maybe have to delete all others font, purge all locales not-needles, but on today have not power to find the answer (at last try to start xsession with asian language config). auch, almost forget- in opera (you know old-gtk browser) it is unmighty to change interface elements and pages font to terminus. as maximum- can make .css with colors and opacity, but change to terminus- nope...
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6193

PostPosted: Sat Jun 20, 2015 8:08 pm    Post subject: Reply with quote

@tclover: a few points:
- I see infinality as tinkering for tinkering sake
- unless the OP is planing to use terms like xterm, it will either be something vte or Qt based, so were back to fontconfig (making anything .Xresources related nice to know, but not all that useful)
- as for your xorg conf snippet, you do remember XkbRules value is meaningless with evdev driver ? (and while there was also path filtering, but IIRC most recent versions already reject anything not /dev/input/event*)
- 'cjk' flag isn't really all that helpful in most of the cases and 'bidi' is for RTL text, which doesn't really cover Japanese (unless you count vertical writing, which isn't really bidi)

@ryokashi: that screenshot is somewhat interesting, just not quite in the way you expect.
That upper left corner is almost certainly an encoding (so a locale) problem.
But what's more interesting is that text output on top...
How exactly do you produce it, so that 'reflection none' string sometimes ends with properly displayed string and sometimes with missing glyph boxes ?
Also, FFS, post output of 'locale' (and given your tinkering, just to be safe, 'locale charmap' too)
Back to top
View user's profile Send private message
stephan-t
Tux's lil' helper
Tux's lil' helper


Joined: 12 May 2014
Posts: 118

PostPosted: Sun Jun 21, 2015 2:19 pm    Post subject: Reply with quote

You need edit the font mapping. However want use terminal font in bar, put some glyph into this font with tool like gucharmap. Original dwm, cannot show some unicode block please add the pango patch.
Back to top
View user's profile Send private message
ryokashi
n00b
n00b


Joined: 15 Jun 2015
Posts: 16

PostPosted: Mon Jun 29, 2015 7:29 pm    Post subject: Reply with quote

stephan-t wrote:
You need edit the font mapping. However want use terminal font in bar, put some glyph into this font with tool like gucharmap. Original dwm, cannot show some unicode block please add the pango patch.


so, was some time not with my baby...and now try gucharmap. suggest to add symbols to fonts? hm, it is not helps to put this font in gtk application like opera. terminus in web-pages not work at all- maybe this font is not-for-all-language nor xft. and with pango- patch is small problem- have not directory with sources dwm. wget it, the --enable savedconfig, so have not brains where to put patch in config.h. and not sure that ja symbols is part of unicode. definitelly it is, but symbols like arrows, colorful tildas- hard to connect to panel. will try the patch on another system- maybe it is help. have an idea- maybe try to use ansi patch or xft in dwm? try all variants. it is about first. and about second- fonts in non-ncurses apps and ja layouts- is pango helps? me think not. even armenian language is right seen in terminal, but not japan. their symbols do bang-puf and dissapeared from console. bad day...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum