Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
failed media-libs/libvpx on ARM (neon)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
shimitar
Apprentice
Apprentice


Joined: 23 Nov 2003
Posts: 274
Location: Italy, Torino

PostPosted: Thu Jun 18, 2015 12:23 pm    Post subject: failed media-libs/libvpx on ARM (neon) Reply with quote

On my ARM tablet (it's an asus tf700t based on NVIDIA Tegra3) i am trying to emerge Chromium, which in turn requires media-libs/libvpx, which fails due to this error:

Code:

#error You must enable NEON instructions (e.g. -mfloat-abi=softfp -mfpu=neon) to use arm_neon.h


Well, is this a bug in the package or what?
My CPU is neon capable, maybe i need a different setting to enable neon systemwide?
Or can i disable neon for this package? There is no neon flag for it...
_________________
Willy Gardiol
willy@gardiol.org
Back to top
View user's profile Send private message
shimitar
Apprentice
Apprentice


Joined: 23 Nov 2003
Posts: 274
Location: Italy, Torino

PostPosted: Thu Jun 18, 2015 10:54 pm    Post subject: Reply with quote

In make.conf changing the CFLAGS --fpu=neon seems to have solved this.

Now i need to find out if i need to rebuild all the system or it's safe to keep it...
_________________
Willy Gardiol
willy@gardiol.org
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum