Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved]Fonts in kde look terrible
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
grooveman
Veteran
Veteran


Joined: 24 Feb 2003
Posts: 1166

PostPosted: Thu Jun 18, 2015 12:45 am    Post subject: [Solved]Fonts in kde look terrible Reply with quote

Hi, I upgrade the other day, and ever since then, my fonts in KDE look awful. They are gray (grey) and wispy... barely legible in the terminal and in the GUI. It seems to affect all my QT apps.

I have these QT packages installed:
Code:
[ebuild   R    ] dev-qt/qtchooser-0_p20150102
[ebuild   R    ] app-eselect/eselect-qtgraphicssystem-1.1.1
[ebuild   R    ] x11-themes/gtk-engines-qtpixmap-0.28-r2
[ebuild   R    ] dev-qt/qtcore-4.8.6-r2
[ebuild   R    ] dev-qt/qtdbus-4.8.6-r1
[ebuild   R    ] dev-qt/qtscript-4.8.6-r2
[ebuild   R    ] dev-qt/qtsql-4.8.6-r1
[ebuild   R    ] dev-qt/qttest-4.8.6-r1
[ebuild   R    ] dev-qt/qtxmlpatterns-4.8.6-r1
[ebuild   R    ] dev-qt/qttranslations-4.8.6-r1
[ebuild   R    ] dev-qt/qtgui-4.8.6-r4
[ebuild   R    ] dev-qt/qt3support-4.8.6-r1
[ebuild   R    ] dev-qt/qtsvg-4.8.6-r1
[ebuild   R    ] dev-qt/qtwebkit-4.8.6-r1
[ebuild   R    ] dev-qt/qtopengl-4.8.6-r1
[ebuild   R    ] dev-libs/libdbusmenu-qt-0.9.2
[ebuild   R    ] sys-auth/polkit-qt-0.112.0-r1
[ebuild   R    ] dev-qt/designer-4.8.6-r1
[ebuild   R    ] dev-qt/qtdeclarative-4.8.6-r1
[ebuild   R    ] media-libs/qt-gstreamer-1.2.0
[ebuild   R    ] media-video/qt-recordmydesktop-0.3.8-r2
[ebuild   R    ] kde-apps/kqtquickcharts-4.14.3


I tried upping my fontconfig to fontconfig-2.11.93, but that didn't help.

Anyone else having this issue? Any suggestions?

Thanks!

G

Code:
Portage 2.2.18 (python 2.7.9-final-0, default/linux/amd64/13.0, gcc-4.8.4, glibc-2.20-r2, 3.18.12-gentoo x86_64)
=================================================================
System uname: Linux-3.18.12-gentoo-x86_64-Intel-R-_Core-TM-_i7-4790K_CPU_@_4.00GHz-with-gentoo-2.2
KiB Mem:    16269540 total,  13913528 free
KiB Swap:    8388604 total,   8388604 free
Timestamp of repository gentoo: Tue, 16 Jun 2015 03:30:01 +0000
sh bash 4.3_p33-r2
ld GNU ld (Gentoo 2.24 p1.4) 2.24
app-shells/bash:          4.3_p33-r2::gentoo
dev-lang/perl:            5.20.2::gentoo
dev-lang/python:          2.7.9-r1::gentoo, 3.3.5-r1::gentoo
dev-util/cmake:           3.2.2::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.16.4::gentoo
sys-apps/sandbox:         2.6-r1::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo
sys-devel/automake:       1.11.6-r1::gentoo, 1.14.1::gentoo
sys-devel/binutils:       2.24-r3::gentoo
sys-devel/gcc:            4.8.4::gentoo
sys-devel/gcc-config:     1.7.3::gentoo
sys-devel/libtool:        2.4.6::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 3.18::gentoo (virtual/os-headers)
sys-libs/glibc:           2.20-r2::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* @EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -mtune=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"                   
CXXFLAGS="-march=native -mtune=native -O2 -pipe"                                                                                                                                   
DISTDIR="/usr/portage/distfiles"                                                                                                                                                   
FCFLAGS="-O2 -pipe"                                                                                                                                                                 
FEATURES="assume-digests binpkg-logs buildpkg config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"                                                                               
FFLAGS="-O2 -pipe"                                                                                                                                                                 
GENTOO_MIRRORS="http://distfiles.gentoo.org"                                                                                                                                       
LANG="en_US.UTF-8"                                                                                                                                                                 
LDFLAGS="-Wl,-O1 -Wl,--as-needed"                                                                                                                                                   
MAKEOPTS="-j7"                                                                                                                                                                     
PKGDIR="/usr/portage/packages"                                                                                                                                                     
PORTAGE_CONFIGROOT="/"                                                                                                                                                             
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"                                                                                                                                       
PORTAGE_TMPDIR="/var/tmp"                                                                                                                                                           
USE="X acl amd64 berkdb bindist bluray bzip2 cleartype cli corefonts cracklib crypt cxx dri dvd ffmpeg fortran fuse gdbm iconv mmx mmxext modules multilib ncurses nls nptl nvidia opengl openmp pam pcre pulseaudio qt3support readline samba session spell sse sse2 ssl tcpd truetype type1 unicode zlib" ABI_X86="32 64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en_US en" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

_________________
To look without without looking within is like looking without without looking at all.


Last edited by grooveman on Sat Jun 27, 2015 1:16 pm; edited 1 time in total
Back to top
View user's profile Send private message
grooveman
Veteran
Veteran


Joined: 24 Feb 2003
Posts: 1166

PostPosted: Sat Jun 27, 2015 1:15 pm    Post subject: Reply with quote

I did fix this, though I'm not sure which tactic fixed it. I did an eselect fontconfig set 25, and re-installed my fontconfig package... now things are back to normal. I really think it was the eselect that got it, since changing my fontconfig package alone didn't seem to help.
_________________
To look without without looking within is like looking without without looking at all.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum