Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Seamonkey: antialias when sites can use other fonts (Solved)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Logicien
Veteran
Veteran


Joined: 16 Sep 2005
Posts: 1360
Location: Montréal

PostPosted: Wed Jun 17, 2015 3:51 pm    Post subject: Seamonkey: antialias when sites can use other fonts (Solved) Reply with quote

Since many years I use Seamonkey and the same amount of time to search how I can resolv the issue that, if I do not allow sites to use other fonts than the ones I have configure in the Seamonkey Preferences, some figurines and icons on sites are not displayed.

When I do not allow sites to use other fonts than the one I have configure in the Seamonkey Preferences, all and only my configured fonts are displayed on all sites and more important, they are all antialiased.
Doing so, some figurines and icons are not displayed because I do not allow sites to use others fonts.

If I allow sites to use other fonts than the one I have configure in the Seamonkey Preferences, some sites use fonts that are not antialiased but all figurines and icons are displayed properly. What I want is to have antialiased fonts on all sites, even if they are not the ones I have configure in the Seamonkey Preferences and have all figurines and icons displayed properly on all sites.

Firefox have the same problem. Some browsers like QupZilla who use Webkit give me what I want. Unfortunately, QupZilla don't include an email program like Seamonkey.

I have seen that there is an addon module for Firefox related with antialias or hinting, but for Seamonkey I see none.

I use infinality-ultimate-meta. It work well but cannot force antialiasing in Seamonkey.
_________________
Paul


Last edited by Logicien on Thu Jun 25, 2015 5:42 pm; edited 1 time in total
Back to top
View user's profile Send private message
lost+found
Guru
Guru


Joined: 15 Nov 2004
Posts: 508
Location: North~Sea~Coa~s~~t~~~

PostPosted: Wed Jun 17, 2015 5:19 pm    Post subject: Reply with quote

Hi,

I also use Seamonkey. I didn't change any font settings in Seamonkey directly. Do you already have Fontconfig configured? The looks of the fonts greatly improved for me, by playing with the Fontconfig settings and install some popular fonts. What's best might be different for your monitor/used fonts. Some fonts need a different hinting setting (see overrides), or they will look awfull. I just have put this config in my $HOME:

~/.fonts.conf --> ~/.config/fontconfig/fonts.conf:
Code:
<?xml version='1.0'?>
<!DOCTYPE fontconfig SYSTEM 'fonts.dtd'>
<fontconfig>
 <match target="font">
  <edit mode="assign" name="rgba">
   <const>rgb</const>
  </edit>
 </match>
 <match target="font">
  <edit mode="assign" name="lcdfilter">
   <!-- lcdnone, lcddefault, lcdlight, lcdlegacy -->
   <const>lcddefault</const>
  </edit>
 </match>
 <match target="font">
  <edit mode="assign" name="hinting">
   <bool>true</bool>
  </edit>
 </match>
 <match target="font">
  <edit mode="assign" name="hintstyle">
   <!-- hintnone, hintslight, hintmedium, hintfull -->
   <const>hintmedium</const>
  </edit>
 </match>
 <match target="font">
  <edit mode="assign" name="antialias">
   <bool>true</bool>
  </edit>
 </match>
 <!-- overrides -->
 <match target="font">
  <test name="family">
   <string>Helvetica</string>
  </test>
  <edit mode="assign" name="hintstyle">
   <const>hintslight</const>
  </edit>
 </match>
 <match target="font">
  <test name="family">
   <string>Helvetica Neue</string>
  </test>
  <edit mode="assign" name="hintstyle">
   <const>hintslight</const>
  </edit>
 </match>
</fontconfig>


These truetype fonts were emerged:
media-fonts/corefonts without tahoma USE flag (Tahoma bold is missing, and the artificially created Tahoma bold looks bad)
media-fonts/dejavu
media-fonts/liberation-fonts

Code:
# eselect fontconfig list
Available fontconfig .conf files (* is enabled):
  [1]   10-autohint.conf
  [2]   10-no-sub-pixel.conf
  [3]   10-scale-bitmap-fonts.conf *
  [4]   10-sub-pixel-bgr.conf
  [5]   10-sub-pixel-rgb.conf
  [6]   10-sub-pixel-vbgr.conf
  [7]   10-sub-pixel-vrgb.conf
  [8]   10-unhinted.conf
  [9]   11-lcdfilter-default.conf
  [10]  11-lcdfilter-legacy.conf
  [11]  11-lcdfilter-light.conf
  [12]  20-unhint-small-dejavu-sans-mono.conf
  [13]  20-unhint-small-dejavu-sans.conf
  [14]  20-unhint-small-dejavu-serif.conf
  [15]  20-unhint-small-vera.conf *
  [16]  25-unhint-nonlatin.conf
  [17]  30-metric-aliases.conf *
  [18]  30-urw-aliases.conf *
  [19]  40-nonlatin.conf *
  [20]  45-latin.conf *
  [21]  49-sansserif.conf *
  [22]  50-user.conf *
  [23]  51-local.conf *
  [24]  57-dejavu-sans-mono.conf
  [25]  57-dejavu-sans.conf
  [26]  57-dejavu-serif.conf
  [27]  60-latin.conf *
  [28]  60-liberation.conf *
  [29]  65-fonts-persian.conf *
  [30]  65-khmer.conf
  [31]  65-nonlatin.conf *
  [32]  69-unifont.conf *
  [33]  70-no-bitmaps.conf
  [34]  70-yes-bitmaps.conf
  [35]  80-delicious.conf *
  [36]  90-synthetic.conf *
  [37]  99pdftoopvp.conf


I've put these Apple fonts in /usr/local/share/fonts/ttf-mac-fonts:
CourierBoldOblique.ttf
CourierBold.ttf
CourierOblique.ttf
Courier.ttf
Geneva.ttf
HelveticaBoldOblique.ttf
HelveticaBold.ttf
HelveticaLightOblique.ttf
HelveticaLight.ttf
HelveticaNeueBoldItalic.ttf
HelveticaNeueBold.ttf
HelveticaNeueCondensedBlack.ttf
HelveticaNeueCondensedBold.ttf
HelveticaNeueItalic.ttf
HelveticaNeueLightItalic.ttf
HelveticaNeueLight.ttf
HelveticaNeueMedium.ttf
HelveticaNeue.ttf
HelveticaNeueUltraLightItalic.ttf
HelveticaNeueUltraLight.ttf
HelveticaOblique.ttf
Helvetica.ttf
LucidaGrande.ttc
MarkerFelt.ttc
Menlo.ttc
Monaco.ttf
Symbol.ttf
ThonburiBold.ttf
Thonburi.ttf
TimesBoldItalic.ttf
TimesBold.ttf
TimesItalic.ttf
TimesRoman.ttf
ZapfDingbats.ttf

These *.ttf versions were manually created from the downloaded *.dfont files, with media-gfx/fondu or media-gfx/fontforge. Some bold fonts have a wrong setting. I fixed it with Fontforge (Element --> Font info...): if the OS/2 Weight Class says `700 Bold' I've put `Bold' in PS Names Weight.

On one box with a smaller monitor, I use Helvetica as default sans serif font. It seems that DejaVu Sans is normally picked by fontconfig when it's installed, but that one takes more space. I've added this to fonts.conf to change the order of preference (sites can override it by css style sheets):
Code:
 <alias>
  <family>sans-serif</family>
  <prefer>
   <family>Helvetica</family>
   <family>DejaVu Sans</family>
   <family>Bitstream Vera Sans</family>
   <family>Luxi Sans</family>
   <family>Nimbus Sans L</family>
   <family>Arial</family>
   <family>Albany AMT</family>
   <family>Verdana</family>
   <family>Lucida Sans Unicode</family>
   <family>BPG Glaho International</family> <!-- lat,cyr,arab,geor -->
   <family>Tahoma</family> <!-- lat,cyr,greek,heb,arab,thai -->
  </prefer>
  <default><family>Helvetica</family></default>
 </alias>
Back to top
View user's profile Send private message
Logicien
Veteran
Veteran


Joined: 16 Sep 2005
Posts: 1360
Location: Montréal

PostPosted: Thu Jun 25, 2015 5:37 pm    Post subject: Reply with quote

The solution is to enable infinality for linux with eselect.
_________________
Paul
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum