Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
fontconfig (or firefox) - small fonts are displayed too thin
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
totony
n00b
n00b


Joined: 03 Dec 2014
Posts: 40

PostPosted: Wed Jun 17, 2015 6:50 am    Post subject: fontconfig (or firefox) - small fonts are displayed too thin Reply with quote

Hi,

I have been trying to set up my options for fontconfig. Everything looks fine, but small fonts are displayed weirdly (i.e. they are too thin/hardly visible).
This happens in the following screenshot (for now, it only seems to happen in firefox, so maybe it is firefox-related?):
http://i.imgur.com/OABzml3.png

Notice the developer tools and the code tag on the wiki? It looks very dark compared to the rest of the page.
On my Windows computer, the characters are visible very well, they appear clearer and brighter than in this screenshot.

Does someone know what option I could set to make it display small fonts better, or less crisp?

For the moment I use:
- Sub-pixel rendering (rgb according to my display)
- lcdfilter-light
- hinting style hintmedium

I tried playing with removing sub-pixel rendering and changing the filter and the hinting style, but to no avail.
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2583

PostPosted: Wed Jun 17, 2015 7:59 am    Post subject: Re: fontconfig (or firefox) - small fonts are displayed too Reply with quote

totony wrote:
This happens in the following screenshot (for now, it only seems to happen in firefox, so maybe it is firefox-related?):
http://i.imgur.com/OABzml3.png

Check your firefox font settings.
Back to top
View user's profile Send private message
totony
n00b
n00b


Joined: 03 Dec 2014
Posts: 40

PostPosted: Wed Jun 17, 2015 11:40 pm    Post subject: Reply with quote

Thank you, turns out firefox is bad at displaying the Nimbus Mono L font, so for those who get the same problem you need to either change the Mono font in the firefox settings (as proposed by charles) or use the following snippet in your fontconfig configuration file:
Code:
<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
  <alias>
    <family>monospace</family>
    <prefer>
      <family>Ubuntu Mono</family>
    </prefer>
  </alias>
</fontconfig>

This will set the prefered font for monospace fonts to ubuntu mono.

You can get a list of mono fonts using fc-list | grep -i mono
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum