Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
pc freezes when "power saving black screen" comes
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5  Next  
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
polle
Veteran
Veteran


Joined: 28 Feb 2003
Posts: 1498
Location: Belgium

PostPosted: Wed Sep 29, 2004 4:06 pm    Post subject: Reply with quote

before your emerge give this command:
setterm -blank 0
this disables the screensaver in your console, look if you have still problems
Back to top
View user's profile Send private message
Quasimoto
n00b
n00b


Joined: 30 Sep 2004
Posts: 2

PostPosted: Thu Sep 30, 2004 6:35 pm    Post subject: Reply with quote

I have the same problem exactly. I then did the setterm -blank 0 and things are perfect now, thanks polle.
Back to top
View user's profile Send private message
neogen
Apprentice
Apprentice


Joined: 10 Oct 2004
Posts: 163

PostPosted: Sun Oct 17, 2004 12:50 am    Post subject: monitor goes on standby Reply with quote

does anyone know how to remove the monitor standby thing,
you know like when not doing anything on your linux box for say about 10 min or so, the monitor turn black and go on standby?

i hate it when its doin that while im emerging something and it take a while to finish, and the monitor goes on standby.
Back to top
View user's profile Send private message
timezone
n00b
n00b


Joined: 07 Sep 2004
Posts: 31
Location: IA

PostPosted: Sun Oct 17, 2004 1:28 am    Post subject: Reply with quote

Look through your menu for a screensaver program and disable the screesaver altogether.
Back to top
View user's profile Send private message
neogen
Apprentice
Apprentice


Joined: 10 Oct 2004
Posts: 163

PostPosted: Sun Oct 17, 2004 6:16 am    Post subject: Reply with quote

plz be more specific, im still a noob hea, thanks, so could u walk me thru this, or at least tell me exactly where to start looking.
Back to top
View user's profile Send private message
Earthwings
Administrator
Administrator


Joined: 14 Apr 2003
Posts: 7753
Location: Karlsruhe, Germany

PostPosted: Sun Oct 17, 2004 7:12 am    Post subject: Reply with quote

http://www.gentoo.org/doc/en/power-management-guide.xml#doc_chap4

If you're using KDE, there are options to control the different timeouts as well.
Back to top
View user's profile Send private message
neogen
Apprentice
Apprentice


Joined: 10 Oct 2004
Posts: 163

PostPosted: Sun Oct 17, 2004 5:32 pm    Post subject: Reply with quote

Quote:
Please notice that this guide describes Power Management for laptops. While some sections might also suite for servers, others do not and may even cause harm. Please do not apply anything from this guide to a server unless you really know what you are doing.


this was taken from the site provided above, im not using a laptop, but a desktop pc, and working with a normal monitor, not LCD, will this guide work with normal monitor?
Back to top
View user's profile Send private message
Earthwings
Administrator
Administrator


Joined: 14 Apr 2003
Posts: 7753
Location: Karlsruhe, Germany

PostPosted: Sun Oct 17, 2004 6:14 pm    Post subject: Reply with quote

neogen wrote:
Quote:
Please notice that this guide describes Power Management for laptops. While some sections might also suite for servers, others do not and may even cause harm. Please do not apply anything from this guide to a server unless you really know what you are doing.


this was taken from the site provided above, im not using a laptop, but a desktop pc, and working with a normal monitor, not LCD, will this guide work with normal monitor?

The following part works for normal monitors:
Quote:

First thing to check is the standby/suspend/off timings of the display. As this depends heavily on your windowmanager, I'll let you figure it out yourself. Just two common places: Blanking the terminal can be done with setterm -blank <number-of-minutesM>, setterm -powersave on and setterm -powerdown <number-of-minutesM>. For Xorg, modify /etc/X11/xorg.conf similar to this:

Code Listing 4.1: LCD suspend settings in Xorg and XFree86
Code:

Section "ServerLayout"
  Identifier  [...]
  [...]
  Option  "BlankTime"  "5"  # Blank the screen after 5 minutes (Fake)
  Option  "StandbyTime"  "10"  # Turn off screen after 10 minutes (DPMS)
  Option  "SuspendTime"  "20"  # Full suspend after 20 minutes
  Option  "OffTime"  "30"  # Turn off after half an hour
  [...]
EndSection

[...]

Section "Monitor"
  Identifier  [...]
  Option  "DPMS"  "true"
  [...]
EndSection

This is the same for XFree86 and /etc/X11/XF86Config.
Back to top
View user's profile Send private message
gentoo409
Tux's lil' helper
Tux's lil' helper


Joined: 04 Aug 2004
Posts: 80

PostPosted: Mon Oct 18, 2004 4:13 pm    Post subject: Trying To Figure Out .bashrc Reply with quote

I'm having a problem with my Gentoo installation. When the bash screensaver comes into effect, the system goes into a kernel panic when I try to come out of it by hitting SHIFT or some other key. This is a pretty common problem for me and happens on at least five machines I've installed Gentoo on. I can get around it by turning the bash screensaver off:

Code:
setterm -blank 0


However, I don't want to have to type that every time I log in. Is there a way I can get this bash command to be issued for all users? I heard you can put stuff in your .bashrc file (like aliases) so I figured I'd put it there. I didn't see one in my /root directory, so I just created one. I put the command in there and rebooted, but it seemed to have no effect so it's obviously not being called.

What am I doing wrong guys?
Back to top
View user's profile Send private message
Kathars!s
Tux's lil' helper
Tux's lil' helper


Joined: 29 Sep 2004
Posts: 78

PostPosted: Mon Oct 18, 2004 5:09 pm    Post subject: Reply with quote

place it in your homedir and you'll be alright ;)
to set this system-wide, try adding a line it to your /etc/profile
Back to top
View user's profile Send private message
BlackEdder
Advocate
Advocate


Joined: 26 Apr 2004
Posts: 2588
Location: Dutch enclave in Egham, UK

PostPosted: Mon Oct 18, 2004 5:13 pm    Post subject: Reply with quote

Well the one in root, won't be called if you su, for that to happen you should pu:
[ -f ~/.bashrc ] && . ~/.bashrc
in .bash_profile . I think you will need to create the file too

You could also take a look at /etc/skel. the base .bashrc is there, if you add it to that one, you won't have to add it to each user. There is BTW no reason to reboot, a logout login should work. There is probably also a way to reload the config files without logging out, but I forgot the command :)
Back to top
View user's profile Send private message
gentoo409
Tux's lil' helper
Tux's lil' helper


Joined: 04 Aug 2004
Posts: 80

PostPosted: Mon Oct 18, 2004 5:29 pm    Post subject: Reply with quote

So what is the difference between adding it into /etc/skel/.bashrc and adding it into /etc/profile? What's the difference between the two and which is looked at first?

I tried putting it in /etc/skel/.bashrc but the system is still blacking out after ten minutes.
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Mon Oct 18, 2004 5:52 pm    Post subject: Reply with quote

Things in /etc/skel are the default files that get created in a new user's home directory, so they don't do anything by themselves. /etc/profile is sourced for all users when they log in.
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
gentoo409
Tux's lil' helper
Tux's lil' helper


Joined: 04 Aug 2004
Posts: 80

PostPosted: Mon Oct 18, 2004 7:25 pm    Post subject: Reply with quote

That would explain it! I put it into /etc/profile and now it works like a dream. I'm not sure what's going on entirely in /etc/profile but it looked like there were a few if statements in there and i didn't want it to get looked over so I just put it right at the top of the file, right after the first few comment lines. Does that sound reasonable?
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Mon Oct 18, 2004 7:28 pm    Post subject: Reply with quote

Entirely reasonable! I tend to put my things at the bottom, but it really doesn't matter either way. :D
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 17297

PostPosted: Tue Oct 19, 2004 1:31 am    Post subject: Reply with quote

Moved from Installing Gentoo.
_________________
The whole system has to go. The modern criminal justice system is incompatible with Neuroscience. --Sapolsky
Back to top
View user's profile Send private message
CyberDog3K
n00b
n00b


Joined: 19 Nov 2004
Posts: 22

PostPosted: Fri Nov 19, 2004 8:35 pm    Post subject: Disable Blank Screen? Reply with quote

My Gentoo system seems to have a default screen saver/power saver or something that blanks the monitor after a few minutes of inactivity. Where is this configured? It's on the console, not part of x/kde. I want to be able to disable this permanently, not per session. Thanks.
Back to top
View user's profile Send private message
TheRAt
Veteran
Veteran


Joined: 03 Jun 2002
Posts: 1580
Location: Salt Spring Island, BC, Canada

PostPosted: Fri Nov 19, 2004 8:43 pm    Post subject: Reply with quote

use the following to disable console blanking:
Code:
setterm -blank 0

_________________
All reality is the construct of the observer.

Get Firefox and rediscover the web!

BOFH Excuse #295:
The Token fell out of the ring. Call us when you find it.
Back to top
View user's profile Send private message
CyberDog3K
n00b
n00b


Joined: 19 Nov 2004
Posts: 22

PostPosted: Sat Nov 20, 2004 2:21 am    Post subject: Reply with quote

msalerno wrote:
This should do the trick:

Code:
echo "setterm -blank" >> /etc/conf.d/local.start


Just what I was looking for! Thanks to both of you.
Back to top
View user's profile Send private message
Lindsey
n00b
n00b


Joined: 24 Sep 2004
Posts: 20

PostPosted: Mon Jan 03, 2005 9:20 am    Post subject: Reply with quote

polle wrote:
before your emerge give this command:
setterm -blank 0
this disables the screensaver in your console, look if you have still problems


Sorry to resurrect this after so long. Just wanted to thank you. It seems to have done the trick. =)
Back to top
View user's profile Send private message
Icethepenguin
Apprentice
Apprentice


Joined: 01 Nov 2003
Posts: 252
Location: Loganville, Ga

PostPosted: Thu Apr 21, 2005 5:49 pm    Post subject: Looking to keep monitors from turning off while compiling? Reply with quote

I'm looking to keep the monitors from turning off while i'm compiling. I'm not in kde or anything, just on the console and would like to keep the monitors from turning off. I have already looked in the BIOS to see if that was turning it off, but didn't see anything.

Thanks in advance,
Kevin
Back to top
View user's profile Send private message
Xamindar
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1155
Location: California

PostPosted: Thu Apr 21, 2005 6:10 pm    Post subject: Reply with quote

I am wondering this as well. Anyone have any ideas? Also, can I change the timeout durration?
Back to top
View user's profile Send private message
Ghent99
n00b
n00b


Joined: 21 Apr 2005
Posts: 39
Location: Chicago, IL, USA

PostPosted: Thu Apr 21, 2005 6:20 pm    Post subject: Reply with quote

Code:
% man setterm
<snip irrelevant output>

       -blank [0-60] (virtual consoles only)
              Sets the interval of inactivity, in minutes, after which the screen will be automatically blanked (using APM if available).  Without an argument, defaults to 0 (disable console blanking).

% setterm -blank 0



See if that's what you're looking for :) Also great in your startup profiles! (~/.profile ~/.bash_profile ~/.cshrc etc, etc)

Also, check out the -powersave options in the same man page :)
_________________
- Ghent
Back to top
View user's profile Send private message
Icethepenguin
Apprentice
Apprentice


Joined: 01 Nov 2003
Posts: 252
Location: Loganville, Ga

PostPosted: Thu Apr 21, 2005 6:25 pm    Post subject: Reply with quote

okay, gave it a try, will see if it worked.


Thanks,
Kevin
Back to top
View user's profile Send private message
matt2kjones
Tux's lil' helper
Tux's lil' helper


Joined: 03 Mar 2004
Posts: 87

PostPosted: Fri May 27, 2005 8:10 pm    Post subject: Stop screen from going black? Reply with quote

I have installed gentoo onto a file server with no X installed

after about 5 mins the console goes black until a key is pressed, at which point the display comes back

is there any way to stop the screen from going black after 5 mins? basically turn it off?

i did a search on the forums for "screen blanking" but only came up with posts about people have system crashes and stuff

thanx
_________________
OSST - Formally: The Linux Mirror Project
OSST - Open Source Software Downloads - Torrents for over 80 Distributions
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Goto page Previous  1, 2, 3, 4, 5  Next
Page 4 of 5

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum