Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Installing KDE 5
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Troopo
Tux's lil' helper
Tux's lil' helper


Joined: 14 Jun 2015
Posts: 134

PostPosted: Sun Jun 14, 2015 9:29 pm    Post subject: Installing KDE 5 Reply with quote

Hi,

This is my first time with gentoo KDE and i wanted to try the new version but the only guide i found was an *upgrade* guide instead of an installation one:
https://wiki.gentoo.org/wiki/KDE/Plasma_5_upgrade

some commands aren't there or something maybe it's outdated i don't know but when i run the following command:
Code:
emerge --ask kde-plasma/plasma-meta


i get the following error which i couldn't get passed:
Code:

the ebuild selected to satisfy "x11-misc/sddm" has unmet requirements.
x11-misc/sddm-0.11.0::gentoo USE="systemd upower (-consolekit)" ABI_X86="64"

the following required_use flag constraints are unsatisfied:
at-most-one-of (upower systemd)

(dependency required by "kde-plasma/plasma-meta-5.3.1::gentoo[sddm,display-manager]" [ebuild])
(dependency required by "kde-plasma/plasma-meta" [argument])


I should mention i'm also new to gentoo but i did install most of the other needed things or so i think.

Anyway i would appreciate the help and will post any info you might need just let me know.

Thanks.
Back to top
View user's profile Send private message
kensington
Developer
Developer


Joined: 02 Jan 2013
Posts: 175
Location: Australia

PostPosted: Mon Jun 15, 2015 7:05 pm    Post subject: Reply with quote

This error means that In x11-misc/sddm, the upower and systemd USE flags are mutually exclusive. Since I assume you're using systemd, you should disable upower for that package.

I'd also suggest filing a bug - I am sure we could improve the handling of this situation.
Back to top
View user's profile Send private message
Troopo
Tux's lil' helper
Tux's lil' helper


Joined: 14 Jun 2015
Posts: 134

PostPosted: Sat Jun 20, 2015 10:32 am    Post subject: Reply with quote

kensington wrote:
This error means that In x11-misc/sddm, the upower and systemd USE flags are mutually exclusive. Since I assume you're using systemd, you should disable upower for that package.

I'd also suggest filing a bug - I am sure we could improve the handling of this situation.


Thank you for helping me with this issue afterwards i was able to finally install KDE and run it.

I would be more than willing to open a bug for this if you think this should be the case (btw anything specific for the details needed to open one or should i just search on how to open bugs for gentoo?)

Also i had to mask 2 packages

- app-office/akonadi-server-1.13.0::gentoo (masked by: package.mask)
- x11-misc/sddm-0.11.0::gentoo (masked by: package.mask)

since their issue are unresolvable i've compiled them individually but then blocked them from appearing, SDDM for upower and akonadi server for lack of QT5 support.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum