Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] openssl downgrade to 1.0.1o - what to rebuild ?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
toralf
Developer
Developer


Joined: 01 Feb 2004
Posts: 3706
Location: Hamburg

PostPosted: Sun Jun 14, 2015 10:22 am    Post subject: [solved] openssl downgrade to 1.0.1o - what to rebuild ? Reply with quote

Downgraded yesterday to stable version and run into this :
Code:
$ cd ~/devel/linux; git pull; echo; git remote update stable
git-remote-https: symbol lookup error: /usr/lib64/libcurl.so.4: undefined symbol: SSL_CTX_set_alpn_protos

Fetching stable
git-remote-https: symbol lookup error: /usr/lib64/libcurl.so.4: undefined symbol: SSL_CTX_set_alpn_protos
error: Could not fetch stable
A "revdep-rebuild -- --ask" showed nothing. Therefore I'm wondering how to get the affected package list (and furthermore, why such an ABI breakage would benefit from subslots ?)

Last edited by toralf on Mon Jun 15, 2015 2:06 pm; edited 1 time in total
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 2152
Location: Berlin, Germany

PostPosted: Mon Jun 15, 2015 11:51 am    Post subject: Reply with quote

You can try
Code:
# revdep-rebuild --library libssl.so.1.0.0

Failing that, maybe
Code:
# revdep-rebuild --library libcurl.so.4
Back to top
View user's profile Send private message
toralf
Developer
Developer


Joined: 01 Feb 2004
Posts: 3706
Location: Hamburg

PostPosted: Mon Jun 15, 2015 2:06 pm    Post subject: Reply with quote

Thx - that was it.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum