Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
mit-krb5 vs heimdal, the fight over smaba4
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
KWhat
l33t
l33t


Joined: 04 Sep 2005
Posts: 620
Location: Los Angeles

PostPosted: Sat Jun 13, 2015 4:49 pm    Post subject: mit-krb5 vs heimdal, the fight over smaba4 Reply with quote

I am having a rather difficult time upgrading to samba 4.

Code:

[blocks B      ] app-crypt/mit-krb5 ("app-crypt/mit-krb5" is hard blocking app-crypt/heimdal-1.5.3-r2)
[blocks B      ] <net-fs/samba-4.1.7 ("<net-fs/samba-4.1.7" is hard blocking sys-libs/ntdb-1.0-r1)
[blocks B      ] app-crypt/heimdal ("app-crypt/heimdal" is hard blocking app-crypt/mit-krb5-1.13.2)

Total: 14 packages (1 upgrade, 13 new), Size of downloads: 30,306 KiB
Conflict: 3 blocks (3 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

net-fs/samba:0

  (net-fs/samba-4.1.18:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=net-fs/samba-4.0.0_alpha1[client] required by (kde-apps/kdebase-kioslaves-4.14.3:4/4.14::gentoo, installed)
    ^^             ^^^^^^^^^^^^                                                                                                                                         
    net-fs/samba (Argument)
    (and 2 more with the same problems)

  (net-fs/samba-3.6.25:0/0::gentoo, installed) pulled in by
    >=net-fs/samba-3.6.23-r1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (media-video/ffmpeg-2.7:0/54.56.56::gentoo, installed)



Code:

plutonium244 kwhat # equery d mit-krb5
 * These packages depend on mit-krb5:
dev-libs/openssl-1.0.2c (kerberos ? >=app-crypt/mit-krb5-1.11.4[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?])

net-fs/nfs-utils-1.3.2-r6 (kerberos ? app-crypt/mit-krb5)
virtual/krb5-0-r1 (>=app-crypt/mit-krb5-1.12.1-r1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?])


plutonium244 kwhat # equery d heimdal
 * These packages depend on heimdal:
net-nds/openldap-2.4.40-r3 (kerberos ? app-crypt/heimdal)

virtual/krb5-0-r1 (>=app-crypt/heimdal-1.5.3-r2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?])


Is it safe to disable the kerberos use flag on openssl or globally?

*** Update: The following mess appears to do the trick.

Code:
emerge -Cav mit-krb5 krb5 =net-fs/samba-3.6.25 && emerge -avu1 samba && echo "# POS depends on samba3 explicitly\nmedia-video/ffmpeg -samba" && emerge -avuDN world


*** Update 2: Dont forget to compile app-crypt/heimdal with CFLAGS=-pthread CXXFLAGS=-pthread
https://bugs.gentoo.org/show_bug.cgi?id=546874
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum