Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Trouble with postfix-3.0.1-r1 and vda USE flag
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
hanj
Veteran
Veteran


Joined: 19 Aug 2003
Posts: 1389

PostPosted: Wed Jun 10, 2015 4:56 pm    Post subject: Trouble with postfix-3.0.1-r1 and vda USE flag Reply with quote

Trying to update postfix to postfix-3.0.1-r1 and receiving the following:

Code:
!!! Problem resolving dependencies for mail-mta/postfix                                                                                       ... done!

!!! The ebuild selected to satisfy "postfix" has unmet requirements.
- mail-mta/postfix-3.0.1-r1::gentoo USE="berkdb eai mysql pam sasl ssl vda -cdb -doc -dovecot-sasl -hardened -ldap -ldap-bind -lmdb -mbox -memcached -nis -postgres (-selinux) -sqlite" ABI_X86="64"

  The following REQUIRED_USE flag constraints are unsatisfied:
    !vda

  The above constraints are a subset of the following complete expression:
    ldap-bind? ( ldap sasl ) !vda


Here are my current USE flags: berkdb eai mysql pam sasl ssl vda

Looks like there is a problem with vda. I would like to continue to use vda since I enforce mail quotas on this server. Any recommendations?

Thanks!
hanji
_________________
Server Admin Blog - Uno-Code.com | Gentoo Hosting at Rackspace!
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7051
Location: almost Mile High in the USA

PostPosted: Wed Jun 10, 2015 5:07 pm    Post subject: Reply with quote

According to the 3.0.1-r1 ebuild:
# No vda support for postfix-3.0

Think you have to downgrade if you want to use vda.
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
hanj
Veteran
Veteran


Joined: 19 Aug 2003
Posts: 1389

PostPosted: Thu Jun 11, 2015 5:15 am    Post subject: Reply with quote

eccerr0r wrote:
According to the 3.0.1-r1 ebuild:
# No vda support for postfix-3.0

Think you have to downgrade if you want to use vda.


Thanks.. I see that now. What is the preferred option for quota support and postfix-3.x?

Thanks!
hank
_________________
Server Admin Blog - Uno-Code.com | Gentoo Hosting at Rackspace!
Back to top
View user's profile Send private message
d-fens
Tux's lil' helper
Tux's lil' helper


Joined: 09 Jan 2004
Posts: 92

PostPosted: Wed Dec 02, 2015 12:52 pm    Post subject: Reply with quote

same problem here, how did you fix it?
Back to top
View user's profile Send private message
Biker
Apprentice
Apprentice


Joined: 11 Jun 2003
Posts: 165
Location: A very dark, cold and moisty place...

PostPosted: Mon May 08, 2017 9:07 pm    Post subject: Reply with quote

https://bugs.gentoo.org/show_bug.cgi?id=606494
_________________
The Internet never forgets.
Where 'never' points in the direction of a moment in the very, very far future.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum