Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KDE 5: I see only black windows
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
roarinelk
Guru
Guru


Joined: 04 Mar 2004
Posts: 501

PostPosted: Mon Jun 08, 2015 7:35 am    Post subject: KDE 5: I see only black windows Reply with quote

Hello,

I've installed KDE5 (kde-plasma/plasma-meta to be exact), but when I launch it, I see no desktop. I can see the
mouse cursor, and on right-clicks, the desktop context menu pops up. I select "desktop settings" and
a window opens up, with everything black inside. Only all kwin-configuration related windows and the
lockscreen show any content.

I did notice that when the mouse hovers above what is supposed to be the K-menu the cursor changes, same goes
for example for the invisble logout dialog when I hit ctrl-alt-delete. So the windows are there, I just don't see anything.

gfx driver is the nvidia blob. What USE flags do people who can use KF5 use with Qt5 and kwin?

Any hints appreciated!
Back to top
View user's profile Send private message
FunzZy
n00b
n00b


Joined: 15 May 2006
Posts: 21

PostPosted: Fri Jan 22, 2016 10:19 pm    Post subject: Reply with quote

Hi,

I got exactly the same problem !

I have found a workaround:

Changing the eselect opengl from nvidia to xorg-x11 fixes the problem.

So it seems this is related to the nvidia driver.

I have no more information about it, but now I am able to display a kde desktop.

If anyone has more information, please help !

Thanks.
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5593

PostPosted: Sat Jan 23, 2016 7:23 pm    Post subject: Reply with quote

That's bizarre... I used to have exactly the same bug on nvidia hardware 8-9 years ago when running compiz. They really haven't fixed it in that time?
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6829
Location: Austria

PostPosted: Sat Jan 23, 2016 7:27 pm    Post subject: Reply with quote

It appears to be a bug with eselect, currently.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
BobWya
Apprentice
Apprentice


Joined: 12 Aug 2012
Posts: 227
Location: Cambridge,UK

PostPosted: Sat Jan 23, 2016 9:21 pm    Post subject: Reply with quote

Quote:
It's cool - I've got a working fix that I'm currently baking 8)

Surprise, surprise... it's all down to the broken open-eselect-1.3.1 implementation...

I've been polishing up my fixes today - so that hopefully they can get mainlined into the main Gentoo tree. Sadly that means I've got to test the re-modified media-libs/mesa and app-eselect/eselect-opengl packages first... I'll push them to my Layman Overlay when the testing is done...


Man, it's taken ~3 weeks to transition to Plasma 5 - but it's worth the wait - once you get it working!! Just as good - if not better than my Arch install of the same... Plasma 5 appears to be quite stable when your GL libraries aren't completely borked... 8)

Bob


Please could I request anyone experiencing issues (primarily with the Nvidia proprietary drivers and starting a Plasma 5 Sessions / SDDM) to test the following (pre-patched) packages:
media-libs/mesa::bobwya
app-eselect/eselect-opengl::bobwya

from my Layman Overlay bobwya

Please also see the Gentoo Bug report "Plasma 5 + Nvidia drivers 361.18 - only EGL support, no GLX support - unable to start Plasma 5 Session" for more information!!
Just remember to rebuild all packages depending on media-libs/mesa::bobwya !!

Ta
Bob
_________________
system: G751JT (ASUS-NotebookSKU); processor: Intel(R) Core(TM) i7-4710HQ CPU @ 2.50GHz; memory: 32GiB System Memory; display: GM204M [GeForce GTX 970M]; disk: 2048GB Samsung SSD 850;BD-CMB UJ172 S;1024GB Samsung SSD 850
Back to top
View user's profile Send private message
roarinelk
Guru
Guru


Joined: 04 Mar 2004
Posts: 501

PostPosted: Sun Jan 24, 2016 9:55 am    Post subject: Reply with quote

I did manage to get it working, on another desktop with the nvidia blob. I don't know *exactly* what I did
to make it work, but I attribute it to removing the "egl" and "gles2" use flags from all qt5 builds.
@BobWya: I'll give your modified builds a try in a sec.
Back to top
View user's profile Send private message
BobWya
Apprentice
Apprentice


Joined: 12 Aug 2012
Posts: 227
Location: Cambridge,UK

PostPosted: Sun Jan 24, 2016 11:25 am    Post subject: Reply with quote

roarinelk wrote:
I did manage to get it working, on another desktop with the nvidia blob. I don't know *exactly* what I did
to make it work, but I attribute it to removing the "egl" and "gles2" use flags from all qt5 builds.
@BobWya: I'll give your modified builds a try in a sec.


Yeah, that sounds like the best build options to choose.

I don't have egl USE flag enabled for my dev-qt/qtgui:5 library (which should reduce the chance of breakage)...

You can easily see what GL libraries Plasma 5 is linking against. I guess you'd have to add these checks to a cron job to dump the output to a file - if you've got a black screen!!

On my system:
Code:
ldd /usr/lib/libQt5Gui.so.5.5.1 | grep GL
        libGL.so.1 => /usr/lib64/opengl/nvidia/lib/libGL.so.1 (0x00007f92107ec000)
        libGLX.so.0 => /usr/lib64/opengl/nvidia/lib/libGLX.so.0 (0x00007f920e03f000)
        libGLdispatch.so.0 => /usr/lib64/opengl/nvidia/lib/libGLdispatch.so.0 (0x00007f920dd30000)


Code:
ldd /usr/bin/kwin_x11 | grep GL
        libGL.so.1 => /usr/lib64/opengl/nvidia/lib/libGL.so.1 (0x00007fa3cc7a8000)
        libEGL.so.1 => /usr/lib64/opengl/nvidia/lib/libEGL.so.1 (0x00007fa3c8daf000)
        libGLX.so.0 => /usr/lib64/opengl/nvidia/lib/libGLX.so.0 (0x00007fa3c6e83000)
        libGLdispatch.so.0 => /usr/lib64/opengl/nvidia/lib/libGLdispatch.so.0 (0x00007fa3c6b75000)


Code:
ldd /usr/bin/sddm-greeter | grep GL
        libGL.so.1 => /usr/lib64/opengl/nvidia/lib/libGL.so.1 (0x00007fc19fc45000)
        libGLX.so.0 => /usr/lib64/opengl/nvidia/lib/libGLX.so.0 (0x00007fc19df54000)
        libGLdispatch.so.0 => /usr/lib64/opengl/nvidia/lib/libGLdispatch.so.0 (0x00007fc19dc46000)


It's not clear to me why Qt5 / KWin 5 is not respecting the:
Code:
LDPATH="/usr/lib32/opengl/nvidia/lib:/usr/lib64/opengl/nvidia/lib"

env variable - in some circumstances - when this set by the existing eselect-opengl utility.


Perhaps I should try re-enabling the egl USE flag to break everything again 8)

Bob
_________________
system: G751JT (ASUS-NotebookSKU); processor: Intel(R) Core(TM) i7-4710HQ CPU @ 2.50GHz; memory: 32GiB System Memory; display: GM204M [GeForce GTX 970M]; disk: 2048GB Samsung SSD 850;BD-CMB UJ172 S;1024GB Samsung SSD 850
Back to top
View user's profile Send private message
frares
n00b
n00b


Joined: 02 Apr 2004
Posts: 20

PostPosted: Thu Jul 14, 2016 5:21 pm    Post subject: Reply with quote

Any news on this issue?

I've just moved to KDE-5 and got the same effects as described by the original poster and followers.

Would like to use the nvidia (although proprietary) instead of xorg-x11 on "eselect opengl".

Thanks!
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6829
Location: Austria

PostPosted: Thu Jul 14, 2016 5:38 pm    Post subject: Reply with quote

Without any information from your side and previous history of Nvidia woes I'd say disable any mention of gles* and egl USE flag.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum