Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
discarded polkit-qt listed qt5 flag [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
CaptainBlood
l33t
l33t


Joined: 24 Jan 2010
Posts: 997

PostPosted: Wed Jun 03, 2015 6:33 pm    Post subject: discarded polkit-qt listed qt5 flag [SOLVED] Reply with quote

I've been trying to install qt5 for a while now.
But polkit-qt was always complaining about missing qt5.
I updated packages.use accordlingly but did'nt stop complaining.

Although I try to be very careful, I may have spoiled some portage config file.

Am I the only one ...

I finally emerged LXQT-META with polkit-qt inhibited.
So I expect to have a very unsecure GUI.

Thks 4 ur attention


Last edited by CaptainBlood on Thu Jun 04, 2015 6:27 pm; edited 2 times in total
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6827
Location: Austria

PostPosted: Wed Jun 03, 2015 6:48 pm    Post subject: Reply with quote

Logs please.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
CaptainBlood
l33t
l33t


Joined: 24 Jan 2010
Posts: 997

PostPosted: Wed Jun 03, 2015 7:47 pm    Post subject: Reply with quote

Sorry,
Code:
equery hasuse qt5
 * Searching for USE flag qt5 ...
[IP-] [  ] app-text/poppler-0.32.0:0/51
[IP-] [  ] dev-qt/qtchooser-0_p20150102:0
[IP-] [  ] dev-util/cmake-2.8.12.2-r1:0
[IP-] [  ] media-libs/phonon-4.7.2:0
[IP-] [  ] media-libs/phonon-gstreamer-4.7.2:0
[IP-] [  ] net-analyzer/wireshark-1.12.5:0/1.12.5
Code:
eix polkit-qt
* sys-auth/polkit-qt
     Available versions:  0.112.0-r1^t {debug examples +qt4 qt5}
     Homepage:            http://www.kde.org/
     Description:         PolicyKit Qt4 API wrapper library
Code:
equery u polkit-qt
[ Legend : U - final flag setting for installation]
[        : I - package is installed with flag     ]
[ Colors : set, unset                             ]
 * Found these USE flags for sys-auth/polkit-qt-0.112.0-r1:
 U I
 - - debug    : Enable extra debug codepaths, like asserts and extra output. If
                you want to get meaningful backtraces see https://wiki.gentoo.o
                rg/wiki/Project:Quality_Assurance/Backtraces
 - - examples : Install examples, usually source code
 - - qt4      : Add support for the Qt GUI/Application Toolkit version 4.x
Code:
eix qtchooser
[I] dev-qt/qtchooser
     Available versions:  0_p20150102 {qt5 test}
     Installed versions:  0_p20150102(15:36:19 14/05/2015)(-qt5 -test)
     Homepage:            https://qt.gitorious.org/qt/qtchooser
     Description:         Qt4/Qt5 version chooser
Code:
equery u qtchooser
[ Legend : U - final flag setting for installation]
[        : I - package is installed with flag     ]
[ Colors : set, unset                             ]
 * Found these USE flags for dev-qt/qtchooser-0_p20150102:
 U I
 - - test : Workaround to pull in packages needed to run with FEATURES=test.
            Portage-2.1.2 handles this internally, so don't set it in
            make.conf/package.use anymore
Code:
emerge -1 lxqt-meta

 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.

Calculating dependencies  .... done!

emerge: there are no ebuilds to satisfy "sys-auth/polkit-qt[qt5(-)]".
(dependency required by "lxqt-base/lxqt-policykit-0.9.0::gentoo" [ebuild])
(dependency required by "lxqt-base/lxqt-meta-0.9.0-r2::gentoo[policykit]" [ebuild])
(dependency required by "lxqt-meta" [argument])
Thks 4 ur attention, interest & support
Back to top
View user's profile Send private message
CaptainBlood
l33t
l33t


Joined: 24 Jan 2010
Posts: 997

PostPosted: Thu Jun 04, 2015 6:25 pm    Post subject: Reply with quote

clue is here:https://forums.gentoo.org/viewtopic-t-997394.html?sid=df9d914335b64e1a418550ff280ed5f5
Thks 4 ur attention, interest & support
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum