Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] awesome & xdg (unknown desktop environment)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
DMoL
Tux's lil' helper
Tux's lil' helper


Joined: 07 May 2006
Posts: 100
Location: Minsk, Belarus

PostPosted: Thu May 28, 2015 11:13 am    Post subject: [solved] awesome & xdg (unknown desktop environment) Reply with quote

Hello!

I use awesome, and no any other DE is installed on my gentoo box.

It is very unconvenient, when I click on link in skype (for example), and it opens a link in Firefox instead of Chromium. How to solve that?

I have tried to tune xdg, but it emits error:

Code:

$ xdg-settings get default-web-browser
xdg-settings: unknown desktop environment


What can I do?

Thanks for help!

WBR, basiliscos.


Last edited by DMoL on Sat May 30, 2015 2:52 pm; edited 1 time in total
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Sat May 30, 2015 10:19 am    Post subject: Reply with quote

maybe skype has a confirguration text file or a menu to set the browser.

alternatively you could rename firefox, than make a link from your desired browser to firefox. Ugly but should work until you remerge firefox again.
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4404

PostPosted: Sat May 30, 2015 11:20 am    Post subject: Reply with quote

I am running awesome, too.
I had a look at xdg-settings (it's a shell script :)) - and exporting "DE=generic" seems to work.
You then can simply export BROWSER=chromium and everything should work (TM)
Back to top
View user's profile Send private message
DMoL
Tux's lil' helper
Tux's lil' helper


Joined: 07 May 2006
Posts: 100
Location: Minsk, Belarus

PostPosted: Sat May 30, 2015 2:52 pm    Post subject: Reply with quote

franzf wrote:
I am running awesome, too.
I had a look at xdg-settings (it's a shell script :)) - and exporting "DE=generic" seems to work.
You then can simply export BROWSER=chromium and everything should work (TM)


Thanks! This seems to be better solution. I found mine via patching xdg-settings:

Code:
--- xdg-settings        2015-05-30 15:47:19.052986969 +0300
+++ /usr/bin/xdg-settings       2015-05-30 15:49:41.360984906 +0300
@@ -442,6 +442,9 @@
          xfce|xfce4|'Xfce Session')
            DE=xfce;
            ;;
+         awesome)
+           DE=generic
+           ;;
       esac
     fi

Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum