Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] x11-drivers/xf86-video-virtualbox emake failed
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Trovalds
n00b
n00b


Joined: 16 Jun 2011
Posts: 13
Location: Cuiaba/MT - Brazil

PostPosted: Thu May 21, 2015 11:09 pm    Post subject: [SOLVED] x11-drivers/xf86-video-virtualbox emake failed Reply with quote

Hi

I'm setting up a new Gentoo in a virtualbox machine, everything's ok until I tried to up Xorg-server.

virtualbox driver refuses to compile, I tried many things but it refuses to compile.

build.log paste: https://bpaste.net/show/e7a5c073dfdb (not pasted here, around 5.000 lines)

Thanks in advance.

(Sorry my english, not my native language)


Last edited by Trovalds on Wed May 27, 2015 3:16 am; edited 1 time in total
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7048
Location: almost Mile High in the USA

PostPosted: Fri May 22, 2015 12:20 am    Post subject: Reply with quote

Some packages depend on /usr/src/linux pointing to the kernel source code you compiled for the virtual machine. So, you need the kernel tree that you build for vbox that will use the vbox video driver there. If you didn't build the target kernel there or have a link (or used eselect) then it will complain about not finding the needed configuration.
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
Trovalds
n00b
n00b


Joined: 16 Jun 2011
Posts: 13
Location: Cuiaba/MT - Brazil

PostPosted: Fri May 22, 2015 4:47 am    Post subject: Reply with quote

eccerr0r wrote:
Some packages depend on /usr/src/linux pointing to the kernel source code you compiled for the virtual machine. So, you need the kernel tree that you build for vbox that will use the vbox video driver there. If you didn't build the target kernel there or have a link (or used eselect) then it will complain about not finding the needed configuration.

Thanks on rapid answer.

Can you show me how to do this, exactly? I compiled my kernel using genkernel. Just (re)compile the kernel inside /usr/src/linux?
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7048
Location: almost Mile High in the USA

PostPosted: Fri May 22, 2015 4:51 am    Post subject: Reply with quote

Make sure your kernel build is linked to /usr/src/linux and try the build again.

Not sure how you built the kernel but usually /usr/src/linuxsomething..... contains the kernel tree and there's a symlink from that to /usr/src/linux. There's also a link in /lib/modules/(version)/build that points back to where you compiled the kernel (after a modules_install) that should link the version to the kernel tree.
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
Trovalds
n00b
n00b


Joined: 16 Jun 2011
Posts: 13
Location: Cuiaba/MT - Brazil

PostPosted: Tue May 26, 2015 3:20 am    Post subject: Reply with quote

No luck yet... any other solution?
Back to top
View user's profile Send private message
ct85711
Veteran
Veteran


Joined: 27 Sep 2005
Posts: 1691

PostPosted: Tue May 26, 2015 4:34 am    Post subject: Reply with quote

Quote:
make[1]: Entering directory '/usr/src/linux-3.18.12-gentoo'
test -e include/generated/autoconf.h -a -e include/config/auto.conf || ( \
echo >&2; \
echo >&2 " ERROR: Kernel configuration is invalid."; \
echo >&2 " include/generated/autoconf.h or include/config/auto.conf are missing.";\
echo >&2 " Run 'make oldconfig && make prepare' on kernel src to fix it."; \
echo >&2 ; \
/bin/false)


Directly says, it's an issue of it not finding the running kernel's source code as eccerr0r just mentioned...

So first off, what's the output of uname -r and ls -l /usr/src/linux. They should match, like on my system I have:
Code:
ct85711@Oate ~ $ uname -r
3.18.5-gentoo
ct85711@Oate ~ $ ls -l /usr/src/linux
lrwxrwxrwx 1 root root 19 Feb 14 20:42 /usr/src/linux -> linux-3.18.5-gentoo


If you unmerged your running kernel's source code, you will have to compile & boot into a different kernel before you compile virtualbox.
Back to top
View user's profile Send private message
Trovalds
n00b
n00b


Joined: 16 Jun 2011
Posts: 13
Location: Cuiaba/MT - Brazil

PostPosted: Tue May 26, 2015 10:11 am    Post subject: Reply with quote

ct85711 wrote:
Quote:
make[1]: Entering directory '/usr/src/linux-3.18.12-gentoo'
test -e include/generated/autoconf.h -a -e include/config/auto.conf || ( \
echo >&2; \
echo >&2 " ERROR: Kernel configuration is invalid."; \
echo >&2 " include/generated/autoconf.h or include/config/auto.conf are missing.";\
echo >&2 " Run 'make oldconfig && make prepare' on kernel src to fix it."; \
echo >&2 ; \
/bin/false)


Directly says, it's an issue of it not finding the running kernel's source code as eccerr0r just mentioned...

So first off, what's the output of uname -r and ls -l /usr/src/linux. They should match, like on my system I have:
Code:
ct85711@Oate ~ $ uname -r
3.18.5-gentoo
ct85711@Oate ~ $ ls -l /usr/src/linux
lrwxrwxrwx 1 root root 19 Feb 14 20:42 /usr/src/linux -> linux-3.18.5-gentoo


If you unmerged your running kernel's source code, you will have to compile & boot into a different kernel before you compile virtualbox.

Ok, tried on a new, fresh virtual machine... manually build my kernel instead of genkernel it.

uname -r and ls -l /usr/src/linux returns:

Code:
3.18.12-gentoo

lrwxrwxrwx 1 root root 20 Mai 26 03:07 /usr/src/linux -> linux-3.18.12-gentoo


New paste (same error): https://bpaste.net/show/1646d6b026d7

Note on initial ebuild:

Code:
 * Determining the location of the kernel source code
 * Found kernel source directory:
 *     /usr/src/linux
 * Found kernel object directory:
 *     /lib/modules/3.18.12-gentoo/build
 * Found sources for kernel version:
 *     3.18.12-gentoo
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7048
Location: almost Mile High in the USA

PostPosted: Tue May 26, 2015 5:54 pm    Post subject: Reply with quote

Fsck. pretexted by bad searching

This is the real error:

Code:
/var/tmp/portage/x11-drivers/xf86-video-virtualbox-4.3.18/work/vboxvideo_drm/vboxvideo_drm.c:125:17: error: drm_mmap undeclared here (not in a function)


I'm only guessing here as I do not use this software. Did you enable DRM and the virtual driver in the kernel you compiled?
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
Trovalds
n00b
n00b


Joined: 16 Jun 2011
Posts: 13
Location: Cuiaba/MT - Brazil

PostPosted: Wed May 27, 2015 3:11 am    Post subject: Reply with quote

After some research, blablabla... this error sounds like a bug after all. I unmasked latest version of driver (4.3.28 ) and... gotcha, no errors.

Thank you everyone that helps here.
Back to top
View user's profile Send private message
shtumpa
Tux's lil' helper
Tux's lil' helper


Joined: 19 Feb 2005
Posts: 136
Location: Australia

PostPosted: Wed Jun 24, 2015 12:39 pm    Post subject: Reply with quote

Trovalds wrote:
After some research, blablabla... this error sounds like a bug after all. I unmasked latest version of driver (4.3.28 ) and... gotcha, no errors.

Thank you everyone that helps here.


Ok, I'm also running into an error with this .. i'm using 4.3.28 << ---

Quote:
/lib/modules/4.1.0-gentoo/build/include/linux/compiler.h:213:29: error: can’t set ‘no_instrument_function’ attribute after definition
static __always_inline void __write_once_size(volatile void *p, void *res, int size)
^
kmk: *** [/var/tmp/portage/x11-drivers/xf86-video-virtualbox-4.3.28/work/VirtualBox-4.3.28/out/linux.amd64/release/obj/RuntimeGuestR0/common/alloc/heapsimple.o] Error 1
kmk: *** Waiting for unfinished jobs....
kmk: *** [/var/tmp/portage/x11-drivers/xf86-video-virtualbox-4.3.28/work/VirtualBox-4.3.28/out/linux.amd64/release/obj/RuntimeGuestR0/common/alloc/heapoffset.o] Error 1
kmk: *** [/var/tmp/portage/x11-drivers/xf86-video-virtualbox-4.3.28/work/VirtualBox-4.3.28/out/linux.amd64/release/obj/RuntimeGuestR0/common/alloc/alloc.o] Error 1
kmk: *** [/var/tmp/portage/x11-drivers/xf86-video-virtualbox-4.3.28/work/VirtualBox-4.3.28/out/linux.amd64/release/obj/RuntimeGuestR0/common/checksum/crc32.o] Error 1
kmk: *** [/var/tmp/portage/x11-drivers/xf86-video-virtualbox-4.3.28/work/VirtualBox-4.3.28/out/linux.amd64/release/obj/RuntimeGuestR0/common/checksum/alt-md5.o] Error 1
kmk: *** [/var/tmp/portage/x11-drivers/xf86-video-virtualbox-4.3.28/work/VirtualBox-4.3.28/out/linux.amd64/release/obj/RuntimeGuestR0/common/err/RTErrConvertToErrno.o] Error 1
kmk: *** [/var/tmp/portage/x11-drivers/xf86-video-virtualbox-4.3.28/work/VirtualBox-4.3.28/out/linux.amd64/release/obj/RuntimeGuestR0/common/checksum/ipv6.o] Error 1
kmk: *** [/var/tmp/portage/x11-drivers/xf86-video-virtualbox-4.3.28/work/VirtualBox-4.3.28/out/linux.amd64/release/obj/RuntimeGuestR0/common/checksum/crc64.o] Error 1
kmk: *** [/var/tmp/portage/x11-drivers/xf86-video-virtualbox-4.3.28/work/VirtualBox-4.3.28/out/linux.amd64/release/obj/RuntimeGuestR0/common/checksum/ipv4.o] Error 1
kmk: *** Exiting with status 2
* ERROR: x11-drivers/xf86-video-virtualbox-4.3.28::gentoo failed (compile phase):
* emake failed


Any suggestions ?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum