Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
X with savage: what good options
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
multix
Apprentice
Apprentice


Joined: 28 Nov 2004
Posts: 216
Location: Italy

PostPosted: Wed May 20, 2015 8:12 am    Post subject: X with savage: what good options Reply with quote

Hi,

the latest Xorg & kernel give new hope to those using a savage card: the framebuffer works fine and also X starts now fine again, with the correct resolution, consoles work on quit.
BUT: I had to disable about everything.

I know some people switched to Vesa, but I want to share and explore the options here and in case open bug reports to freedesktop.org. I only need some 2D acceleration (windows moving & scrolling, that's all).

I understand, but correct me, that there is EXA acceleration (with or without DRI) and then ShadowFB, two indipendent things. Can they be used togehter or not?

From reading other forums (ubuntu, etc) I gather that ShadowFB should give a performance increase independently from Accel itself.

If I enable it, I get a unusable display: it is corrupted in the sense that it looks like things get drawn several times (I see like 4 cursors) moving... I suppose wrong offset when drawing. However for most people this seems to work and is used instead of EXA acceleration.


EXA acceleration... shows a "fine looking" screen on X start, but it corrupts on usage, parts of the screen become black and when exiting the console remains black. I suppose there are serious problems. A pity, because it looks quite fast indeed before ruining.
_________________
Unix is user friendly. It is only careful selecting its friends.
Back to top
View user's profile Send private message
multix
Apprentice
Apprentice


Joined: 28 Nov 2004
Posts: 216
Location: Italy

PostPosted: Thu May 21, 2015 9:41 pm    Post subject: Reply with quote

Just for the record, this is my current setup:

For the monitor (specific for my ThinkPad possibly):
Code:

Section "Monitor"
        Identifier   "Monitor0"
        ModelName "T23 14.1"
        Modeline     "1024x768_75.00" 81.80 1024 1080 1192 1360 768 769 772 802 -HSync +Vsync
        Option       "PreferredMode" "1024x768_75.00"
EndSection


For the device itself:
Code:

Section "Device"
        Option     "NoAccel"           "true"
        #Option     "AccelMethod"               "EXA"
        #Option     "HWCursor"                  # [<bool>]
        #Option     "SWCursor"                  # [<bool>]
        #Option     "ShadowFB"           "true"
        #Option     "DisableCOB"         "false"
        #Option     "BCIforXv"                  # [<bool>]
        #Option     "BusType"                   # [<str>]
        #Option     "DmaType"                   # [<str>]
        Option     "DmaMode"                    "Any"
        #Option     "AGPMode"                   # <i>
        #Option     "AGPSize"                   # <i>
        Option     "DRI"                "true"
        Identifier  "Card0"
        Driver      "savage"
        VendorName  "S3 Inc."
        BoardName   "SuperSavage IX/C SDR"
        BusID       "PCI:1:0:0"
EndSection


As you see, I disabled all acceleration.

Shuold ShadowFB work, without EXA?

Other, better options you may suggest?
_________________
Unix is user friendly. It is only careful selecting its friends.
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 6957
Location: Saint Amant, Acadiana

PostPosted: Thu May 21, 2015 11:27 pm    Post subject: Reply with quote

Methinks I already mentioned it in another thread, but my solution with T23 was
Code:
Driver      "fbdev"

_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
multix
Apprentice
Apprentice


Joined: 28 Nov 2004
Posts: 216
Location: Italy

PostPosted: Tue May 26, 2015 6:27 pm    Post subject: Reply with quote

Well, that is, I suppose, cheating, you are using the framebuffer driver :)


I have opened a bug about this, although I have small hopes:
https://bugs.freedesktop.org/show_bug.cgi?id=90634

Since most reports, threads and other things i found on the net are pretty inconclusive. I try to make at least a meaningful bug report because I found few.
_________________
Unix is user friendly. It is only careful selecting its friends.
Back to top
View user's profile Send private message
multix
Apprentice
Apprentice


Joined: 28 Nov 2004
Posts: 216
Location: Italy

PostPosted: Tue May 26, 2015 6:31 pm    Post subject: Reply with quote

Option "AccelMethod" "EXA"
Option "ShadowFB" "false"


-> with this little (it means DRI is disabled since the COB option is missing) the display is as slow as unaccelerated, but already contains the display bugs

killing X leaves a hung machine: hard restart is needed, no response on console or from remote.
_________________
Unix is user friendly. It is only careful selecting its friends.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum