Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
where are the kde5 apps?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
drini
n00b
n00b


Joined: 29 Aug 2002
Posts: 64
Location: Mérida, Mexico

PostPosted: Sat May 09, 2015 3:37 am    Post subject: where are the kde5 apps? Reply with quote

I finally managed to install kde-5.3 and frameworks 5.9 (emerge @kde-plasma-5.3 and emerge @kde-frameworks-5.9)

It seems you can't have both kde4 and kde5 simultaneously installed, so I had to remove all kde4 in order to remove emerge blocks.

Now I'm on kde5, it's yellow, it's white, it's pretty, but it's barren. No terminal, no filemanager, no nothing.

I'm kind of lost, what do I need to install?
I'm not expecting solid stable apps, I know it's development status, but... I kinda expected apps at least.
_________________
f
G -----> H G
p \ /_ ----- ~ f(G)
\ / f ker f
G/ker f
Back to top
View user's profile Send private message
drini
n00b
n00b


Joined: 29 Aug 2002
Posts: 64
Location: Mérida, Mexico

PostPosted: Sat May 09, 2015 4:30 am    Post subject: Reply with quote

oh.... they are masked on ~amd64 ... *grumble*
so I add

Code:
=kde-apps/kde-apps-meta-9999 **

to accept_keywords

Code:

hunabku drini # emerge kde-apps-meta -av

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy ">=kde-apps/kde-l10n-9999".
(dependency required by "kde-apps/kde-apps-meta-9999::kde[nls]" [ebuild])
(dependency required by "kde-apps-meta" [argument])

_________________
f
G -----> H G
p \ /_ ----- ~ f(G)
\ / f ker f
G/ker f
Back to top
View user's profile Send private message
davidm
Guru
Guru


Joined: 26 Apr 2009
Posts: 557
Location: US

PostPosted: Sat May 09, 2015 4:33 am    Post subject: Reply with quote

You can install most of the kde4 versions of the applications such as konsole, kate, or Dolphin. In fact there isn't even yet an official plasma 5/kf5 release of Dolphin. Many applications have to yet been ported to KF5 but in most cases the comparable kde4 applications are still fully compatible with Plasma 5.3. You can install them individually if you want as needed.

See this topic if interested in installing some later application releases beyond what is available in the regular amd64/~amd64 portage tree. There are lots of later ebuilds residing in kde-apps in the kde-overlay. This will get you some applications built for kf5/plasma 5 as well as others which are still kde4. See Yamakuzure's post about 'kde-apps-meta'.

https://forums.gentoo.org/viewtopic-p-7744598.html#7744598
https://forums.gentoo.org/viewtopic-t-1015002-start-50.html
Back to top
View user's profile Send private message
drini
n00b
n00b


Joined: 29 Aug 2002
Posts: 64
Location: Mérida, Mexico

PostPosted: Sat May 09, 2015 4:47 am    Post subject: Reply with quote

thank you for the information.

What confused me is that portage didn't tell me I could unmask packages (like kde-apps/kde-l10n) in order to satisfy the dependency

I'm stuck now on how to unmask kde-l10n:
Code:

hunabku package.use # emerge kde-apps-meta -av

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy ">=kde-apps/kde-l10n-9999".
(dependency required by "kde-apps/kde-apps-meta-9999::kde[nls]" [ebuild])
(dependency required by "kde-apps-meta" [argument])


I've tried
Code:

=kde-apps/kde-apps-meta-9999 **
=kde-apps/kde-l10n **


Code:

=kde-apps/kde-apps-meta-9999 **
=kde-apps/kde-l10n-9999 **


Code:

=kde-apps/kde-apps-meta-9999 **
kde-apps/kde-l10n-9999 **


Code:

=kde-apps/kde-apps-meta-9999 **
kde-apps/kde-l10n **


For the record, here's what's available:
Code:


*  app-i18n/kde-l10n-scripts [ Masked ]
      Latest version available: 9999
      Latest version installed: [ Not Installed ]
      Size of files: 0 KiB
      Homepage:      https://github.com/vpelcak/kde-scripts
      Description:   Set of scripts to manage KDE translation files
      License:       LGPL-3

*  kde-apps/kde-l10n [ Masked ]
      Latest version available: 15.04.0
      Latest version installed: [ Not Installed ]
      Size of files: 21 227 KiB
      Homepage:      http://l10n.kde.org
      Description:   KDE internationalization package
      License:       GPL-2

*  kde-base/kde-l10n
      Latest version available: 4.14.3
      Latest version installed: [ Not Installed ]
      Size of files: 21 188 KiB
      Homepage:      http://l10n.kde.org
      Description:   KDE internationalization package
      License:       GPL-2

_________________
f
G -----> H G
p \ /_ ----- ~ f(G)
\ / f ker f
G/ker f
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum