Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gave up]xbmc won't install
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Irre
Guru
Guru


Joined: 09 Nov 2013
Posts: 425
Location: Stockholm

PostPosted: Sat Dec 13, 2014 10:39 pm    Post subject: [gave up]xbmc won't install Reply with quote

I'm trying to emerge xbmc(kodi) native on my Cubieboard2 (ARMv7).

Build is successfull (three hours compilation time!), but install fails :evil: :
Code:
...

LD      kodi.bin
-----------------------
Kodi built successfully
-----------------------
>>> Source compiled.
>>> Test phase [not enabled]: media-tv/xbmc-9999

>>> Install xbmc-9999 into /var/tmp/portage/media-tv/xbmc-9999/image/ category media-tv
make -j3 DESTDIR=/var/tmp/portage/media-tv/xbmc-9999/image/ install
Copying support and legal files...
Copying kodi binary to /var/tmp/portage/media-tv/xbmc-9999/image//usr/lib/kodi/
Done!ibXBMC_gui-arm.so
Copying system files to /var/tmp/portage/media-tv/xbmc-9999/image//usr/share/kodi
You can run kodi with the command 'kodi'
 -- strings.po

Copying bindings to /var/tmp/portage/media-tv/xbmc-9999/image//usr/include/kodi
 * ERROR: media-tv/xbmc-9999::gentoo failed (install phase):
 *   !!! newexe: tools/EventClients/Clients/XBMC Send/xbmc-send.py does not exist
 *
 * If you need support, post the output of `emerge --info '=media-tv/xbmc-9999::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=media-tv/xbmc-9999::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/media-tv/xbmc-9999/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-tv/xbmc-9999/temp/environment'.
 * Working directory: '/var/tmp/portage/media-tv/xbmc-9999/work/xbmc-9999'
 * S: '/var/tmp/portage/media-tv/xbmc-9999/work/xbmc-9999'
 * ERROR: media-tv/xbmc-9999::gentoo failed (install phase):
 *   (no error message)
 *
 * Call stack:
 *     ebuild.sh, line   93:  Called src_install
 *   environment, line 4029:  Called python_newscript 'tools/EventClients/Clients/XBMC Send/xbmc-send.py' 'xbmc-s                 end'
 *   environment, line 3827:  Called python_newexe 'tools/EventClients/Clients/XBMC Send/xbmc-send.py' 'xbmc-send                 '
 *   environment, line 3817:  Called die
 * The specific snippet of code:
 *       newexe "${f}" "${newfn}" || die );
 *
 * If you need support, post the output of `emerge --info '=media-tv/xbmc-9999::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=media-tv/xbmc-9999::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/media-tv/xbmc-9999/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-tv/xbmc-9999/temp/environment'.
 * Working directory: '/var/tmp/portage/media-tv/xbmc-9999/work/xbmc-9999'
 * S: '/var/tmp/portage/media-tv/xbmc-9999/work/xbmc-9999'
 * QA Notice: Unrecognized configure options:
 *
 *      --enable-external-libraries
 *      --disable-hal
 *      --enable-external-libraries
 *      --disable-hal
 * QA Notice: make jobserver unavailable:
 *
 *      make[1]: warning: jobserver unavailable: using -j1.  Add '+' to parent make rule.
 *      make[1]: warning: jobserver unavailable: using -j1.  Add '+' to parent make rule.
 *      make[1]: warning: jobserver unavailable: using -j1.  Add '+' to parent make rule.
 *      make[2]: warning: jobserver unavailable: using -j1.  Add '+' to parent make rule.
 *      make[2]: warning: jobserver unavailable: using -j1.  Add '+' to parent make rule.
 *      make[2]: warning: jobserver unavailable: using -j1.  Add '+' to parent make rule.

>>> Failed to emerge media-tv/xbmc-9999, Log file:

>>>  '/var/tmp/portage/media-tv/xbmc-9999/temp/build.log'

 * Messages for package media-tv/xbmc-9999:

 * ERROR: media-tv/xbmc-9999::gentoo failed (install phase):
 *   !!! newexe: tools/EventClients/Clients/XBMC Send/xbmc-send.py does not exist
 *
 * If you need support, post the output of `emerge --info '=media-tv/xbmc-9999::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=media-tv/xbmc-9999::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/media-tv/xbmc-9999/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-tv/xbmc-9999/temp/environment'.
 * Working directory: '/var/tmp/portage/media-tv/xbmc-9999/work/xbmc-9999'
 * S: '/var/tmp/portage/media-tv/xbmc-9999/work/xbmc-9999'
 * ERROR: media-tv/xbmc-9999::gentoo failed (install phase):
 *   (no error message)
 *
 * Call stack:
 *     ebuild.sh, line   93:  Called src_install
 *   environment, line 4029:  Called python_newscript 'tools/EventClients/Clients/XBMC Send/xbmc-send.py' 'xbmc-send'
 *   environment, line 3827:  Called python_newexe 'tools/EventClients/Clients/XBMC Send/xbmc-send.py' 'xbmc-send'
 *   environment, line 3817:  Called die
 * The specific snippet of code:
 *       newexe "${f}" "${newfn}" || die );
 *
 * If you need support, post the output of `emerge --info '=media-tv/xbmc-9999::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=media-tv/xbmc-9999::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/media-tv/xbmc-9999/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-tv/xbmc-9999/temp/environment'.
 * Working directory: '/var/tmp/portage/media-tv/xbmc-9999/work/xbmc-9999'
 * S: '/var/tmp/portage/media-tv/xbmc-9999/work/xbmc-9999'
 * After world updates, it is important to remove obsolete packages with
 * emerge --depclean. Refer to `man emerge` for more information.
emerge --info '=media-tv/xbmc-9999::gentoo'
Code:
Portage 2.2.15 (python 2.7.8-final-0, default/linux/arm/13.0/armv7a/desktop, gcc-4.8.3, glibc-2.20, 3.4.101-sun7i+ armv7l)
=================================================================
                         System Settings
=================================================================
System uname: Linux-3.4.101-sun7i+-armv7l-ARMv7_Processor_rev_4_-v7l-with-gentoo-2.2
KiB Mem:      976468 total,    259328 free
KiB Swap:    1048572 total,   1038200 free
Timestamp of tree: Sat, 13 Dec 2014 16:00:01 +0000
sh bash 4.3_p30-r1
ld GNU ld (Gentoo 2.24 p1.4) 2.24
app-shells/bash:          4.3_p30-r1
dev-java/java-config:     2.1.12-r1
dev-lang/perl:            5.20.1-r3
dev-lang/python:          2.7.8, 3.4.2
dev-util/cmake:           3.0.2
dev-util/pkgconfig:       0.28-r2
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.13.6
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.69

Is it possible to manually install, or must the error be corrected and emerge rerun?


Last edited by Irre on Fri Jan 02, 2015 8:19 am; edited 1 time in total
Back to top
View user's profile Send private message
nativemad
Developer
Developer


Joined: 30 Aug 2004
Posts: 917
Location: Switzerland

PostPosted: Mon Dec 15, 2014 7:40 am    Post subject: Reply with quote

Hi,

i've hit the same thing after around 12 hours on my pi! :oops:

https://bugs.gentoo.org/show_bug.cgi?id=526992

I hope ccache will save me some hours now.....

HTH, Cheers
_________________
Power to the people!
Back to top
View user's profile Send private message
Irre
Guru
Guru


Joined: 09 Nov 2013
Posts: 425
Location: Stockholm

PostPosted: Mon Dec 15, 2014 8:31 am    Post subject: Reply with quote

Thank you for information about the bug. I have a working Raspberry PI with xbmc. But it uses Raspian linux. I like everything to be "gentoo" :)
Back to top
View user's profile Send private message
nativemad
Developer
Developer


Joined: 30 Aug 2004
Posts: 917
Location: Switzerland

PostPosted: Mon Dec 15, 2014 9:36 am    Post subject: Reply with quote

yeah, i tried raspbmc, openelec as well as raspbian and even arch on the pi with xbmc.
But always something was missing...
Maybe gentoo users are just a bit spoilt! :wink:
_________________
Power to the people!
Back to top
View user's profile Send private message
Irre
Guru
Guru


Joined: 09 Nov 2013
Posts: 425
Location: Stockholm

PostPosted: Tue Dec 16, 2014 8:53 am    Post subject: Reply with quote

Tonight it was possible to emerge an explicit version of xbmc
Code:
emerge -v =media-tv/xbmc-13.2
But I don't know if it usable as I have no hdmi-monitor available yet. Trying to run via ssh gave this error
Code:
ssh -Y 192.168.1.6 xbmc
Password:

(process:24807): Gtk-WARNING **: Locale not supported by C library.
   Using the fallback 'C' locale.
libGL error: failed to open drm device: No such file or directory
libGL error: failed to load driver: i965
ERROR: Unable to create GUI. Exiting
Back to top
View user's profile Send private message
Amarok
n00b
n00b


Joined: 11 Nov 2003
Posts: 70

PostPosted: Thu Jan 01, 2015 8:15 pm    Post subject: Reply with quote

!!! newexe: tools/EventClients/Clients/XBMC Send/xbmc-send.py does not exist

its kodi

i change it to tools/EventClients/Clients/Kodi Send/kodi-send.py in my ebuild

and with eselect i change to python 2.7
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 49412
Location: 56N 3W

PostPosted: Thu Jan 01, 2015 8:28 pm    Post subject: Reply with quote

Irre,

Eww.
Code:
libGL error: failed to load driver: i965

Thats an Intel driver on an Arm board. I think I heard the crash in Scotland. :)

I've just got a CubieTruck ... Android has to go.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Irre
Guru
Guru


Joined: 09 Nov 2013
Posts: 425
Location: Stockholm

PostPosted: Fri Jan 02, 2015 8:12 am    Post subject: Reply with quote

NeddySeagoon wrote:
Irre,

Eww.
Code:
libGL error: failed to load driver: i965

Thats an Intel driver on an Arm board. I think I heard the crash in Scotland. :)

I've just got a CubieTruck ... Android has to go.
Thank you.
Code:
ssh -Y 192.168.1.6 qupzilla
works fine, but I now realize that I'm far away from having a working XBMC on my arm-machine. "XBMC needs hardware accelerated OpenGL rendering" and it is probably not possible to run XBMC via ssh. I have much to learn. How to generate a working kernel, how to configure the boot loader on Cubieboard etc. 8O
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 49412
Location: 56N 3W

PostPosted: Fri Jan 02, 2015 2:37 pm    Post subject: Reply with quote

Irre,

Well XBMC works on a Raspberry pi, so there is hope.
You are correct that it won't work over ssh though.

However, VNC can be set up in 'screen scraper' mode, so that you can see whats on the screen over the network.

I have no idea, yet, if the Allwinner 20 graphics is as well supported as the Pi. That's fun for another day.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
DawgG
l33t
l33t


Joined: 17 Sep 2003
Posts: 850

PostPosted: Fri Jan 09, 2015 11:37 am    Post subject: Reply with quote

i don't mean to be a heretic here but don't you think it's a little crazy to compile really big pkgs like xbmc on raspi et al?

Quote:
yeah, i tried raspbmc, openelec as well as raspbian and even arch on the pi with xbmc.
But always something was missing...

i use openelec on my raspi and it's quite alright (not the best multimedia-hardware to begin with). being a spoilt gentoo-user i build it from the source and adapt the configs to what I like. it's quite an easy process and you can always check out the latest stuff with git. on a powerful machine the whole process takes about 4-5 hours if you start with nothing. guide is here: http://wiki.openelec.tv/index.php/Compile_from_source and there are almost no extra pkgs that need to be installed on your standard gentoo-install. i think openelec is a very well-done project and development is very fast.
_________________
DUMM KLICKT GUT.
Back to top
View user's profile Send private message
VinzC
Watchman
Watchman


Joined: 17 Apr 2004
Posts: 5097
Location: Dark side of the mood

PostPosted: Tue May 05, 2015 3:32 pm    Post subject: Reply with quote

NeddySeagoon wrote:
Irre,

Eww.
Code:
libGL error: failed to load driver: i965

Thats an Intel driver on an Arm board. I think I heard the crash in Scotland. :)

I've just got a CubieTruck ... Android has to go.

:lol:
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
1739!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum