Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
No TTY on CTRL+ALT+F1-6 when no user is logged-in in DM
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
xicod
n00b
n00b


Joined: 03 Oct 2013
Posts: 18

PostPosted: Sat Apr 11, 2015 8:08 am    Post subject: No TTY on CTRL+ALT+F1-6 when no user is logged-in in DM Reply with quote

The problem is like this:
Trying to switch to a TTY using CTRL+ALT+F1 keys immediately after boot seeing a graphical user login prompt in GDM/Lightdm gives a black blank screen.
Switching back to DM with CTRL+ALT+F7, logging in and then hitting CTRL+ALT+F1 will give the desired TTY login prompt.
If I log out in GUI and try to switch to TTY - again gives a blank screen.
Conclusion - there's a direct connection between the authentication status in DM and switching ability to TTY,
which sounds to me like a "security feature", possibly in systemd (because it happens with GDM and Lightdm).

System is latest stable, using systemd and an Nvidia graphics card (which I'm pretty sure is not related)

Please assist ..
Back to top
View user's profile Send private message
ferrelas
Tux's lil' helper
Tux's lil' helper


Joined: 14 Jun 2008
Posts: 107

PostPosted: Thu Apr 16, 2015 2:03 am    Post subject: Reply with quote

Would you ever need to do that?

Also, the obvious solution is to stop using the graphical login manager.
Back to top
View user's profile Send private message
The Doctor
Moderator
Moderator


Joined: 27 Jul 2010
Posts: 2574

PostPosted: Thu Apr 16, 2015 3:49 am    Post subject: Reply with quote

OP, what kind of video card do you have and what kind of drivers are you using? There have been similar cases with the higher end cards not properly supporting the console mode.
_________________
First things first, but not necessarily in that order.

Apologies if I take a while to respond. I'm currently working on the dematerialization circuit for my blue box.
Back to top
View user's profile Send private message
xicod
n00b
n00b


Joined: 03 Oct 2013
Posts: 18

PostPosted: Sat Apr 18, 2015 8:16 pm    Post subject: Reply with quote

The Doctor wrote:
OP, what kind of video card do you have and what kind of drivers are you using? There have been similar cases with the higher end cards not properly supporting the console mode.


This is a Lenovo Y510p laptop with two Nvidia GT755M cards. Using the latest available stable nvidia binary driver.
Back to top
View user's profile Send private message
xicod
n00b
n00b


Joined: 03 Oct 2013
Posts: 18

PostPosted: Fri May 01, 2015 3:50 pm    Post subject: Reply with quote

Any ideas?
Back to top
View user's profile Send private message
khamryn
n00b
n00b


Joined: 05 May 2015
Posts: 2

PostPosted: Tue May 05, 2015 4:37 am    Post subject: Reply with quote

Hi, I am too having this very issue. haven't been paying attention due to life stuff, so I have no idea when (or if) a update caused this. I do not use a DM (use startx), use Proprietary ATI-drivers, and run a mixed-system of stable and testing. Had no issues with going back to the shell with the proprietary drivers until recently. Think it may have been caused (at least for me) when the new ati-drivers was added back in early April possible. I may do a downgrade when I have time, but it's a pain due to dependence conflicts with newer packages. If anyone had experienced this issue and found a resolution, please reply. :D
Back to top
View user's profile Send private message
khamryn
n00b
n00b


Joined: 05 May 2015
Posts: 2

PostPosted: Wed May 06, 2015 9:40 am    Post subject: Reply with quote

Found my solution. I downgraded x.org from 1.17 to 1.16. I overlooked this upgrade a while back and didn't realize console wouldn't display once the GUI started until this week.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum