Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Solution for Firefox behaving laggy/stiff/unresponsive
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
gorg86
Tux's lil' helper
Tux's lil' helper


Joined: 20 May 2011
Posts: 123

PostPosted: Sun May 03, 2015 4:38 am    Post subject: Solution for Firefox behaving laggy/stiff/unresponsive Reply with quote

Hi,

I was experimenting with Wayland/Weston different Compositors for X etc. when I discovered the solution for this sinister bug appearently nobody has an answer for on the net.
If Firefox is randomly stiff and laggy especially if you browse websites that use lots of javascript or HTML5 or just watching youtube and you tried to compile with different useflags etc. especially the system-* and custom-* flags, you turned on/off hardware acceleration, you exhausted all possibilities in about:config and the problem still persists here is one more thing you can try:

Turn on VSync.

The only way I could do that properly was with compton or compiz. The frame limiting factor seems to take a lot of load from the gecko engine. My FF is now supersmooth.
I compiled FF with the custom-* flags and without all the system-* flags.

Just my 2 cents.
Back to top
View user's profile Send private message
rudregues
Apprentice
Apprentice


Joined: 29 Jan 2013
Posts: 227
Location: Brazil

PostPosted: Sun May 24, 2015 6:19 pm    Post subject: Re: Solution for Firefox behaving laggy/stiff/unresponsive Reply with quote

gorg86 wrote:
Hi,

I was experimenting with Wayland/Weston different Compositors for X etc. when I discovered the solution for this sinister bug appearently nobody has an answer for on the net.
If Firefox is randomly stiff and laggy especially if you browse websites that use lots of javascript or HTML5 or just watching youtube and you tried to compile with different useflags etc. especially the system-* and custom-* flags, you turned on/off hardware acceleration, you exhausted all possibilities in about:config and the problem still persists here is one more thing you can try:

Turn on VSync.

The only way I could do that properly was with compton or compiz. The frame limiting factor seems to take a lot of load from the gecko engine. My FF is now supersmooth.
I compiled FF with the custom-* flags and without all the system-* flags.

Just my 2 cents.
This bug was occurring just in X or in Wayland too? I think there is no VSync in Wayland http://forum.kodi.tv/showthread.php?tid=202865&pid=1780842#pid1780842
_________________
Emerging en gentoo
Back to top
View user's profile Send private message
gorg86
Tux's lil' helper
Tux's lil' helper


Joined: 20 May 2011
Posts: 123

PostPosted: Sun May 24, 2015 10:16 pm    Post subject: Reply with quote

Wayland does VSync by default, at least on my machine (there is no tearing at all, so I assume it is turned on). The bug did not occur in Wayland but even if it did, in this particular case that would mean nothing because firefox ran on top of the Wayland-X.org compatibility layer or whatever it is called. I assume that there is something wrong with firefox and not with X.org in this case, beacuse it occured on different machines running Windows and Linux.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum