Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] slot conflict in updating xorg-server
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
queen
Veteran
Veteran


Joined: 19 Jul 2005
Posts: 1612

PostPosted: Sat Apr 25, 2015 6:18 pm    Post subject: [SOLVED] slot conflict in updating xorg-server Reply with quote

I try to update the latest version of xorg-server. The problem is that I get slot conflict. I changed USE flags and other things, but nothing helped. This is the output.
Code:

emerge -pvN xorg-server

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] x11-proto/fontsproto-2.1.3::gentoo [2.1.2::gentoo] USE="-doc" 151 KiB
[ebuild  N     ] media-libs/libepoxy-1.2::gentoo  USE="{-test}" ABI_X86="(64) -32 (-x32)" 261 KiB
[ebuild     U  ] x11-base/xorg-server-1.16.4:0/1.16.1::gentoo [1.15.2-r2:0/1.15.2::gentoo] USE="glamor%* ipv6 nptl udev xorg -dmx -doc -kdrive -minimal (-selinux) -static-libs -suid* -systemd% -tslib -unwind -wayland% -xnest -xvfb" 5,681 KiB

Total: 3 packages (2 upgrades, 1 new), Size of downloads: 6,093 KiB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-base/xorg-server:0

  (x11-base/xorg-server-1.16.4:0/1.16.1::gentoo, ebuild scheduled for merge) pulled in by
    x11-base/xorg-server (Argument)

  (x11-base/xorg-server-1.15.2-r2:0/1.15.2::gentoo, installed) pulled in by
    x11-base/xorg-server:0/1.15.2= required by (x11-drivers/xf86-video-intel-2.99.917:0/0::gentoo, installed)
                        ^^^^^^^^^^                                                                                                               
    (and 7 more with the same problem)

x11-proto/fontsproto:0

  (x11-proto/fontsproto-2.1.3:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-proto/fontsproto-2.1.3 required by (x11-base/xorg-server-1.16.4:0/1.16.1::gentoo, ebuild scheduled for merge)
    ^^                     ^^^^^                                                                                                                                             

  (x11-proto/fontsproto-2.1.2:0/0::gentoo, installed) pulled in by
    <x11-proto/fontsproto-2.1.3 required by (x11-libs/libXfont-1.4.9:0/0::gentoo, installed)
    ^                     ^^^^^                                                                                                                   


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.
!!! The following installed packages are masked:
- app-emulation/emul-linux-x86-xlibs-20140508::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Michał Górny <mgorny@gentoo.org> (28 Mar 2015)
# on behalf of gx86-multilib project <multilib@gentoo.org>
# Mask emul-linux-x86 packages along with unported old versions
# of reverse dependencies for removal in 60 days, bug #544876.
# Please use multilib ebuilds with abi_x86_32 instead.

- app-emulation/emul-linux-x86-baselibs-20140508-r12::gentoo (masked by: package.mask)
- media-video/mplayer2-2.0_p20131009::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Ben de Groot <yngwin@gentoo.org> (15 Mar 2015)
# These projects have been abandoned upstream. Most mplayer2 devs have moved
# on to media-video/mpv, and users are suggested to do the same. We have
# media-video/baka-mplayer and media-video/smplayer available as Qt-based GUIs.
# See bugs 452484, 485994, 512082, 519212. Removal in 30 days.

- app-emulation/emul-linux-x86-opengl-20140508::gentoo (masked by: package.mask)
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.



Any suggestions how to solve this issue?


Last edited by queen on Sun Apr 26, 2015 7:51 pm; edited 1 time in total
Back to top
View user's profile Send private message
wjn
n00b
n00b


Joined: 18 Apr 2015
Posts: 14
Location: JP

PostPosted: Sat Apr 25, 2015 7:42 pm    Post subject: Reply with quote

This xorg-server's upgrading requires rebuilding its dependent packages such as xf86-video-intel (and 7 more packages).
(Most of them are components of X.Org. They should be rebuilt for the new xorg-server.)

Try emerging with --deep option (-D option).
# emerge -pvND xorg-server
Back to top
View user's profile Send private message
queen
Veteran
Veteran


Joined: 19 Jul 2005
Posts: 1612

PostPosted: Sat Apr 25, 2015 8:00 pm    Post subject: Reply with quote

wjn wrote:
This xorg-server's upgrading requires rebuilding its dependent packages such as xf86-video-intel (and 7 more packages).
(Most of them are components of X.Org. They should be rebuilt for the new xorg-server.)

Try emerging with --deep option (-D option).
# emerge -pvND xorg-server


this is the output I get after your suggestion

Code:

emerge -pvND xorg-server

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-base/xorg-server:0

  (x11-base/xorg-server-1.16.4:0/1.16.1::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-base/xorg-server-1.15.2-r2:0/1.15.2::gentoo, ebuild scheduled for merge) pulled in by
    x11-base/xorg-server:0/1.15.2= required by (x11-drivers/xf86-video-intel-2.99.917:0/0::gentoo, installed)
                        ^^^^^^^^^^                                                                                                               
    (and 3 more with the same problem)

x11-proto/fontsproto:0

  (x11-proto/fontsproto-2.1.3:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-proto/fontsproto-2.1.3 required by (x11-base/xorg-server-1.16.4:0/1.16.1::gentoo, ebuild scheduled for merge)
    ^^                     ^^^^^                                                                                                                                             

  (x11-proto/fontsproto-2.1.2:0/0::gentoo, installed) pulled in by
    <x11-proto/fontsproto-2.1.3 required by (x11-base/xorg-server-1.15.2-r2:0/1.15.2::gentoo, ebuild scheduled for merge)
    ^                     ^^^^^                                                                                                                                                 


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


!!! All ebuilds that could satisfy "dev-qt/qtchooser" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-qt/qtchooser-0_p20150102::gentoo (masked by: ~amd64 keyword)

(dependency required by "dev-qt/qtcore-4.8.6-r1::gentoo" [ebuild])
(dependency required by "x11-drivers/ati-drivers-14.12-r3::gentoo[qt4]" [installed])
(dependency required by "x11-base/xorg-drivers-1.16::gentoo[video_cards_fglrx]" [installed])
(dependency required by "x11-base/xorg-server-1.15.2-r2::gentoo[xorg]" [ebuild])
(dependency required by "xorg-server" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 6958
Location: Saint Amant, Acadiana

PostPosted: Sat Apr 25, 2015 8:38 pm    Post subject: Reply with quote

-u is for upgrading. Make it emerge -pvNDu xorg-server.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
mv
Watchman
Watchman


Joined: 20 Apr 2005
Posts: 6276

PostPosted: Sat Apr 25, 2015 8:45 pm    Post subject: Reply with quote

I suggest even to run a full emerge -NaDu @world
Your problem is that many packages (like libXfont) need to be upgraded, too, but your emerge command doesn't allow portage to do this.
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 2152
Location: Berlin, Germany

PostPosted: Sat Apr 25, 2015 8:56 pm    Post subject: Reply with quote

Try this:
Code:
# emerge -1 xorg-server @x11-module-rebuild

Explanation: x11-drivers packages have a subslot dependency on the installed X server because these packages typically only work with the X server they were built against. If they somehow don't appear in emerge's dependency graph (because xorg-drivers was built without VIDEO_CARDS="intel" or for some other reason) they will cause a conflict during the upgrade. Adding "@x11-module-rebuild" will ensure the rebuild of these packages against the new X server.
Back to top
View user's profile Send private message
queen
Veteran
Veteran


Joined: 19 Jul 2005
Posts: 1612

PostPosted: Sat Apr 25, 2015 9:14 pm    Post subject: Reply with quote

chithanh wrote:
Try this:
Code:
# emerge -1 xorg-server @x11-module-rebuild

Explanation: x11-drivers packages have a subslot dependency on the installed X server because these packages typically only work with the X server they were built against. If they somehow don't appear in emerge's dependency graph (because xorg-drivers was built without VIDEO_CARDS="intel" or for some other reason) they will cause a conflict during the upgrade. Adding "@x11-module-rebuild" will ensure the rebuild of these packages against the new X server.


Thanks for your reply. I tried your suggestion and it still gives me slot conflict.

Code:

emerge -1 xorg-server @x11-module-rebuild
Calculating dependencies... done!
[ebuild     U  ] x11-proto/fontsproto-2.1.3 [2.1.2]
[ebuild  N     ] media-libs/libepoxy-1.2  USE="{-test}" ABI_X86="(64) -32 (-x32)"
[ebuild     U  ] x11-base/xorg-server-1.16.4 [1.15.2-r2] USE="glamor%* -suid* -systemd% -wayland%"
[ebuild   R    ] x11-drivers/xf86-input-mouse-1.9.1
[ebuild   R    ] x11-drivers/xf86-video-fbdev-0.4.4
[ebuild   R    ] x11-drivers/xf86-input-evdev-2.9.1
[ebuild   R    ] x11-drivers/xf86-video-intel-2.99.917
[ebuild   R    ] x11-drivers/xf86-input-synaptics-1.8.1
[ebuild   R    ] x11-drivers/xf86-input-keyboard-1.8.0
[ebuild   R    ] x11-drivers/xf86-video-vesa-2.3.3
[ebuild   R    ] x11-drivers/xf86-video-v4l-0.2.0
[ebuild   R   ~] x11-drivers/xf86-video-virtualbox-4.3.26
[ebuild   R    ] x11-drivers/ati-drivers-14.12-r3

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-proto/fontsproto:0

  (x11-proto/fontsproto-2.1.2:0/0::gentoo, installed) pulled in by
    <x11-proto/fontsproto-2.1.3 required by (x11-libs/libXfont-1.4.9:0/0::gentoo, installed)
    ^                     ^^^^^                                                                                                                   

  (x11-proto/fontsproto-2.1.3:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-proto/fontsproto-2.1.3 required by (x11-base/xorg-server-1.16.4:0/1.16.1::gentoo, ebuild scheduled for merge)
    ^^                     ^^^^^                                                                                                                                             


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


!!! The following installed packages are masked:
- app-emulation/emul-linux-x86-opengl-20140508::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Michał Górny <mgorny@gentoo.org> (28 Mar 2015)
# on behalf of gx86-multilib project <multilib@gentoo.org>
# Mask emul-linux-x86 packages along with unported old versions
# of reverse dependencies for removal in 60 days, bug #544876.
# Please use multilib ebuilds with abi_x86_32 instead.

- app-emulation/emul-linux-x86-baselibs-20140508-r12::gentoo (masked by: package.mask)
- media-video/mplayer2-2.0_p20131009::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Ben de Groot <yngwin@gentoo.org> (15 Mar 2015)
# These projects have been abandoned upstream. Most mplayer2 devs have moved
# on to media-video/mpv, and users are suggested to do the same. We have
# media-video/baka-mplayer and media-video/smplayer available as Qt-based GUIs.
# See bugs 452484, 485994, 512082, 519212. Removal in 30 days.

- app-emulation/emul-linux-x86-xlibs-20140508::gentoo (masked by: package.mask)
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


I see the culprit is libXfont that I can't upgrade to version 1.5.1 no matter what I try.

Code:
emerge =x11-libs/libXfont-1.5.1
Calculating dependencies... done!
[ebuild     U  ] x11-proto/fontsproto-2.1.3 [2.1.2]
[ebuild     U  ] x11-libs/libXfont-1.5.1 [1.4.9]

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/libXfont:0

  (x11-libs/libXfont-1.5.1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    =x11-libs/libXfont-1.5.1 (Argument)

  (x11-libs/libXfont-1.4.9:0/0::gentoo, installed) pulled in by
    <x11-libs/libXfont-1.5.0 required by (x11-base/xorg-server-1.15.2-r2:0/1.15.2::gentoo, installed)
    ^                  ^^^^^                                                                                                                               

x11-proto/fontsproto:0

  (x11-proto/fontsproto-2.1.3:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-proto/fontsproto-2.1.3 required by (x11-libs/libXfont-1.5.1:0/0::gentoo, ebuild scheduled for merge)
    ^^                     ^^^^^                                                                                                                                     

  (x11-proto/fontsproto-2.1.2:0/0::gentoo, installed) pulled in by
    <x11-proto/fontsproto-2.1.3 required by (x11-libs/libXfont-1.4.9:0/0::gentoo, installed)
    ^                     ^^^^^                                                                                                                   


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


!!! The following installed packages are masked:
- app-emulation/emul-linux-x86-opengl-20140508::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Michał Górny <mgorny@gentoo.org> (28 Mar 2015)
# on behalf of gx86-multilib project <multilib@gentoo.org>
# Mask emul-linux-x86 packages along with unported old versions
# of reverse dependencies for removal in 60 days, bug #544876.
# Please use multilib ebuilds with abi_x86_32 instead.

- app-emulation/emul-linux-x86-xlibs-20140508::gentoo (masked by: package.mask)
- app-emulation/emul-linux-x86-baselibs-20140508-r12::gentoo (masked by: package.mask)
- media-video/mplayer2-2.0_p20131009::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Ben de Groot <yngwin@gentoo.org> (15 Mar 2015)
# These projects have been abandoned upstream. Most mplayer2 devs have moved
# on to media-video/mpv, and users are suggested to do the same. We have
# media-video/baka-mplayer and media-video/smplayer available as Qt-based GUIs.
# See bugs 452484, 485994, 512082, 519212. Removal in 30 days.

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


Any idea how to solve the libXfont issue?
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 2152
Location: Berlin, Germany

PostPosted: Sat Apr 25, 2015 9:22 pm    Post subject: Reply with quote

You may need to emerge all these packages at once.
Code:
# emerge -1 xorg-server @x11-module-rebuild libXfont fontsproto


Also note that not using -1 (--oneshot) will make the packages be recorded in the /var/lib/portage/world file. This can prevent automated blocker resolution by portage in some cases, therefore only packages which you explicitly want installed should be in world.
Back to top
View user's profile Send private message
queen
Veteran
Veteran


Joined: 19 Jul 2005
Posts: 1612

PostPosted: Sat Apr 25, 2015 9:53 pm    Post subject: Reply with quote

chithanh wrote:
You may need to emerge all these packages at once.
Code:
# emerge -1 xorg-server @x11-module-rebuild libXfont fontsproto


Also note that not using -1 (--oneshot) will make the packages be recorded in the /var/lib/portage/world file. This can prevent automated blocker resolution by portage in some cases, therefore only packages which you explicitly want installed should be in world.


Thanks. This one seems to work. :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum