Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Помогите обновить серевер на gentoo
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Russian
View previous topic :: View next topic  
Author Message
xlin
n00b
n00b


Joined: 24 Apr 2015
Posts: 3

PostPosted: Fri Apr 24, 2015 6:14 pm    Post subject: Помогите обновить серевер на gentoo Reply with quote

Доброго дня. Прошу помощи. Достался сервер на gentoo в наследство. Используется как основной шлюз и почтовый сервер. Так же там же сквид. В общем критичный сервер. Сам ранее админил только CentOS и Debian.

Система не обновлялась около кода. Начал делать, но много не понятно. Надеюсь на ваш профессионализм.

Как тут быть? Сделал следующее.

Code:
emerge --sync
etc-update (-3)


выхлоп
http://pastebin.com/R3uWZnpj


Обновил питон как предложила сама ОС

Code:
 ~ # eselect python list
Available Python interpreters:
  [1]   python2.7
  [2]   python3.2 *
  [3]   python3.3
 ~ #  eselect python set --python3 python3.3

~ # eselect python list

Available Python interpreters:
  [1]   python2.7
  [2]   python3.2
  [3]   python3.3 *
mail ~ # python-updater
!!! SYNC setting found in make.conf.
    This setting is Deprecated and no longer used.  Please ensure your 'sync-type' and 'sync-uri' are set correctly in /etc/portage/repos.conf/gentoo.conf
!!! SYNC setting found in make.conf.
    This setting is Deprecated and no longer used.  Please ensure your 'sync-type' and 'sync-uri' are set correctly in /etc/portage/repos.conf/gentoo.conf
!!! SYNC setting found in make.conf.
    This setting is Deprecated and no longer used.  Please ensure your 'sync-type' and 'sync-uri' are set correctly in /etc/portage/repos.conf/gentoo.conf
 * Starting Python Updater...
 * Main active version of Python:    3.3
 * Active version of Python 2:       2.7
 * Active version of Python 3:       3.3
 * Globally supported Python ABIs in installed repositories:
 *   gentoo:                         2.4 2.5 2.6 2.7 3.1 3.2 3.3 2.5-jython 2.7-jython 2.7-pypy-1.7 2.7-pypy-1.8 2.7-pypy-1.9 2.7-pypy-2.0
!!! SYNC setting found in make.conf.
    This setting is Deprecated and no longer used.  Please ensure your 'sync-type' and 'sync-uri' are set correctly in /etc/portage/repos.conf/gentoo.conf
!!! SYNC setting found in make.conf.
    This setting is Deprecated and no longer used.  Please ensure your 'sync-type' and 'sync-uri' are set correctly in /etc/portage/repos.conf/gentoo.conf
!!! SYNC setting found in make.conf.
    This setting is Deprecated and no longer used.  Please ensure your 'sync-type' and 'sync-uri' are set correctly in /etc/portage/repos.conf/gentoo.conf                                     
 *   Adding to list: sys-libs/libcap-ng:0
!!! SYNC setting found in make.conf.                                                                                                                                                           
    This setting is Deprecated and no longer used.  Please ensure your 'sync-type' and 'sync-uri' are set correctly in /etc/portage/repos.conf/gentoo.conf                                     
 * emerge -Dv1 --keep-going sys-libs/libcap-ng:0
!!! SYNC setting found in make.conf.                                                                                                                                                           
    This setting is Deprecated and no longer used.  Please ensure your 'sync-type' and 'sync-uri' are set correctly in /etc/portage/repos.conf/gentoo.conf                                     

 * IMPORTANT: 9 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] sys-libs/libcap-ng-0.7.4::gentoo [0.7.3::gentoo] USE="python -static-libs" PYTHON_TARGETS="python2_7%* python3_3%* -python3_4%" 398 KiB

Total: 1 package (1 upgrade), Size of downloads: 398 KiB

!!! The following installed packages are masked:
- virtual/perl-MIME-Base64-3.130.0-r4::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Andreas K. Huettel <dilfridge@gentoo.org> (29 Mar 2015)
# Mask Perl 5.18 for removal. Please upgrade to Perl 5.20

- virtual/perl-Digest-MD5-2.520.0-r2::gentoo (masked by: package.mask)
- dev-db/postgresql-server-9.2.7::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Aaron W. Swenson <titanofold@gentoo.org> (28 Dec 2014)
# Split ebuilds are no longer maintained. Migrate to the unified
# ebuilds invoking the following, substituting SLOT for the desired
# slot and optionally enabling the server and/or docs USE flags:
#   emerge dev-db/postgresql:SLOT
# No further action is required.

- virtual/perl-Time-HiRes-1.972.500-r3::gentoo (masked by: package.mask)
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) sys-libs/libcap-ng-0.7.4::gentoo

Компилился
Code:

 * GNU info directory index is up-to-date.

!!! existing preserved libs:
>>> package: dev-db/mysql-5.5.40
 *  - /usr/lib64/libmysqlclient.so.16
 *  - /usr/lib64/mysql/libmysqlclient.so.16
 *  - /usr/lib64/mysql/libmysqlclient.so.16.0.0
 *      used by /usr/lib64/perl5/vendor_perl/5.12.4/x86_64-linux/auto/DBD/mysql/mysql.so (dev-perl/DBD-mysql-4.20.0)
Use emerge @preserved-rebuild to rebuild packages using these libraries

 * IMPORTANT: 9 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.

Вижу что ругается на postgresql.
Code:
#eselect postgresql list
Available PostgreSQL Slots
  9.2 *                      server-9.2.7 base-9.2.7
  9.3                        base-9.3.3

#eix -s postgresql
[I] app-eselect/eselect-postgresql
     Available versions:  1.2.1
     Installed versions:  1.2.1(14:34:49 20.06.2014)
     Homepage:            http://www.gentoo.org/
     Description:         Utility to select the default PostgreSQL slot

[U] dev-db/postgresql
     Available versions: 
     (9.0)  9.0.19^t ~9.0.19-r1^t
     (9.1)  9.1.15^t ~9.1.15-r1^t
     (9.2)  9.2.10 ~9.2.10-r1
     (9.3)  9.3.6 ~9.3.6-r1
     (9.4)  9.4.1 ~9.4.1-r1
     (9.5)  **9999
       {doc kerberos ldap nls pam perl -pg_legacytimestamp python +readline selinux +server ssl static-libs tcl threads uuid xml zlib KERNEL="linux" LINGUAS="af cs de en es fa fr hr hu it ko nb pl pt_BR ro ru sk sl sv tr zh_CN zh_TW" PYTHON_SINGLE_TARGET="python2_7 python3_3 python3_4" PYTHON_TARGETS="python2_7 python3_3 python3_4"}
     Installed versions:  9.2.7(9.2)^t(15:25:59 10.04.2014)(kerberos nls pam python readline ssl zlib -doc -ldap -pg_legacytimestamp -threads LINGUAS="ru -af -cs -de -en -es -fa -fr -hr -hu -it -ko -nb -pl -pt_BR -ro -sk -sl -sv -tr -zh_CN -zh_TW" PYTHON_SINGLE_TARGET="python2_7 -python2_6 -python3_2 -python3_3" PYTHON_TARGETS="python2_7 python3_3 -python2_6 -python3_2") 9.3.3(9.3)^t(14:50:30 20.06.2014)(kerberos nls pam python readline ssl zlib -doc -ldap -pg_legacytimestamp -threads LINGUAS="ru -af -cs -de -en -es -fa -fr -hr -hu -it -ko -nb -pl -pt_BR -ro -sk -sl -sv -tr -zh_CN -zh_TW" PYTHON_SINGLE_TARGET="python2_7 -python2_6 -python3_2 -python3_3" PYTHON_TARGETS="python2_7 python3_3 -python2_6 -python3_2")
     Homepage:            http://www.postgresql.org/
     Description:         PostgreSQL RDBMS

Code:
portage # cat package.mask
>=dev-db/postgresql-server-9.3

Заранее благодарен.
Back to top
View user's profile Send private message
xlin
n00b
n00b


Joined: 24 Apr 2015
Posts: 3

PostPosted: Fri Apr 24, 2015 6:17 pm    Post subject: Reply with quote

Еще я так понимаю ему хочется обновить Perl. Но и его не получается обновить. Сейчас думаю, если сервер не дай Бог перезапустить, то уже не взлетит.
Code:
# emerge -av dev-lang/perl

 * IMPORTANT: config file '/etc/portage/package.accept_keywords' needs updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] dev-lang/perl-5.20.2:0/5.20::gentoo [5.16.3:0/5.16::gentoo] USE="berkdb gdbm -debug -doc -ithreads" 13 410 KiB
[ebuild  N     ] perl-core/Data-Dumper-2.154.0::gentoo  99 KiB
[ebuild  N     ] virtual/perl-Data-Dumper-2.154.0::gentoo  0 KiB
[ebuild  N     ] perl-core/File-Temp-0.230.400-r1::gentoo  59 KiB
[ebuild     U  ] virtual/perl-File-Temp-0.230.400-r2::gentoo [0.220.0-r2::gentoo] 0 KiB

Total: 5 packages (2 upgrades, 3 new), Size of downloads: 13 567 KiB
                                                                                                                                                                                               
!!! Multiple package instances within a single package slot have been pulled                                                                                                                   
!!! into the dependency graph, resulting in a slot conflict:                                                                                                                                   
                                                                                                                                                                                               
dev-lang/perl:0                                                                                                                                                                                 
                                                                                                                                                                                               
  (dev-lang/perl-5.20.2:0/5.20::gentoo, ebuild scheduled for merge) pulled in by                                                                                                               
    dev-lang/perl (Argument)
    =dev-lang/perl-5.20* required by (virtual/perl-Digest-1.170.0-r4:0/0::gentoo, installed)
    ^              ^^^^^                                                                                                                           
    (and 1 more with the same problems)

  (dev-lang/perl-5.16.3:0/5.16::gentoo, installed) pulled in by
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/PlRPC-0.202.0-r2:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                             
    (and 22 more with the same problem)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


!!! The following installed packages are masked:
- virtual/perl-Digest-MD5-2.520.0-r2::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Andreas K. Huettel <dilfridge@gentoo.org> (29 Mar 2015)
# Mask Perl 5.18 for removal. Please upgrade to Perl 5.20

- virtual/perl-MIME-Base64-3.130.0-r4::gentoo (masked by: package.mask)
- virtual/perl-Time-HiRes-1.972.500-r3::gentoo (masked by: package.mask)
- dev-db/postgresql-server-9.2.7::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Aaron W. Swenson <titanofold@gentoo.org> (28 Dec 2014)
# Split ebuilds are no longer maintained. Migrate to the unified
# ebuilds invoking the following, substituting SLOT for the desired
# slot and optionally enabling the server and/or docs USE flags:
#   emerge dev-db/postgresql:SLOT
# No further action is required.

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
Back to top
View user's profile Send private message
xlin
n00b
n00b


Joined: 24 Apr 2015
Posts: 3

PostPosted: Fri Apr 24, 2015 6:47 pm    Post subject: Reply with quote

emerge -pvuND world
Code:
emerge -pvuND world

 * IMPORTANT: config file '/etc/portage/package.accept_keywords' needs updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.

These are the packages that would be merged, in order:

Calculating dependencies... done!


[ebuild    U  ] net-misc/ntp-4.2.8-r1::gentoo [4.2.6_p5-r10::gentoo] USE="samba ssl vim-syntax -caps -debug -ipv6 -openntpd -parse-clocks (-selinux) -snmp -zeroconf" 6 638 KiB
[ebuild    U  ] net-analyzer/nmap-6.47-r1::gentoo [6.25::gentoo] USE="lua nls ssl -ipv6 -ncat -ndiff -nmap-update -nping (-system-lua) -zenmap% (-gtk%)" LINGUAS="ru -de -es -fr -hr -hu -id -it -ja -pl -pt_BR -pt_PT -ro -sk -zh" PYTHON_TARGETS="python2_7%*" 7 694 KiB
[ebuild    U  ] net-misc/openvpn-2.3.6::gentoo [2.3.2::gentoo] USE="iproute2 lzo pam plugins ssl -down-root -examples -passwordsave -pkcs11 (-polarssl) (-selinux) -static -systemd%" 1 185 KiB
[ebuild    U  ] net-misc/openssh-6.7_p1::gentoo [6.6_p1-r1::gentoo] USE="bindist hpn kerberos pam pie%* -X -X509 -ldap -ldns -libedit -sctp% (-selinux) -skey -static (-tcpd%*)" 1 352 KiB
[ebuild    U  ] net-proxy/squid-3.4.11-r1::gentoo [3.3.12::gentoo] USE="htcp%* kerberos logrotate pam postgres samba sqlite ssl wccp%* wccpv2%* -caps -ecap -esi% -icap-client (-ipf-transparent) -ipv6 (-kqueue) -ldap -mysql -nis (-pf-transparent) -qos -radius -sasl (-selinux) -snmp -ssl-crtd {-test} -tproxy" 2 112 KiB
[ebuild    U  ] dev-lang/php-5.5.24:5.5::gentoo [5.5.18:5.5::gentoo] USE="apache2 berkdb bzip2 cli crypt ctype exif fileinfo filter gd gdbm hash iconv imap intl json kerberos ldap mysql nls opcache pdo phar posix postgres readline session simplexml sqlite ssl tokenizer unicode xml zlib -bcmath -calendar -cdb -cgi -cjk -curl -debug -embed -enchant (-firebird) -flatfile -fpm (-frontbase) -ftp -gmp -inifile -iodbc -ipv6 -ldap-sasl -libedit -libmysqlclient -mhash -mssql -mysqli* -oci8-instant-client -odbc -pcntl -qdbm -recode (-selinux) -sharedmem -snmp -soap -sockets -spell (-sybase-ct) -systemd -sysvipc -threads -tidy -truetype -vpx -wddx -xmlreader -xmlrpc -xmlwriter -xpm -xslt -zip" 13 025 KiB
[ebuild    U  ] net-analyzer/tcpdump-4.6.2-r1::gentoo [4.5.1-r1::gentoo] USE="drop-root samba ssl -ipv6 -smi -suid {-test}" 1 080 KiB
[ebuild    U  ] net-dns/bind-tools-9.10.1_p1::gentoo [9.9.4::gentoo] USE="readline ssl -doc -gost% -gssapi -idn -ipv6 -urandom -xml" 8 161 KiB
[ebuild    U  ] app-misc/mc-4.8.13::gentoo [4.8.11::gentoo] USE="edit nls samba slang xdg -X -gpm -mclib -sftp -spell {-test}" 2 180 KiB
[ebuild    U  ] mail-mta/postfix-3.0.0::gentoo [2.10.3::gentoo] USE="berkdb dovecot-sasl eai%* pam postgres sqlite ssl -cdb -doc -hardened -ldap -ldap-bind -lmdb% -mbox -memcached -mysql -nis -sasl (-selinux) -vda" 4 140 KiB
[nomerge      ] dev-db/mysql-5.6.24::gentoo [5.5.40::gentoo] USE="community perl ssl (-cluster) -debug -embedded -extraengine -jemalloc -latin1 -minimal -profiling (-selinux) -static -static-libs -systemtap -tcmalloc {-test} (-bindist%*) (-max-idx-128%)" ABI_X86="(64%*) -32% (-x32)"
[nomerge      ]  dev-util/cmake-2.8.12.2-r1::gentoo  USE="ncurses -emacs -qt4 (-qt5) {-test}"
[ebuild    U  ]   net-misc/curl-7.42.0::gentoo [7.31.0::gentoo] USE="kerberos samba%* ssl -adns -idn -ipv6 -ldap -metalink -rtmp -ssh -static-libs {-test} -threads" ABI_X86="(64%*) -32% (-x32)" CURL_SSL="openssl -axtls -gnutls -nss -polarssl (-winssl) (-cyassl%)" 3 253 KiB
[nomerge      ] net-misc/ntp-4.2.8-r1::gentoo [4.2.6_p5-r10::gentoo] USE="samba ssl vim-syntax -caps -debug -ipv6 -openntpd -parse-clocks (-selinux) -snmp -zeroconf"
[ebuild  N    ]  dev-libs/libevent-2.0.22::gentoo  USE="ssl threads -debug -static-libs {-test}" ABI_X86="(64) -32 (-x32)" 835 KiB
[ebuild    U  ] app-admin/syslog-ng-3.6.2::gentoo [3.4.7::gentoo] USE="ssl tcpd -amqp% -caps -dbi -geoip -ipv6 -json -mongodb -pacct% -redis% -smtp -spoof-source -systemd (-pcre%*)" 3 133 KiB
[nomerge      ] net-proxy/squid-3.4.11-r1::gentoo [3.3.12::gentoo] USE="htcp%* kerberos logrotate pam postgres samba sqlite ssl wccp%* wccpv2%* -caps -ecap -esi% -icap-client (-ipf-transparent) -ipv6 (-kqueue) -ldap -mysql -nis (-pf-transparent) -qos -radius -sasl (-selinux) -snmp -ssl-crtd {-test} -tproxy"
[ebuild    U  ]  net-fs/samba-3.6.25::gentoo [3.6.23::gentoo] USE="acl ads aio client ldap netapi pam readline server smbclient winbind -addns -avahi -caps -cluster -cups -debug -dmapi -doc -examples -fam -ldb -quota (-selinux) -smbsharemodes -swat -syslog" ABI_X86="(64%*) -32% (-x32)" 33 323 KiB
[ebuild    U  ]   net-nds/openldap-2.4.38-r2::gentoo [2.4.35-r1::gentoo] USE="berkdb crypt kerberos samba ssl syslog tcpd -cxx -debug -experimental -gnutls -icu -iodbc -ipv6 -minimal -odbc -overlays -perl -sasl (-selinux) -slp -smbkrb5passwd" ABI_X86="(64%*) -32% (-x32)" 5 390 KiB
[nomerge      ] net-proxy/squid-3.4.11-r1::gentoo [3.3.12::gentoo] USE="htcp%* kerberos logrotate pam postgres samba sqlite ssl wccp%* wccpv2%* -caps -ecap -esi% -icap-client (-ipf-transparent) -ipv6 (-kqueue) -ldap -mysql -nis (-pf-transparent) -qos -radius -sasl (-selinux) -snmp -ssl-crtd {-test} -tproxy"
[nomerge      ]  dev-perl/DBD-Pg-2.19.3-r1::gentoo [2.19.3::gentoo]
[ebuild  NS   ]   dev-db/postgresql-9.4.1:9.4::gentoo [9.2.7:9.2::gentoo, 9.3.3:9.3::gentoo] USE="kerberos nls pam python readline server ssl zlib -doc -ldap -perl -pg_legacytimestamp (-selinux) -static-libs -tcl -threads -uuid -xml" LINGUAS="ru -af -cs -de -en -es -fa -fr -hr -hu -it -ko -nb -pl -pt_BR -ro -sk -sl -sv -tr -zh_CN -zh_TW" PYTHON_SINGLE_TARGET="python2_7 -python3_3 -python3_4" PYTHON_TARGETS="python2_7 python3_3 -python3_4" 17 139 KiB
[ebuild    U  ]   virtual/krb5-0-r1::gentoo [0::gentoo] ABI_X86="(64%*) -32% (-x32)" 0 KiB
[ebuild    U  ] net-misc/wget-1.16::gentoo [1.14::gentoo] USE="nls pcre ssl zlib -debug -gnutls -idn -ipv6 -ntlm -static {-test%} -uuid" 1 658 KiB
[nomerge      ] dev-lang/php-5.5.24:5.5::gentoo [5.5.18:5.5::gentoo] USE="apache2 berkdb bzip2 cli crypt ctype exif fileinfo filter gd gdbm hash iconv imap intl json kerberos ldap mysql nls opcache pdo phar posix postgres readline session simplexml sqlite ssl tokenizer unicode xml zlib -bcmath -calendar -cdb -cgi -cjk -curl -debug -embed -enchant (-firebird) -flatfile -fpm (-frontbase) -ftp -gmp -inifile -iodbc -ipv6 -ldap-sasl -libedit -libmysqlclient -mhash -mssql -mysqli* -oci8-instant-client -odbc -pcntl -qdbm -recode (-selinux) -sharedmem -snmp -soap -sockets -spell (-sybase-ct) -systemd -sysvipc -threads -tidy -truetype -vpx -wddx -xmlreader -xmlrpc -xmlwriter -xpm -xslt -zip"
[nomerge      ]  virtual/imap-c-client-1::gentoo  USE="ssl"
[nomerge      ]   net-libs/c-client-2007f-r4::gentoo  USE="kerberos pam ssl -chappa -doc -ipv6 -static-libs -topal"
[ebuild    U  ]   app-crypt/mit-krb5-1.13-r1::gentoo [1.11.4::gentoo] USE="keyutils pkinit threads -doc -openldap (-selinux) {-test} -xinetd" ABI_X86="(64%*) -32% (-x32)" 11 800 KiB
[ebuild    U  ]    dev-libs/openssl-1.0.1l-r1::gentoo [1.0.1h-r1::gentoo] USE="bindist kerberos tls-heartbeat zlib -gmp -rfc3779 -static-libs {-test} -vanilla (-sse2%*)" ABI_X86="(64%*) -32% (-x32)" CPU_FLAGS_X86="(sse2%*)" 4 327 KiB

Total: 20 packages (18 upgrades, 1 new, 1 in new slot), Size of downloads: 128 416 KiB

 * Error: circular dependencies:

(dev-libs/openssl-1.0.1l-r1:0/0::gentoo, ebuild scheduled for merge) depends on
 (app-crypt/mit-krb5-1.13-r1:0/0::gentoo, ebuild scheduled for merge) (buildtime)
  (dev-libs/openssl-1.0.1l-r1:0/0::gentoo, ebuild scheduled for merge) (buildtime)

It might be possible to break this cycle
by applying any of the following changes:
- app-crypt/mit-krb5-1.13-r1 (Change USE: -pkinit)
- dev-libs/openssl-1.0.1l-r1 (Change USE: -kerberos)

Note that this change can be reverted, once the package has been installed.

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

  (dev-lang/perl-5.20.2:0/5.20::gentoo, ebuild scheduled for merge) pulled in by
   =dev-lang/perl-5.20* required by (virtual/perl-Digest-MD5-2.530.0-r2:0/0::gentoo, ebuild scheduled for merge)
   ^           ^^^^^                                                                                                            
   (and 8 more with the same problem)

  (dev-lang/perl-5.16.3:0/5.16::gentoo, installed) pulled in by
   dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/net-server-2.7.0-r1:0/0::gentoo, installed)
             ^^^^^^^^                                                                                    
   (and 15 more with the same problem)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


!!! The following installed packages are masked:
- dev-db/postgresql-server-9.2.7::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Aaron W. Swenson <titanofold@gentoo.org> (28 Dec 2014)
# Split ebuilds are no longer maintained. Migrate to the unified
# ebuilds invoking the following, substituting SLOT for the desired
# slot and optionally enabling the server and/or docs USE flags:
#   emerge dev-db/postgresql:SLOT
# No further action is required.

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

Еще смущает что хочет обновить postfix со 2 до третьей версии =( Как бы не упал почтовик.
Back to top
View user's profile Send private message
promusik
n00b
n00b


Joined: 23 Feb 2015
Posts: 3
Location: Russia, Magadan

PostPosted: Sun Apr 26, 2015 8:17 am    Post subject: Reply with quote

Ну в самом первом посте он сразу ругается на настройки синхронизации, "курить" мануал по этому поводу можно начать здесь: https://wiki.gentoo.org/wiki/Project:Portage/Sync .

Далее смотри что натыкано в /etc/portage/package.mask и /etc/portage/package.unmask . Там возможно много уже не актуального содержится, я бы почистил, ну и потом начал маскировать пакеты, которые он не может собрать, и там по цепочке...
Back to top
View user's profile Send private message
TigerJr
Guru
Guru


Joined: 19 Jun 2007
Posts: 483
Location: /dev/x0

PostPosted: Thu Apr 30, 2015 9:41 pm    Post subject: Reply with quote

Я бы на сервере emerge -u world вообще не делал. Да и emerge --sync побоялся, не протестировав на собаках.

Вам оно реально нужно?? Проблемы при обновлении, перезагрузки, не дай бог отказы в работе(почтовик например).

Я бы рекомендовал откатить на старый портейдж emerge-webrsync --revert опцией

Да и зачем вам этот питон:3.2 ????

Большинство скриптов используют питон:2.7 и очень мало написаны с использованием питон:3.2
Quote:
Если вы конечно не геронтолог...


Quote:
Да и emerge --sync побоялся


Основная причина в том что старые ebuild удаляются из новых портейджей. Тоесть если у вас установлен почтовик postfix-2.10.2 или младше, то после выполнения emerge --sync возможностей его пере установить у вас уже не будет, если какие либо пакеты зависят от него например mysql, а он требует mysql-5.5.32 которого уже в portage может тоже не быть - вы получаете циклическую зависимость и отсутствие возможностей их переустановить. Только вручную удалив оба пакеты вы сможете установить новые, конфигурация postfix-2.10.2 и postfix-3.0.0 может существенно отличаться.

ИТОГ:
Вы приходите к системе которая наполовину состоит из старых пакетов - наполовину из новых.
Полное обновление emerge -u world и emerge -u system скорее всего завершиться циклическими зависимостями и в этот момент сможет нарушить работу некоторых программ.
И вам лучше было бы установить всю систему заного - вместо того чтобы мучиться её обновлением.

PS

Однажды я сделал emerge --sync на портейдже возраст которого был 3 года, он завершился неудачей.
После изменения EAPI я ни одну программу установить не смог из-за конфликта версий EAPI и циклических зависимостей portage и из установленных пакетов 3 летней давности.
Это было в одном из OpenVZ контейнеров, в результате привело к обновлению и переустановке всех шаблонов OpenVZ.

Quote:
~ # eselect python list
Available Python interpreters:
[1] python2.7
[2] python3.2 *
[3] python3.3


Ставь eselect python set python2.7
_________________

Do not update portage without hotdog!

Xenogentooway?
Back to top
View user's profile Send private message
Seriyyy95
n00b
n00b


Joined: 10 Jul 2015
Posts: 1
Location: Ukraine, Litin

PostPosted: Fri Jul 10, 2015 12:52 pm    Post subject: Reply with quote

Еще инфа по настройке синхронизации только уже на русском: http://losst.ru/nastrojka-portage-sync-v-gentoo
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Russian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum