Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] xterm subst. verbose output information by "â"
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
commander-keen
n00b
n00b


Joined: 09 Oct 2013
Posts: 47
Location: Europe

PostPosted: Fri Apr 24, 2015 2:27 pm    Post subject: [SOLVED] xterm subst. verbose output information by "â& Reply with quote

Im a using X11+icewm.

However my xterm seems to lose some verbose information. Here a short example:
Code:

maex@crimson:tmp $ mkdir a
maex@crimson:tmp $ touch a/b a/c a/d
maex@crimson:tmp $ cp -rv a x
â -> â
â -> â
â -> â
â -> â


Now what bothers me are the funny "â" characters. I'd rather see which files were copied. However this appears to be caused by X/icewm. When I do the same in a TTY the verbose information is displayed fine.

I piped the output into a file, revealing the following content:
Code:

‘a’ -> ‘y’
‘a/d’ -> ‘y/d’
‘a/c’ -> ‘y/c’
‘a/b’ -> ‘y/b’

Note: for some reasons the content I see in my editor is not displayed correctly by the forum either, so I uploaded a screenshot here:
http://students.fim.uni-passau.de/~schieder/debugfile.jpg

It looks like all desired verbose information is still there but wrapped by weird characters and my terminal fails to display them thus hides parts of the output.


Last edited by commander-keen on Sat Apr 25, 2015 8:51 am; edited 1 time in total
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6193

PostPosted: Fri Apr 24, 2015 5:11 pm    Post subject: Reply with quote

Well, you're probably using it wrong. :twisted:

A blind guess says those names are utf8 and your locale isn't.
Back to top
View user's profile Send private message
commander-keen
n00b
n00b


Joined: 09 Oct 2013
Posts: 47
Location: Europe

PostPosted: Sat Apr 25, 2015 7:13 am    Post subject: Reply with quote

Not quite shure if I did this the right way, but: I still get the "â"s when I switch to UTF8.

Code:
maex@crimson:~ $ locale -a
C
de_DE
de_DE@euro
de_DE.iso88591
de_DE.iso885915@euro
deutsch
en_US
en_US.iso88591
en_US.utf8
français
french
fr_FR
fr_FR@euro
fr_FR.iso88591
fr_FR.iso885915@euro
german
POSIX
maex@crimson:tmp $ LC_ALL=en_US.utf8 locale charmap
UTF-8
maex@crimson:tmp $ cp -rv a x
â -> â
â -> â
â -> â
Back to top
View user's profile Send private message
commander-keen
n00b
n00b


Joined: 09 Oct 2013
Posts: 47
Location: Europe

PostPosted: Sat Apr 25, 2015 7:43 am    Post subject: Reply with quote

Turns out your locale hint was very close.
Only thing is, the encoding problem is not caused by the bash, but by the xterm itself. This is why I had no problems on the TTYs. Anyhow here is what I did:

Ctrl+Rightclick somewhere in the xterm. -> Select UTF-8 Encoding.

Et voila:
Code:
maex@crimson:tmp $ cp -rv a/ y
‘a/d’ -> ‘y/a/d’
‘a/c’ -> ‘y/a/c’
‘a/b’ -> ‘y/a/b’


Only thing left to do now is to set this as default for all new xterms. Seems like others ran into that before...
https://unix.stackexchange.com/questions/35748/how-can-i-save-the-xterm-configuration-i-set-at-runtime
Back to top
View user's profile Send private message
commander-keen
n00b
n00b


Joined: 09 Oct 2013
Posts: 47
Location: Europe

PostPosted: Sat Apr 25, 2015 8:50 am    Post subject: Reply with quote

Ok so apparently there are two ways to do this:
first is to edit ".Xdefaults" and set the following content:
Code:
.xterm.vt100.utf8: true
.xterm.vt100.utf8Fonts: false
XTerm*locale: true


Second is to launch the terminal with an extra argument:
Code:
xterm -en en_US.UTF-8


Either way results in the options "UTF-8 Encoding" and "UTF-8 Fonts" being checked. However the first way still showed me some "â"'s though the actual verbose information was printed somewhere in between. So I decided for the second way and changed my keyboard shortcut to run the xterm with the extra argument. Looks fine now:
Code:
maex@crimson:~ $ cp -rv /tmp/a /tmp/everythingisawesome
‘/tmp/a’ -> ‘/tmp/everythingisawesome’
‘/tmp/a/d’ -> ‘/tmp/everythingisawesome/d’
‘/tmp/a/c’ -> ‘/tmp/everythingisawesome/c’
‘/tmp/a/b’ -> ‘/tmp/everythingisawesome/b’
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum